TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Series3 HDTV DVRs
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 10-24-2007, 10:32 PM   #1
W Auggie H
Tivo Enthusiast
 
W Auggie H's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA, USA
Posts: 364
TTG Transfer - Choppy PC Playback

I was excited, as most of you were today(yesterday) to finally have MVR/TTG enabled for my THD. One of the first things I tried was to transfer "Heros"(HD) from this week to my PC. It took several hours to transfer. When I tried to play it back on my PC using the default Windows Media Player the playback was choppy. The audio seemed fine, it was just the video. Not smooth at all. Picture was good but playback, not so much. Any thoughts. My PC is not that old. P4 with 2.5GB RAM.
__________________
William
W Auggie H is offline   Reply With Quote
Old 10-24-2007, 11:31 PM   #2
jrock
Registered User
 
jrock's Avatar
 
Join Date: Aug 2002
Location: Connecticut
Posts: 676
I have a P4 3.4 GHZ with 2 GB of ram and it took me 1 hour to transfer Ugly Betty in HD. The file is just under 6 GB. I do notice it is very slightly choppy every so often. It has to be due to the large file size. I'm not sure how to fix this though. My PC is plenty powerfull enough. Maybe we need a better player than windows media.
jrock is offline   Reply With Quote
Old 10-24-2007, 11:46 PM   #3
drew00001
Registered User
 
Join Date: Jan 2007
Posts: 311
What kind of RAM?

I am assuming you have SDRAM since you have a P4. Is this correct?

I have a AMD FX60 with 2 GB DDR ram. This is faster than a P4 but probably not as fast as a Intel Core 2 Duo (w/ DDR2 RAM).

The only video I transferred was "The People vs Larry Flint," which was a 2.5 hour movie, at 18GB. The film transferred fine, but was choppy because playback outpaced the download. Next time I transfer something, I will wait longer before starting to watch . . . Or maybe I will buy a better router. The one I am using isn't good enough for an 18GB file transfer.

My best guess is that your system is getting old . . . sorry. I would also recomend a good graphics processor. Your post did not indicate what you are using.
drew00001 is offline   Reply With Quote
Old 10-25-2007, 12:01 AM   #4
rupesh97
Registered User
 
Join Date: Nov 2006
Posts: 13
Depending on the relative speed of your hardware components, your hard disk could be the bottleneck. In that case, you may wish to disable anti virus checking for that folder. This can do wonders in some situations.
rupesh97 is offline   Reply With Quote
Old 10-25-2007, 06:12 AM   #5
pkscout
Registered User
 
pkscout's Avatar
 
Join Date: Jan 2003
Location: Honolulu, HI
Posts: 3,888
Here's a link to the fourm specifically for MRV and TiVoToGo. You might check there for some answers.

http://www.tivocommunity.com/tivo-vb...splay.php?f=35
pkscout is offline   Reply With Quote
Old 10-25-2007, 08:08 AM   #6
jtseltmann
Registered User
 
Join Date: May 2005
Posts: 147
I have a new Dell Dimension Intel Core2 Quad 2.4ghz processor with 2Mb of Ram with Windows Vista. I have tranferred recordings to the PC via wireless and now via wired and I watched the entire program on the 24" widescreen...it was flawless. I had no problems with audio or video. The entire 1 hour HD recoding of Law And Order SVU took about 1.5 hours to xfer.
__________________
1 TiVo HD w/1TB int drive (1 M Card)
2 TiVo HD (4 CCards)
Wired Ethernet
Samsung LN52A650 - 52" LCD 120Hz
Samsung PN50B550 - 50" Plasma
Samsung LNS2641D -26" LCD
Harmony One
Harmony 659
jtseltmann is offline   Reply With Quote
Old 10-25-2007, 08:29 AM   #7
sinanju
Registered User
 
Join Date: Jan 2005
Posts: 590
I'm seeing the same thing on my Thinkpad T60 with a 2GHz core duo processor and 3GB of memory.

Interestingly, if I liberate the MPEG with DSD and view it in Intervideo WinDVD, it's perfect. Additionally, the Intervideo codecs result in better picture and sound than the codecs that come with the Desktop Plus.
sinanju is offline   Reply With Quote
Old 10-25-2007, 09:04 AM   #8
Revolutionary
Too sleepy for TV...
 
Join Date: Dec 2004
Location: Virginia
Posts: 575
EDIT
Quote:
Originally Posted by W Auggie H
I was excited, as most of you were today(yesterday) to finally have MVR/TTG enabled for my THD. One of the first things I tried was to transfer "Heros"(HD) from this week to my PC. It took several hours to transfer. When I tried to play it back on my PC using the default Windows Media Player the playback was choppy. The audio seemed fine, it was just the video. Not smooth at all. Picture was good but playback, not so much. Any thoughts. My PC is not that old. P4 with 2.5GB RAM.
/EDIT

You have a combination of 1) an insufficient system and 2) poor software to blame.

Taking the latter first, WMP is a lowsy player at default settings. You need to tweak the performance settings and employ a good MPEG-2 codec to get good playback performance. I recommend the NVIDIA PureVideo codec. To get smoother playback, try changing the "default renderer" in the Advanced performance settings dialogue to "Video Mixing Renderer" and not "Legacy;" use use the "Overlays" tick.

That said, no codec or settings tweak will help if your system if it just doesn't have the horses. High definition MPEG video is very resource intensive. The hardware requirements for HD-DVD and Blu-Ray bear this out (dual core processor, 1GB of RAM, advanced video card). What speed is your P4? What kind of video hardware do you have (discrete video card, integrated video, etc)? I personally have a P4 3.2Ghz with 1.5GB of RAM and a GeForce 8600 card in my HTPC, and it struggles on high bitrate recordings with a lot of motion in the frame. Lower bitrate stuff plays like a champ.

Your harddrive is almost certainly not the bottleneck. Virtually any harddrive in the last 10 years will have sufficient bandwidth to push a constant HD MPEG-2 stream.

Lastly, try closing any unneccessary software or system processes (all the crap in the system tray, other than your firewall and anti-virus) and see if that improves playback.
__________________
"Mmm... forbidden donut."

Last edited by Revolutionary : 10-25-2007 at 10:22 AM. Reason: clarification
Revolutionary is offline   Reply With Quote
Old 10-25-2007, 09:31 AM   #9
sinanju
Registered User
 
Join Date: Jan 2005
Posts: 590
Quote:
Originally Posted by Revolutionary
You have a combination of [...].
Well, none of those things are the problem on my system. All of the settings to which you refer have been flipped in just about every permutation. Nor is it a horsepower problem -- the exact same recording simply plays beautifully in WinDVD once the mpg has been liberated.

I agree that WMP is crappy software. Additionally, and unfortunately, the Plus codecs seem to be more geared toward transcoding for low bitrate/low resolution devices than high-quality playback.

The odd thing is that disabling the Plus codecs by renaming their files so that WMP is forced to use the Intervideo codecs still results in choppy (more like a rollercoaster, actually) playback. So, my bet is on something in WMP or the DirectShow filter itself.

But it isn't horsepower... WMP is taking 65% of my CPU and the rest is going to System Idle.
sinanju is offline   Reply With Quote
Old 10-25-2007, 10:20 AM   #10
Revolutionary
Too sleepy for TV...
 
Join Date: Dec 2004
Location: Virginia
Posts: 575
Quote:
Originally Posted by sinanju
Well, none of those things are the problem on my system. All of the settings to which you refer have been flipped in just about every permutation. Nor is it a horsepower problem -- the exact same recording simply plays beautifully in WinDVD once the mpg has been liberated.

I agree that WMP is crappy software. Additionally, and unfortunately, the Plus codecs seem to be more geared toward transcoding for low bitrate/low resolution devices than high-quality playback.

The odd thing is that disabling the Plus codecs by renaming their files so that WMP is forced to use the Intervideo codecs still results in choppy (more like a rollercoaster, actually) playback. So, my bet is on something in WMP or the DirectShow filter itself.

But it isn't horsepower... WMP is taking 65% of my CPU and the rest is going to System Idle.
I wasn't specifically responding to your post, actually. My comments were directed at the OP.

But addressing yours, there may be two options. First, are you using discrete graphics or an integrated chipset? The GPU is a major factor in accelerated HD video playback.

Second, renaming the default DirectShow video codec is a very, very bad idea. If you want to change the codec that WMP uses by default, then you need to get the Radlight filter manager (or equivalent). Search for it on afterdawn.com or videohelp.com. Just change the relative priority levels for the Tivo Plus codec (-) and the Intervideo codec (+). XP requires a restart to register the changes.

Third, depending on what Intervideo codec you are using, it may not default to use hardware acceleration in WMP, even though it will in the Intervideo player. This alone could account for the difference you are seeing between players. You can search on places like afterdawn and the MediaPortal forums to find the relevant registry changes to make sure that the Intervideo codec uses hardware acceleration in WMP. This is another reason I prefer the NDIVIA codec: not only does it give the best playback for MPEG-2 video, but it also allows you to select hardware acceleration in the codec control panel.
__________________
"Mmm... forbidden donut."
Revolutionary is offline   Reply With Quote
Old 10-25-2007, 10:48 AM   #11
W Auggie H
Tivo Enthusiast
 
W Auggie H's Avatar
 
Join Date: Oct 2001
Location: Atlanta, GA, USA
Posts: 364
Quote:
Originally Posted by Revolutionary
EDIT
/EDIT

You have a combination of 1) an insufficient system and 2) poor software to blame.

Taking the latter first, WMP is a lowsy player at default settings. You need to tweak the performance settings and employ a good MPEG-2 codec to get good playback performance. I recommend the NVIDIA PureVideo codec. To get smoother playback, try changing the "default renderer" in the Advanced performance settings dialogue to "Video Mixing Renderer" and not "Legacy;" use use the "Overlays" tick.
You are probably correct. I haven't really done any tweaks to WMP and I am using the defaults. I don't watch much on my PC. In general everything else that I play runs fine. It is just with these huge HD shows. I am going to look at a few things you mention and will see how that goes. Thanks for the info.
__________________
William
W Auggie H is offline   Reply With Quote
Old 10-25-2007, 10:57 AM   #12
wolverines
Registered User
 
Join Date: Jul 2005
Posts: 39
Quote:
Originally Posted by sinanju
I'm seeing the same thing on my Thinkpad T60 with a 2GHz core duo processor and 3GB of memory.

Interestingly, if I liberate the MPEG with DSD and view it in Intervideo WinDVD, it's perfect. Additionally, the Intervideo codecs result in better picture and sound than the codecs that come with the Desktop Plus.
What is DSD?
wolverines is offline   Reply With Quote
Old 10-25-2007, 11:22 AM   #13
snathanb
Registered User
 
Join Date: Sep 2006
Posts: 462
Quote:
Originally Posted by wolverines
What is DSD?
Direct Show Dump.
snathanb is offline   Reply With Quote
Old 10-25-2007, 02:41 PM   #14
gdomeier
Registered User
 
Join Date: Nov 2001
Location: Sartell, MN USA
Posts: 64
I have a similar problem. I was getting no video playback or audio. I installed a windows codec bundle. That give me choppy video playback with no audio. I have tried playing hd and sd content. The sd actually plays worse.
gdomeier is offline   Reply With Quote
Old 10-25-2007, 02:47 PM   #15
Revolutionary
Too sleepy for TV...
 
Join Date: Dec 2004
Location: Virginia
Posts: 575
Quote:
Originally Posted by gdomeier
I have a similar problem. I was getting no video playback or audio. I installed a windows codec bundle. That give me choppy video playback with no audio. I have tried playing hd and sd content. The sd actually plays worse.
PC Specs?

What codec bundle? The only one I trust is Cole2k.
__________________
"Mmm... forbidden donut."
Revolutionary is offline   Reply With Quote
Old 10-26-2007, 09:20 AM   #16
bown
Registered User
 
Join Date: Nov 2006
Posts: 80
I was having really choppy playback. In fact, HD content was unwatchable.

I looked at the "Advanced Performance" settings in WMP and turned on "Turn on DirectX Video Acceleration" and that fixed my problem. I'm not sure why that wasn't turned on by default, but at least it works now.
bown is offline   Reply With Quote
Old 10-26-2007, 12:08 PM   #17
gdomeier
Registered User
 
Join Date: Nov 2001
Location: Sartell, MN USA
Posts: 64
Quote:
Originally Posted by Revolutionary
PC Specs?

What codec bundle? The only one I trust is Cole2k.
I have 1.5 gigs of ram. I don't recall my processor speed, but it's older. An athlon 2600 or something similar.

I did install the cole2k. Same thing. I found last night that installing videoredo, that my playback and sound work pretty well with that.
gdomeier is offline   Reply With Quote
Old 10-26-2007, 01:47 PM   #18
yunlin12
Tivonation Citizen
 
yunlin12's Avatar
 
Join Date: Mar 2003
Location: San Jose, CA
Posts: 1,221
I assume you guys all have S3 or HD, are you guys on 9.2J or 9.1 software?
__________________
ReplayTV 3000 (RIP)
Hughes HDVR2 DTivo (adopted by friend)
Tivo S2 Dual Tuner (Craiglisted)
Tivo S3 750GB (decommissioned)
Tivo HD 750GB (adopted by parents)
Tivo Premiere
Tivo Premiere XL
yunlin12 is offline   Reply With Quote
Old 10-26-2007, 02:18 PM   #19
Laserfan
Registered User
 
Join Date: Apr 2000
Location: USA
Posts: 405
I thought that Tivo Desktop added a DirectShow filter so WMP could play .tivo files, but I don't see anything like that in the TD installation.

What IS the codec that is used to play-back .tivo files?
__________________
TiVo Series3 (v11.0m-01-2-648)
TiVo HD (v11.0m-01-2-648)
Philips HDR312 Standalone (v3.0) RETIRED-RIP
Laserfan is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 08:40 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |