TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 05-20-2007, 09:41 AM   #1
miller890
Member
 
miller890's Avatar
 
Join Date: Feb 2002
Location: MA
Posts: 345
HD Photos 2.0 Not Working

On TivoDesktop 2.4a (same with 2.4) when I enable Photos 2.0 for HD series-3 I receive an application error on startup. I running Java v 1.6.0 (build 1.6.0_01-b06) and I have uninstalled and reinstalled both Java the Tivo desktop a number of time. The strange thing is that it will work just after the Tivo Desktop install, but after a reboot the following error is shown in a Java popup window and Photos 2.0 no longer works.

Quote:
Error: Could not load file/URL spedified: hdphots.jnlp
Exception:
CouldNotLoadArgumentException[ Could not load file/URL specified: hdphotos.jnlp]
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)
Quote:
Wrapper Exception:
java.io.FileNotFoundException: hdphotos.jnlp (The system cannot find the file specified)
at java.io.FileInputStream.open(Native Method)
at java.io.FileInputStream.<init>(Unknown Source)
at java.io.FileInputStream.<init>(Unknown Source)
at com.sun.javaws.jnl.LaunchDescFactory.buildDescriptor(Unknown Source)
at com.sun.javaws.Main.launchApp(Unknown Source)
at com.sun.javaws.Main.continueInSecureThread(Unknown Source)
at com.sun.javaws.Main$1.run(Unknown Source)
at java.lang.Thread.run(Unknown Source)

__________________
TiVo
Roamio Pro
w/LT | Premier Elite w/LT | Roamio Basic w/msd | Mini w/LT | Series 3 1.5TB w/LT | Series 3 1.5TB w/LT | S2DT 1TB retired| S2-140 retired | Stream
Comcast, all wired to 1GB

Last edited by miller890 : 05-25-2007 at 12:01 PM.
miller890 is offline   Reply With Quote
Old 05-21-2007, 08:21 AM   #2
miller890
Member
 
miller890's Avatar
 
Join Date: Feb 2002
Location: MA
Posts: 345
I am running out of ideas...

So far I have tried a clean install of both Desktop 2.4 & 2.4a and Java 1.6 a few times on XP w/SP2. I have disabled ZoneAlert and anti-virus software when installing and later when attempting to start Photos 2.0; HD photos again will only work just after install - reboot and I get the error above. At one time I had Tivo Desktop 2.4 beta w/photos and an older Java version working fine; maybe something that was left behind that needs to be removed. Maybe the problem is the newer and only version of java that java.com offers.

Does anyone know if "Could not load file/URL specified: hdphotos.jnlp" is local or remote file?

Any suggestions/ideas would be appreciated. Thanks.
__________________
TiVo
Roamio Pro
w/LT | Premier Elite w/LT | Roamio Basic w/msd | Mini w/LT | Series 3 1.5TB w/LT | Series 3 1.5TB w/LT | S2DT 1TB retired| S2-140 retired | Stream
Comcast, all wired to 1GB
miller890 is offline   Reply With Quote
Old 06-09-2007, 08:16 AM   #3
miller890
Member
 
miller890's Avatar
 
Join Date: Feb 2002
Location: MA
Posts: 345
bump
__________________
TiVo
Roamio Pro
w/LT | Premier Elite w/LT | Roamio Basic w/msd | Mini w/LT | Series 3 1.5TB w/LT | Series 3 1.5TB w/LT | S2DT 1TB retired| S2-140 retired | Stream
Comcast, all wired to 1GB
miller890 is offline   Reply With Quote
Old 06-28-2007, 02:33 PM   #4
miller890
Member
 
miller890's Avatar
 
Join Date: Feb 2002
Location: MA
Posts: 345
bump
__________________
TiVo
Roamio Pro
w/LT | Premier Elite w/LT | Roamio Basic w/msd | Mini w/LT | Series 3 1.5TB w/LT | Series 3 1.5TB w/LT | S2DT 1TB retired| S2-140 retired | Stream
Comcast, all wired to 1GB
miller890 is offline   Reply With Quote
Old 06-28-2007, 04:32 PM   #5
Dennis Wilkinson
Registered User
 
Dennis Wilkinson's Avatar
 
Join Date: Sep 2001
Location: East Freetown, MA
Posts: 2,064
Quote:
Originally Posted by miller890
Does anyone know if "Could not load file/URL specified: hdphotos.jnlp" is local or remote file?
hdphotos.jnlp is a local file, and should be in C:\Program Files\TiVo\Desktop\Hme\

While the .jnlp file is local, it loads some remote resources. I suppose that could play into it. Some JNLP downloads are cached; it could be that your cached versions aren't behaving, I suppose, although I don't recall where those live under the WinXP JVM.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dennis Wilkinson is offline   Reply With Quote
Old 07-02-2007, 12:08 AM   #6
tannebil
Registered User
 
Join Date: Mar 2006
Posts: 65
I had the same problem until I uninstalled 2.4a and reinstalled. The non-working install was on D: while the working install is using the default location on C:. I chalked it up to a hard coded path name someplace but don't really know for certain.
tannebil is offline   Reply With Quote
Old 06-28-2014, 12:01 PM   #7
dw_penn
Registered User
 
Join Date: Feb 2007
Posts: 2
Popup Error

My hat's off to everyone I read as I sought a solution for myself. Everyone I read was clearly operating from a higher level of understanding than I myself. I decided there was one way to handle this and that was to stop hdphotos.jnlp from starting in the first place since it doesn't interfere with my particular use of the TiVo Desktop Server. I used Task-Watcher (made by the same producer as Win-Patrol, it stops anything listed that you don't want started).

Still from the banter I did glean something worth a try. In my perusal I found a thread that suggested prior versions of Java didn't have the problem, but that Oracle removed them from download access. Knowing that last part to be incorrect I un-installed my up-to-date Java and selected an older version from the archives and that eliminated the error and conflict with TiVo and O.S. security. I can still use Task-Watcher to keep Java from annoying me with later version announcements. At some future point I can give a newer version a try and either they or TiVo may have worked out the issue by then. DP
dw_penn is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 05:47 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |