TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 05-27-2007, 06:02 PM   #511
TreborPugly
Unreal!
 
TreborPugly's Avatar
 
Join Date: May 2002
Location: Eastern TN
Posts: 4,542
Cool, I think I found an undiscovered but with the 8.3 folders fix!

1. Go into Folder "A" - see the proper list
2. Go back out to the top of your share, or back to the Now Playing list, whatever,
3. Go into Folder "B" - see the proper list for folder "B". Scroll through files with arrows, no problem.
4. Use your "skip to tick" button, which normally will jump you to the end of the list, right? It jumps, but now you are seeing the contents of Folder "A"!

If you go back out and into Folder "B", or Folder "C", it will show stuff right, but whenever you use the skip to tick to jump to the end, it will go back to Folder "A".

(Oh, well, after trying to leave folder "C", I had my Tivo Crash, so, maybe not...)
__________________
Next?
TreborPugly is offline   Reply With Quote
Old 05-28-2007, 11:22 PM   #512
sraveh
Registered User
 
Join Date: Feb 2005
Posts: 1
mp3 Playlist

Hi,

I've been using pyTivo for a couple of month now and I love it.
I used Galleon before and I think pyTivo is doing great job.
One thing that I miss or do not know how to configure is mp3 playlist. I tried pointing pyTivo to a directory that contains my playlist but it complains that it empty.
Does pyTivo support playlist?


Thanks,
Simon
sraveh is offline   Reply With Quote
Old 05-29-2007, 01:33 PM   #513
brunson
Registered User
 
Join Date: Apr 2005
Posts: 14
8.3 subfolder problem

Has anyone reported this to TiVo? It seems like they could fix it in a future release.
brunson is offline   Reply With Quote
Old 05-29-2007, 01:39 PM   #514
KRKeegan
Im lost and confused
 
KRKeegan's Avatar
 
Join Date: Jul 2004
Location: Los Angeles, CA
Posts: 215
Quote:
Originally Posted by brunson
Has anyone reported this to TiVo? It seems like they could fix it in a future release.
Yeah I did, I even got a response back that they were forwarding it to the correct department and requesting my contact information.

That was however, almost a month ago and I have not heard anything back from them at all. But I hope it gets fixed.

Kevin
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A much better place to receive pyTivo help and updates.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A python real time video transcoding server for TiVo.
KRKeegan is offline   Reply With Quote
Old 05-30-2007, 09:13 AM   #515
cr33p
Registered User
 
Join Date: Jan 2005
Location: Ann Arbor MI
Posts: 644
First of all I have been using pytivo ever since I stumbled on it when it first dropped might I just add its the whip, much thanks Anywho on to my question, does pytivo support any info details like xml data? When I choose a vid out of my NPL it just tells me the name of the file but does not tell me the duration or any other data. Is there a way to have this info imputted with pytivo ?

Thanks

Chris
cr33p is offline   Reply With Quote
Old 05-30-2007, 04:03 PM   #516
KRKeegan
Im lost and confused
 
KRKeegan's Avatar
 
Join Date: Jul 2004
Location: Los Angeles, CA
Posts: 215
Quote:
Originally Posted by cr33p
First of all I have been using pytivo ever since I stumbled on it when it first dropped might I just add its the whip, much thanks Anywho on to my question, does pytivo support any info details like xml data? When I choose a vid out of my NPL it just tells me the name of the file but does not tell me the duration or any other data. Is there a way to have this info imputted with pytivo ?
No nothing yet I am afraid, that is a project of mine that has been stumbling around in my head for a while. I have 2 issues to solve:
1. How to store the data, (Database, or individual files, or some embedded tag like ID3)
2. How to input the data, (probably need some html interface to add titles and the like)

It is on the list of things to do, but I am afraid it is a big step, so it might take me a while to get around to it. :-p

Kevin
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A much better place to receive pyTivo help and updates.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A python real time video transcoding server for TiVo.
KRKeegan is offline   Reply With Quote
Old 05-30-2007, 07:22 PM   #517
gonzotek
tivo_xml developer
 
gonzotek's Avatar
 
Join Date: Sep 2004
Location: Outside Phildadelphia
Posts: 2,229
Quote:
Originally Posted by KRKeegan
No nothing yet I am afraid, that is a project of mine that has been stumbling around in my head for a while. I have 2 issues to solve:
1. How to store the data, (Database, or individual files, or some embedded tag like ID3)
2. How to input the data, (probably need some html interface to add titles and the like)

It is on the list of things to do, but I am afraid it is a big step, so it might take me a while to get around to it. :-p

Kevin
My vote would be for #1, using an ajax-ified html form to pre-fill in as many fields as possible(for instance different episodes of the same series will contain many similar meta fields the same way different tracks of an album will). Using a DB also gives the opportunity to query it independently of pyTiVo functions, to (for example) create an output file in another format for another device(ipod or whatever), with metadata transported over. If there's a standard for tagging mpeg2 video (I'm not aware of any, will id3v2 or ape tags work???), tagging the files would be useful for some things, but I think a db would provide faster results, since once the files are added(or updated) they wouldn't need to be read from disk (unless updated again).
gonzotek is offline   Reply With Quote
Old 05-30-2007, 08:01 PM   #518
KRKeegan
Im lost and confused
 
KRKeegan's Avatar
 
Join Date: Jul 2004
Location: Los Angeles, CA
Posts: 215
Quote:
Originally Posted by gonzotek
My vote would be for #1, using an ajax-ified html form to pre-fill in as many fields as possible(for instance different episodes of the same series will contain many similar meta fields the same way different tracks of an album will).
That would be very cool, someone may have to help me with ajax, I have never worked with it.
Quote:
Originally Posted by gonzotek
Using a DB also gives the opportunity to query it independently of pyTiVo functions, to (for example) create an output file in another format for another device(ipod or whatever), with metadata transported over.
My only problem with a db is that moving or renaming files will of course cause an issue.
Quote:
Originally Posted by gonzotek
If there's a standard for tagging mpeg2 video (I'm not aware of any, will id3v2 or ape tags work???), tagging the files would be useful for some things, but I think a db would provide faster results, since once the files are added(or updated) they wouldn't need to be read from disk (unless updated again).
There is, but it is not available in all of the video formats that ffMpeg supports, thus it is not a good idea.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A much better place to receive pyTivo help and updates.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A python real time video transcoding server for TiVo.
KRKeegan is offline   Reply With Quote
Old 06-01-2007, 08:56 AM   #519
buffalova
Registered User
 
Join Date: Jul 2006
Posts: 30
Hello all. I have read this entire post and believe my problem has been discussed but am not sure how to proceed.

On my TSN240 tivo when I transfer a video with a ratio greater than 4:3 specifically 1.37 or 704x512 I receive a conversion that has black bar on both sides where as 704x528 works.
If I set the tivo to display 4:3 instead of 16:9 it produces a correct video but is now enclosed in a frame of black bars so to speak.

I even tried the suggested mpeg4 modifier to make it a true 4:3 ratio. I tried it for pixel AR as well as display AR but that didn't see to help either.

I was going to try changing this statement to false but it doesn't even appear in my pytivo.conf file

#If you want to use 16:9 or 4:3 on this tivo
#aspect169=true


If I use Gui4fmpeg and convert manually to the tivo desktop folder it works fine which to me seems like an edit is possible I just don't know what to edit.

Is there a simple edit I can do or is it that some files with this machine will not convert correctly?

What is odd it that it doesn't do this on my TSN540 tivo. Many thanks

I have WinXP
buffalova is offline   Reply With Quote
Old 06-02-2007, 09:49 AM   #520
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 6,007
Quote:
Originally Posted by buffalova
Hello all. I have read this entire post and believe my problem has been discussed but am not sure how to proceed.
Have you tried the *** Wiki ***? Particularly the 'Notes" in the configuration section and the discussion of aspect ratio.

Quote:
Originally Posted by buffalova
On my TSN240 tivo when I transfer a video with a ratio greater than 4:3 specifically 1.37 or 704x512 I receive a conversion that has black bar on both sides where as 704x528 works.
If I set the tivo to display 4:3 instead of 16:9 it produces a correct video but is now enclosed in a frame of black bars so to speak.
Just out of curiosity, what is the source of the videos, and what type are they?
Quote:
Originally Posted by buffalova
I even tried the suggested mpeg4 modifier to make it a true 4:3 ratio. I tried it for pixel AR as well as display AR but that didn't see to help either.
pyTivo cannot find out the PAR (or DAR) from ffmpeg. Thus it must assume square pixels, i.e., that the desired DAR is that represented by the input file dimensions.
Quote:
Originally Posted by buffalova
I was going to try changing this statement to false but it doesn't even appear in my pytivo.conf file

#If you want to use 16:9 or 4:3 on this tivo
#aspect169=true
Read the Wiki notes on the configuration page describing the format of the pyTivo.conf file. Many parameters, including aspect169, will get default values if they don't appear in the file. Default for aspect169 is false. If you want a different value just add the line in the proper section.

To get better help here, post your pyTivo.conf file, at least the parts before the sections defining shares.
Quote:
Originally Posted by buffalova
If I use Gui4fmpeg and convert manually to the tivo desktop folder it works fine which to me seems like an edit is possible I just don't know what to edit.

Is there a simple edit I can do or is it that some files with this machine will not convert correctly?
In general there are some files (specifically those with non-square pixels) that will not be handled properly by pyTivo (because it has no knowledge of PAR or DAR).
Quote:
Originally Posted by buffalova
What is odd it that it doesn't do this on my TSN540 tivo. Many thanks
There are differences in the Tivo models in this regard. The width and height settings in your .conf file can make a difference here.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 06-02-2007, 10:16 AM   #521
buffalova
Registered User
 
Join Date: Jul 2006
Posts: 30
Thanks for the suggestions dlfl Iwill do some more reading in the interim here is the data on the file I am trying that adds the padding left and right. Any file that seems to have a ratio larger than 4:3 seems to be doing this. I suspect 16:9 will too although the one I tried looked squished without the side bars.

File data

General #0
Complete name : M:\Current\Friends Season 2\209_the one with phoebe's dad.avi
Format : AVI
Format/Info : Audio Video Interleave
Format/Family : RIFF
File size : 193 MiB
PlayTime : 21mn 51s
Bit rate : 1227 Kbps
StreamSize : 2.02 MiB

Video #0
Codec : DivX 5
Codec/Family : MPEG-4
Codec settings/Packe : Yes
Codec settings/BVOP : Yes
Codec settings/QPel : No
Codec settings/GMC : 0
Codec settings/Matri : Default
PlayTime : 21mn 51s
Bit rate : 1094 Kbps
Width : 704 pixels
Height : 512 pixels
Aspect ratio : 1.375
Frame rate : 25.000 fps
Resolution : 8 bits
Chroma : 4:2:0
Interlacement : Progressive
Bits/(Pixel*Frame) : 0.121
StreamSize : 171 MiB
Writing library : DivX503b894p

Audio #0
Codec : MPEG-1 Audio layer 3
PlayTime : 21mn 51s
Bit rate : 126 Kbps
Bit rate mode : CBR
Channel(s) : 2 channels
Sampling rate : 48 KHz
Resolution : 16 bits
StreamSize : 19.8 MiB
Writing library : Lame


And this is my Pytivo.conf file


[DEFAULT]
path = <Pick A Path>
type = video

[Series]
type = video
path = P:/series


[Server]
guid = {413878CF-5198-4540-96DF-266DA141A276}
ffmpeg = C:\Program Files\pyTivo\plugins\video\ffmpeg_mp2.exe
width = 544
port = 9032

[Current]
type = video
path = M:\current

[MyMovies]
type = video
path = M:\movies

[Next]
type = video
path = M:\Next

I did try changing the 544 to 720 but received the same results. I think I even tried 480 but can't be positive I did.

Thanks again for any guidance
buffalova is offline   Reply With Quote
Old 06-02-2007, 03:07 PM   #522
buffalova
Registered User
 
Join Date: Jul 2006
Posts: 30
Just a quick note dlfl. I got it to work.

I have no idea what I did to make it work.

I added each tivo separately into the pytivo.conf file with aspect169=false and then I added debug=true to try to print out the error and it works perfectly now. I did remove the debug line because of an earlier post that said it would create a useless huge file. Thanks again.
buffalova is offline   Reply With Quote
Old 06-02-2007, 09:48 PM   #523
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 6,007
Quote:
Originally Posted by buffalova
Just a quick note dlfl. I got it to work.

I have no idea what I did to make it work.
.............
Me neither! I don't see a problem with your original .conf file and I can't see how anything you said you changed would make a difference.

Assuming:
1. Your TV is 4:3
2. Your TiVo is set to 4:3 (if that is settable on a 240)
3. aspect169 was set false (or missing from the .conf file)
4. 1:37 AR in your input AVI

I would have expected the file to display with a very small amount of letterboxing (top and bottom black bands) but NOT black bands at the sides. The letterboxing would be so small that it would probably not be visible due to the vertical overscan in the TV.

If your TV is actually 16:9 then the file WOULD display with black pillars at the sides if it had logic to know it was trying to display a 4:3 aspect video coming out of ffmpeg via pyTivo. (ffmpeg does set the DAR in the transferred mpeg2 to correspond to what aspect169 is set to.)

Glad it's working OK for you now, anyway
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 06-07-2007, 01:01 AM   #524
morac
Cat God
 
morac's Avatar
 
Join Date: Mar 2003
Location: NJ
Posts: 6,534
Quote:
Originally Posted by dlfl
Unfortunately there is no way to get DAR or PAR from ffmpeg, which pyTivo uses to get info about a video file. Thus pyTivo makes the assumption of square pixels, i.e., DAR = FAR (at least in most cases).
Why not use mencoder instead of ffmpeg? This program can encode to mpeg2 and is capable of extracting the aspect ratio data. It even has an option to automatically encode the output file with the same aspect ratio (page is for mpg4, but it works with mpg2 as well.

http://www.mplayerhq.hu/design7/news.html
http://ffdshow.faireal.net/mirror/mplayer/
morac is offline   Reply With Quote
Old 06-07-2007, 10:44 AM   #525
govardha
Registered User
 
Join Date: Jan 2004
Posts: 36
I have a question on pyTivo/ffmpeg functionality and how to extend it?

I have 2 different types of files which I have issues with. I have a .ts file which causes pyTivo to barf and a divx file which has the audio track in ac2/ac3 which fails with unknown codec or so.

I further use ffmpegx to convert them(.ts to svcd & the divx file to divx/mp3) and it works just fine in my tivo. Is there any way I can add this step that negates my manual intervention to handle these file encoding/decoding?

Thanks!
G
__________________
GG
govardha is offline   Reply With Quote
Old 06-07-2007, 02:36 PM   #526
Justin Thyme
Contra sceleris
 
Justin Thyme's Avatar
 
Join Date: Mar 2005
Posts: 3,306
Problem with installation? Check Firewall settings.

May be mentioned somewhere, but here is an installation note for those using PyTivo with Firewall software.

Firewall software, and Trend Micro PC-Cillin in particular will block the program PYTHONSERVER from touching your home network. It's really PyTivo that is making the request, and you will see no PyTivo folders if you don't fix it. What you do is to give permission. Norton and I think zonealarm will ask you the first time it tries. If you mistakenly deny, you have to go into the program list and give back permission.

For Trend Micro users, it won't warn you- it will just block access. To fix, go into
Network Security -> Firewall -> [double click profile- eg Direct Connection] -> Exception list tab -> click Add

Permit outgoing UDP access to Pythonservice. for all IP addresses. Where is Pythonservice.exe? XP users that use default installation will find it here- c:\Python25\lib\site-packages\win32\pythonservice.exe
Justin Thyme is offline   Reply With Quote
Old 06-13-2007, 09:25 AM   #527
ScaryMike
Registered User
 
Join Date: Aug 2002
Location: Madison, WI
Posts: 201
I just wanted to toss out another thank you to the people involved in this project/program.

I use PyTivo daily and find it completely invaluable. The latest version with the folder fix has been running great for me since you released it.

Thanks again.
ScaryMike is offline   Reply With Quote
Old 06-13-2007, 04:08 PM   #528
Dajad
Registered User
 
Dajad's Avatar
 
Join Date: Oct 1999
Location: Toronto
Posts: 1,534
Does PyTiVo work with Vista? Vista 64?

...Dale
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
<- Get the gifts you REALLY want! (now in public beta) -
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Dajad is offline   Reply With Quote
Old 06-13-2007, 05:03 PM   #529
gonzotek
tivo_xml developer
 
gonzotek's Avatar
 
Join Date: Sep 2004
Location: Outside Phildadelphia
Posts: 2,229
Quote:
Originally Posted by Dajad
Does PyTiVo work with Vista? Vista 64?

...Dale
According to this post from late March, it does. The poster doesn't mention if he's on a 32 or 64 bit system. Let us know if you also get going it under vista(or vista 64) and we'll add it to the wiki.
gonzotek is offline   Reply With Quote
Old 06-14-2007, 05:39 PM   #530
Stu_Bee
Registered User
 
Join Date: Jan 2002
Location: Silicon Valley, Ca
Posts: 887
Thanks for Pytivo!
I've been running it for the last month on my PC (after the last Tivo Update broke the folders in Tivo.Net).
Installed Ubuntu yesterday, and got Pytivo up and running fairly quickly utilizing the already existing video files in my PC's NTFS volume.
Great app!
__________________
Tivo Series 3
Stu_Bee is offline   Reply With Quote
Old 06-14-2007, 06:11 PM   #531
gonzotek
tivo_xml developer
 
gonzotek's Avatar
 
Join Date: Sep 2004
Location: Outside Phildadelphia
Posts: 2,229
Quote:
Originally Posted by Stu_Bee
Thanks for Pytivo!
I've been running it for the last month on my PC (after the last Tivo Update broke the folders in Tivo.Net).
Installed Ubuntu yesterday, and got Pytivo up and running fairly quickly utilizing the already existing video files in my PC's NTFS volume.
Great app!
I should note I've also been happily running it under Ubuntu (first 6.10/Edgy, and now 7.04/Feisty) and various modern flavors of Windows(2000, 2003, XP, Media Center).
gonzotek is offline   Reply With Quote
Old 06-16-2007, 02:40 AM   #532
bjmarte
Registered User
 
Join Date: Jun 2007
Posts: 2
I'm having a problem getting pyTivo working correctly. I installed C:\pyTivo. I changed the ffmped location in the configuration file to point to c:\pyTivo\plugins\video\ffmpeg_mp2.exe. I used the MyMovies share and pointed it to the directory where I have a bunch of .Tivo and .mpg files in subdirectories. Everything else in the config is unchanged.

When I go to either of my Tivos I can see the MyMovies share and navigate to it and see any files in that directory and the subdirectories. The problem is that when I navigate to a subdirectory I can't see any of the movies there. Anybody have any ideas on how to fix this?
bjmarte is offline   Reply With Quote
Old 06-16-2007, 10:59 AM   #533
bjmarte
Registered User
 
Join Date: Jun 2007
Posts: 2
Ok, nevermind. After reading the posts about dlfl's similar problems I rebooted my TIVO and it looks like it is working fine now. I didn't read it closely enough the first time and kept rebooting my computer and wondering why it didn't work.
bjmarte is offline   Reply With Quote
Old 06-16-2007, 01:49 PM   #534
Justin Thyme
Contra sceleris
 
Justin Thyme's Avatar
 
Join Date: Mar 2005
Posts: 3,306
PyTivo transfers on hold?- troubleshooting fix

For some odd reason, when I initiated a pyTivo transfer the other day, everything appeared to start as the other hundred or so transfers I've done, but when I checked back later, I found it in still in the to do list with an X by it as if it were waiting for another transfer to complete first. I fiddled with a few obvious things on the PC server side with no resolution.

Fix- Rebooted the Tivo and it worked fine again. It hadn't been rebooted in about 4 months so I guess it had accumulated some cruft.
Justin Thyme is offline   Reply With Quote
Old 06-17-2007, 11:38 AM   #535
etsolow
Don't Try
 
etsolow's Avatar
 
Join Date: Feb 2001
Location: Wisconsin
Posts: 1,445
Is there a new download location? I can't get to armooo.net.
etsolow is offline   Reply With Quote
Old 06-18-2007, 08:46 PM   #536
KRKeegan
Im lost and confused
 
KRKeegan's Avatar
 
Join Date: Jul 2004
Location: Los Angeles, CA
Posts: 215
Hrm, well that isn't a good sign. I will see what I can do about finding armooo. In the meantime I can probably post up a zip of both current versions on my server.

And I apologize for being so absent, I have a bad commute to my current job that is just sucking all my time away. In a few weeks I should be back with some more updates.

Kevin
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A much better place to receive pyTivo help and updates.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A python real time video transcoding server for TiVo.
KRKeegan is offline   Reply With Quote
Old 06-20-2007, 12:06 AM   #537
cyclone
Registered User
 
Join Date: Nov 2004
Location: Silicon Valley
Posts: 18
Difficulty on Mac

I'm getting the following exception on my Mac (I had to replace all instances of "ht-tp" with "ZZZZ" because it thought I was posting links):
Code:
/Users/Bill/pyTivo/Cheetah/Compiler.py:1508: UserWarning: 
You don't have the C version of NameMapper installed! I'm disabling Cheetah's
useStackFrames option as it is painfully slow with the Python version of NameMapper.
You should get a copy of Cheetah with the compiled C version of NameMapper.
  "\nYou don't have the C version of NameMapper installed! "
192.168.0.6 - - [19/Jun/2007 22:01:00] "GET /TiVoConnect?Command=QueryContainer&Container=%2F ZZZZ/1.0" 200 -
720
----------------------------------------
Exception happened during processing of request from ('192.168.0.6', 4868)
Traceback (most recent call last):
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/SocketServer.py", line 464, in process_request_thread
    self.finish_request(request, client_address)
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/SocketServer.py", line 254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/SocketServer.py", line 522, in __init__
    self.handle()
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/BaseZZZZServer.py", line 316, in handle
    self.handle_one_request()
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/BaseZZZZServer.py", line 310, in handle_one_request
    method()
  File "/Users/Bill/pyTivo/ZZZZserver.py", line 54, in do_GET
    self.RootContiner()
  File "/Users/Bill/pyTivo/ZZZZserver.py", line 78, in RootContiner
    self.wfile.write(t)
  File "/Library/Frameworks/Python.framework/Versions/2.5/lib/python2.5/socket.py", line 255, in write
    data = str(data) # XXX Should really reject non-string non-buffers
  File "/Users/Bill/pyTivo/Cheetah/Template.py", line 990, in __str__
    def __str__(self): return getattr(self, mainMethName)()
  File "_Users_Bill_pyTivo_templates_root_container_tmpl.py", line 104, in respond
  File "/Users/Bill/pyTivo/Cheetah/NameMapper.py", line 235, in valueFromSearchList
    executeCallables=executeCallables)
  File "/Users/Bill/pyTivo/Cheetah/NameMapper.py", line 215, in _valueForName
    _raiseNotFoundException(key, obj)
  File "/Users/Bill/pyTivo/Cheetah/NameMapper.py", line 175, in _raiseNotFoundException
    raise NotFound(excString)
NotFound: cannot find 'type'
Any suggestions?

Bill
cyclone is offline   Reply With Quote
Old 06-20-2007, 11:14 AM   #538
gimgol
Registered User
 
Join Date: Mar 2006
Posts: 5
armoo down?

Quote:
Originally Posted by KRKeegan
Hrm, well that isn't a good sign. I will see what I can do about finding armooo. In the meantime I can probably post up a zip of both current versions on my server
armoo seems well and truly down at the moment. Could you post the latest on your server and let me know where to get the files? I would like to try this out and all links seem to point to armoo.

Thanks.
gimgol is offline   Reply With Quote
Old 06-20-2007, 12:31 PM   #539
KRKeegan
Im lost and confused
 
KRKeegan's Avatar
 
Join Date: Jul 2004
Location: Los Angeles, CA
Posts: 215
cyclone can you post your config file for me?

Sorry all I forgot to upload the script last night. I will do my best to remember tonight.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A much better place to receive pyTivo help and updates.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

A python real time video transcoding server for TiVo.
KRKeegan is offline   Reply With Quote
Old 06-20-2007, 02:24 PM   #540
cyclone
Registered User
 
Join Date: Nov 2004
Location: Silicon Valley
Posts: 18
Sure - here's my conf file. It's essentially identical to the one I used successfully under XP, other than changing paths for ffmpeg and the shares.
Code:
[Server]
port=9032

#Full path to ffmpeg including filename
ffmpeg=/opt/local/bin/ffmpeg

#This will make a large debug.txt file in you base directory.  It only debugs
#transcode.py right now.
#debug=false

# Audio bit-rate, default 192K
audio_br=128K

# Video bit-rate, default 4096K
video_br=2Mi

#Beacon broadcast address(es)
#Typically use 255.255.255.255 but on some multihomed machines you may
#need to specify the subnet broadcast address(es) of your Tivo boxes
#beacon=255.255.255.255

#Output Pixel Width: if you have an HDTV you might want to try 720 or 704
#Valid: 720, 704, 544, 480, 352
width=720
#height=720

#If you want to use 16:9 or 4:3 on this tivo
aspect169=true

##Per tivo options
# section named _tivo_TSN with the tsn in all caps
#[_tivo_2400000DEADBEEF]

[MyMovies]
#Type can be either 'video' or 'music'
type=video

#Path is the full path to your files (No trailing slash needed)
#For windows: path=c:\videos
[CyMac Videos]
path=/Users/Bill/Videos

cyclone is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 01:21 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |