TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Underground Playground > TiVo Underground
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 05-15-2006, 09:24 PM   #1561
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by pearkel
Hey guys looking for a little guidance. I have lost my twp on one of my hacked tivos. I went to uninstall tweak and keep getting some syntax error line 79 and It won't uninstall nor will it let me reinstall tweak keeps saying please uninstall first. This is on a pre-zippered tivo. So what is the best path for me to take. I would like to get the script updated to the other 2 tivos that have been zippered.
Thanks
Restore the backup author file and .profile, then delete the enhancements directory, then run tweak.sh. Alternatively, you can grab the tools disk download drom the Zipper website, extract the uninstall script from rbautch_files.tgz, FTP it to your tivo and then run it. You could also try to fix your existing uninstall script by running dos2unix on it (if dos line ending were the problem).
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-16-2006, 10:15 PM   #1562
llurkin
Registered User
 
Join Date: Apr 2005
Posts: 36
While I have run the Zipper on about 4 drives in my two systems with no problems, I am now stumped.

I have experienced a problem with the Zipper and tweak.sh that is driving me to distraction. So much so, that I have printed out tweak.sh and am single stepping through the process. As a background, I've created the enhancements directory, then moved rbautch_files.tgz into the directory. I've also created /enhancements/varhacks..

Then the following tar command causes the same message as tweak.sh

bash-2.02# pwd
/enhancements
bash-2.02# dir
rbautch_files.tgz varhacks
bash-2.02# tar -zxvf /rbautch_files.tgz 1>/dev/null
unzip: cannot find /rbautch_files.tgz, /rbautch_files.tgz.zip or /rbautch_files.tgz.ZIP.
bash-2.02# tar -zxvf rbautch_files.tgz 1>/dev/null
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: rbautch_files.tgz may be a plain executable, not an archive
unzip: cannot find zipfile directory in one of rbautch_files.tgz or
rbautch_files.tgz.zip, and cannot find rbautch_files.tgz.ZIP, period.
bash-2.02#

What is this message saying. It does not seem to matter if I type the exact commands that exist in tweak.sh, or the tar command when I am actually in the /enhancements directory.

The drive is a 80% full 200 gig that I don't wish to loose the recordings.

What should I do now?
__________________
To continually do the same process, and expect a different result is a short trip to insanity!
llurkin is offline   Reply With Quote
Old 05-16-2006, 10:42 PM   #1563
Luv2DrvFst
Registered User
 
Luv2DrvFst's Avatar
 
Join Date: Nov 2005
Posts: 186
Quote:
Originally Posted by llurkin
While I have run the Zipper on about 4 drives in my two systems with no problems, I am now stumped.

I have experienced a problem with the Zipper and tweak.sh that is driving me to distraction. So much so, that I have printed out tweak.sh and am single stepping through the process. As a background, I've created the enhancements directory, then moved rbautch_files.tgz into the directory. I've also created /enhancements/varhacks..

Then the following tar command causes the same message as tweak.sh

bash-2.02# pwd
/enhancements
bash-2.02# dir
rbautch_files.tgz varhacks
bash-2.02# tar -zxvf /rbautch_files.tgz 1>/dev/null
unzip: cannot find /rbautch_files.tgz, /rbautch_files.tgz.zip or /rbautch_files.tgz.ZIP.
bash-2.02# tar -zxvf rbautch_files.tgz 1>/dev/null
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: rbautch_files.tgz may be a plain executable, not an archive
unzip: cannot find zipfile directory in one of rbautch_files.tgz or
rbautch_files.tgz.zip, and cannot find rbautch_files.tgz.ZIP, period.
bash-2.02#

What is this message saying. It does not seem to matter if I type the exact commands that exist in tweak.sh, or the tar command when I am actually in the /enhancements directory.

The drive is a 80% full 200 gig that I don't wish to loose the recordings.

What should I do now?
You don't want rbautch-files.tgz in /enhancements. In fact you don't even want to create /enhancements -- that's what tweak.sh does. You put rbautch-files.tgz in /hacks -- the same directory that tweak.sh is in.
__________________
Zipper'd Hughes SD-DVR120 (501 hrs)
Zipper'd Philips DSR-7000 (265 hrs)
Luv2DrvFst is offline   Reply With Quote
Old 05-16-2006, 10:52 PM   #1564
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by llurkin
While I have run the Zipper on about 4 drives in my two systems with no problems, I am now stumped.

I have experienced a problem with the Zipper and tweak.sh that is driving me to distraction. So much so, that I have printed out tweak.sh and am single stepping through the process. As a background, I've created the enhancements directory, then moved rbautch_files.tgz into the directory. I've also created /enhancements/varhacks..

Then the following tar command causes the same message as tweak.sh

bash-2.02# pwd
/enhancements
bash-2.02# dir
rbautch_files.tgz varhacks
bash-2.02# tar -zxvf /rbautch_files.tgz 1>/dev/null
unzip: cannot find /rbautch_files.tgz, /rbautch_files.tgz.zip or /rbautch_files.tgz.ZIP.
bash-2.02# tar -zxvf rbautch_files.tgz 1>/dev/null
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: rbautch_files.tgz may be a plain executable, not an archive
unzip: cannot find zipfile directory in one of rbautch_files.tgz or
rbautch_files.tgz.zip, and cannot find rbautch_files.tgz.ZIP, period.
bash-2.02#

What is this message saying. It does not seem to matter if I type the exact commands that exist in tweak.sh, or the tar command when I am actually in the /enhancements directory.

The drive is a 80% full 200 gig that I don't wish to loose the recordings.

What should I do now?
Sounds like the rbautch_files.tgz file is corrupt or didnt download correctly. If you delete that file and rerun tweak.sh it will automatically download a fresh one for you. If that doesnt work, extract a new .tgz file from the tools disk and FTP it to your Tivo.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-16-2006, 11:15 PM   #1565
llurkin
Registered User
 
Join Date: Apr 2005
Posts: 36
OK..
I went to www.mastersav and downloaded a fresh copy of rbautch_files.tgz

I started Tera Term and entered my tivo and got a bash prompt. typed "mount -o remount,rw / " in tera term, then, while I was in the directory where the new copy of the tgz was, I started ftp, and put the file into /hacks/

then..

bash-2.02# mount -o remount,rw /
bash-2.02# dir
mfs_network rbautch_files.tgz superpatch-67all-NutKase-1.1.tcl tweak.sh
network.tcl set_mrv_name_67.tcl superpatch-67all-NutKase-1.1.txt tweak_uninstall.sh
bash-2.02# sh tweak.sh
Existing rbautch_files.tgz archive found in /hacks/
Skipping new script download...

Running rbautch Hacked Tivo Enhancements...
End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive. In the
latter case the central directory and zipfile comment will be found on
the last disk(s) of this archive.
note: /enhancements/rbautch_files.tgz may be a plain executable, not an archive
unzip: cannot find zipfile directory in one of /enhancements/rbautch_files.tgz or
/enhancements/rbautch_files.tgz.zip, and cannot find /enhancements/rbautch_files.tgz.ZIP, period.
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Checking your telnet settings. Do you want to continue? [y/n]: y

Do you want to run the "express" version (for advanced users)? [y/n]: y
cat: /enhancements/start.sh: No such file or directory
unzip: cannot find /^sleep/d, /^sleep/d.zip or /^sleep/d.ZIP.
bash-2.02#


It almost seems that the tivo has a command that states, on error, tell him about the zip commands.

I have taken the drive out 4 times, and ran the zipper on the drive.

It is confounding what is going on..
__________________
To continually do the same process, and expect a different result is a short trip to insanity!
llurkin is offline   Reply With Quote
Old 05-16-2006, 11:25 PM   #1566
llurkin
Registered User
 
Join Date: Apr 2005
Posts: 36
I wonder if it would be wise to erase the /hacks/ directory, and zipper the drive again?

Any thoughts..
__________________
To continually do the same process, and expect a different result is a short trip to insanity!
llurkin is offline   Reply With Quote
Old 05-17-2006, 09:25 AM   #1567
llurkin
Registered User
 
Join Date: Apr 2005
Posts: 36
Angry

removed the /hacks directory, and the /enhancements directory, rezippered the drive in my PC.

Put it in the Tivo, used tera term, and timorously typed sh tweak.sh in the /hacks directory.

NOTHING CHANGED!.. SAME REPORT! Ie: here's how to use zip...

Well, like Edison, I know alot of ways not to get the result I want.
__________________
To continually do the same process, and expect a different result is a short trip to insanity!
llurkin is offline   Reply With Quote
Old 05-17-2006, 10:01 AM   #1568
JoelCFC25
Registered User
 
Join Date: Apr 2006
Posts: 18
Looking at tweak.sh, it's clear to me that the script is finding the appropriately named file rbautch_files.tgz, creating /enhancements, and moving the .tgz file there. It's bombing upon attempting to unzip (before it even gets to untarring) the file.

Googling the phrase "End-of-central-directory signature not found. Either this file is not
a zipfile, or it constitutes one disk of a multi-part archive." is informative and points to what the author suggested, that your rbautch_files.tgz is corrupted somehow. That is occurring either upon original download of the file, or upon transfering it via FTP. Just to be clear--you aren't transfering it in ascii mode are you? I know that's a silly question but just to cover all the bases....
JoelCFC25 is offline   Reply With Quote
Old 05-17-2006, 01:22 PM   #1569
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Try the following commands to eliminate FTP as the problem:
Code:
wget -O /enhancements/rbautch_files.tgz http://www.mastersav.com/tivo_tweak/rbautch_files.tgz
tar -zxvf /enhancements/rbautch_files.tgz

__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-17-2006, 06:56 PM   #1570
sonyuser
Registered User
 
Join Date: Sep 2005
Posts: 22
I Think Fakecall Is Acting Up ??

I have been running this script for several months now without a hitch. Great work by Rbautch. Have had phone line plugged in because I like the caller ID. Fakecall had been working as stated all this time and confirmed as it always said the next call would either be the upcoming Sunday or Wednesday.

On my last phone bill, I saw numerous outgoing phone calls on my phone bill to DTV. I had never seen these before. I have my receiver set up to reboot periodically per the script. Not sure why these phone calls started happening. I do NOT purchase any PPV. When I look at call status now, it no longer is on Sun or Wed.

Is there anyway to manually run the FAKECALL script? I did a search (find) for Fakecall but could not find it. Trying to see what is going on.
sonyuser is offline   Reply With Quote
Old 05-17-2006, 07:24 PM   #1571
Luv2DrvFst
Registered User
 
Luv2DrvFst's Avatar
 
Join Date: Nov 2005
Posts: 186
Quote:
Originally Posted by sonyuser
I have been running this script for several months now without a hitch. Great work by Rbautch. Have had phone line plugged in because I like the caller ID. Fakecall had been working as stated all this time and confirmed as it always said the next call would either be the upcoming Sunday or Wednesday.

On my last phone bill, I saw numerous outgoing phone calls on my phone bill to DTV. I had never seen these before. I have my receiver set up to reboot periodically per the script. Not sure why these phone calls started happening. I do NOT purchase any PPV. When I look at call status now, it no longer is on Sun or Wed.

Is there anyway to manually run the FAKECALL script? I did a search (find) for Fakecall but could not find it. Trying to see what is going on.
There are two types of calls a DTiVo makes -- one for the TiVo stuff which the hacks and fakecall block, the other is to DTV. This is how software updates and PPV purchases get handled. My DTiVo seems to dial out to DTV about once every 60 days. I suspect that what your unit is doing is normal and not causing any problems.

Fakecall can be run by typing the following at a bash prompt:

/enhancements/fakecall.tcl

Linux is very particular about case, so a search for Fakecall is different than a search for fakecall. Also, the full name of the file is fakecall.tcl. A search hint is to use an * to more easily find files, for example:

ffind fakecall*
__________________
Zipper'd Hughes SD-DVR120 (501 hrs)
Zipper'd Philips DSR-7000 (265 hrs)
Luv2DrvFst is offline   Reply With Quote
Old 05-17-2006, 07:39 PM   #1572
llurkin
Registered User
 
Join Date: Apr 2005
Posts: 36
Thanks for the suggestions, but before they were posted, I tried one other item that appears to have worked well.

Because the program crashed at the same place each time, everything pointed to a corrupt rbautch_files.tgz file. By removing the file with rm, my suspicion was that, like dos, removing a file in Linux just removed some letters from the filename. When the file was reloaded, it was being put in the same place, with the same corruption. So.. I did a tweak_uninstall, then I used mv to rename the corrupt file to rbautch_files.tgg, then ftp'd the rbautch_files.tgz from my PC file back to the Tivo.

In my mind, all the zipper files were where they were supposed to be, so I ran sh tweak.sh and.. SUCCESS!

Now I have some other things I wish to do, and if they work, and haven't been reported before, I'll post the results.

Thanks to Rbautch and Gunnyman for a GREAT PROGRAM!
__________________
To continually do the same process, and expect a different result is a short trip to insanity!
llurkin is offline   Reply With Quote
Old 05-17-2006, 08:54 PM   #1573
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by sonyuser
I have been running this script for several months now without a hitch. Great work by Rbautch. Have had phone line plugged in because I like the caller ID. Fakecall had been working as stated all this time and confirmed as it always said the next call would either be the upcoming Sunday or Wednesday.

On my last phone bill, I saw numerous outgoing phone calls on my phone bill to DTV. I had never seen these before. I have my receiver set up to reboot periodically per the script. Not sure why these phone calls started happening. I do NOT purchase any PPV. When I look at call status now, it no longer is on Sun or Wed.

Is there anyway to manually run the FAKECALL script? I did a search (find) for Fakecall but could not find it. Trying to see what is going on.
Navigate to /busybox and run it with tivosh fakecall.tcl
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-18-2006, 02:53 PM   #1574
pallen4215
Registered User
 
pallen4215's Avatar
 
Join Date: Mar 2005
Posts: 118
Quote:
Originally Posted by 6stringbass
If you've Zippered yourself then you can use a USB200M or get one of the Netgear adapters.
I didn't use zipper, but I did use rbautch's enhancement script. Will I need to do anything else?

Last edited by pallen4215 : 05-19-2006 at 01:16 PM.
pallen4215 is offline   Reply With Quote
Old 05-18-2006, 08:35 PM   #1575
alert5
Registered User
 
Join Date: Nov 2003
Posts: 133
Quote:
Originally Posted by sonyuser
I have been running this script for several months now without a hitch. Great work by Rbautch. Have had phone line plugged in because I like the caller ID. Fakecall had been working as stated all this time and confirmed as it always said the next call would either be the upcoming Sunday or Wednesday.

On my last phone bill, I saw numerous outgoing phone calls on my phone bill to DTV. I had never seen these before. I have my receiver set up to reboot periodically per the script. Not sure why these phone calls started happening. I do NOT purchase any PPV. When I look at call status now, it no longer is on Sun or Wed.

Is there anyway to manually run the FAKECALL script? I did a search (find) for Fakecall but could not find it. Trying to see what is going on.
Actually I think crontabs with callerID enabled kicks off a forced reboot every Sunday and Wednesday. Fakecall in my crontabs root is set to execute once a day. The default for Fakecall was 10:20PM CST everyday with my version of the tweak. I changed this to reflect my time zone (EDT) when I modified my callerID box forced reboots to happen at 3:25AM EDT.

I would check your cron root to be sure Fakecall is happening daily, not just when a reboot occurs.
alert5 is offline   Reply With Quote
Old 05-18-2006, 09:31 PM   #1576
alert5
Registered User
 
Join Date: Nov 2003
Posts: 133
Wed May 17 02:20:05 UTC 2006 Fakecall was run successfully, run verified
Wed May 17 07:14:03 UTC 2006 TWP stopped
Wed May 17 07:15:04 UTC 2006 TWP started
Wed May 17 07:22:01 UTC 2006 cron.test.out deleted
Wed May 17 07:28:02 UTC 2006 Fakecall was run successfully, run verified

The above is from my cronlog-main. It will show you if Fakecall is the result of a reboot or a scheduled daily Fakecall.
alert5 is offline   Reply With Quote
Old 05-26-2006, 04:07 PM   #1577
isdnmatt
Registered User
 
Join Date: Feb 2005
Posts: 36
Is there something wrong with the archive that the script is downloading? I was able to use the script about 2 weeks ago, and now I get an error of tar:invalid tar magic.
isdnmatt is offline   Reply With Quote
Old 05-26-2006, 07:23 PM   #1578
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
tar: Invalid tar magic

My problems all started here - "tar: Invalid tar magic"

I downloaded tweak.zip, ftp to the tivo, unziped it there. then from a bash prompt typed sh tweak.sh. Here is what happened:

bash-2.02# sh tweak.sh
Original unpatched tivoapp found in /tvbin. This takes up lots of space and may
interfere with running this script. Enter r to remove it, k to keep it, or e to
exit this this script now so you can FTP it to your PC. Enter r k or e here: r
Downloading latest Enhancement script...
Connecting to {removed url per your restrictions}[69.90.236.30]:80
rbautch_files.tgz 100% |*****************************| 2032 KB 00:00 ETA
Downloaded main scripts successfully!


Running rbautch Hacked Tivo Enhancements...
tar: Invalid tar magic
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Checking your telnet settings. Do you want to continue? [y/n]: y

Do you want to run the "express" version (for advanced users)? [y/n]: n
tweak.sh: /enhancements/start.sh: No such file or directory
bash-2.02# path
bash: path: command not found
bash-2.02# sh tweak.sh
Enhancements directory detected. Run the uninstall script first. Exiting...
bash-2.02# sh tweak-uninstall.sh
tweak-uninstall.sh: tweak-uninstall.sh: No such file or directory
bash-2.02#


I can't install, can't uninstall. Kind of stuck. The main thing I was wanting from the script was the usb2 drivers. What should I do now?

Thanks,
Harvey
eclipsme is offline   Reply With Quote
Old 05-26-2006, 07:50 PM   #1579
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by eclipsme
My problems all started here - "tar: Invalid tar magic"

I downloaded tweak.zip, ftp to the tivo, unziped it there. then from a bash prompt typed sh tweak.sh. Here is what happened:

bash-2.02# sh tweak.sh
Original unpatched tivoapp found in /tvbin. This takes up lots of space and may
interfere with running this script. Enter r to remove it, k to keep it, or e to
exit this this script now so you can FTP it to your PC. Enter r k or e here: r
Downloading latest Enhancement script...
Connecting to {removed url per your restrictions}[69.90.236.30]:80
rbautch_files.tgz 100% |*****************************| 2032 KB 00:00 ETA
Downloaded main scripts successfully!


Running rbautch Hacked Tivo Enhancements...
tar: Invalid tar magic
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Checking your telnet settings. Do you want to continue? [y/n]: y

Do you want to run the "express" version (for advanced users)? [y/n]: n
tweak.sh: /enhancements/start.sh: No such file or directory
bash-2.02# path
bash: path: command not found
bash-2.02# sh tweak.sh
Enhancements directory detected. Run the uninstall script first. Exiting...
bash-2.02# sh tweak-uninstall.sh
tweak-uninstall.sh: tweak-uninstall.sh: No such file or directory
bash-2.02#


I can't install, can't uninstall. Kind of stuck. The main thing I was wanting from the script was the usb2 drivers. What should I do now?

Thanks,
Harvey
Download Alphawolfs all in one utilities and install them on your tivo. Then either try to run the script again, or try out the tar command on the /enhancements/rbautch_files.tgz archive first. I'll check the archive to make sure nothing is wrong with it.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-26-2006, 08:38 PM   #1580
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
I think it's the archive itself. I'll uploaded it again to see if it fixes it.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-26-2006, 09:32 PM   #1581
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Fixed it. tar magic is good again. Try it now.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 05-27-2006, 07:19 AM   #1582
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
Hmm. You may have fixed the original problem - don't know - haven't been able to get that far yet. I still can't install or uninstall. Here is a dump:

bash-2.02# unzip tweak.zip
Archive: tweak.zip
replace tweak.sh? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: tweak.sh
bash-2.02# ls
tweak.sh tweak.zip
bash-2.02# sh tweak.sh
Enhancements directory detected. Run the uninstall script first. Exiting...
bash-2.02# sh tweak-uninstall.sh
tweak-uninstall.sh: tweak-uninstall.sh: No such file or directory
bash-2.02#

Harvey
eclipsme is offline   Reply With Quote
Old 05-27-2006, 07:44 AM   #1583
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
Quote:
Originally Posted by rbautch
Download Alphawolfs all in one utilities and install them on your tivo. Then either try to run the script again, or try out the tar command on the /enhancements/rbautch_files.tgz archive first. I'll check the archive to make sure nothing is wrong with it.

BTW - I have the busybox utilities on my tivo - is that what you mean here? I tried to tar the rbautch_files.tgz archive, but with the same error, of course. Without being able to run the original script, this archive still has the problem that you seem to have solved. I am thinking of deleting the enhancments folder, and then starting over, but am leary without hearing from you first. I will hang tight.

Thanks for the help,

Harvey
eclipsme is offline   Reply With Quote
Old 05-27-2006, 09:05 AM   #1584
SteelersFan
"On Welfare"
 
SteelersFan's Avatar
 
Join Date: Sep 2004
Location: Saugus, CA
Posts: 819
Quote:
Originally Posted by eclipsme
Hmm. You may have fixed the original problem - don't know - haven't been able to get that far yet. I still can't install or uninstall. Here is a dump:

bash-2.02# unzip tweak.zip
Archive: tweak.zip
replace tweak.sh? [y]es, [n]o, [A]ll, [N]one, [r]ename: y
inflating: tweak.sh
bash-2.02# ls
tweak.sh tweak.zip
bash-2.02# sh tweak.sh
Enhancements directory detected. Run the uninstall script first. Exiting...
bash-2.02# sh tweak-uninstall.sh
tweak-uninstall.sh: tweak-uninstall.sh: No such file or directory
bash-2.02#

Harvey
Two possibilities:
1. Try: sh tweak_uninstall.sh (Notice the underscore instead of the dash)
2. Try ftp'ing a fresh copy of tweak_uninstall.sh (or tweak-uninstall.sh) and try again.
__________________
6 x S2DTivos
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
HR21-700, HR21-100
SteelersFan is offline   Reply With Quote
Old 05-27-2006, 09:18 AM   #1585
slydog75
Not all that sly
 
slydog75's Avatar
 
Join Date: Jul 2004
Location: Warminster, PA
Posts: 9,195
Quote:
Originally Posted by SteelersFan
Two possibilities:
1. Try: sh tweak_uninstall.sh (Notice the underscore instead of the dash)
2. Try ftp'ing a fresh copy of tweak_uninstall.sh (or tweak-uninstall.sh) and try again.
Problem is he doesn't have a tweak_uninstall.sh (at least not in that directory). When he did a list there was only tweak.sh and tweak.zip. tweak_uninstall.sh is created when you run tweak.sh so he's kinda in a catch 22.

I think deleting your enhancements directory may do the trick. Actually don't delete it just rename it so the script doesn't see it. Then if this messes something else up you can just rename it back.
__________________
--Adam--

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"The trouble with quotes on the Internet is that you can never know if they are genuine." - Mark Twain
slydog75 is offline   Reply With Quote
Old 05-27-2006, 09:23 AM   #1586
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
Quote:
Originally Posted by SteelersFan
Two possibilities:
1. Try: sh tweak_uninstall.sh (Notice the underscore instead of the dash)
2. Try ftp'ing a fresh copy of tweak_uninstall.sh (or tweak-uninstall.sh) and try again.
I tried it from both the tweak and the enhancements directory. The problem here, I think, is that the uninstall script never got installed.

Where would I ftp it from? The only file on my computer is the new tweak.zip (as of this morning).

Can I do a manual uninstall?

Can I manually run the script that installs the usb drivers?

Here is listing of the enhancments directory, if it helps:

bash-2.02# ls
LG-standard-v193.slice fakecall.osd
License.txt fakecall.tcl
TWP_archive.tgz ipflags.tcl
TWPrestart.sh joe.tgz
backup.itcl ncid-0.61.series2-tivo.tgz
backup_run.sh net-launch.sh
backup_write_static.tcl net-status.tcl
cert-remover.tcl netperf
ckwireless.tcl netserver
crond.bin network-delete.tcl
dbload30.tcl network-en.tcl
delete.tcl new_splash_rcb.png
drivers rbautch_files.tgz
endpad.tcl varhacks
endpadplus.tcl
bash-2.02#

Thanks again,
Harvey
eclipsme is offline   Reply With Quote
Old 05-27-2006, 09:50 AM   #1587
SteelersFan
"On Welfare"
 
SteelersFan's Avatar
 
Join Date: Sep 2004
Location: Saugus, CA
Posts: 819
Quote:
Originally Posted by eclipsme
Where would I ftp it from? The only file on my computer is the new tweak.zip (as of this morning).

Harvey
Here is where the file is. Copy it to your PC then FTP from PC to Tivo. During he last Zipper install I did it put that file into the /hacks folder.
__________________
6 x S2DTivos
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
!
HR21-700, HR21-100
SteelersFan is offline   Reply With Quote
Old 05-27-2006, 09:50 AM   #1588
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
Quote:
Originally Posted by slydog75
Problem is he doesn't have a tweak_uninstall.sh (at least not in that directory). When he did a list there was only tweak.sh and tweak.zip. tweak_uninstall.sh is created when you run tweak.sh so he's kinda in a catch 22.

I think deleting your enhancements directory may do the trick. Actually don't delete it just rename it so the script doesn't see it. Then if this messes something else up you can just rename it back.
Yes, exactly.

I renamed enhancements and re-ran the tweak script. It just finished and I am rebooting. "Almost there...." I didn't replace the splash screen, but did most everything else.

I am always most concerned at this point. Will it actually boot? Will running the uninstall script remove all changes? I do I do that with a Tivo that won't boot? Pull the drive, I guess, and do it from a PC.

Now I have 'acquiring information from satellite..." Looking good so far.

Now a blank screan and... HOORAY! I have TV again. Thanks for all the help, everyone. I am off to explore what I have done.

Harvey
eclipsme is offline   Reply With Quote
Old 05-27-2006, 09:55 AM   #1589
slydog75
Not all that sly
 
slydog75's Avatar
 
Join Date: Jul 2004
Location: Warminster, PA
Posts: 9,195
Gratz and enjoy!
__________________
--Adam--

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


"The trouble with quotes on the Internet is that you can never know if they are genuine." - Mark Twain
slydog75 is offline   Reply With Quote
Old 05-27-2006, 05:02 PM   #1590
eclipsme
Registered User
 
Join Date: May 2006
Posts: 24
One note... well, maybe 2 or 3...

If you let the script change the bash prompt, tytools will also need to be told what the new prompt is or tserver will not work. Actually, it is tserver where the problem is, but you change the the expected prompt in tytools.

Also, I had a minor problem with the caller id. My tv overscans a bit too much for my taste, but there seems to be no permanant way to change that, even through service codes. Caller id by default comes up at the very top of the screen, which was mostly cut off on my set. This behavior is changable in the out2osd.conf file found in /enhancements/varhacks/hack/etc. This does not seem to be the default location for this file, but is where I found it after using this script.

All in all, very happy and very greatful to rbautch for the script and to those who helped me out.

BTW - my network speed has increased 4 fold thanks to the usb2 driver! Yay!

Harvey
eclipsme is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 11:26 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |