TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Underground Playground > TiVo Underground
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 12-11-2005, 11:37 AM   #961
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by Greencat
I am trying to upgrade the script. I originally had a script dated 8/2/05. I ran the uninstall and it appeared to work.



I then ftp the new script, ran dos2unix, ran the script
and the script ran until it got this error


This is a log of the script


The script then went to the bash. I can't run the uninstall since it's not on the tivo.

I can't re-run the script. Any suggestions?
Thanks
Sounds like your mixing versions of the script. Make sure you delete the old tweak.sh and rbautch_files.tgz before attempting to run it. Also sounds like your DNS isnt set right, but the script will fix it for you. Also, delete the /enhancements directory, which should allow you to re-run the script.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by rbautch : 12-11-2005 at 12:05 PM.
rbautch is offline   Reply With Quote
Old 12-12-2005, 12:11 AM   #962
Runch Machine
Registered User
 
Join Date: Feb 2002
Location: Minneapolis
Posts: 1,048
Multiroom Viewing after the Zipper

I've zipped my Samsung Directivo and are thrilled with the results. I've been reading up on multiroom viewing and transfering shows between Tivos. Is it possible to transfer programs between my Zipped Samsung DirecTivo and my Toshiba DVD recorder/Tivo DVR? The Toshiba has a paid subscription to the Tivo service. The Message I get when I try to access the other Tivo is that the machine I am trying to access is not enabled for MRV. Go to Tivo.com/manage to add it to the accound.

Of course there is no way to add a Directv/Tivo to my Tivo account. Is there any way around this?

If this isn't the proper place to post this, please direct me the the proper forum. Thanks.
__________________
Sony HDTV KDF-70XBR950 70" LCD RPTV
Tivo Series 3 with 750gig Esata drive
Channel Master 4228 in attic for perfect over the air reception.
DirecTV HR20 DVR with 1 terrabyte Drive inside.
Runch Machine is offline   Reply With Quote
Old 12-12-2005, 10:47 AM   #963
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
I'm not sure, but you might try copying this to a new thread to get more exposure.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-12-2005, 11:20 AM   #964
rpdre1
Registered User
 
Join Date: Feb 2005
Posts: 273
from the superpatch release notes:

WHO NEEDS IT
It is necessary to enable HMO/MRV, using this patch, on DTivos running 6.x because this capability isn't provided with 6.x software versions nor is it available as a paid service.

All SA tivos have the HMO/MRV service available with a proper (i.e, not BASIC) service level. SA tivo owners only require superpatch-67all if:

1. You want to MRV unencrypted video that was recorded using the NoCSO (record video unencrypted for later extraction) patch.
2. You want to MRV with other DTivos NOT IN YOUR GROUP CERT, like DTivos running 4.x or 6.x

You can find out more about what exactly, HMO and MRV services are at TiVo.com.

Superpatch-67all checks your tivo software version and patches any 6.x, or 7.x, tivo software version appropriately using 'selectively kill blowfish' patch locations and, in addition, will allow SA tivo owners to continue to call in for guide updates.
Note: You can't MRV between hacked(recording unscrambled) and unhacked(recording scrambled) tivos.





so you will need to hack your standalone to get telnet and ftp access (you cant use the zipper on the standalone) and then run the superpatch on the sa.

you will need to unscramble the existing recordings and extract/reinsert them on the SA before you will be able to mrv them to the dtivo.

i think you will be able mrv the post-superpatch SA recordings but the pre-superpatch recordings will not be able to be mrv'd until you unscramble them.

.. yea its complicated and you WILL have to do a lot of reading.

you cant talk about extraction/insertion here so go to http://www.google.com/search?q=the+other+tivo+forum
(first link; ddb forum)
rpdre1 is offline   Reply With Quote
Old 12-12-2005, 06:34 PM   #965
mjhorv
Registered User
 
Join Date: Nov 2005
Location: PA
Posts: 6
I am getting this error when trying to run new script. I am using a mac and using telnet -K command. i ran unistall and deleted enhancements folder and rbautch_files.tgz. any ideas?
LT-bash# sh tweak.sh
tweak.sh: line 15: syntax error near unexpected token `elif'
'weak.sh: line 15: ` elif [ "$tivoapp" = "e" ]; then
mjhorv is offline   Reply With Quote
Old 12-12-2005, 06:50 PM   #966
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by mjhorv
I am getting this error when trying to run new script. I am using a mac and using telnet -K command. i ran unistall and deleted enhancements folder and rbautch_files.tgz. any ideas?
LT-bash# sh tweak.sh
tweak.sh: line 15: syntax error near unexpected token `elif'
'weak.sh: line 15: ` elif [ "$tivoapp" = "e" ]; then
Did you transfer the file to your tivo in binary mode?
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-12-2005, 06:52 PM   #967
mjhorv
Registered User
 
Join Date: Nov 2005
Location: PA
Posts: 6
didn't run dos2unix. it is working now. thanks
mjhorv is offline   Reply With Quote
Old 12-13-2005, 02:00 PM   #968
matrix165
Registered User
 
Join Date: Dec 2005
Posts: 7
skipping callerid setup and other enhancements

/tivo-vb/showthread.php?p=3550246&highlight=skipping#post3550246


hello all,

thanks for the script, i am using it in conjunction with ZIPPER. i am using it on a rcadvr80 that was previously unhacked. when i run the script it skips many of the enhancement that i want:-(. i first ran it with a "no" to express mode, and got those skipping problems. than i ran the unistall script, and then ran it with a "yes" to express mode and still got the skipping installation problem(but i do got pretty bash;-).
i referenced the post above, as a similar problem but i dont understand, if he fixed the problem or not.
matrix165 is offline   Reply With Quote
Old 12-13-2005, 02:13 PM   #969
Gunnyman
Super FunBall
 
Gunnyman's Avatar
 
Join Date: Jul 2003
Location: Greenville SC
Posts: 29,067
did you follow the directions for telnet with XP and service pack 2? this is a classic symptom of not doing so.
__________________
It's a sociological cornucopia of silliness.
Gamertag: GGwallen
Gunnyman is offline   Reply With Quote
Old 12-13-2005, 03:11 PM   #970
matrix165
Registered User
 
Join Date: Dec 2005
Posts: 7
thanks gunnyman, that was the problem...

i had already done that fix in xp, but i was using putty.exe and forgot to uncheck the return key.

have i told you guys u are doing a wonderful job, lately? thanks so much...
matrix165 is offline   Reply With Quote
Old 12-13-2005, 04:58 PM   #971
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
I would like to distribute or link to a free telnet client with the script that does not add extra carriage returns, or has a setting to supress them. Is putty such a client? Does anyone have any other recommendations? I use absolute telnet myself, which aint free.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-13-2005, 05:50 PM   #972
Gunnyman
Super FunBall
 
Gunnyman's Avatar
 
Join Date: Jul 2003
Location: Greenville SC
Posts: 29,067
Russ I just ran the enhance script using windows built in Hyperterminal with no issues with extra CR.
__________________
It's a sociological cornucopia of silliness.
Gamertag: GGwallen
Gunnyman is offline   Reply With Quote
Old 12-13-2005, 06:28 PM   #973
Greencat
Registered User
 
Join Date: Jan 2004
Location: Grand Rapids MI
Posts: 169
Quote:
Originally Posted by rbautch
Sounds like your mixing versions of the script. Make sure you delete the old tweak.sh and rbautch_files.tgz before attempting to run it. Also sounds like your DNS isnt set right, but the script will fix it for you. Also, delete the /enhancements directory, which should allow you to re-run the script.
I deleted the files and the directory and had the same problem. I tried my other tivo and the same results.

Quote:
bash-2.02# sh /var/packages/tweak.sh
mv: rbautch-files.tgz: No such file or directory
Running rbautch Hacked Tivo Enhancements...
tar: /enhancements/rbautch-files.tgz: No such file or directory
Do you want to run the "express" version (for advanced users)? [y/n]: n
chmod: /enhancements/*: No such file or directory
/var/packages/tweak.sh: /enhancements/start.sh: No such file or directory
bash-2.02#
Any suggestions? These Dtivos were not upgraded with the zipper. Does that make a difference?
Greencat is offline   Reply With Quote
Old 12-13-2005, 08:07 PM   #974
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by Greencat
tar: /enhancements/rbautch-files.tgz: No such file or directory
This means you're running an old script (where the archived had a dash instead of an underline in "rbautch_files.tgz". I changed the file name to be consistent with html website requirements. Get the latest script from the first post in this thread.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-14-2005, 07:15 AM   #975
matrix165
Registered User
 
Join Date: Dec 2005
Posts: 7
putty.exe and extra carriage return...

you can remove the extra carriage return in putty.exe, by unchecking the box under catagory/connection/telnet, labeled "return key sends telnet new line instead of M"

i hope this helps...;-)
matrix165 is offline   Reply With Quote
Old 12-14-2005, 06:57 PM   #976
Greencat
Registered User
 
Join Date: Jan 2004
Location: Grand Rapids MI
Posts: 169
Quote:
Originally Posted by rbautch
Sounds like your mixing versions of the script. Make sure you delete the old tweak.sh and rbautch_files.tgz before attempting to run it. Also sounds like your DNS isnt set right, but the script will fix it for you. Also, delete the /enhancements directory, which should allow you to re-run the script.
Still no luck

Quote:
bash-2.02# cd /var/packages
bash-2.02# ls
tweak.sh
bash-2.02# sh /var/packages/tweak.sh
Downloading latest Enhancement script...
wget: www.mastersav.com: Host name lookup failure

Downloaded main scripts successfully!
Running rbautch Hacked Tivo Enhancements...
tar: Short read
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Do you want to run the "express" version (for advanced users)? [y/n]: n
/var/packages/tweak.sh: /enhancements/start.sh: No such file or directory
Do you want to continue? [y/n]: y

bash-2.02# find rbautch*
/enhancements/rbautch_files.tgz
bash-2.02# find tweak*
/var/packages/tweak.sh
bash-2.02#
Is there a problem with the no such file or directory error?

Does the script only work on systems upgraded with the zipper?

Is there a way to create a log or can I enter the script steps manually to see why it fails? I gave the full path to tweak just incase there is another tweak on the drive. Also you can see that I used Find to look for duplicate entries.

Last edited by Greencat : 12-15-2005 at 07:06 AM.
Greencat is offline   Reply With Quote
Old 12-14-2005, 09:42 PM   #977
tbeckner
TiVo Fan
 
Join Date: Oct 2001
Location: Bend, OR, USA
Posts: 1,352
Quote:
Originally Posted by matrix165
you can remove the extra carriage return in putty.exe, by unchecking the box under catagory/connection/telnet, labeled "return key sends telnet new line instead of M"

i hope this helps...;-)
Or you can very simply run telnet with a vt100 selection, which takes care of the extra CRs.

Telnet -t vt100 <IP Address or WIN/DNS name>
__________________
Orig Join Date: 5/2000
TiVo 540 8.1 1/26/2007
Sony SVR-2000 3.0 5/23/2000
(3) Hughes HDVR2 6.2
(2) Hughes SD-DVR80 6.2
(2) Buggy HR24 6/25/2011
DirecTV 10/94
tbeckner is offline   Reply With Quote
Old 12-15-2005, 10:38 AM   #978
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by Greencat
Is there a problem with the no such file or directory error?
No

Quote:
Does the script only work on systems upgraded with the zipper?
No

The download is failing because your DNS settings are not correct. The script is set up to detect if the download fails, and then prompts you to fix the DNS settings. The problem is that this
Quote:
Host name lookup failure
does not jive with this:
Quote:
Downloaded main scripts successfully!
The script reports success only if the file rbautch_files.tgz is resident in your current directory (indicating a successful download), and it won't change the DNS settings unless that file is not there.

First, confirm that you are using the latest version of the script from the first post in this thread. Then confirm that the files archive is NOT in your current directory and then rerun the script to see if it catches the failure and prompts you to enter new DNS settings. If you get the same result, check again if the files archive is in your current directory.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-15-2005, 11:21 AM   #979
dfriedland
Registered User
 
Join Date: Apr 2002
Posts: 36
Quote:
Originally Posted by Greencat
Still no luck



Is there a problem with the no such file or directory error?

Does the script only work on systems upgraded with the zipper?

Is there a way to create a log or can I enter the script steps manually to see why it fails? I gave the full path to tweak just incase there is another tweak on the drive. Also you can see that I used Find to look for duplicate entries.


Same exact problem here!!!!
dfriedland is offline   Reply With Quote
Old 12-15-2005, 12:01 PM   #980
dfriedland
Registered User
 
Join Date: Apr 2002
Posts: 36
I can install the older version of the enhancement scripts, but as soon as i run tweak-uninstall.sh, and re-run the NEW tweak.sh I get the same errors as above:
Downloading latest Enhancement script...
wget: www.mastersav.com: Host name lookup failure

Downloaded main scripts successfully!
Running rbautch Hacked Tivo Enhancements...
tar: Short read
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Do you want to run the "express" version (for advanced users)? [y/n]: n
/var/packages/tweak.sh: /enhancements/start.sh: No such file or directory
Do you want to continue? [y/n]: y

And then it exits......I've erased the old tweak files, the enhancements dir, and I still get the same. Any ideas?
It won't even let me adjust the DNS.
dfriedland is offline   Reply With Quote
Old 12-15-2005, 12:26 PM   #981
GaryD9
Registered User
 
Join Date: Mar 2002
Location: Gaithersburg, MD
Posts: 90
Quote:
Originally Posted by rbautch (from the Zipper thread)
Yea, let's move it over there. There is a thread on DDB on how to build a MIPS cross compiler on cygwin, which was started by tmesis. I've been trying for a few weeks to build it, with no luck so far. I know what you mean about busybox, I want to compile a full featured version of wget. My problem is likely that I learn everything from Google, and I've never compiled or cross-compiled anything in my life. Google has taught me quite a bit of tcl and the customized version of tcl that tivo uses called tivosh. I'd be happy to help you fill in the gaps. Let me know exactly what you want the script to do.
cygwin? Compile linux stuff on a Win32 machine? Ugh! It should be easier to find a cross compiler from linux (x32 or x64) to linux (mips)

Actually, I already have something similar: a linux mips cross compiler for compiling binaries to my linux-based Linksys router... I'll have to dig some...

What I want, in the end, is a simple way to know how long the box has been up. This would be similar to 'uptime', but NOT in human readable form. I can also get it from "cat /proc/uptime" and doing some math - but I'd have to parse the contents of uptime first (uptime contains TWO numbers: number of seconds since booting, and number of IDLE seconds (not exactly, but close) since reboot.

In C, this is trivial: call a kernel function to get, basically, the same thing that /proc/uptime provides, but in a structure. Then, take the proper element of the structure, do the math (/60/60/24) and return the value.

I'll try to find time (ha!) tonight to find a cross compiler... Perhaps I should just write the silly thing as a daemon so its not dependent on crond... hmmm

(For those not reading the zipper thread - I'm trying to rework the reboot portion of rbauth's stuff to conditionally reboot based on: only FORCE a reboot if the system has been up 6 days. Otherwise, attempt a reboot if not recording once a day if the system has been up over 3 days.. )
GaryD9 is offline   Reply With Quote
Old 12-15-2005, 12:37 PM   #982
Greencat
Registered User
 
Join Date: Jan 2004
Location: Grand Rapids MI
Posts: 169
Quote:
Originally Posted by rbautch
The download is failing because your DNS settings are not correct. The script is set up to detect if the download fails, and then prompts you to fix the DNS settings. The problem is that this does not jive with this: The script reports success only if the file rbautch_files.tgz is resident in your current directory (indicating a successful download), and it won't change the DNS settings unless that file is not there.
Could it be finding the file from another Dtivo on the network and downloading it? When I get home tonight I will try the new script again but I think I have done this many times with no sucess. I used the find command to look for extra rbautch_files.tgz files and never find one.

Should I try to fix the DNS first? Is there a script for it since 6.2 took the menu option out?

Thanks for your help
Greencat is offline   Reply With Quote
Old 12-15-2005, 03:09 PM   #983
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by GaryD9
cygwin? Compile linux stuff on a Win32 machine? Ugh! It should be easier to find a cross compiler from linux (x32 or x64) to linux (mips)

Actually, I already have something similar: a linux mips cross compiler for compiling binaries to my linux-based Linksys router... I'll have to dig some...

What I want, in the end, is a simple way to know how long the box has been up. This would be similar to 'uptime', but NOT in human readable form. I can also get it from "cat /proc/uptime" and doing some math - but I'd have to parse the contents of uptime first (uptime contains TWO numbers: number of seconds since booting, and number of IDLE seconds (not exactly, but close) since reboot.

In C, this is trivial: call a kernel function to get, basically, the same thing that /proc/uptime provides, but in a structure. Then, take the proper element of the structure, do the math (/60/60/24) and return the value.

I'll try to find time (ha!) tonight to find a cross compiler... Perhaps I should just write the silly thing as a daemon so its not dependent on crond... hmmm

(For those not reading the zipper thread - I'm trying to rework the reboot portion of rbauth's stuff to conditionally reboot based on: only FORCE a reboot if the system has been up 6 days. Otherwise, attempt a reboot if not recording once a day if the system has been up over 3 days.. )
This bad boy will give you the current "up time" in days:
Code:
x=86400; secup=`cat /proc/uptime | cut -d '.' -f0`; daysup=$(($secup / $x)); echo $daysup

__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-15-2005, 03:13 PM   #984
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by Greencat
Could it be finding the file from another Dtivo on the network and downloading it? When I get home tonight I will try the new script again but I think I have done this many times with no sucess. I used the find command to look for extra rbautch_files.tgz files and never find one.

Should I try to fix the DNS first? Is there a script for it since 6.2 took the menu option out?

Thanks for your help
You can fix DNS by editing the /etc/resolv.conf file with your routers IP address. I selfishly want to get to the root of the problem in case there is an anomoly in the script, so I'd rather you try to get the script to do it for you instead of doing it manually.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-15-2005, 03:48 PM   #985
Greencat
Registered User
 
Join Date: Jan 2004
Location: Grand Rapids MI
Posts: 169
Quote:
Originally Posted by rbautch
I selfishly want to get to the root of the problem in case there is an anomoly in the script, so I'd rather you try to get the script to do it for you instead of doing it manually.
If the script can not download without the DNS how does it find rbautch_files.tgz? I did a find command on rbautch* and only found the file in /enhancements. Since I deleted this directory each time it must be finding this somewhere on the lan?

Will it hurt if I rename rbautch_files.tgz on the Dtivo that is working to test if the script is finding it there?

Is the IP address the router address. For example 192.168.10.1. I didn't think that was a DNS but does it forward the request on to my ISP DNS?

Thanks for your help
Greencat is offline   Reply With Quote
Old 12-15-2005, 04:32 PM   #986
rbautch
User
 
Join Date: Feb 2004
Location: Chicago, IL
Posts: 3,628
Quote:
Originally Posted by Greencat
If the script can not download without the DNS how does it find rbautch_files.tgz? I did a find command on rbautch* and only found the file in /enhancements. Since I deleted this directory each time it must be finding this somewhere on the lan?
It's not finding it on your LAN, but if it keeps showing up, I think that it may be creating a "dummy file" that's actually empty. Try FTPing the rbautch_files.tgz arhive to you pc and see if there's anything in there.
Quote:
Will it hurt if I rename rbautch_files.tgz on the Dtivo that is working to test if the script is finding it there?
Won't hurt, but I doubt that's what's happening. You can test it by just disconnecting your other tivos.

Quote:
Is the IP address the router address. For example 192.168.10.1. I didn't think that was a DNS but does it forward the request on to my ISP DNS?
On a typical network setup, your router address is your DNS address.
__________________
DSR7000 x 4, HR10-250, Prom Modded R10

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
or
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
rbautch is offline   Reply With Quote
Old 12-15-2005, 07:28 PM   #987
dfriedland
Registered User
 
Join Date: Apr 2002
Posts: 36
Quote:
Originally Posted by rbautch
You can fix DNS by editing the /etc/resolv.conf file with your routers IP address. I selfishly want to get to the root of the problem in case there is an anomoly in the script, so I'd rather you try to get the script to do it for you instead of doing it manually.
Hmmmm. I went to edit my file, and it already had my correct router address in it.
dfriedland is offline   Reply With Quote
Old 12-15-2005, 07:37 PM   #988
GaryD9
Registered User
 
Join Date: Mar 2002
Location: Gaithersburg, MD
Posts: 90
Quote:
Originally Posted by rbautch
This bad boy will give you the current "up time" in days:
Code:
x=86400; secup=`cat /proc/uptime | cut -d '.' -f0`; daysup=$(($secup / $x)); echo $daysup
That'll work for now. I'll give you a 'complete' script in an hour or two. It won't be completely tested (of course), but it SHOULD work. Once I have a cross compiler going (this weekend?) I'll write a seperate daemon for doing this - removing the reliance on crond, allowing a "window" of reboot times (ie: Tivo can reboot anytime between 08:10 UTC and 10:10 UTC if nothing is recording..), etc.
GaryD9 is offline   Reply With Quote
Old 12-15-2005, 08:25 PM   #989
Greencat
Registered User
 
Join Date: Jan 2004
Location: Grand Rapids MI
Posts: 169
Quote:
Originally Posted by rbautch
It's not finding it on your LAN, but if it keeps showing up, I think that it may be creating a "dummy file" that's actually empty. Try FTPing the rbautch_files.tgz arhive to you pc and see if there's anything in there.
.
Your correct the file is zero bytes. What would you suggest?

I tried adding the DNS and running the script. This is the results. I wanted to see how far it would get. I have another tivo that I did not change the DNS.


Quote:
bash-2.02# sh tweak.sh
Downloading latest Enhancement script...
Connecting to www.mastersav.com[69.90.236.30]:80
wget: Unable to connect to remote host (69.90.236.30): Network is unreachable

Downloaded main scripts successfully!

Running rbautch Hacked Tivo Enhancements...
tar: Short read
mv: /enhancements/tweak_uninstall.sh: No such file or directory
Do you want to run the "express" version (for advanced users)? [y/n]: y
cat: /enhancements/start.sh: No such file or directory
Do you want to continue? [y/n]: y

bash-2.02#
I did this with the firewall onthe router turned off. Is this using port 80 and do some ISPs block that port?

Last edited by Greencat : 12-15-2005 at 08:46 PM.
Greencat is offline   Reply With Quote
Old 12-15-2005, 08:28 PM   #990
GaryD9
Registered User
 
Join Date: Mar 2002
Location: Gaithersburg, MD
Posts: 90
Okay, I've changed my crontab to remove the reboot warning osd's, and changed the crontab entry for the actual reboot to call this script:

I've barely tested this, but I don't see why it wouldn't work. At least the timers work.

In the meantime, I'm pulling the S2 cross compiler toolchain (source) right now to see if I can get a cross-compiler working on my amd64 linux server. If so, I'll probably replace this script with (as mentioned earlier) a single executable that does it's own time checking, can handle ranges, etc...
Code:
#/bin/sh
daysup=$((`cat /proc/uptime | cut -d '.' -f0` / 86400));
# daysup=$((`cat /var/uptime | cut -d '.' -f0` / 86400));

if [ $daysup -gt 5 ]; then
  echo 'SCHEDULED REBOOT IN 20 MINUTES...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  sleep 10m
  echo 'SCHEDULED REBOOT IN 10 MINUTES...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  sleep 10m
  echo 'SCHEDULED REBOOT IN 10 SECONDS...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  reboot
elif [ $daysup -gt 3 ]; then
  echo 'SCHEDULED REBOOT IN 20 MINUTES (if not recording)...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  sleep 10m
  echo 'SCHEDULED REBOOT IN 10 MINUTES (if not recording)...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  sleep 10m
  echo 'SCHEDULED REBOOT IN 10 SECONDS (if not recording)...' | /var/hack/bin/out2osd -c1 -fblack1 -byellow -d3
  tivosh /enhancements/safereboot.tcl; echo "`date` SCHEDULED REBOOT" >> /var/spool/cron/cronlogs/CRONLOG-MAIN
fi

GaryD9 is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 11:30 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |