TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > DirecTV TiVo Powered PVRs & Receivers
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 04-15-2013, 08:31 PM   #1
chamelea
Registered User
 
Join Date: Feb 2004
Location: USA West Coast
Posts: 108
Dead Buffer Workaround

WORKAROUND: I just discovered that setting a "record" instruction for the channel with a dead buffer will reset the non-functional buffer. Upon noticing a channel lacked its green time-bar (i.e., a dead buffer), I pressed the Guide button, then clicked on the very next scheduled program for that dead channel (should be within the next half-hour). As soon as the scheduled recording began, the dead buffer was reactivated.

Yes, the red reset button DOES reactivate a dead buffer, but that workaround disables both tuners for 5 minutes or more, while also losing some settings and user prefs or pointers in the DVR. I evolved the above workaround for a dead buffer this morning, when trying to avoid a full reset.

BACKGROUND: In my experience, pausing a dead buffer freezes the green-bar progress timer (at say 26 mins). If I try to record the channel with a dead buffer, I just get a blank recording (black screen) that's also frozen at that same timer point. Changing by one channel (up or down) DOES activate a new buffer for that new channel. But I find upon retuning to the original channel that it still has a non-functioning, dead buffer.

Today, scheduling RECORD for the next program break re-started the buffer. Hoping others finding a dead buffer might please check out the workaround & report back.
__________________

Nov '12 SWM Dish w/ THR22-100
Now retired: Oct '02 Elliptical dish
Sony SAT-60, Phillips 7000, HR10-250 w/PTVnet)
chamelea is offline   Reply With Quote
Old 04-21-2013, 12:06 AM   #2
Klankster
Registered User
 
Join Date: Aug 2004
Location: Port Washington, WI
Posts: 86
Very interesting -- we had this "dead buffer" issue months ago, and it was so bad that we were on the verge of seeing if getting a new unit would fix the problem. Then one day the problem stopped -- we didn't see the "dead buffer" issue for quite a while -- months in fact.

Then about a week ago my wife reported that she had paused a program to answer the phone and when she tried to unpause it, it was stuck -- the old problem was back! This sounds like what you call a "dead buffer" and it's gotten very bad again -- it happened a couple of times today alone. We just did a system restart to see if that clears up the problem, but I have to wonder what is going on with this unit!

We have a Series 3 that we keep around to pick OTA broadcasts from Milwaukee and it has NEVER had this problem. We had the prior DirecTV HD TiVo and an original broadcast TiVo and of all of them, the DirecTV TiVo is the ONLY one that ever did this to us.

Does anyone know if TiVo is aware of this bug? It's a serious one, and I'm just glad we're not the only people experiencing it.

I'll try your fix the next time I see the problem show up -- am I reading it right in that you have to wait up to half an hour (the point where the scheduled record starts) to pick up watching the program you had paused? While an OK workaround as these things go, TiVo really needs to fix this bug.
__________________
Tom Hudson

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Klankster is offline   Reply With Quote
Old 04-22-2013, 06:28 PM   #3
chamelea
Registered User
 
Join Date: Feb 2004
Location: USA West Coast
Posts: 108
Dead Buffer on THR-22

Can't say about Series 3, but I've had the THR-22 for some months now and the dead buffer is a recurrent malady, one of the few complaints about the new dTiVo.

Since my original post I've had two or three instances for which the workaround does correct the problem. There are numerous ways to program a recording if your buffer dies, but see notes below.
  1. Click the GUIDE button to call the programming schedule, then SELECT the next-scheduled program block, something from 10 to 45 minutes in the future. This method is valid as a workaround.
  2. Click INFO button to call the channel banner, then press SELECT to begin a recording. This method DOES NOT clear the dead buffer, it simply inserts a blank (black) recording into Now Playing list.
  3. I've also found that I can program a manual recording under the TivoCentral menus, and this approach will also clear the dead buffer.

__________________

Nov '12 SWM Dish w/ THR22-100
Now retired: Oct '02 Elliptical dish
Sony SAT-60, Phillips 7000, HR10-250 w/PTVnet)
chamelea is offline   Reply With Quote
Old 04-29-2013, 09:07 AM   #4
chamelea
Registered User
 
Join Date: Feb 2004
Location: USA West Coast
Posts: 108
I find continuing need to use my workaround to restore a missing buffer. But as I've done so, I believe there's a pattern to the problem, maybe a source of the bug.

I got up early - couldn't sleep - and found one tuner was busy receiving an update. This was NOT the frustrating "enhanced content" but rather a regular data stream, perhaps schedule data or such.

The dialog stated that there were only 2 mins remaining. I elected to just wait, curious about whether their time estimate was accurate. Sure enough, the dialog updated to 30 seconds remaining, even down to 3 seconds remaining, and then restored a live CNN broadcast. I switched tuners to find the same broadcast on both tuners ... one of the dTiVo pet peeves when they fail to restore (and rebuffer) my preferred channels.

However, I also discovered that the buffer on one channel was dead~! If I was to suggest the software engineers study the dead buffer problem, I'd ask them to see if the "unbuffered" maintenance downloads, regular and enhanced content, are failing to restart the buffers when they restore a tuner's broadcast channel.
__________________

Nov '12 SWM Dish w/ THR22-100
Now retired: Oct '02 Elliptical dish
Sony SAT-60, Phillips 7000, HR10-250 w/PTVnet)
chamelea is offline   Reply With Quote
Old 05-03-2013, 05:21 PM   #5
chamelea
Registered User
 
Join Date: Feb 2004
Location: USA West Coast
Posts: 108
I am finding a "dead buffer" almost daily on my THR22. It's frequent enough now that I'm getting over the aggravation mode, and just switch into my fix-it mode. Here's the quickest method I've found to restore the buffer:
  • Switch from the live channel directly to TiVo Central, then to menu choices:
  • to => Find Programs
  • to => Record by Time or Channel
  • to => Set Up Manual Recording
  • Press SELECT, which programs the DVR to begin a recording on that current channel at the next half-hour
On average, there will be about 15 mins to wait before the manual recording begins, which restores the dead buffer.
__________________

Nov '12 SWM Dish w/ THR22-100
Now retired: Oct '02 Elliptical dish
Sony SAT-60, Phillips 7000, HR10-250 w/PTVnet)
chamelea is offline   Reply With Quote
Old 06-06-2013, 01:11 AM   #6
chamelea
Registered User
 
Join Date: Feb 2004
Location: USA West Coast
Posts: 108
FWIW, I just checked my THR-22 to see latest software version is 01B5.

I see that it has been a month since I last posted here. Cannot recall how long ago I last had a dead buffer, but I'm guessing it has been 2 weeks or so. Maybe they actually fixed it ... ??
__________________

Nov '12 SWM Dish w/ THR22-100
Now retired: Oct '02 Elliptical dish
Sony SAT-60, Phillips 7000, HR10-250 w/PTVnet)
chamelea is offline   Reply With Quote
Old 06-06-2013, 09:36 AM   #7
Klankster
Registered User
 
Join Date: Aug 2004
Location: Port Washington, WI
Posts: 86
Glad to hear you've been running OK.

We haven't seen any dead buffers since getting the 01B5 update (fingers crossed). But I did see a message somewhere that another person is still getting dead buffers despite running 01B5, so who knows.

In a semi-related topic, when I complained to TiVo about this, they just passed the buck and said it was DirecTV's problem. So if it starts happening again, we need to complain loud and long to DirecTV support.
__________________
Tom Hudson

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Klankster is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 02:40 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |