TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 10-16-2014, 12:13 AM   #7261
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Quote:
Originally Posted by ThAbtO View Post
I know Comma and Period is used for the Tivo PL browsing windows, but can't they be also used for the remote jump buttons also? I doubt F11 and F12 would work since those are not on MACs.

Trying to think of keys which are paired,

< and > (shifted keys) -> 1st choice
- (dash) and = (equals) -> 2nd choice
I'm talking about screens on the TiVo with virtual keyboards. You can use your keyboard directly when kmttg is on the Remote tab. i.e. Instead of scrolling around in virtual keyboard you can just start typing with your keyboard (for example a-z and many other keys), so many of the keys are already bound for that purpose, hence the use of many non-simple keyboard shortcuts for most buttons.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-16-2014, 12:20 AM   #7262
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,801
Something weird to note:

I am currently resume downloading and the title bar says "download -8% kmttg v1.1d"
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 10-16-2014, 12:31 AM   #7263
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Quote:
Originally Posted by ThAbtO View Post
Something weird to note:

I am currently resume downloading and the title bar says "download -8% kmttg v1.1d"
Press "j" to get info about show in message window and look for:
ByteOffset
size

kmttg uses size-ByteOffset as the approximate total file size to be downloaded when resuming, so if TiVo is not reporting "size" correctly that could be the problem.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-16-2014, 10:21 AM   #7264
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 5,207
Quote:
Originally Posted by npgerry View Post
I need some help with an error I am getting when I try to push to my Premiere using KMTTG and pyTivo.

I used to have no problem pushing to my Premiere, but it has been a while since I have done it (since before the latest update) and now I am getting the following error message from pyTivo:

ERROR: pyTivo.video.video:<error><code>badArgument</code><text>Bad value for pcBodyId in bodyOfferModify: None</text></error>

With pyTivo running on my PC, I am able to see it on the Premier and pull files from it to the Tivo

Any help would be appreciated. Thanks
What happens when you push directly from pyTivo?

1. If you get the same result, you should check your pyTiVo configuration. Also make sure you are using the latest version. If you can't find the problem, post your log in the pyTivo thread.

2. If it works, you should check the pyTivo settings in kmttg.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 10-17-2014, 11:58 AM   #7265
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
I keep seeing this today, when trying to scan for Season Premieres:

>> RUNNING 'REMOTE Season Premieres' JOB FOR TiVo: Living Room
SeasonPremieres - JSONObject["offer"] not found.
>> RUNNING 'REMOTE Channels List' JOB FOR TiVo: Bedroom
Saving channel info to file: C:\kmttg\Bedroom.channels
REMOTE job completed: 0:00:01
---DONE--- job='REMOTE Channels List' TiVo=Bedroom
Saving channel info to file: C:\kmttg\Bedroom.channels
>> RUNNING 'REMOTE Season Premieres' JOB FOR TiVo:Bedroom
SeasonPremieres - JSONObject["offer"] not found.


I've rebooted everything, TiVo and computers, made several service connections, and it just seems like the function quit working, while I have made no changes to anything to cause it. All hardwired, and all networking equipment has been power cycled, and everything is working, except this.
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!
nooneuknow is offline   Reply With Quote
Old 10-17-2014, 12:14 PM   #7266
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Season Premieres relies on connection to mind.tivo.com to work, so could be your connection to that server is not working. I was just able to run a full Season Premiere scan myself however, so it's working for me.
(Also make sure you have at least 1 channel selected in the right side list in Season Premieres tab).
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-17-2014, 12:56 PM   #7267
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
Quote:
Originally Posted by moyekj View Post
Season Premieres relies on connection to mind.tivo.com to work, so could be your connection to that server is not working. I was just able to run a full Season Premiere scan myself however, so it's working for me.
(Also make sure you have at least 1 channel selected in the right side list in Season Premieres tab).
I can ping mind.tivo.com, do everything else I want with kmttg, and do have a customized list of channels selected to the right.

I use the function a lot, and am very familiar with it. It stopped working the night before yesterday. The last thing I did, before it stopped working, was tell all my TiVos to make a service connection, after I had already successfully done a premier scan, and wanted to get the freshest guide data. Several connections later, with indexing and GC completing fine, and some reboots, still not working.

EDIT to Insert: I have also tried clearing the channel lists, and reselecting the channel groups to scan, as well as trying the guide option set to show all channels, instead of what is just enabled in the checklist on each TiVo, which carries the unchecked channels to the premier search channel lists, upon refresh. I tried a lot of things, and gave things a couple days before coming in to report.

Also, a bug/glitch I've seen others report somewhere, around the time of the TiVo software roll, is the remote reboot function. If used on an idle TiVo, it will reboot the TiVo. If used on a TiVo that has had any hand held remote commands sent recently, it will lock out the hand remote (and never reboot it, even later), and I could only regain control of the TiVo by using KMTTG to launch Netflix, then using the TiVo button on the hand remote to exit Netflix. Others have reported having to pull power (I think in the TiVo software threads). At the time, you didn't have the software to verify it could happen. It never happened for me before the update, but I don't remotely reboot that often.
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!

Last edited by nooneuknow : 10-17-2014 at 01:01 PM.
nooneuknow is offline   Reply With Quote
Old 10-17-2014, 01:25 PM   #7268
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
For reboot I'll look at it, but it's probably something I'll just end up removing if it no longer works with updated TiVo software.

For Season Premieres like I said it's working fine for me with 20.4.4a software on Roamio Pro, Premiere and Elite units, so don't know what else to suggest. If it was working for you not long ago and nothing has changed in your environment (TiVo software, Java installation, etc and you are not using TiVo beta software) then the only variable left is middlemind.tivo.com connection (not mind.tivo.com as I said in previous post), so perhaps waiting a couple of days to see if it clears up. I don't have much confidence in reliability of tivo servers, so that's always the top of my suspect list.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-17-2014, 02:49 PM   #7269
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
Quote:
Originally Posted by moyekj View Post
For reboot I'll look at it, but it's probably something I'll just end up removing if it no longer works with updated TiVo software.

For Season Premieres like I said it's working fine for me with 20.4.4a software on Roamio Pro, Premiere and Elite units, so don't know what else to suggest. If it was working for you not long ago and nothing has changed in your environment (TiVo software, Java installation, etc and you are not using TiVo beta software) then the only variable left is middlemind.tivo.com connection (not mind.tivo.com as I said in previous post), so perhaps waiting a couple of days to see if it clears up. I don't have much confidence in reliability of tivo servers, so that's always the top of my suspect list.
I like the reboot function. It had been working fine, until I tried it on TiVos that had not been idle for a while. Perhaps you could "hide" the button, and only make it available when enabled, as a "experimental" function. I haven't seen enough reports, or had it affect me enough, that I mind, as long as I know there are risks of (temporarily) losing command via handheld remote. The amber TiVo LED indicates the commands are received, and core functions go on. It just takes a nudge from within KMTTG to bring and affected TiVo back. I really welcomed the function, and would bet it's fixed by the next TiVo update.

I always check tivo, mind, and middlemind availability, when anything odd is going on, at all. I can ping all of them. Any other tests you can recommend?

I'm not complaining, or expecting you to do anything. I'm just happy KMTTG even exists. It seems like when my base Roamios' pause ads went to the full showcase thumbnails, rather than a single line, which was the height of a menu line, that's when things went wonky, with season premier searches.

Given how TiVo's ad changes have done everything from causing random rebooting, boot looping, end-of-program rebooting, to even full-on bricking, I'd put KMTTG on the bottom of the suspect list. I'm just reporting what I'm seeing.

I keep looking, but have yet to see the usual uproar, when TiVo takes up more screen real-estate with any ad. I made one mention of it, and nobody has confirmed, or denied, sightings of the showcase thumbnails being used as pause ads. Maybe that change broke something. With TiVo's track record, something should have broke, or started malfunctioning, since my ads changed, again.
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!
nooneuknow is offline   Reply With Quote
Old 10-17-2014, 03:27 PM   #7270
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
I'm still getting the "traditional" (skinny light blue background) pause ads as of last night on my Roamio Pro. Though I use SPSPS backdoor which quickly hides pause ads I still see it pop up for an instant when I use pause.

I don't really have anything else to suggest. There is an extended debug mode that can be turned on for RPC debugging, but requires changing 1 line of kmttg code and a new jar file if you really want to go down that road I can generate it for you which may help clarify where the problem starts.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 10-17-2014 at 03:37 PM.
moyekj is offline   Reply With Quote
Old 10-17-2014, 09:48 PM   #7271
Mgalin
Registered User
 
Join Date: Jan 2002
Posts: 43
Help!

Can't connect to my Roamio Pro anymore.. Anyone know what this error means? I am able to use a web browser and get to http://192.168.x.x and get the tivo interface..

Failed to retrieve Now Playing List from RoamioPRO
Exit code: 56
Check YOUR MAK & IP settings
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 31 100 31 0 0 41 0 --:--:-- --:--:-- --:--:-- 41

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0curl: (56) SSLRead() return error -9806
Mgalin is offline   Reply With Quote
Old 10-17-2014, 10:28 PM   #7272
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Mgalin, I'm assuming you are using a Mac? I've been getting several reports from Mac users updating their OS of same problem using curl. Workaround is switch to use Java downloads instead: config-Program Options-Use Java for downloads instead of curl.
Sounds like I just need to default kmttg to use Java downloads instead of curl, at least for Mac platform.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-18-2014, 10:57 AM   #7273
nvt
Registered User
 
Join Date: Aug 2003
Location: MD
Posts: 60
Upgrading to v1.1 e Playlist Blank

I downloaded the latest upgrade v1.1.e and installed and ran
All my settings remained but unlike all previous upgrades that I have applied now I get a blank playlist

I tried refreshing - it appears as refreshing message and then disappear with a blank playlist

I checked the log files and the only error showing

2014_10_18_11:46:49 ERROR: Required 'tivo_password' is not set in pyTivo config file: /Applications/pyTivo/pyTivo.conf

- this is now a new error message as I have this dating back to September
(I did hunt around to see what was missing but cannot find a Password option in this file and am stumped on what my Tivo userID and password is - but this is not my issue)

I checked kmttg for the access to the "REMOTE" and this is workmen fine as I can see my tiro season passes, todo list etc so it is seeing the TiVo(s)

Is there a problem with this latest release or some for m of incompatibility (I just upgraded to Mac OS X 10.10 Yosemite)

Thanks,

Nick
__________________
2 Premiers XL Cablecard
Series 2 540 (Hacked and upgraded)
Lifetime Service and Upgraded
Retired:
Series 2 (240and Dual Tuner 649)
nvt is offline   Reply With Quote
Old 10-18-2014, 11:54 AM   #7274
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Nick, see post above yours. With latest Mac OS update curl no longer works for getting information from TiVos, so you have to switch to Java downloads.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-18-2014, 04:13 PM   #7275
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,076
Quote:
Originally Posted by nvt View Post
2014_10_18_11:46:49 ERROR: Required 'tivo_password' is not set in pyTivo config file: /Applications/pyTivo/pyTivo.conf

- this is now a new error message as I have this dating back to September
(I did hunt around to see what was missing but cannot find a Password option in this file
There are no options in that file until you put them there.

Quote:
am stumped on what my Tivo userID and password is
The same as your account on tivo.com.

Quote:
but this is not my issue
Well, it's not your blank list issue, but it is your (unmentioned) inability to push issue.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 10-18-2014, 09:15 PM   #7276
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
Quote:
Originally Posted by nooneuknow View Post
I keep seeing this today, when trying to scan for Season Premieres:

>> RUNNING 'REMOTE Season Premieres' JOB FOR TiVo: Living Room
SeasonPremieres - JSONObject["offer"] not found.
>> RUNNING 'REMOTE Channels List' JOB FOR TiVo: Bedroom
Saving channel info to file: C:\kmttg\Bedroom.channels
REMOTE job completed: 0:00:01
---DONE--- job='REMOTE Channels List' TiVo=Bedroom
Saving channel info to file: C:\kmttg\Bedroom.channels
>> RUNNING 'REMOTE Season Premieres' JOB FOR TiVo:Bedroom
SeasonPremieres - JSONObject["offer"] not found.


I've rebooted everything, TiVo and computers, made several service connections, and it just seems like the function quit working, while I have made no changes to anything to cause it. All hardwired, and all networking equipment has been power cycled, and everything is working, except this.
It turned out to be that I needed to unselect a few channels that lacked guide data (or typical guide data), or the Premier Search would hang on them.

I'm slipping, that I didn't sit and wait to see exactly where/when the process aborted with the above errors. I was too focused on the console window.

I'm pretty sure it's related to the newer, larger, graphical, showcase thumbnail-style, pause ads that I seem to be getting an early preview of, due to being on the priority list for the current software. The problem channels were not added-in, but were part of the groups of channels I'd select to speed up the search, by getting rid of the music channel blocks. Since they are sports channels, and I don't watch sports, no loss trimming a few small blocks out of what was left after pruning out the music channels.

One thing for certain, is whatever inflicted the problem, came from a manual service connection, and didn't resolve with scheduled ones.
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!
nooneuknow is offline   Reply With Quote
Old 10-19-2014, 02:56 PM   #7277
nvt
Registered User
 
Join Date: Aug 2003
Location: MD
Posts: 60
Quote:
Originally Posted by nvt View Post
... v1.1.e a....now I get a blank playlist
I checked the log files and the only error showing
I discovered the other log file and find an exit code of 56

>> Getting Now Playing List from FamilyHD5 ...
/usr/bin/curl --anyauth --globoff --user tivo:MAK --insecure --cookie-jar /tmp/cookie1563224942974211407.tmp --url https://192.168.1.10/TiVoConnect?Com...AnchorOffset=0 --output /tmp/NPL6455312545575672490.tmp
Failed to retrieve Now Playing List from FamilyHD5
Exit code: 56
Check YOUR MAK & IP settings
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed

0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- --:--:-- --:--:-- 0
100 31 100 31 0 0 88 0 --:--:-- --:--:-- --:--:-- 88
curl: (56) SSLRead() return error -9806


There is also a slew of Java error codes.... so now I wonder if this is Yosemite upgrade that also came with a mandated Java v8 install

>>>>> Java Error Codes >>
java.lang.NullPointerException
at com.apple.laf.AquaComboBoxUI$1.itemStateChanged(AquaComboBox UI.java:97)
at javax.swing.JComboBox.fireItemStateChanged(JComboBox.java:12 23)
at javax.swing.JComboBox.selectedItemChanged(JComboBox.java:128 0)
at javax.swing.JComboBox.contentsChanged(JComboBox.java:1329)
at javax.swing.AbstractListModel.fireContentsChanged(AbstractLi stModel.java:118)
at javax.swing.DefaultComboBoxModel.setSelectedItem(DefaultComb oBoxModel.java:93)
at javax.swing.JComboBox.setSelectedItem(JComboBox.java:576)
at com.tivo.kmttg.gui.configMain.read(configMain.java:881)
at com.tivo.kmttg.gui.configMain.display(configMain.java:162)
at com.tivo.kmttg.gui.gui$25.actionPerformed(gui.java:1022)
at javax.swing.AbstractButton.fireActionPerformed(AbstractButto n.java:2022)
at javax.swing.AbstractButton$Handler.actionPerformed(AbstractB utton.java:2346)
at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultBu ttonModel.java:402)
at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel .java:259)
at javax.swing.AbstractButton.doClick(AbstractButton.java:376)
at javax.swing.plaf.basic.BasicMenuItemUI.doClick(BasicMenuItem UI.java:833)
at com.apple.laf.AquaMenuItemUI.doClick(AquaMenuItemUI.java:157 )
at javax.swing.plaf.basic.BasicMenuItemUI$Handler.mouseReleased (BasicMenuItemUI.java:877)
at java.awt.Component.processMouseEvent(Component.java:6525)
at javax.swing.JComponent.processMouseEvent(JComponent.java:332 1)
at java.awt.Component.processEvent(Component.java:6290)
at java.awt.Container.processEvent(Container.java:2234)
at java.awt.Component.dispatchEventImpl(Component.java:4881)
at java.awt.Container.dispatchEventImpl(Container.java:2292)
at java.awt.Component.dispatchEvent(Component.java:4703)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container. java:4898)
at java.awt.LightweightDispatcher.processMouseEvent(Container.j ava:4533)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java: 4462)
at java.awt.Container.dispatchEventImpl(Container.java:2278)
at java.awt.Window.dispatchEventImpl(Window.java:2739)
at java.awt.Component.dispatchEvent(Component.java:4703)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:746)
at java.awt.EventQueue.access$400(EventQueue.java:97)
at java.awt.EventQueue$3.run(EventQueue.java:697)
at java.awt.EventQueue$3.run(EventQueue.java:691)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Pro tectionDomain.java:75)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Pro tectionDomain.java:86)
at java.awt.EventQueue$4.run(EventQueue.java:719)
at java.awt.EventQueue$4.run(EventQueue.java:717)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(Pro tectionDomain.java:75)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:716)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDis patchThread.java:201)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispat chThread.java:116)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDis patchThread.java:105)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread. java:101)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread. java:93)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:82 )

<<<
__________________
2 Premiers XL Cablecard
Series 2 540 (Hacked and upgraded)
Lifetime Service and Upgraded
Retired:
Series 2 (240and Dual Tuner 649)
nvt is offline   Reply With Quote
Old 10-19-2014, 05:20 PM   #7278
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
nvt, I already gave you the solution above, read my post.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-20-2014, 04:41 PM   #7279
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,801
I wanted to see what happened when I pressed DELETE on Roamio with a currently recording show with KMTTG and it stopped recording. The 2nd time, it was deleted.
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 10-20-2014, 04:44 PM   #7280
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Quote:
Originally Posted by ThAbtO View Post
I wanted to see what happened when I pressed DELETE on Roamio with a currently recording show with KMTTG and it stopped recording. The 2nd time, it was deleted.
That is behaving exactly as designed.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-20-2014, 05:05 PM   #7281
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
Quote:
Originally Posted by ThAbtO View Post
I wanted to see what happened when I pressed DELETE on Roamio with a currently recording show with KMTTG and it stopped recording. The 2nd time, it was deleted.
Bored, much? If I handed you a box with a big red button, labeled "sterilize planet", would you press it?
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!
nooneuknow is offline   Reply With Quote
Old 10-20-2014, 07:20 PM   #7282
Mgalin
Registered User
 
Join Date: Jan 2002
Posts: 43
Quote:
Originally Posted by moyekj View Post
Mgalin, I'm assuming you are using a Mac? I've been getting several reports from Mac users updating their OS of same problem using curl. Workaround is switch to use Java downloads instead: config-Program Options-Use Java for downloads instead of curl.
Sounds like I just need to default kmttg to use Java downloads instead of curl, at least for Mac platform.
Yup - completely resolved it. Curl must be different in Yosemite.. No issues prior to upgrade.. Also worked on my Windows PC - without changes. Good to go here.. This software is fantastic. KMTTG is the next best things next to sliced bread and PyTivo!
Mgalin is offline   Reply With Quote
Old 10-20-2014, 09:15 PM   #7283
nooneuknow
TiVo User Since 2007
 
Join Date: Feb 2011
Location: Cox Cable Market, NV
Posts: 2,921
Quote:
Originally Posted by moyekj View Post
Workaround is switch to use Java downloads instead: config-Program Options-Use Java for downloads instead of curl.
On Windows 7/8.x PCs, does this setting make any difference, other than the mechanism? Any Pro/Cons to one, or the other?

There are some settings that sometimes are just good to have options for, like using TiVo Beacon, instead of Bonjour. Every now and then, I used to have to switch that setting, as one would see everything, while the other wouldn't. I've had it left on TiVo Beacon for a long time now. But, am glad the choice is there.

If I leave it set to TiVo Beacon, can I uninstall Bonjour? I hear it's best to leave it installed, as it is used by other things...
__________________
Cisco tuning adapters should never be used inline (using the TA coax OUT port) to connect a TiVo, if MoCA is in use. Use a splitter w/PoE filter on leg to TA, use other leg for the TiVo. Enjoy!
nooneuknow is offline   Reply With Quote
Old 10-20-2014, 09:19 PM   #7284
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
Downloads method shouldn't really matter either way. Some claim they find one faster than the other but I don't think there is much difference.

kmttg doesn't use Bonjour on your PC (it uses Java mDNS code for Bonjour discovery), so makes no difference if you have it installed or not on your PC for kmttg purposes.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-21-2014, 01:17 AM   #7285
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 171
downloading question and minor bug report

I know this has been covered before and I was just wondering and I probably know the answer but putting it on here anyway, is there any difference with the premiere units in downloading java vs curl as far is broken downloads go or is that not related. I never have a broken dl on my series 3, but it seems to be happening all the time on my premiere. It drives me crazy that they never fix these kind of easy to squash bugs, but anyway, any suggestions? I feel like the answers is just suck it up but just want to make sure.

Number 2 issue is more of a comment and bug report. On series 3/HD when using TWP to delete shows, there needs to be inserted a longer pause. Depending on I think network activity or box activity, I can only delete a max of three shows at a time without erroring out. If I manually delete 3, then pause and delete 3 again, it works fine, but if I select 5 or say 10 shows to delete, it will error after the 3rd or 4th show usually. Not a huge issue, but a very consistent one.
Inline deleting while performing operations works fine, this is just manual selection and delete. I can post a log entry if necessary, well never mind, I have some here....

Code:
>> TivoWebPlus delete succeeded.
>> TivoWebPlus delete succeeded.
>> TivoWebPlus delete succeeded.
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857394
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857395
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4854459
java.net.SocketTimeoutException: Read timed out
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4854453
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857543
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857537
java.net.SocketTimeoutException: Read timed out
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4863051
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4863052
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4854457
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857538
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4857396
TWP Delete: connection failed: http://192.168.0.java.net.SocketTimeojava.net.SocketTimeoutException: Read timed out
utException: Read timed out
33:8080/confirm/del/4854458
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4835167
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4835149
TWP Delete: connection failed: http://192.168.0.33:8080/confirm/del/4863042
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read tijava.net.SocketTimeoutException: Read timed out
med out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
java.net.SocketTimeoutException: Read timed out
>> Getting Now Playing List from sanjonny .

sanjonny is offline   Reply With Quote
Old 10-21-2014, 01:09 PM   #7286
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,185
sanjonny, I have no way to test TWP delete, but I checked in code for next release that puts a 2 second sleep between successive TWP delete calls so maybe that will help.

For incomplete downloads no it doesn't matter what method you use to download - the failure is on the TiVo side. It MAY make a difference using PS vs TS container, but likely not.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-21-2014, 02:18 PM   #7287
sanjonny
Registered User
 
Join Date: Nov 2008
Posts: 171
Quote:
Originally Posted by moyekj View Post
sanjonny, I have no way to test TWP delete, but I checked in code for next release that puts a 2 second sleep between successive TWP delete calls so maybe that will help.

For incomplete downloads no it doesn't matter what method you use to download - the failure is on the TiVo side. It MAY make a difference using PS vs TS container, but likely not.
I thought as much on the dl problem. So annoying that is an easy fix I am sure but they are way more concerned with other stuff instead of crushing 10 year old bugs or whatever. IT IS very annoying that my 15 year old replay works better for some of these issues than the premiere and the HD also on some things works better. The replaytv functionality blows away the tivo with little things like being able to search on a show that has already passed and other stuff that are really nice interactive features. Of course they don't care about stuff their users actually would appreciate.....

I will try delete when the next rev comes up and let you know if the delay works. I am guessing it will!

Thanks as always and thanks for your updates to Streambaby. Just noticed those in your sig, gotta check it out.
sanjonny is offline   Reply With Quote
Old Today, 01:47 AM   #7288
wuzznuubi
Registered User
 
Join Date: Jan 2013
Posts: 42
Angry Java Update fails ad nauseum

kmttg _was_ great. After being notified of a java jre update (was at jre-7u65-32bit) and trying to install it, I now have no java so kmttg won't run. [Win7-64]
Tried both 32 and 64 bit versions of jre-7u55, 65, 67, 71 and 8u25. Stupid java update says (depending on bitness and version, either);
1) Installation failed. The wizard was interrupted before Java v# Update v# could be completely installed.
2) Close Programs to Continue. The programs listed are currently using Java. They must be closed so that Java files can be updated. (list of programs is either blank or contains 2 instances of jp2launcher.exe which don't appear in task manager as running apps, processes or services)

Ends up with error code 1603 and a suggestion to refer to the Java Help Center website (which is an oxymoron).

Now can't uninstall java as it no longer appears in add/remove programs and even JavaRa won't fix it.

After spending 12 hours this week on this stupid java update issue I gave up and went back to using pytivo to offload my TiVo and now I really miss kmttg!
wuzznuubi is offline   Reply With Quote
Old Today, 01:52 AM   #7289
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,801
Quote:
Originally Posted by wuzznuubi View Post
kmttg _was_ great. After being notified of a java jre update (was at jre-7u65-32bit) and trying to install it, I now have no java so kmttg won't run. [Win7-64]
Tried both 32 and 64 bit versions of jre-7u55, 65, 67, 71 and 8u25. Stupid java update says (depending on bitness and version, either);
1) Installation failed. The wizard was interrupted before Java v# Update v# could be completely installed.
2) Close Programs to Continue. The programs listed are currently using Java. They must be closed so that Java files can be updated. (list of programs is either blank or contains 2 instances of jp2launcher.exe which don't appear in task manager as running apps, processes or services)

Ends up with error code 1603 and a suggestion to refer to the Java Help Center website (which is an oxymoron).

Now can't uninstall java as it no longer appears in add/remove programs and even JavaRa won't fix it.

After spending 12 hours this week on this stupid java update issue I gave up and went back to using pytivo to offload my TiVo and now I really miss kmttg!
You didn't mention rebooting your PC.
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 06:40 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |