TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 12-09-2013, 04:34 PM   #4531
xekester
Registered User
 
Join Date: Nov 2005
Posts: 40
Issue Retrieving Movie Share - Part 4

OK, brute force method - Copied the first two part movie back to my pc and ran ffmpeg -i on them.

Thanks for you continuing help.
Xekester

Fellowship Part 1
ffmpeg version 1.1 Copyright (c) 2000-2013 the FFmpeg developers
built on Jan 8 2013 16:10:57 with gcc 4.7.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --e
nable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwben
c --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 86.100 / 54. 86.100
libavformat 54. 59.106 / 54. 59.106
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 32.100 / 3. 32.100
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100
[dca @ 0037d3a0] Number of channels changed in DCA decoder (6 -> 7)
[matroska,webm @ 01f0ea80] Stream #3: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Stream #5: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Stream #7: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 3 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 5 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 7 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, matroska,webm, from 'C:\Temp\Fellowship1.mkv':
Metadata:
title : THE LORD OF THE RINGS: THE FELLOWSHIP OF THE RING (EXT.) PT. 1
creation_time : 2012-01-06 03:41:47
Duration: 01:45:43.42, start: 0.000000, bitrate: 36179 kb/s
Chapter #0.0: start 0.000000, end 456.789667
Metadata:
title : Chapter 00
Chapter #0.1: start 456.789667, end 635.551578
Metadata:
title : Chapter 01
Chapter #0.2: start 635.551578, end 939.855578
Metadata:
title : Chapter 02
Chapter #0.3: start 939.855578, end 1198.488956
Metadata:
title : Chapter 03
Chapter #0.4: start 1198.488956, end 1532.614400
Metadata:
title : Chapter 04
Chapter #0.5: start 1532.614400, end 1797.378911
Metadata:
title : Chapter 05
Chapter #0.6: start 1797.378911, end 1930.678733
Metadata:
title : Chapter 06
Chapter #0.7: start 1930.678733, end 2091.798022
Metadata:
title : Chapter 07
Chapter #0.8: start 2091.798022, end 2178.176000
Metadata:
title : Chapter 08
Chapter #0.9: start 2178.176000, end 2704.159778
Metadata:
title : Chapter 09
Chapter #0.10: start 2704.159778, end 2804.301489
Metadata:
title : Chapter 10
Chapter #0.11: start 2804.301489, end 3081.411667
Metadata:
title : Chapter 11
Chapter #0.12: start 3081.411667, end 3312.434111
Metadata:
title : Chapter 12
Chapter #0.13: start 3312.434111, end 3450.071622
Metadata:
title : Chapter 13
Chapter #0.14: start 3450.071622, end 3811.516022
Metadata:
title : Chapter 14
Chapter #0.15: start 3811.516022, end 4036.115400
Metadata:
title : Chapter 15
Chapter #0.16: start 4036.115400, end 4133.587778
Metadata:
title : Chapter 16
Chapter #0.17: start 4133.587778, end 4235.940022
Metadata:
title : Chapter 17
Chapter #0.18: start 4235.940022, end 4515.385867
Metadata:
title : Chapter 18
Chapter #0.19: start 4515.385867, end 4666.620289
Metadata:
title : Chapter 19
Chapter #0.20: start 4666.620289, end 5051.546489
Metadata:
title : Chapter 20
Chapter #0.21: start 5051.546489, end 5172.500667
Metadata:
title : Chapter 21
Chapter #0.22: start 5172.500667, end 5381.584533
Metadata:
title : Chapter 22
Chapter #0.23: start 5381.584533, end 5594.672400
Metadata:
title : Chapter 23
Chapter #0.24: start 5594.672400, end 5754.081667
Metadata:
title : Chapter 24
Chapter #0.25: start 5754.081667, end 5852.972111
Metadata:
title : Chapter 25
Chapter #0.26: start 5852.972111, end 6343.420000
Metadata:
title : Chapter 26
Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(eng): Audio: dts (DTS-HD MA), 48000 Hz, 6.1, fltp, 1536 kb/s (default)
Metadata:
title : Lossless
Stream #0:2(eng): Audio: dts (DTS-ES), 48000 Hz, 6.1, fltp, 1536 kb/s
Metadata:
title : 3/2+1
Stream #0:3(eng): Subtitle: hdmv_pgs_subtitle (default)
Stream #0:4(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:5(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:6(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:7(eng): Subtitle: hdmv_pgs_subtitle

Fellowship Part 2
ffmpeg version 1.1 Copyright (c) 2000-2013 the FFmpeg developers
built on Jan 8 2013 16:10:57 with gcc 4.7.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --e
nable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwben
c --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 86.100 / 54. 86.100
libavformat 54. 59.106 / 54. 59.106
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 32.100 / 3. 32.100
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100
[dca @ 0037d3a0] Number of channels changed in DCA decoder (6 -> 7)
[matroska,webm @ 01f0ea80] Stream #3: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Stream #5: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Stream #7: not enough frames to estimate rate; consider increasing probesize
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 3 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 5 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[matroska,webm @ 01f0ea80] Could not find codec parameters for stream 7 (Subtitle: hdmv_pgs_subtitle): unspecified size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, matroska,webm, from 'C:\Temp\Fellowship1.mkv':
Metadata:
title : THE LORD OF THE RINGS: THE FELLOWSHIP OF THE RING (EXT.) PT. 1
creation_time : 2012-01-06 03:41:47
Duration: 01:45:43.42, start: 0.000000, bitrate: 36179 kb/s
Chapter #0.0: start 0.000000, end 456.789667
Metadata:
title : Chapter 00
Chapter #0.1: start 456.789667, end 635.551578
Metadata:
title : Chapter 01
Chapter #0.2: start 635.551578, end 939.855578
Metadata:
title : Chapter 02
Chapter #0.3: start 939.855578, end 1198.488956
Metadata:
title : Chapter 03
Chapter #0.4: start 1198.488956, end 1532.614400
Metadata:
title : Chapter 04
Chapter #0.5: start 1532.614400, end 1797.378911
Metadata:
title : Chapter 05
Chapter #0.6: start 1797.378911, end 1930.678733
Metadata:
title : Chapter 06
Chapter #0.7: start 1930.678733, end 2091.798022
Metadata:
title : Chapter 07
Chapter #0.8: start 2091.798022, end 2178.176000
Metadata:
title : Chapter 08
Chapter #0.9: start 2178.176000, end 2704.159778
Metadata:
title : Chapter 09
Chapter #0.10: start 2704.159778, end 2804.301489
Metadata:
title : Chapter 10
Chapter #0.11: start 2804.301489, end 3081.411667
Metadata:
title : Chapter 11
Chapter #0.12: start 3081.411667, end 3312.434111
Metadata:
title : Chapter 12
Chapter #0.13: start 3312.434111, end 3450.071622
Metadata:
title : Chapter 13
Chapter #0.14: start 3450.071622, end 3811.516022
Metadata:
title : Chapter 14
Chapter #0.15: start 3811.516022, end 4036.115400
Metadata:
title : Chapter 15
Chapter #0.16: start 4036.115400, end 4133.587778
Metadata:
title : Chapter 16
Chapter #0.17: start 4133.587778, end 4235.940022
Metadata:
title : Chapter 17
Chapter #0.18: start 4235.940022, end 4515.385867
Metadata:
title : Chapter 18
Chapter #0.19: start 4515.385867, end 4666.620289
Metadata:
title : Chapter 19
Chapter #0.20: start 4666.620289, end 5051.546489
Metadata:
title : Chapter 20
Chapter #0.21: start 5051.546489, end 5172.500667
Metadata:
title : Chapter 21
Chapter #0.22: start 5172.500667, end 5381.584533
Metadata:
title : Chapter 22
Chapter #0.23: start 5381.584533, end 5594.672400
Metadata:
title : Chapter 23
Chapter #0.24: start 5594.672400, end 5754.081667
Metadata:
title : Chapter 24
Chapter #0.25: start 5754.081667, end 5852.972111
Metadata:
title : Chapter 25
Chapter #0.26: start 5852.972111, end 6343.420000
Metadata:
title : Chapter 26
Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
Stream #0:1(eng): Audio: dts (DTS-HD MA), 48000 Hz, 6.1, fltp, 1536 kb/s (default)
Metadata:
title : Lossless
Stream #0:2(eng): Audio: dts (DTS-ES), 48000 Hz, 6.1, fltp, 1536 kb/s
Metadata:
title : 3/2+1
Stream #0:3(eng): Subtitle: hdmv_pgs_subtitle (default)
Stream #0:4(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:5(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:6(eng): Subtitle: hdmv_pgs_subtitle
Stream #0:7(eng): Subtitle: hdmv_pgs_subtitle
xekester is offline   Reply With Quote
Old 12-13-2013, 01:20 PM   #4532
Stormspace
Electrocuted by TiVo
 
Stormspace's Avatar
 
Join Date: Apr 2004
Location: Hartsville, SC
Posts: 4,792
Hey, I decided to move my pyTivo server from my honking power eating Dell XPS to a RaspberryPi. It's working splendidly, except every TiVo in the house sees the recording as protected by the copyright holder. All of them. I thought perhaps it was a mounting issue since the recordings are on an external USB drive(NTFS formatted). Samba shares work fine as far as I've tested them. So is there a setting I'm missing?

PS: I'm only using pyTivo as a hosting server. It's not pushing or receiving content from anywhere other than perhaps as a file copy over the network via a Samba Share.
__________________
137hr DTS2
20/180hr HD
166hr DTS2
180hr S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Stormspace is offline   Reply With Quote
Old 12-13-2013, 02:41 PM   #4533
gonzotek
tivo_xml developer
 
gonzotek's Avatar
 
Join Date: Sep 2004
Location: Outside Phildadelphia
Posts: 2,189
Quote:
Originally Posted by Stormspace View Post
Hey, I decided to move my pyTivo server from my honking power eating Dell XPS to a RaspberryPi. It's working splendidly, except every TiVo in the house sees the recording as protected by the copyright holder. All of them. I thought perhaps it was a mounting issue since the recordings are on an external USB drive(NTFS formatted). Samba shares work fine as far as I've tested them. So is there a setting I'm missing?

PS: I'm only using pyTivo as a hosting server. It's not pushing or receiving content from anywhere other than perhaps as a file copy over the network via a Samba Share.
File formats and pytivo debug logs? It's likely either a permissions problem or a conversion problem (if the files are not already mpeg2, .tivo or mp4 [via pushes or 'ts=on'-enabled pulls] then pytivo will require ffmpeg to convert to a compatible format). If it's a conversion issue, it looks like it's possible to get ffmpeg going on the Pi, but it might not be practical in usage for pytivo (read: it probably will be WAY slow):
https://trac.ffmpeg.org/wiki/How%20t...i%20(Raspbian)
__________________
Follow @pytivo on Twitter for project updates and more!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
A Web app for Roku Remote Control
gonzotek is offline   Reply With Quote
Old 12-13-2013, 05:11 PM   #4534
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by Stormspace View Post
Hey, I decided to move my pyTivo server from my honking power eating Dell XPS to a RaspberryPi. It's working splendidly, except every TiVo in the house sees the recording as protected by the copyright holder. All of them. I thought perhaps it was a mounting issue since the recordings are on an external USB drive(NTFS formatted). Samba shares work fine as far as I've tested them. So is there a setting I'm missing?

PS: I'm only using pyTivo as a hosting server. It's not pushing or receiving content from anywhere other than perhaps as a file copy over the network via a Samba Share.
Are you using the same version of ffmpeg as before?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-14-2013, 12:50 AM   #4535
Soapm
Registered User
 
Soapm's Avatar
 
Join Date: May 2007
Location: So close, yet too far away
Posts: 1,446
Perhaps the attached looks familiar to someone. I haven't connected to my premier since the last software update. As you can see in the attached, it shows up on the pyTivo web page as an ip address instead of it's name "other". Anyone with a clue what could be causing that?

I can see the shares from my Linux box running pytivo but they always appear empty when I click on them. Same with clicking on the ip link on the webpage, it just times out.

There has to be something obvious this is saying but I can't hear the message... lol...

Nevermind, just as I posed the above I hit connect and got the new updated OS. After install all is well again. Not sure what it was about that old OS version but it sure didn't network very well.
Attached Images
File Type: jpg pytivo.jpg (11.7 KB, 17 views)

Last edited by Soapm : 12-14-2013 at 01:14 AM. Reason: Resolved...
Soapm is offline   Reply With Quote
Old 12-15-2013, 09:42 AM   #4536
Stormspace
Electrocuted by TiVo
 
Stormspace's Avatar
 
Join Date: Apr 2004
Location: Hartsville, SC
Posts: 4,792
Quote:
Originally Posted by lpwcomp View Post
Are you using the same version of ffmpeg as before?
Gonzotek
This implementation is for distribution only. I'm fairly certain its a permission issue since the files, file structure, file system, and everything is identical. I moved an external USB drive to the PI from an Ubuntu box. The Samba config, pyTiVo.conf and all other scripts are the same since I copied them over from the old box.

Samba shares to the video locations work fine.

The mount line from fstab:
Code:
UUID=4ADCC900DCC8E6F3 /media/FantomHD ntfs-3g defaults,rw,uid=pi,gid=pi 0 0
This line isn't the same. I had trouble using the original one from the Ubuntu box.

PS: All files on the drive are mpeg2.
__________________
137hr DTS2
20/180hr HD
166hr DTS2
180hr S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Stormspace : 12-15-2013 at 12:03 PM.
Stormspace is offline   Reply With Quote
Old 12-18-2013, 10:35 AM   #4537
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,849
Quote:
Originally Posted by Stormspace View Post
Gonzotek
This implementation is for distribution only.
That's not the point. PyTivo relies on ffmpeg to give it information about the videos. An incompatibility in the ffmpeg build could easily cause the symptoms you mention. This is especially true since the rift in the ffmpeg camp. Debian, at least, has decided to take the wholly despicable route of renaming aconv to ffmpeg so they don't have to distribute the "real" ffmpeg. I had to compile ffmpeg from source to replace the distro version, something I haven't had to do for quite some years.

Quote:
Originally Posted by Stormspace View Post
I'm fairly certain its a permission issue since the files, file structure, file system, and everything is identical.
It doesn't sound like it, to me, but it's easy enough to simply change to the directory containing the videos and issue the command:

Code:
sudo chmod -R 644 *
Quote:
Originally Posted by Stormspace View Post
I moved an external USB drive to the PI from an Ubuntu box. The Samba config, pyTiVo.conf and all other scripts are the same since I copied them over from the old box.

Samba shares to the video locations work fine.
Which also suggests it is not a permissions issue.

Quote:
Originally Posted by Stormspace View Post
The mount line from fstab:
Code:
UUID=4ADCC900DCC8E6F3 /media/FantomHD ntfs-3g defaults,rw,uid=pi,gid=pi 0 0
This line isn't the same. I had trouble using the original one from the Ubuntu box.
That's not surprising.
lrhorer is offline   Reply With Quote
Old 12-19-2013, 03:02 PM   #4538
Stormspace
Electrocuted by TiVo
 
Stormspace's Avatar
 
Join Date: Apr 2004
Location: Hartsville, SC
Posts: 4,792
Quote:
Originally Posted by lrhorer View Post
That's not the point. PyTivo relies on ffmpeg to give it information about the videos. An incompatibility in the ffmpeg build could easily cause the symptoms you mention. This is especially true since the rift in the ffmpeg camp. Debian, at least, has decided to take the wholly despicable route of renaming aconv to ffmpeg so they don't have to distribute the "real" ffmpeg. I had to compile ffmpeg from source to replace the distro version, something I haven't had to do for quite some years.


It doesn't sound like it, to me, but it's easy enough to simply change to the directory containing the videos and issue the command:

Code:
sudo chmod -R 644 *

Which also suggests it is not a permissions issue.


That's not surprising.
OK. What you are saying makes more sense now. I thought ffmpeg was being used to convert the files on the fly. These are already in the right format. And yes I did read about ffmpeg being a little different on the Pi, or maybe it was something else. I was skimming that part since it seemed to install with no problems. I'll double check the ffmpeg, for now I've been able to use TiVo desktop with the samba share as a source and it's working. I'm not going to say working well though. I think another few gray hairs popped out while I was waiting.
__________________
137hr DTS2
20/180hr HD
166hr DTS2
180hr S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Stormspace is offline   Reply With Quote
Old 12-21-2013, 02:01 AM   #4539
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,849
Quote:
Originally Posted by Stormspace View Post
OK. What you are saying makes more sense now. I thought ffmpeg was being used to convert the files on the fly.
Well, it's used for that, too. First, however, pyTivo needs to determine whether or not the file needs to be transcoded at such time that it may be transferred. Ffmpeg is used to obtain that info, and then if and when the transfer request comes across, the file is piped through ffmpeg if need be, or transferred directly, if not.
lrhorer is offline   Reply With Quote
Old 12-24-2013, 12:57 PM   #4540
swerver
Registered User
 
Join Date: May 2012
Posts: 181
Whenever I push files using pytivo, there is a dropdown to select which tivo to send to. In my case, I have a roamio and a mini, so it will always be to the roamio, but the dropdown defaults to the mini, which obviously cannot accept a transfer anyway. Can I remove it from the list somehow? I thought I saw this mentioned in the thread somewhere but my search is coming up empty.

Thanks
swerver is online now   Reply With Quote
Old 12-24-2013, 04:14 PM   #4541
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
Quote:
Originally Posted by swerver View Post
Can I remove it from the list somehow?
It should go away if you use only new-style beacons. Disable the old-style beacons via "beacon = listen" or just "beacon =".
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 12-26-2013, 08:28 PM   #4542
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Just encountered a weird problem. I have several episodes of "Continuum" recorde3d in August that I downloaded in TS mode from one of my Premieres. All of the episodes had 1 minute leading and trailing padding. When I pull them back, they are getting the title of what I can only presume was on immediately preceding the showing.

For instance, one episode appears in the NPL as "Joe Rogan Questions Everything" while another appears as "Haven".

The Premiere is running 20.3.8. The downloads to the computer were done 11/17/2013, obviously before the update. The pulls back to the TiVo were done today.

Edit: My assumption was wrong. It is getting the title of whatever is on immediately after the showing.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"

Last edited by lpwcomp : 12-26-2013 at 09:06 PM.
lpwcomp is offline   Reply With Quote
Old 12-27-2013, 12:55 AM   #4543
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
The internal metadata in a .TiVo file comes in two blocks: "showing" and "vActualShowing". "showing" is the program you scheduled to record, but "vActualShowing" is all the programs that aired (as far as the TiVo knows) in the recorded time period. Typically these are identical, but in the case of a padded recording, there will also be metadata for the shows that came before and/or after, depending on the padding.

It sounds like, in this case, your TiVo is picking up the last record from vActualShowing, instead of using the "showing" block. Either that, or perhaps pyTivo is picking up the wrong programID, and this is overriding the embedded .TiVo metadata when passed back (though that would be the first time I ever saw the embedded metadata not take precedence). I'll have to check... in the meantime, you could see if you get the same result via TiVo Desktop.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 12-27-2013, 10:54 AM   #4544
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by wmcbrine View Post
The internal metadata in a .TiVo file comes in two blocks: "showing" and "vActualShowing". "showing" is the program you scheduled to record, but "vActualShowing" is all the programs that aired (as far as the TiVo knows) in the recorded time period. Typically these are identical, but in the case of a padded recording, there will also be metadata for the shows that came before and/or after, depending on the padding.

It sounds like, in this case, your TiVo is picking up the last record from vActualShowing, instead of using the "showing" block. Either that, or perhaps pyTivo is picking up the wrong programID, and this is overriding the embedded .TiVo metadata when passed back (though that would be the first time I ever saw the embedded metadata not take precedence). I'll have to check... in the meantime, you could see if you get the same result via TiVo Desktop.
TD gets the correct info.

Additional info: When looking at it via the pyTivo share on the TiVo before transferring, the information is correct.

There are very odd things going on. I'm starting to think that there is a problem on my TiVo. One episode initially transferred by TD went into the "Continuum" group and had the correct data. I then transferred it again via pyTiVo. It got info for "Heroes of Cosplay". The TD xferred version, while it stayed in the "Continuum" group, suddenly had the info for the "Heroes of Cosplay" episode.

Other episodes stopped allowing me to xfer via pyTiVo at all (Message #86) until I xferred them via TD.

The only episode that got Season and Episode numbers was the only one that had no padding.

Removing "ts=on" had no effect.

They all have ".tivo.txt" metadata files, but that appears to be working correctly and only affecting the fields missing from the embedded metadata like "displayMajorNumber" and "callsign".
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-29-2013, 07:50 AM   #4545
johnjay829
Registered User
 
Join Date: Jan 2007
Posts: 41
Hello all i was just wondering if anyone was able to get being able to send videos to another tivo on a different network working
johnjay829 is offline   Reply With Quote
Old 12-29-2013, 11:56 AM   #4546
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by johnjay829 View Post
Hello all i was just wondering if anyone was able to get being able to send videos to another tivo on a different network working
Yes.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-29-2013, 12:08 PM   #4547
johnjay829
Registered User
 
Join Date: Jan 2007
Posts: 41
Quote:
Originally Posted by lpwcomp View Post
Yes.
care to share the setup
johnjay829 is offline   Reply With Quote
Old 12-29-2013, 02:00 PM   #4548
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by johnjay829 View Post
care to share the setup
Sure.

You need to add the following to the [Server] section of your pyTivo.conf file:
Code:
externalurl = http://nnn.nnn.nnn.nnn:9032
allowedips = 127.0.0.1 192.168.1.
where nnn.nnn.nnn.nnn is the external IP address of your system. Mine begins with 99. For my router/modem (3600HGV) it is under Broadband-Current Internet Connection-IP Address

Then you need to add a section for the remote TiVo:

Code:
[_tivo_<TSN of remote TiVo>]
tivo_username = <tivo.com username of remote TiVo's account>
tivo_password = <tivo.com password of remote TiVo's account>
tivo_mak = <MAK of remote TiVo>
external = True
The < and > are not part of the entry. The TSN should be entered with no dashes.

You also need to open port 9032 in whatever firewalls you have.

This is for pushes to a remote TiVo. I was never able to get pulls to a remote TiVo to work.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-30-2013, 09:04 AM   #4549
johnjay829
Registered User
 
Join Date: Jan 2007
Posts: 41
Quote:
Originally Posted by lpwcomp View Post
Sure.

You need to add the following to the [Server] section of your pyTivo.conf file:
Code:
externalurl = http://nnn.nnn.nnn.nnn:9032
allowedips = 127.0.0.1 192.168.1.
where nnn.nnn.nnn.nnn is the external IP address of your system. Mine begins with 99. For my router/modem (3600HGV) it is under Broadband-Current Internet Connection-IP Address

Then you need to add a section for the remote TiVo:

Code:
[_tivo_<TSN of remote TiVo>]
tivo_username = <tivo.com username of remote TiVo's account>
tivo_password = <tivo.com password of remote TiVo's account>
tivo_mak = <MAK of remote TiVo>
external = True
The < and > are not part of the entry. The TSN should be entered with no dashes.

You also need to open port 9032 in whatever firewalls you have.

This is for pushes to a remote TiVo. I was never able to get pulls to a remote TiVo to work.

Thanks i will give it a try. also can i use a dns address for external address..it changes about weekely from my isp

Last edited by johnjay829 : 12-30-2013 at 10:41 AM.
johnjay829 is offline   Reply With Quote
Old 12-30-2013, 03:44 PM   #4550
spaldingclan
Registered User
 
Join Date: Aug 2012
Posts: 193
has anyone ever been able to get metadata with cover art working with pytivo? I've been using "metagenerator" to add show info but the art never comes over with it.
spaldingclan is offline   Reply With Quote
Old 12-30-2013, 04:58 PM   #4551
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by johnjay829 View Post
Thanks i will give it a try. also can i use a dns address for external address..it changes about weekely from my isp
I really don't know for sure, but I doubt it. Is there no way to get your ISP to assign you a fixed IP address?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-30-2013, 05:49 PM   #4552
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
Quote:
Originally Posted by spaldingclan View Post
has anyone ever been able to get metadata with cover art working with pytivo? I've been using "metagenerator" to add show info but the art never comes over with it.
The TiVo doesn't support cover art via HMO. The cover art they do show, in the HDUI, is derived from the programId. Images were only added to the metadata .txt "standard" for the benefit of other programs, like Streambaby, and are not used by pyTivo. (Exception: Someone did a mod to display them on the Push page, IIRC.)
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by wmcbrine : 12-31-2013 at 11:53 PM.
wmcbrine is offline   Reply With Quote
Old 12-31-2013, 08:05 AM   #4553
johnjay829
Registered User
 
Join Date: Jan 2007
Posts: 41
Quote:
Originally Posted by lpwcomp View Post
I really don't know for sure, but I doubt it. Is there no way to get your ISP to assign you a fixed IP address?
not for free lol.. it is fine that is an easy update to make when it changes
johnjay829 is offline   Reply With Quote
Old 12-31-2013, 10:15 AM   #4554
swerver
Registered User
 
Join Date: May 2012
Posts: 181
Quote:
Originally Posted by wmcbrine View Post
It should go away if you use only new-style beacons. Disable the old-style beacons via "beacon = listen" or just "beacon =".
Thanks that did it!
swerver is online now   Reply With Quote
Old 12-31-2013, 11:23 AM   #4555
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by johnjay829 View Post
not for free lol.. it is fine that is an easy update to make when it changes
But they do give you a fixed URL? That's just weird.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-31-2013, 11:56 PM   #4556
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
Quote:
Originally Posted by lpwcomp View Post
But they do give you a fixed URL? That's just weird.
It's trivial to get a fixed domain name; there are several free services that do it. The names aren't a limited resource like IPs are.

These aren't top-level domains (which I don't think you can get for free), but things like "yourname.dyndns.org".
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 01-01-2014, 01:49 PM   #4557
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,367
Quote:
Originally Posted by wmcbrine View Post
It's trivial to get a fixed domain name; there are several free services that do it. The names aren't a limited resource like IPs are.

These aren't top-level domains (which I don't think you can get for free), but things like "yourname.dyndns.org".
So would using a domain name as the externalurl work?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 01-01-2014, 02:05 PM   #4558
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
It should. You do need the IP for a pull (for "Manually add..."), though.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 01-04-2014, 07:14 AM   #4559
zundian
Registered User
 
Join Date: Mar 2008
Posts: 54
I just changed computers, and am dealing with a weird issue in a Windows 8 environment.

Everything is working normally, except any new files I get don't show up in the NPL or in the web version on the computer. Anything transferred from my old computer is fine, and the new folders show up, but nothing is in them, according to pytivo.

I thought maybe it was a codec issue, and downloading CCCP seemed to have fixed the issue until my next reboot.

Any ideas?

ETA: doing some experimenting, it seems like pytivo is only recognizing the first folder? If I move the new files to the main folder it picks them up, but doesn't recognize them in the new sub folder.
ETA 2: Putting old content into the same sub folder hides it from pytivo. How odd.

Last edited by zundian : 01-04-2014 at 07:31 AM.
zundian is offline   Reply With Quote
Old 01-04-2014, 08:44 AM   #4560
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,758
Quote:
Originally Posted by zundian View Post
I thought maybe it was a codec issue, and downloading CCCP seemed to have fixed the issue until my next reboot.
pyTivo doesn't use codecs in that way -- it uses FFmpeg, which has its own codecs built-in, and doesn't connect with the system codecs.

Quote:
Any ideas?
Post the log?
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 01:08 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |