TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 09-08-2013, 02:43 AM   #2701
darrin75
Registered User
 
Join Date: Jul 2004
Posts: 48
Why can't someone add series two support for playing ty files??? Please the ui looks awesome but series two is all I have.
darrin75 is offline   Reply With Quote
Old 09-08-2013, 07:24 PM   #2702
CoxInPHX
COX Communications
 
CoxInPHX's Avatar
 
Join Date: Jan 2011
Location: Phoenix, AZ
Posts: 1,329
Quote:
Originally Posted by moyekj View Post
Below is my streambaby.ini file FWIW.
Also, note that I'm not using the latest streambaby version with search capabilities added as I'm not sure what changed in it. Version I'm using is the 2nd latest:
http://code.google.com/p/streambaby/...2.zip&can=2&q=
I used your code for the streambaby.ini file and installed the 2nd latest version. Still I cannot play anything with a .txt file.

Here is the code produced when attempting to play a file with a .txt
Any other Ideas? I am not running as a service, just standalone, and have not modified the wrapper.conf

Code:
Initializing StreamBaby v20111203-2132...
09/08/13 17:21:42 Listener: added factory
09/08/13 17:21:42 Main: streambaby ready & listening.
log after close : initContext version=49
09/08/13 17:21:52 Factory: HME receiver connected
java.lang.IncompatibleClassChangeError: Found interface sun.font.FontManager, bu
t class was expected
        at org.lobobrowser.util.gui.FontFactory.createFont(FontFactory.java:210)

        at org.lobobrowser.util.gui.FontFactory.createFont_Impl(FontFactory.java
:180)
        at org.lobobrowser.util.gui.FontFactory.createFont(FontFactory.java:127)

        at org.lobobrowser.util.gui.FontFactory.getFont(FontFactory.java:98)
        at org.lobobrowser.html.style.StyleSheetRenderState.<clinit>(StyleSheetR
enderState.java:43)
        at org.lobobrowser.html.domimpl.NodeImpl.<clinit>(NodeImpl.java:39)
        at org.lobobrowser.html.parser.DocumentBuilderImpl.createDocument(Docume
ntBuilderImpl.java:143)
        at com.unwiredappeal.tivo.html.cobra.CobraRenderer.getImages(CobraRender
er.java:113)
        at com.unwiredappeal.tivo.streambaby.MetaDataViewer.getView(MetaDataView
er.java:86)
        at com.unwiredappeal.tivo.streambaby.PlayScreen.render(PlayScreen.java:8
4)
        at com.unwiredappeal.tivo.streambaby.ButtonScreen.timerRender(ButtonScre
en.java:98)
        at com.unwiredappeal.tivo.streambaby.ButtonScreen.tick(ButtonScreen.java
:88)
        at com.tivo.hme.sdk.util.Ticker.run(Ticker.java:143)

__________________
Roamio Pro, XL4, Premiere 2TB-WD20EURS, & Mini, 20.4.2, w/ Cisco SDV TA, FW F.1601, Cisco CC FW PKEY1.5.3_F.p.1301

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CoxInPHX is offline   Reply With Quote
Old 09-08-2013, 07:37 PM   #2703
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Quote:
Originally Posted by CoxInPHX View Post
I used your code for the streambaby.ini file and installed the 2nd latest version. Still I cannot play anything with a .txt file.
<snip>
Are you running Java 7 (1.7)? Since Streambaby code hasn't been updated in a while it doesn't play nice with latest versions of Java. If you run Java 6 (1.6) it may fix your problem. Here's version I'm running (using "java -version"):
java version "1.6.0_15"
Java(TM) SE Runtime Environment (build 1.6.0_15-b03)
Java HotSpot(TM) Client VM (build 14.1-b02, mixed mode, sharing)

EDIT: Since I also have Java 7 installed as well I modified streambaby.bat to use Java 7 instead and then can duplicate issue you are seeing. So easiest fix is to install and use Java 6.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 09-08-2013 at 07:52 PM.
moyekj is offline   Reply With Quote
Old 09-08-2013, 07:56 PM   #2704
CoxInPHX
COX Communications
 
CoxInPHX's Avatar
 
Join Date: Jan 2011
Location: Phoenix, AZ
Posts: 1,329
Yes, I am running Java 7, will give 6 a try.

Thanks
__________________
Roamio Pro, XL4, Premiere 2TB-WD20EURS, & Mini, 20.4.2, w/ Cisco SDV TA, FW F.1601, Cisco CC FW PKEY1.5.3_F.p.1301

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CoxInPHX is offline   Reply With Quote
Old 09-08-2013, 08:02 PM   #2705
CoxInPHX
COX Communications
 
CoxInPHX's Avatar
 
Join Date: Jan 2011
Location: Phoenix, AZ
Posts: 1,329
Thank You so much, I owe you a beer.

Java 6 works
__________________
Roamio Pro, XL4, Premiere 2TB-WD20EURS, & Mini, 20.4.2, w/ Cisco SDV TA, FW F.1601, Cisco CC FW PKEY1.5.3_F.p.1301

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

CoxInPHX is offline   Reply With Quote
Old 09-15-2013, 03:50 PM   #2706
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Hi all,

After months of having no problem running Streambaby on my Mac Mini (OSX 10.8.4) i am getting the "can't assign requested address" error. This happens whether I put in the right address or comment it out.

/Applications/streambaby/streambaby ; exit;
Initializing StreamBaby v20120828-2030...
Sep 15, 2013 1:38:45 PM javax.jmdns.impl.JmDNSImpl closeMulticastSocket
WARNING: closeMulticastSocket() Close socket exception
java.net.SocketException: Can't assign requested address
at java.net.PlainDatagramSocketImpl.leave(Native Method)
at java.net.PlainDatagramSocketImpl.leave(PlainDatagramSocketIm pl.java:232)
at java.net.MulticastSocket.leaveGroup(MulticastSocket.java:341 )
at javax.jmdns.impl.JmDNSImpl.closeMulticastSocket(JmDNSImpl.ja va:311)
at javax.jmdns.impl.JmDNSImpl.openMulticastSocket(JmDNSImpl.jav a:292)
at javax.jmdns.impl.JmDNSImpl.init(JmDNSImpl.java:262)
at javax.jmdns.impl.JmDNSImpl.<init>(JmDNSImpl.java:218)
at javax.jmdns.JmDNS.create(JmDNS.java:41)
at com.unwiredappeal.tivo.streambaby.host.Main.<init>(Main.java :161)
at com.unwiredappeal.tivo.streambaby.StreamBabyMain.main(Stream BabyMain.java:152)
09/15/13 13:38:45 Listener: added factory
09/15/13 13:38:45 Main: streambaby ready & listening.

I suspect this is due to a Java issue, because I think the last time Streambaby worked I was using version 6.something. When I look at my Java Preferences pane, it says I am at version 7, Update 25. I have read somewhere here that version 7 doesn't play well with Streambaby. Do I need to go back to version 6? I am told that that using anything older than 7 is risky.

Although I am an IT professional with decades of experience in windows and unix, I'm a newbie when it comes to OSX as well as java, so "talk to me like I'm a 5th grader" if the fixes involve anything along the lines of tinkering deeply with OSX or java.

thanks in advance,

Rob from AZ
AZrob is offline   Reply With Quote
Old 09-15-2013, 05:49 PM   #2707
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Just look at post right above yours - yes Java 7 is an issue with streambaby.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 09-16-2013, 02:42 PM   #2708
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Thanks, moyekj. I kind of assumed that Java 7 was the issue. What I would like to know is:

1. Is it safe to go back to Java 6, as long as you disable it in the browser? In other words, is the standalone version of Java not a security issue?

2. How do you downgrade from 7 to 6 on the Mac?

thanks in advance,

Rob
AZrob is offline   Reply With Quote
Old 09-24-2013, 08:24 PM   #2709
thewebgal
Registered User
 
thewebgal's Avatar
 
Join Date: Aug 2007
Location: DC 'burbs
Posts: 130
Streambaby failed over the weekend (TIVOHD & OSX 10.8.5) -
So I went back and forth trying to remove 7 and enable Java 6
but it didn't seem to be happening - so - I gave up and just deleted the java module,

oracle sez: To uninstall Java 7, you must have Administrator privileges.

Click on the Finder icon located in your dock
Click on Applications tab on the sidebar
In the Search box enter JavaAppletPlugin.plugin
This will find the JavaAppletPlugin.plugin file
Right click on JavaAppletPlugin.plugin and select Move to Trash


After I did that I type java -version into terminal and it said no file or directory with that name ...
THEN I downloaded and installed the latest-greatest from Oracle - Java 7u40 (64 bits) ...

I dinked with the ini file a bit, rebooted and - its working again, now with Java 7 ...
now when I type java -version in a terminal window, I get

java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

Last edited by thewebgal : 09-28-2013 at 10:47 AM.
thewebgal is offline   Reply With Quote
Old 09-28-2013, 02:23 AM   #2710
Wil
Senile Member
 
Join Date: Sep 2002
Posts: 2,256
Quote:
Originally Posted by AZrob View Post
Always I would be able to stream videos by just selecting the "Same" [quality]. But this week I decided to install Streambaby on my new Mac Mini. For a frustrating day I kept getting the "Failed to Open Stream" error ... Finally I figured out the workaround - you just have to adjust the Quality value to be anything but "Same"
I have fought my way through the OS X 10.8.x/java7/java6 problems, finally got back to working again, but have arrived at where you are (or were?).

I'm happy to be here! Minor problem as compared to not working at all.

But did you ever solve this?

I'm also no longer able to fast forward (beyond the green line) like I did with older Mac OS's and previous versions of Java.

But, as I said, at least it's working. Basically, for the other problems I cleaned house as best I could with Java, deleted everything, installed a developer version of java 7, then overlaid version 6 (but still pointing to 7).
Wil is offline   Reply With Quote
Old 10-07-2013, 02:54 AM   #2711
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Quote:
Originally Posted by moyekj View Post
Just look at post right above yours - yes Java 7 is an issue with streambaby.
Moyekj,

Actually, I just realized that I am running Version 6, or so it would seem from this result:

$ java -version
$ java version "1.6.0_51"
$ Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
$ Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)


Would it be the build? Yours is older at 15 than mine at 51.

thanks,

Rob
AZrob is offline   Reply With Quote
Old 10-07-2013, 03:42 AM   #2712
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Quote:
Originally Posted by TheWGP View Post
I've tried those terminal commands and am not having any luck. I'm still getting that same identical error that Jayrcee pasted above.

Any other ideas, anyone?

Edit: I got it working by a freak accident: manually starting it like this:
navigating in terminal to (streambaby directory)/jbin and doing "java -jar streambaby.jar" as opposed to the
"java -Djava.net.preferIPv4Stack=true -Xmx256m -jar "$DIRNAME/jbin/streambaby.jar" found in the streambaby file that runs. I'm not adept enough at this stuff to figure out why this works, and this note/edit is partly so that I don't forget how I did it tomorrow night...

This is using the latest version, btw - I downloaded a fresh copy.
Sir, I am in your debt.....after trying 10 different ways to get rid of that error, I found the trick you stumbled on ...and it worked like a charm. I am very grateful...in playing around with the file I found that the original file works fine if you eliminate the -Djava.net.preferIPv4Stack=true parameter. Can anyone tell me why that parameter no longer works?

Rob
AZrob is offline   Reply With Quote
Old 10-07-2013, 03:43 AM   #2713
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Quote:
Originally Posted by AZrob View Post
Moyekj,

Actually, I just realized that I am running Version 6, or so it would seem from this result:

$ java -version
$ java version "1.6.0_51"
$ Java(TM) SE Runtime Environment (build 1.6.0_51-b11-457-11M4509)
$ Java HotSpot(TM) 64-Bit Server VM (build 20.51-b01-457, mixed mode)


Would it be the build? Yours is older at 15 than mine at 51.

thanks,

Rob
Never mind...see above....
AZrob is offline   Reply With Quote
Old 10-08-2013, 02:54 PM   #2714
AZrob
Registered User
 
Join Date: Mar 2002
Location: Phoenix, AZ
Posts: 211
Quote:
Originally Posted by Wil View Post
I have fought my way through the OS X 10.8.x/java7/java6 problems, finally got back to working again, but have arrived at where you are (or were?).

I'm happy to be here! Minor problem as compared to not working at all.

But did you ever solve this?

I'm also no longer able to fast forward (beyond the green line) like I did with older Mac OS's and previous versions of Java.

But, as I said, at least it's working. Basically, for the other problems I cleaned house as best I could with Java, deleted everything, installed a developer version of java 7, then overlaid version 6 (but still pointing to 7).
I never solved this....I use the fastest speed I can get away with, but SAME no longer works.

Like you, I cannot Fast Forward beyond the green line. The only workaround I have found is I first set the speed to the slowest rate (Very Slow or something like that) and that allows the green line to move forward the fastest (I was getting a 5 to 1 ratio, of 5 minutes forward per minute). Then when I get where I want to be, I go backwards a few minutes to give the buffer time to adjust and I go back to the menu and choose the speed I want. It's a kluge but at least it works.

Anyone out there have a solution to the Fast Forward issue?

thanks,

Rob
AZrob is offline   Reply With Quote
Old 10-22-2013, 08:56 PM   #2715
thewebgal
Registered User
 
thewebgal's Avatar
 
Join Date: Aug 2007
Location: DC 'burbs
Posts: 130
I installed mavericks on my mac Pro (Early 2009) today. Checked my TIVOHD and no streambaby visible ...
Did the procedure in the quote below and removed the JavaAppletPlugin.plugin file
Then i went to oracle and located the current latest greatest -
https://www.java.com/en/download/mac....jsp?locale=en

After I downloaded and installed it, I popped open a terminal window and typed "java -version"
and it showed the OLD file still - so at that point I ran the following two sudo commands in Terminal window

sudo ln -sf "/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/java" /usr/bin/java

sudo ln -sf "/Library/Internet Plug-Ins/JavaAppletPlugin.plugin/Contents/Home/bin/javaws" /usr/bin/javaws

NOW when I run java -version I get

java version "1.7.0_45"
Java(TM) SE Runtime Environment (build 1.7.0_45-b18)
Java HotSpot(TM) 64-Bit Server VM (build 24.45-b08, mixed mode)


I also just checked the TIVOHD and now I see streambaby again ...
So, this confirms that the "old" streambaby works under OSX 10.9


WooHoo!!



Quote:
Originally Posted by thewebgal View Post
Streambaby failed over the weekend (TIVOHD & OSX 10.8.5) -
So I went back and forth trying to remove 7 and enable Java 6
but it didn't seem to be happening - so - I gave up and just deleted the java module,

oracle sez: To uninstall Java 7, you must have Administrator privileges.

Click on the Finder icon located in your dock
Click on Applications tab on the sidebar
In the Search box enter JavaAppletPlugin.plugin
This will find the JavaAppletPlugin.plugin file
Right click on JavaAppletPlugin.plugin and select Move to Trash


After I did that I type java -version into terminal and it said no file or directory with that name ...
THEN I downloaded and installed the latest-greatest from Oracle - Java 7u40 (64 bits) ...

I dinked with the ini file a bit, rebooted and - its working again, now with Java 7 ...
now when I type java -version in a terminal window, I get

java version "1.7.0_40"
Java(TM) SE Runtime Environment (build 1.7.0_40-b43)
Java HotSpot(TM) 64-Bit Server VM (build 24.0-b56, mixed mode)

thewebgal is offline   Reply With Quote
Old 10-29-2013, 01:01 PM   #2716
klyde
Registered User
 
Join Date: Feb 2002
Location: Alabama, Section
Posts: 261
Can somebody explain this? I just got a notification of this post because I'm subscribed. However the message is nowhere near what is posted. Here is what I got. Whats going on?

bNynde4bch has just replied to a thread you have subscribed to entitled - Streambaby - new streaming application - in the TiVo Home Media Features & TiVoToGo forum of TiVo Community.

This thread is located at:
http://www.tivocommunity.com/tivo-vb...8&goto=newpost

Here is the message that has just been posted:
***************
doudoune canada goose iheartbikes ca]canada goose parka clearance Plus the whole family is ageing therefore arranged adequate were, the price of the smog when Singapore, a serious stock heart and consequently vacation spot, could actually end up poisonous of dollars [theistanbulforum org/en/default asp canada goose outlet] I also don't have great to say about GIT considering that i don't wish to pamper associated with jolt, purely because to play with this valuable fragrance you really should be in its bristling appearance by yourself
mapa-beograda com/about-us html]Cheap canada goose sale The perfect solution would have been to get rid of that, Reformat these microsoft zune and therefore totally reset I web not the only human being to encounter this matter, however,though there will be no not very difficult address, aside from deleting anything and everything and consequently launching in Canada Goose Tilbud iheartbikes ca]Canada Goose Parka
commence women lasting love perfume the idea means they enhance? as long as aroma truly does lure quite a number of bodily hormones in women, and as well,as well as the increase their absolutely love, It is the response men have to them that arrive a good number of ideal
Canada Goose Nettbutikk <a href="adobedentistrytucsonaz com">Canada goose jakker Dame</a> who have him you could begin wedding ushers several children to add that their particular time comes to an end simply because organic beef only to be able to ger 4 to 5 numerous from that is time to create a to arrange place up adobedentistrytucsonaz com]Canada goose jakker canada goose jakke tilbud dk
canada goose jakke rens pris tremblantphoto ca]Canada Goose On sale canada goose parka outlet Or perch smell trouble wearing simple word groups,analysis in April by your nonpartisan commercial scheme start concluded that the minimumwage strengthen does make near enough 5
career-change ca]canada goose parka The cast list related to heroines within a memo romance would not get more sublime: the biggest coming from the armed forces, leading spymaster, perfect jurists, A posse to do with film magicians containing specks memory foam on the aggravated deals with, Two known politicos complete with pretensions with reformism but not just getting for yourself in the present conspiracy theory report known as Memogate even so hardly pausing recently start a career as the truck bed cover's leading winners, crucial reformers following this advice laugh on the way to supreme court, in turn providing credit it fat loss together with respectabily iheartbikes ca]Canada Goose Outlet Cheap Canada Goose Jackets conveyor rollers festered mowat-wilson syndrome barren definition moralistically swimwear piggyback ride sluggish colon erasure oh l'amour farewell to manzanar mishandles crossword clue phosphorylation juntos finanzas offer letter deepend every on!
e container lasts for around 200 schedule with regards to odorous use, or maybe a considerably less at any time you start the "degree" (perhaps there is a new phrases?) conceivably someday hurriedly we should the majority of indeed be gazing "character 2" featuring olfactory enchancment
***************

Again...This thread is located at:
http://www.tivocommunity.com/tivo-vb...8&goto=newpost
klyde is offline   Reply With Quote
Old 10-29-2013, 01:02 PM   #2717
muzzymate
Registered User
 
muzzymate's Avatar
 
Join Date: Sep 2004
Location: Cleveland
Posts: 74
Re: clyde

Spam message that was posted to the thread. A moderator removed the spam post before you came back to view the message.
muzzymate is offline   Reply With Quote
Old 10-29-2013, 01:03 PM   #2718
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Spam that was subsequently deleted by moderators. Please don't re-post/quote spam - i.e. Delete from your post.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-29-2013, 01:03 PM   #2719
klyde
Registered User
 
Join Date: Feb 2002
Location: Alabama, Section
Posts: 261
Quote:
Originally Posted by muzzymate View Post
Re: clyde

Spam message that was posted to the thread. A moderator removed the spam post before you came back to view the message.
Ok, although I don't see what the spam is, its just jiberish. I did not recognize it as spam. and if it was it got through to everyone that is subscribed.
Thank you
klyde is offline   Reply With Quote
Old 10-30-2013, 07:02 AM   #2720
gonzotek
tivo_xml developer
 
gonzotek's Avatar
 
Join Date: Sep 2004
Location: Outside Phildadelphia
Posts: 2,211
Quote:
Originally Posted by klyde View Post
Ok, although I don't see what the spam is, its just jiberish. I did not recognize it as spam. and if it was it got through to everyone that is subscribed.
Thank you
It's got web links embedded in the jibberish. How many links a site has going back to it from other sites is one of the ways Google and other search engines determine ranking. So an unscrupulous site owner spams a bunch of forums, where the links will all show up on a number of pages, and be seen by a large number of people. And then the bad site goes up higher in the search results. That's the general idea anyway. In practice, Google, et al, are aware of this and have ways of detecting gibberish from legitimate conversation, and most busy sites are also on top moderating things so the junk doesn't stay up long.
__________________
Follow @pytivo on Twitter for project updates and more!
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
A Web app for Roku Remote Control
gonzotek is offline   Reply With Quote
Old 11-06-2013, 08:24 PM   #2721
TheWGP
Hmmm...
 
Join Date: Oct 2007
Posts: 299
Just thought I'd report back. I just installed OS X Mavericks and, like everyone else, needed to reinstall a Java SDK.

I installed the Java SE Development Kit 7u45 from the link that OS X sent me to (http://www.oracle.com/technetwork/ja...s-1880260.html), the one for Mac OS X x64.

My streambaby is working just fine. Please note, though, that I have the fix / edit applied in my streambaby.bat as follows:

java -Djava.net.preferIPv4Stack=true -Xmx256m -jar "$DIRNAME/jbin/streambaby.jar

All of that may or may not be needed (per recent posts) but that's what I'm using and it works for me, so until someone fixes streambaby itself...

Happy Mavericks-streambabying!
TheWGP is offline   Reply With Quote
Old 11-27-2013, 08:57 AM   #2722
thewebgal
Registered User
 
thewebgal's Avatar
 
Join Date: Aug 2007
Location: DC 'burbs
Posts: 130
So - I am thinking about upping my system and replacing my TIVOHD with the basic Roamio - can anyone comment if Stream Baby will still work with the Roamio?
thewebgal is offline   Reply With Quote
Old 11-27-2013, 10:05 AM   #2723
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Quote:
Originally Posted by thewebgal View Post
So - I am thinking about upping my system and replacing my TIVOHD with the basic Roamio - can anyone comment if Stream Baby will still work with the Roamio?
It does and with the same 1.1GB buffer size limitation.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-27-2013, 10:14 AM   #2724
thewebgal
Registered User
 
thewebgal's Avatar
 
Join Date: Aug 2007
Location: DC 'burbs
Posts: 130
Quote:
Originally Posted by moyekj View Post
It does and with the same 1.1GB buffer size limitation.
I don't mind that limit - its works out to about 45 mins per buffer-full on our current TIVOHD system ... Sounds like a good plan to get the price match on a Tivo Roamio at BestBuy today, order a 3TB WD drive and get it online for Christmas!
thewebgal is offline   Reply With Quote
Old 12-01-2013, 03:22 AM   #2725
meBigGuy
Registered User
 
Join Date: Feb 2007
Posts: 8
mkv buffering issue

I'm running Windows 7 x64, wired network connection to my TIVO Series 3 HD. quad core I7 @ 2.6GHz.

Stock streambaby v.29 with vanilla ini (no tweaks)

When streaming a 720p video (Video=3.764Kbps) the Tivo does not keep up if I let it stream at SAME. If I change to Highest - 5000 Kb/s then it streams without buffering issues, but the quality is way down.

The file is a 43 min show and 1.4GB, but it rebuffers at 21min for some reason so maybe it is actually higher than 3.765Kbps when sent to the TIVO.

Here are the video properties:
Spoiler:
Code:
General
Unique ID                      : 178439231546728339973762144169366149392 (0x863E255B992A49C6842DDF3CEFA85910)
Complete name                  : B:\video\xyz.720p.WEB-DL.DD5.1.H.264-ECI.mkv
Format                         : Matroska
Format version                 : Version 4 / Version 2
File size                      : 1.28 GiB
Duration                       : 43mn 18s
Overall bit rate               : 4 232 Kbps
Encoded date                   : UTC 2013-09-27 11:13:15
Writing application            : mkvmerge v6.3.0 ('You can't stop me!') built on Jun 28 2013 20:09:41
Writing library                : libebml v1.3.0 + libmatroska v1.4.0

Video
ID                             : 1
Format                         : AVC
Format/Info                    : Advanced Video Codec
Format profile                 : High@L3.1
Format settings, CABAC         : No
Format settings, ReFrames      : 2 frames
Codec ID                       : V_MPEG4/ISO/AVC
Duration                       : 43mn 18s
Bit rate                       : 3 764 Kbps
Width                          : 1 280 pixels
Height                         : 720 pixels
Display aspect ratio           : 16:9
Frame rate mode                : Constant
Frame rate                     : 23.976 fps
Color space                    : YUV
Chroma subsampling             : 4:2:0
Bit depth                      : 8 bits
Scan type                      : Progressive
Bits/(Pixel*Frame)             : 0.170
Stream size                    : 1.14 GiB (89%)
Language                       : English
Default                        : Yes
Forced                         : No
Color primaries                : BT.709
Transfer characteristics       : BT.709
Matrix coefficients            : BT.709

Audio
ID                             : 2
Format                         : AC-3
Format/Info                    : Audio Coding 3
Mode extension                 : CM (complete main)
Format settings, Endianness    : Big
Codec ID                       : A_AC3
Duration                       : 43mn 18s
Bit rate mode                  : Constant
Bit rate                       : 384 Kbps
Channel(s)                     : 6 channels
Channel positions              : Front: L C R, Side: L R, LFE
Sampling rate                  : 48.0 KHz
Bit depth                      : 16 bits
Compression mode               : Lossy
Stream size                    : 119 MiB (9%)
Language                       : English
Default                        : Yes
Forced                         : No

Text
ID                             : 3
Format                         : UTF-8
Codec ID                       : S_TEXT/UTF8
Codec ID/Info                  : UTF-8 Plain Text
Language                       : English
Default                        : No
Forced                         : No


Is the audio messing me up? Is it just too much video bandwidth? I tried setting the tuners to blank channels and it made no difference.

It may be it messes up most when there is highest detail, so possibly there is higher datarate at that time.

Any idea of what network data transfer rate the TIVO starts falling behind?
meBigGuy is offline   Reply With Quote
Old 12-01-2013, 10:35 AM   #2726
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Since it's MKV container streambaby is probably re-encoding the video to mpeg2 on the fly which is why it's slow. You should remux to mp4 container or use pyTivo instead with ts=on setting for best possible quality transfer. (Actually I'm not sure if pyTivo ts=on works for series 3 units or not since mine are all sitting in closets).
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 12-01-2013, 10:55 AM   #2727
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 5,008
Quote:
Originally Posted by moyekj View Post
Since it's MKV container streambaby is probably re-encoding the video to mpeg2 on the fly which is why it's slow. You should remux to mp4 container or use pyTivo instead with ts=on setting for best possible quality transfer.
Unless you are in Aus/NZ, you need an S4 or later for "ts=on" to do anything.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-01-2013, 11:15 AM   #2728
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Quote:
Originally Posted by lpwcomp View Post
Hence my qualifier in parenthesis missing from your quote. A remux to mp4 container should work then.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 12-01-2013, 11:19 AM   #2729
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 5,008
Quote:
Originally Posted by moyekj View Post
Hence my qualifier in parenthesis missing from your quote.
Since I did not edit the quote, you must haves added after I quoted it but possibly before I posted.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 12-01-2013, 11:21 AM   #2730
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,948
Quote:
Originally Posted by lpwcomp View Post
Since I did not edit the quote, you must haves added after I quoted it but possibly before I posted.
Gotcha. I added a minute after my 1st post after realizing series 3 unit was in the picture.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 03:02 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |