TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Series3 HDTV DVRs
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 08-27-2013, 05:38 PM   #1
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Amazon HD Instant Video download problems

I can't get purchased HD Instant Video rentals to download and play correctly on my Tivo HD (model 652). I rent and initiate from the Amazon web site.

SD videos download and play fine. HD videos start downloading but either the download speed is ridiculously slow or it stalls completely, although in one case a 2-hr movie downloaded in 4 hrs -- but it stalled during playback just 15 mins into the video and there was no way to play the rest of it. This same movie, on a retry, was still downloading after 12 hrs upon which it quit and the message in the To Do Recording History said someone at my end cancelled it (not true).
I've tried several HD downloads and they all exhibit the same issues.

I've unregistered and re-registered my Tivo -- no change. My TiVo is on wired ethernet that tests greater than 10 Mbps download speeds. I have a BR player that can stream these same videos even over WiFi with no problem.

I've restarted the TiVo. I have 11.0m software now and the problem was the same with 11.0k.

Amazon wants me to reboot my router and then call them (again) if I still have problems. They claim to have great diagnostic tools they can apply to this problem -- but not til I reboot the router. So I'll do that ..... then test their great diagnostic powers.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 08-27-2013, 07:37 PM   #2
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Update:
I power-cycled my router and started another HD download. Same problem, e.g., 10 mins of video downloaded in 53 minutes. I called Amazon support and the rep said that definitely wasn't right and said he was documenting it and submitting it to their techies. He said he saw other people were having the same problem but if that were true I would think there would be recent posts on this forum.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 08-28-2013, 07:25 AM   #3
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Another update:
Last night I downloaded a 52 minute HD video, Rome Season 1, Episode 1.
It took 3.5 hours to download and playback would freeze at the 22 minute point with no way to access video beyond that point.

Can anyone else using a TivoHD (model 652) confirm either:
1. Successful download and playback of Amazon Instant Video HD videos.
(or)
2. Unable to do so like me ?
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 08-28-2013, 10:07 AM   #4
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Yet another update:
This morning I downloaded and viewed the SD version of Rome, Season 1, Episode 1. The video has big black borders on all sides but the zoom setting makes it fill the screen and the PQ is pretty decent on my "little" 40" screen. I suspect it would not satisfy on larger screens though.

The SD version downloads at about real time rates and allows viewing to start just a few minutes after download starts -- significant advantages.

SD versions will probably be the compromise solution for me but I'm going to continue to pester Amazon -- they say my Tivo model supports their HD downloads and they should make it so, or stop saying that.

BTW, they didn't exploit sex and nudity much in that series did they?
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 08-31-2013, 11:13 AM   #5
HerronScott
Registered User
 
Join Date: Jan 2002
Location: Staunton, VA
Posts: 936
Since it's free, I just started the download on my S3 OLED and will let you know how it goes. I'll repeat it on my son's S3 HD when I get a chance as well (it's upstairs so harder to monitor the download time).

Scott
HerronScott is offline   Reply With Quote
Old 08-31-2013, 11:47 AM   #6
HerronScott
Registered User
 
Join Date: Jan 2002
Location: Staunton, VA
Posts: 936
It took 28 minutes to download and was 1.98GB in size on my S3 OLED. I let it play from 20-25 minutes with no problems.

I'll go repeat this on my son's HD and let you know the results.

Scott
HerronScott is offline   Reply With Quote
Old 08-31-2013, 12:41 PM   #7
HerronScott
Registered User
 
Join Date: Jan 2002
Location: Staunton, VA
Posts: 936
OK test completed on an HD. It took 37 minutes to download and same size was reported (1.98GB) on my son's HD. This is on an 802.11G wireless bridge connection just FYI. I heard my son on a Skype call with his girlfriend when I went to check on the download near the end so this may have accounted for the slightly longer download time. No issues with playback at 22 minutes or beyond.

Given the really really long download time I would guess some kind of corruption in the download?

Scott
HerronScott is offline   Reply With Quote
Old 08-31-2013, 02:28 PM   #8
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Quote:
Originally Posted by HerronScott View Post
OK test completed on an HD. It took 37 minutes to download and same size was reported (1.98GB) on my son's HD. This is on an 802.11G wireless bridge connection just FYI. I heard my son on a Skype call with his girlfriend when I went to check on the download near the end so this may have accounted for the slightly longer download time. No issues with playback at 22 minutes or beyond.

Given the really really long download time I would guess some kind of corruption in the download?

Scott
Thanks Scott. What kind of download speeds does your internet test at?
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 08-31-2013, 02:45 PM   #9
HerronScott
Registered User
 
Join Date: Jan 2002
Location: Staunton, VA
Posts: 936
We've got Comcast's normal package (Performance with Powerboost). Right now it's measuring 27mbps down and 4.5mbps up. Shaperprobe shows 23mbps down without shaping and 4.5mbps up with no shaping detected.

Scott
HerronScott is offline   Reply With Quote
Old 08-31-2013, 03:06 PM   #10
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Quote:
Originally Posted by HerronScott View Post
We've got Comcast's normal package (Performance with Powerboost). Right now it's measuring 27mbps down and 4.5mbps up. Shaperprobe shows 23mbps down without shaping and 4.5mbps up with no shaping detected.

Scott
1.98 GB in 37 mins is around 7.3 Mbps, which seems reasonable, about 70% of what model 652's are good for on TTG transfers. Your internet is a lot faster than mine but I usually test above 10 Mbps down, 1 Mbps up, so my slow Amazon downloads are not explained by that.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 09-01-2013, 10:35 AM   #11
HerronScott
Registered User
 
Join Date: Jan 2002
Location: Staunton, VA
Posts: 936
Quote:
Originally Posted by dlfl View Post
1.98 GB in 37 mins is around 7.3 Mbps, which seems reasonable, about 70% of what model 652's are good for on TTG transfers. Your internet is a lot faster than mine but I usually test above 10 Mbps down, 1 Mbps up, so my slow Amazon downloads are not explained by that.
Is that DSL or a lower tier with your cable provider?

Any chance you could take your TiVo to a friend's house to test the same download (preferably with a different Internet provider)?

Scott
HerronScott is offline   Reply With Quote
Old 09-01-2013, 12:59 PM   #12
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Quote:
Originally Posted by HerronScott View Post
Is that DSL or a lower tier with your cable provider?

Any chance you could take your TiVo to a friend's house to test the same download (preferably with a different Internet provider)?

Scott
It's medium speed TWC (Roadrunner) cable spec'ed at 10 Mbps down, and my Tivo is hardwired to the router. My internet rarely tests less than 10 Mbps and never below 5 Mbps. I have a number of internet connected devices on my network including several that stream video. Nary a problem with those. When I TTG from my Tivo to PC I see the maximum rate that a TivoHD can sustain, i.e, about 11 Mbps.

Having a hard time believing it's my network or internet that is the problem.

As of yesterday I could not even get Instant Video downloads, including non-HD videos, to even start, so am working with their support again.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 09-04-2013, 02:04 PM   #13
edubbrulez
Registered User
 
Join Date: Mar 2004
Location: SE, PA
Posts: 420
Interesting.

I'm experiencing the same problem on my TiVo HD. Tried twice to download and play Jack Reacher in HD. The video downloaded - but when I tried to play it playback paused around the 1hr 30 min mark the first time. The second time around the 30 min mark.

When I say paused - the last frame of the video from the playback is shown - and that's it. I thought it might have been related to a botched download - but I checked my router's wireless activity and I see that it downloaded the entire movie (5GB) twice.

Very strange.
edubbrulez is offline   Reply With Quote
Old 09-04-2013, 02:53 PM   #14
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Quote:
Originally Posted by edubbrulez View Post
Interesting.

I'm experiencing the same problem on my TiVo HD. Tried twice to download and play Jack Reacher in HD. The video downloaded - but when I tried to play it playback paused around the 1hr 30 min mark the first time. The second time around the 30 min mark.

When I say paused - the last frame of the video from the playback is shown - and that's it. I thought it might have been related to a botched download - but I checked my router's wireless activity and I see that it downloaded the entire movie (5GB) twice.

Very strange.
Are you also experiencing the Tivo Search problem?

My Amazon problem got progressively worse over the last week or so. At first it was just that HD videos would not download or downloaded at ridiculously slow speeds, then had defects. In the next phase, only non-HD videos would download. Finally (as of yesterday) when I rent a video on the Amazon website, the button, or link, to download isn't even displayed. I've talked to Amazon Instant Video support several times and have un-linked then re-linked my Tivo several times.

Just now I tested YouTube and Netflix and they work fine -- but they aren't downloads, rather they are streaming.

Today I noticed that pyTivo pushes no longer work while pulls do work. I think the pushes depend of the same download handshake with the TiVo mind server (mind.tivo.com) as the Amazon downloads. I suspect the Tivo Search unavailability and these download problems are all related.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 09-04-2013, 05:44 PM   #15
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Interesting post by a Tivo employee concerning the unavailabilty of Tivo Search on some Series 3 boxes:
http://www.tivocommunity.com/tivo-vb...71#post9799671
Two posts later I asked if this might be related to Amazon download problems.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 09-05-2013, 02:36 PM   #16
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
The Tivo Search problem and, simultaneously, pyTivo push failures have been fixed. My amazon instant video download problems continue. Their support says the techies are working on it and it affects more than just my account. Strange since no one else is posting about it here.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 09-06-2013, 01:27 PM   #17
JLCKJC
Registered User
 
Join Date: Sep 2013
Posts: 1
I am also experiencing what appear to be corrupt video down loads from Amazon. All other functions and features of my Tivo Premiere XL function perfectly. I have a firm 802.11n network connection at 5GHz.

The videos usually download as expected but when played they will run for some time and then freeze with some video corruption at the top of screen. I can't view beyond that point. If I restart the video it will play to the same point and fail in the same way. The problem is random, sometimes I get a good download other times not. Usually the downloads are fast but I have seen situations where they seem to take much more time than is usually the case. I've also seen the Tivo reboot during a download and restart the download all over again. All symptoms of the same problem I think.
JLCKJC is offline   Reply With Quote
Old 09-07-2013, 11:15 AM   #18
fishbate
Registered User
 
Join Date: Sep 2005
Posts: 10
I've had same problem. Was able to download episodes of Breaking Bad in HD to my Premiere XL, but it freezes up about 30 minutes into show. Ended up streaming it through my kid's Wii, which played just fine. I've downloaded several SD videos which played without problems. Has anyone been able to download and play Amazon HD videos successfully?

Last edited by fishbate : 09-07-2013 at 11:17 AM. Reason: clarification
fishbate is offline   Reply With Quote
Old 09-07-2013, 03:04 PM   #19
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Last night my Tivo downloaded 7 shows that I had tried to download several days ago. All of them were free "shorts" except one 52 Min HD video (Rome, Pilot). All the short videos were fine. The Rome episode looks OK just scanning through it from start to finish, but I haven't watched every second of it.

So I was encouraged to think things were fixed. I went to the Amazon site and tried to start downloads on two more HD shorts. One of them went fine. On the other one, when I would click the "1-click purchase" button I would get the rotating wait symbol for a long time then finally a message would pop up saying the purchase was taking too long to complete. And the video would not download, nor was it in my Video Library. I gave them a nasty-gram feedback on that one -- actually it was the Ironsides trailer or sneak preview. Maybe it was a problem with just that video.

I would like to test a 2 hr HD movie download, but actually there are none that I want to see bad enough to pay for. I'm in the fortunate position of having other ways to get video content. So my pursuit of this issue is based more on principle than on practical need.

I did note I was getting 4 to 5 Mbps transfer rates on the transfers, much faster than last week.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 11-08-2013, 07:55 PM   #20
westtown73
Registered User
 
Join Date: Nov 2007
Posts: 27
I am experiencing this as well on my Tivo HD. Two weeks ago and tonight I ordered HD movies from Amazon and the download proceeded at a snail's pace. The first one eventually completed, but we got about half way through, and the file was corrupted. The one tonight won't be watchable according to the Tivo, for another 8 hours. Was there ever any resolution to this issue?
westtown73 is offline   Reply With Quote
Old 11-08-2013, 09:41 PM   #21
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
The issue had gone away as indicated in my previous post, but there was never any explanation or feedback of any sort from Amazon, although three different support reps had assured me they would let me know what they found.

I haven't had occasion to want to download any Amazon Instant Videos since then. A real test would have to involve a full movie or full episode and there aren't any of those that are worth the rental cost to me at the moment.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 11-08-2013, 11:35 PM   #22
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
Update: As a test, downloaded Rome, Season 1, Episode 1, HD version. It's 52 min. and took 1 hr, 12 min to download. Per Tivo, the file size is 1.98 GB and the download speed was 3.99 Mbps. This is somewhat below average but a connection to Tivo (guide update) was underway during this download.

Download of the last 12 min of the video took only 9 min, after the guide update connection had completed, indicating a download speed of 6.7 Mbps, although the accuracy of this is limited by the accuracy of the data used.

It appears HD downloads are working reasonably well for me, although the behavior you're seeing matches what I had seen in the past, when I started this thread.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 11-09-2013, 07:21 AM   #23
westtown73
Registered User
 
Join Date: Nov 2007
Posts: 27
Thanks for your test. I noticed someone else in the thread "amazon slow download" posted about the same issue on 11/4 so it is still present. Both my downloads were on a Friday night around 6PM, so it could be a congestion issue. I'll do my next download at some other time to see if that fixes the problem.
westtown73 is offline   Reply With Quote
Old 11-09-2013, 07:29 AM   #24
dlfl
Cranky old novice
 
dlfl's Avatar
 
Join Date: Jul 2006
Location: Near Dayton, Ohio
Posts: 5,937
When I had this issue it went on for several days or maybe a week. Hope your experience is better. Although they provide no meaningful feedback, I assume complaining to Amazon makes a difference. If your problems don't clear up quickly I would recommend doing that.

Where is the "amazon slow download" thread you mentioned? A link would be helpful.
__________________

"It must be swell to be so perfect and odor-free" -- Del Griffith


VideoReDo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

pyTivo users: Try
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dlfl is offline   Reply With Quote
Old 11-09-2013, 10:37 AM   #25
westtown73
Registered User
 
Join Date: Nov 2007
Posts: 27
Link to Other Amazon Download Issues Thread

Here's the link. It puts the blame on Amazon.

http://www.tivocommunity.com/tivo-vb...download+movie
westtown73 is offline   Reply With Quote
Old 11-11-2013, 06:58 PM   #26
sandyjasmine
Registered User
 
Join Date: Aug 2007
Posts: 10
Quote:
Originally Posted by westtown73 View Post
Here's the link. It puts the blame on Amazon.

http://www.tivocommunity.com/tivo-vb...download+movie
That makes sense
sandyjasmine is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 03:54 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |