TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > DirecTV TiVo Powered PVRs & Receivers
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 07-16-2013, 10:58 AM   #1
turquoisewords
Registered User
 
Join Date: Jul 2013
Posts: 1
Hughes SD-DVR40 hard drive issue

Please bear with me as I go through a somewhat complex set of troubleshooting and the eventual results ...

My Hughes SD-DVR40 (with WD Caviar Blue 250gb replacement [IDE] hard drive) started having problems in the spring -- many recorded programs would play with almost unwatchable pixelation, pauses, etc. The unit would also periodically reboot (but always come back up). Then about two weeks ago it failed to boot (stuck at the "Powering Up" screen). I figured the hard drive (which replaced the original 40gb drive in 2011) was bad. I had a spare WD10EARS 1tb SATA drive that I I had not been using and decided to try that. Ordered a cheap SATA to IDE adapter ($6.95) from Amazon. Then I used dd_rescue to copy the 250gb drive to the 1tb SATA drive (under linux). Strange that I got no errors. I also ran the Western Digital DOS-based diagnostics (from a USB thumb drive) on the supposedly bad disk and got zero errors on both the short and long tests. Hmmm. Also used the WD program to turn off idle parking (wdidle3) on the WD10EARS 1tb drive.

Next my problems compounded after putting the 1tb drive in the dvr40 when it would not even display the "Powering Up" screen and no front panel lights at all. Thinking that maybe something was wrong with the SATA/IDE adapter I put the original IDE 250gb drive back in. Same problem -- no power. Sure looked like a power supply issue now. So I went on ebay and bought a used dvr40 and then swapped in the power supply from the ebay dvr40. Since the original 250gb drive had no errors on the WD diagnostic tests I left it in. Now the dvr40 powered on and went to the "Powering Up" screen (green light lit), but did not get past that. Oh well. Next step: put in the 1tb drive (with SATA/IDE adapter) and tried that. Bingo! Worked perfectly -- all my recorded programs and season passes still there. The nice thing about the $6.95 SATA/IDE adapter is that it has a drive activity LED that you can watch with the dvr cover off -- it pretty much is constantly flashing (even when no programs are being recorded). No wonder Tivo disk drives fail so frequently -- they are active 24 by 7.

So my question: how is it possible that a disk drive can pass all diagnostic tests but still fail to boot? The obvious answer would be corruption on the disk. But in my case we can rule that out since I had used dd_rescue to make an exact block by block copy of the original drive. I'm stumped.
turquoisewords is offline   Reply With Quote
Old 07-16-2013, 12:51 PM   #2
stevel
Dumb Blond
 
stevel's Avatar
 
Join Date: Aug 2000
Location: Nashua, NH
Posts: 24,180
TC CLUB MEMBER
The WD diagnostic tests are mainly what qualifies for a RMA and they are not at all rigorous.

As for the drive always active, yes, that's for the live buffers. The drives used in DVRs are designed for this.
__________________
Steve
stevel is offline   Reply With Quote
Old 07-16-2013, 11:00 PM   #3
Arcady
Stargate Fan
 
Arcady's Avatar
 
Join Date: Oct 2004
Location: Philadelphia, PA
Posts: 2,888
How many hours do you get with a 1tb drive in that thing?

Seems like a lot of effort for horrible SD video...
__________________
Roamio Pro (3TB)
Premiere Elite (2TB)
Premiere (320GB)
Two TiVo Minis

Left DirecTV 4/15/07. Left TWC 8/8/11. Now on Comcast Xfinity.
Arcady is offline   Reply With Quote
Old 07-17-2013, 07:00 AM   #4
stevel
Dumb Blond
 
stevel's Avatar
 
Join Date: Aug 2000
Location: Nashua, NH
Posts: 24,180
TC CLUB MEMBER
Nowadays a 1TB drive is an inexpensive choice. You would pay more for a smaller drive, especially if you wanted IDE.
__________________
Steve
stevel is offline   Reply With Quote
Old 07-18-2013, 10:19 PM   #5
Ropajohn
Registered User
 
Join Date: Feb 2007
Posts: 2
I installed a 1TB drive in a DirecTV R10 and it reports 880 hours.

I did have a problem with it when the drive was getting full (500+ shows and a bunch in the deleted folder). The guide started to get slower (as in not getting shows very far ahead) and slower as the drive filled up. Eventually, the guide was only displaying shows a few hours ahead. I re-booted the unit because at the time I didn't know what else to do and it stuck on 9% download. On a whim, I started to delete some "deleted" shows and then re-booted the unit and it started up fine. As I deleted more "TiVo Suggestions" shows the unit "appeared" to operate faster and the guide started to display shows further out (in time). After deleting 350+ shows the unit seems to operate great now.
Ropajohn is offline   Reply With Quote
Old 07-19-2013, 07:17 AM   #6
DrSmith
Registered User
 
Join Date: Jan 2009
Posts: 9
Quote:
Originally Posted by Arcady View Post
Seems like a lot of effort for horrible SD video...
Sorry to be off topic, but I have yet to see anything on HD (other than live sports) that is HD worthy. Long live SD. I'll take 100 hours of SD over 10 hours of HD storage every time.
DrSmith is offline   Reply With Quote
Old 07-24-2013, 11:51 PM   #7
RickySharon
Registered User
 
Join Date: Nov 2012
Posts: 13
Quote:
Originally Posted by DrSmith View Post
Sorry to be off topic, but I have yet to see anything on HD (other than live sports) that is HD worthy. Long live SD. I'll take 100 hours of SD over 10 hours of HD storage every time.
You took the words out of my mouth I just don't see any difference except cost.
RickySharon is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 07:33 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |