TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 06-21-2013, 08:27 PM   #1
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
Streambaby stops working after Pytivo video push

I've had Streambaby working for several weeks on new computer until this evening.

It starts up as a service and is running. However, it sees the folder, sees the MP4 files fine.

Then when I attempt to play the file I get "please wait" until a V01 error (service unavailable) appears after several minutes.

I do have port 7290 open as TCP. This has worked fine for weeks until now.

Is the issue related to Pytivo push of videos? I am wondering if there could be a conflict between the 2 apps somehow?

Please help. Thanks.
atomarchio is offline   Reply With Quote
Old 06-21-2013, 09:21 PM   #2
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,929
No, there is no connection.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 06-22-2013, 05:58 AM   #3
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
Quote:
Originally Posted by wmcbrine View Post
No, there is no connection.
I get that. If I see the Streambaby app "running" as a service and I can view the files, how do I troubleshoot the connection?
atomarchio is offline   Reply With Quote
Old 06-22-2013, 07:11 AM   #4
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
I tried reinstalling but the issue remains. Here is copy of log file.

06/22/13 08:04:57 StreamBabyMain$BshLogger: Download ffmpeg for first-run...
06/22/13 08:04:57 StreamBabyMain$BshLogger: Connecting: http://streambaby.googlecode.com/fil...-win32.tar.bz2
06/22/13 08:04:58 StreamBabyMain$BshLogger: Downloading...
06/22/13 08:04:59 StreamBabyMain$BshLogger: Finished downloading, begin extract.
06/22/13 08:05:00 StreamBabyMain$BshLogger: extracting: avcodec-52.dll (bin/avcodec-52.dll)
06/22/13 08:05:00 StreamBabyMain$BshLogger: extracting: avdevice-52.dll (bin/avdevice-52.dll)
06/22/13 08:05:00 StreamBabyMain$BshLogger: extracting: avformat-52.dll (bin/avformat-52.dll)
06/22/13 08:05:01 StreamBabyMain$BshLogger: extracting: avutil-49.dll (bin/avutil-49.dll)
06/22/13 08:05:01 StreamBabyMain$BshLogger: extracting: ffmpeg.exe (bin/ffmpeg.exe)
06/22/13 08:05:01 StreamBabyMain$BshLogger: extracting: ffplay.exe (bin/ffplay.exe)
06/22/13 08:05:01 StreamBabyMain$BshLogger: extracting: SDL.dll (bin/SDL.dll)
06/22/13 08:05:01 StreamBabyMain$BshLogger: extracting: swscale-0.dll (bin/swscale-0.dll)
06/22/13 08:05:01 StreamBabyMain$BshLogger: Retrieval of ffmpeg complete
06/22/13 08:05:01 FFmpegJavaVideoModule: Unable to load FFmpeg native libraries
06/22/13 08:05:01 Listener: added factory
06/22/13 08:05:01 Main: streambaby ready & listening.
atomarchio is offline   Reply With Quote
Old 06-22-2013, 10:32 AM   #5
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,881
Start simple and run streambaby in a console instead of as a service and make sure it works that way 1st. Read debugging_problems Wiki for how to get more debug information in streambaby.log.

If you've updated to Java 7 recently there are some issues running streambaby there according to streambaby thread posts, so you are better off running 32 bit Java 6 version instead.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 06-22-2013, 01:02 PM   #6
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
I just followed your instructions.

The error still appears to be something about "pegJavaConfig$1: Error attempting toload ffmpeg libraries: Unable to load library 'avutil-49': The specified module could not be found."

I am running Java 6 update 34. 64 bit

Any suggestions on what I can do at this? I am not sure how to proceed from here.






06/22/13 13:56:17 StreamBabyConfig: WorkingDir: "C:\Users\streambaby-20120828-2030"
06/22/13 13:56:17 StreamBabyConfig: StreamBabyDir: C:\Users\streambaby-20120828-2030
06/22/13 13:56:17 StreamBabyConfig: CurDir: C:\Users\streambaby-20120828-2030\native
06/22/13 13:56:17 StreamBabyConfig: CoverDir:
06/22/13 13:56:17 FFmpegJavaConfig$1: Loading avutil, default: avutil-49
06/22/13 13:56:17 FFmpegJavaConfig$1: Error attempting toload ffmpeg libraries: Unable to load library 'avutil-49': The specified module could not be found.

06/22/13 13:56:17 FFmpegJavaVideoModule: Unable to load FFmpeg native libraries
06/22/13 13:56:17 FFmpegExeVideoModule: FFmpegPath: C:\Users\streambaby-20120828-2030\native\ffmpeg.exe
06/22/13 13:56:17 FFmpegExeVideoModule: FFmpegExeModule: Loaded
06/22/13 13:56:17 StreamBabyMain: STARTING StreamBaby v20120828-2030...
06/22/13 13:56:17 Main: args= start=true
06/22/13 13:56:17 Main: args= loader=sun.misc.Launcher$AppClassLoader@1a45a877
06/22/13 13:56:17 Listener: config=com.tivo.hme.host.util.Config@787bb290 logger=com.unwiredappeal.tivo.utils.Log$ILoggerImpl@10849bc
06/22/13 13:56:17 Listener: factoryList=[StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]]
06/22/13 13:56:17 Listener: factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]
06/22/13 13:56:17 Listener: name=/streambaby/
06/22/13 13:56:17 Listener:
06/22/13 13:56:17 Listener: added factory
06/22/13 13:56:17 Main: factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]
06/22/13 13:56:17 Main: MDNS: http://192.168.1.106:7290/streambaby/
06/22/13 13:56:17 Main: streambaby ready & listening.
06/22/13 13:56:17 Main: mdns_type=_tivo-hme._tcp.local. factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream] port=7290
06/22/13 13:56:23 TiVoListener: addService: BASEMENT
06/22/13 13:56:23 TiVoListener: Updating service: _http._tcp.local. (BASEMENT)
06/22/13 13:56:23 TiVoListener: resolveService: _http._tcp.local. (BASEMENT)
06/22/13 13:56:23 TiVoListener: jmDns found TiVo: BASEMENT, tsn: 746000190AAB5CB
06/22/13 13:56:23 TiVoListener: addService: HEARTH ROOM
06/22/13 13:56:23 TiVoListener: Updating service: _http._tcp.local. (HEARTH ROOM)
06/22/13 13:56:23 TiVoListener: resolveService: _http._tcp.local. (HEARTH ROOM)
06/22/13 13:56:23 TiVoListener: jmDns found TiVo: HEARTH ROOM, tsn: 746000190729927
06/22/13 13:56:23 TiVoListener: addService: myrouter
06/22/13 13:56:23 TiVoListener: Updating service: _http._tcp.local. (myrouter)
06/22/13 13:56:23 TiVoListener: resolveService: _http._tcp.local. (myrouter)
06/22/13 13:56:23 TiVoListener: addService: Photosmart Prem C410 series [09818F]
06/22/13 13:56:23 TiVoListener: Updating service: _http._tcp.local. (Photosmart Prem C410 series [09818F])
06/22/13 13:56:23 TiVoListener: resolveService: _http._tcp.local. (Photosmart Prem C410 series [09818F])
06/22/13 13:56:23 TiVoListener: addService: BEDROOM
06/22/13 13:56:23 TiVoListener: Updating service: _http._tcp.local. (BEDROOM)
06/22/13 13:56:23 TiVoListener: resolveService: _http._tcp.local. (BEDROOM)
06/22/13 13:56:23 TiVoListener: jmDns found TiVo: BEDROOM, tsn: 7460001909BD3A5
atomarchio is offline   Reply With Quote
Old 06-22-2013, 10:53 PM   #7
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,881
Try 32 bit version of Java 6 instead of 64 bit - the ffmpeg dll files are 32 bit AFAIK.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 06-22-2013 at 11:02 PM.
moyekj is offline   Reply With Quote
Old 06-23-2013, 06:01 AM   #8
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
That fixed my Streambaby problem. Thanks.

But now I can't get Pytivo to push video files. It worked fine just prior to this.

Did the change in Java now cause a problem with Pytivo? I submitted a request to push video files which seems to worked fine. I got the refresh in 5 seconds screen and checked the log. I don't see any errors there.

Where I can start to find the this problem?
atomarchio is offline   Reply With Quote
Old 06-23-2013, 06:31 AM   #9
atomarchio
Registered User
 
Join Date: Sep 2006
Posts: 570
Everything else in Pytivo works fine including music, pictures, and I can see the video folders on the Tivo.

I just read the troubleshooting page and can't see any issues. I am wondering if this java change now caused the problem with Pytivo push?
atomarchio is offline   Reply With Quote
Old 06-23-2013, 09:41 AM   #10
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,881
Quote:
Originally Posted by atomarchio View Post
I just read the troubleshooting page and can't see any issues. I am wondering if this java change now caused the problem with Pytivo push?
They are not at all related - pyTivo uses Python, not Java. You should probably post your pyTivo related issue in the main pyTivo thread along with the pyTivo console output with "debug=on" in your pyTivo.conf file. Unless somehow you configured to use same ports in streambaby and pyTivo there should not be any conflicts between them.
Note that streambaby has a "push" option as well (though not as robust as pyTivo). See:
http://code.google.com/p/streambaby/...hConfiguration
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 09:42 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |