TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Forum Extras > Forum Operations Center
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 09-06-2012, 02:43 AM   #1
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
TCF Mobile nag prompt again

A while ago you guys enabled the "Only nag once" for the mobile apps like Tapatalk/ForumRunner.

It's off. Please enable it again. I don't want to get nagged every single time I re-start my mobile browser.

--Carlos V.
Unbeliever is offline   Reply With Quote
Old 09-06-2012, 07:17 AM   #2
Mike Lang
Super Moderator
 
Mike Lang's Avatar
 
Join Date: Nov 1999
Posts: 5,486
It's been on. Make sure your device is handling cookies correctly.
Mike Lang is offline   Reply With Quote
Old 09-06-2012, 07:25 PM   #3
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
Not just 1 device. 2 Android devices (tablet/phone) (using both the built in browser and Firefox), and 2 iOS devices (tablet/phone) (using the built in browser) and even a Maemo device (phone) (Firefox and built-in).

Cookies are fine.

--Carlos V.
Unbeliever is offline   Reply With Quote
Old 09-06-2012, 07:28 PM   #4
Mike Lang
Super Moderator
 
Mike Lang's Avatar
 
Join Date: Nov 1999
Posts: 5,486
I'm not getting nagged on an iPhone, iPod, or two different iPads.
Mike Lang is offline   Reply With Quote
Old 09-06-2012, 07:30 PM   #5
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
Are you issuing the cookie from a 3rd host? Mine are set to "from visited" only.

--Carlos V.
Unbeliever is offline   Reply With Quote
Old 09-06-2012, 07:36 PM   #6
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
Quote:
Originally Posted by Mike Lang View Post
I'm not getting nagged on an iPhone, iPod, or two different iPads.
To duplicate what I'm doing, close all your open tabs and go back to the home screen.

Then start up Safari again and visit TCF. Nag window. Leave any tabs open when you leave Safari and come back, no nag.

Its behaving like a session cookie, not a persistent one.

--Carlos V.
Unbeliever is offline   Reply With Quote
Old 09-06-2012, 08:06 PM   #7
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
Give it a while for the video to be processed by Youtube, but look at this:

TCF Nag behavior


Initial startup: Nag.
Go visit another site, go away, come back to safari and visit TCF: No nag.
Close all tabs, go away, come back and visit TCF: Nag.

That's essentially the behavior of all the mobile browsers I tried. Make the browser quit, and the nag reappears.

--Carlos V.
Unbeliever is offline   Reply With Quote
Old 09-06-2012, 09:33 PM   #8
Mike Lang
Super Moderator
 
Mike Lang's Avatar
 
Join Date: Nov 1999
Posts: 5,486
That's not happening to me. Set to from visited.
Mike Lang is offline   Reply With Quote
Old 09-06-2012, 10:57 PM   #9
dslunceford
Registered User
 
dslunceford's Avatar
 
Join Date: Oct 2000
Location: No. VA/D.C.
Posts: 5,039
I've seen it on my iPad and iPhone, and noticed it. Have cookies enabled and set to "visited." Not certain if I've seen in the last week or so, but do recall it occurring more than once recently.

Will try to remember to post/check settings if I see it occur again.
__________________
--Steve



To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
dslunceford is offline   Reply With Quote
Old 09-08-2012, 02:24 AM   #10
Unbeliever
Random Nobody
 
Join Date: Feb 2001
Location: Altadena, CA
Posts: 4,085
More info.

It's the frfdate cookie. It's set to expire at the end of a session. The skip_frf_cookie is properly persistent.

I moved over to my desktop and used Firefox User Agent Switcher to emulate a mobile host because it is easier for me to examine cookies.



Note the expiration field.

On my mobile devices, I actually do quit out of the browsers. I just don't home-screen out of them. On iOS, if any tabs have non-blank windows, it will stay active, and a single blank tab will quit. For Firefox, I actually hit 'quit'. If you want to duplicate, try rebooting your device. Once a session quits, that cookie goes away, and a re-visit to TCF brings up the nag screen.

I simulated it by both quitting and re-starting my desktop browser (masquerading as iOS Safari), and simulating a quit by deleting the frfdate cookie. Both caused a nag prompt revisiting TCF.

--Carlos V.
Attached Images
File Type: png frfdate.png (38.4 KB, 30 views)
Unbeliever is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 06:23 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |