TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 06-23-2012, 12:07 PM   #4111
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Quote:
Originally Posted by wmcbrine View Post
Just use pyTivo for that.
If one is not going to run tivodecode and comskip, absolutely. Of course one can run a script to handle those. One cannot delete the show after transferring, either, although that might be possible with Expect for the Premier and perhaps Curl with an S3.

Last edited by lrhorer : 06-23-2012 at 12:18 PM.
lrhorer is offline   Reply With Quote
Old 06-23-2012, 12:15 PM   #4112
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Quote:
Originally Posted by markmarz View Post
Okay, now I'm confused. Let me make clear what I'm doing now and where I'd like to end up. Right now I'm using vidmgr to push to my tivo. vidmgr uses the pyTivo.conf file to figure out where to push from; at least that's what I infer from:

Code:
[pytivos]
pytivo1.config=/usr/share/pyTivo/pyTivo.conf
vidmgr uses pyTivo to do the actual push as well, doesn't he?
Yes.

Quote:
Originally Posted by markmarz View Post
I'd like to be able to use the same instance of pyTivo .. currently running as a daemon .. to pull shows from the tivo onto a different share than the push share.

I don't see a way to configure that in pyTivo or vidmgr. Please feel free to push my nose directly into it.
That is typically the case. There can be many, many shares. The TTG directory is specified separately, and although it can be the same directory as one of the shares, it does not have to be a share directory. For example, my pyTivo.conf is:

Code:
[_tivo_SD]
audio_lang = en, eng, 0x80, 5.1, ac3

[_tivo_HD]
audio_lang = en, eng, 0x80, 5.1, ac3

[_tivo_00000DEADBEEF]

[Server]
tivo_password = XXXXXXX
tivo_mak = YYYYYYYYYYYY
ffmpeg = /usr/bin/ffmpeg
togo_path = /RAID/Server-Main/Movies/TiVo_TS
debug = True
tivo_username = ZZZZZZZ@zzz.zzz
port = 9032


[pyMusic]
type = music
path = /RAID/Music

[RAID Server]
force_alpha = True
type = video
path = /RAID/Recordings

[DVD]
path = /RAID/DVD
force_alpha = True
type = dvdvideo
fast_index = true

[Unverified]
type = video
path = /usr/share/pyTivo/Unverified

lrhorer is offline   Reply With Quote
Old 06-23-2012, 12:17 PM   #4113
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,924
Quote:
Originally Posted by markmarz View Post
Okay, now I'm confused. Let me make clear what I'm doing now and where I'd like to end up. Right now I'm using vidmgr to push to my tivo. vidmgr uses the pyTivo.conf file to figure out where to push from; at least that's what I infer from:

Code:
[pytivos]
pytivo1.config=/usr/share/pyTivo/pyTivo.conf
vidmgr uses pyTivo to do the actual push as well, doesn't he?

I'd like to be able to use the same instance of pyTivo .. currently running as a daemon .. to pull shows from the tivo onto a different share than the push share.

I don't see a way to configure that in pyTivo or vidmgr. Please feel free to push my nose directly into it.
You need to define a share in pyTivo.

First shutdown vidmgr.

Try opening a browser tab, navigate to http://localhost:9032/, select "Web Configuration", "Add Section", put in whatever you want to name the share, "Save Changes", highlight the new section in the list, put "video" as the type, put in the full path to the directory, put "True" in the force_alpha field if you want it sorted alphabetically, "Save Changes" then "Restart pyTivo".

Restart vidmgr.

If the above doesn't work, shutdown both pyTivo and vidmgr and use a text editor to modify the pyTivo.conf file to add the share. You need to create an entry in the file that looks something like this:
Code:
[Videos]
type = video
path = /mnt/samba/Videos
force_alpha = True
(The "force_alpha" line is optional) Change "Videos" inside the [] to be whatever you want the new share name to be and "/mnt/samba/Videos" to be the full path of the directory you want to use. Save the edited file (you'll be replacing the existing file) Then restart pyTivo and vidmgr.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"

Last edited by lpwcomp : 06-23-2012 at 12:21 PM. Reason: forgot that togo path was separate
lpwcomp is offline   Reply With Quote
Old 06-23-2012, 12:22 PM   #4114
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,914
pyTivo will handle tivodecode just fine.

markmarz, the directory or share name (either way) for pyTivo to pull to is specified by "togo_path" in the "Server" section of pyTivo.conf. And any video share can be pushed from, as others have said. I don't use VidMGR, so I can't comment on that.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 06-23-2012, 12:35 PM   #4115
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Quote:
Originally Posted by wmcbrine View Post
pyTivo will handle tivodecode just fine.
Oh, it can spawn an external script on the file after transferring it? I didn't realize. In that case, of course, an external script calling tivodecode and then wine / comskip would be easy to set up. The section that calls a delete would be a bit trickier, but may be reasonable, as well. The trick will b e determining from which Tivo the file was transferred.

William,

When calling the external script, can pyTivo pass the name or IP of the TiVo?
lrhorer is offline   Reply With Quote
Old 06-23-2012, 02:31 PM   #4116
todd_j_derr
Registered User
 
Join Date: Jun 2000
Location: Pittsburgh, PA, USA
Posts: 171
TC CLUB MEMBER
Quote:
Originally Posted by todd_j_derr View Post
Crap, I only tested the new ffmpeg using WMP on my computer but for some reason the resulting files did not play at all well on my Xoom - it dropped a lot of frames and was basically unwatchable.
The third time was a charm. This time I ditched ffmpeg and did the transcoding (manually) using handbrake with a Xoom preset I cobbled together from various sources on the net. Also I was finally smart enough to test the files before I was sitting on a plane Now I just need to incorporate that into a kmttg preset and I'll be good to go - although doing it manually isn't that big of a burden since handbrake has an encoding queue.
todd_j_derr is offline   Reply With Quote
Old 06-23-2012, 02:45 PM   #4117
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,914
Quote:
Originally Posted by lrhorer View Post
Oh, it can spawn an external script on the file after transferring it?
No. It will decode while transferring. It pipes it through.

May I suggest that further discussion of pyTivo be taken to the pyTivo thread, or its own thread, instead of the kmttg thread? I only brought it up to point out that it was not necessary to reengineer kmttg in order to do what pyTivo already does.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 06-24-2012, 06:56 AM   #4118
catfan64
Registered User
 
Join Date: Mar 2002
Location: Louisville KY
Posts: 215
encoding option

I am using KMTTG to copy recordings from a Tivo series 2. The only setting I use is decrypt, which removes the .tivo extension. I can burn the copied recording (.mpg) to a DVD, or copy to a usb thumb drive, and play on my DVD player or laptop, but it doesn't fill the whole screen. Does anyone know the best encode profile to use, that would make it fill the whole screen, without losing any video quality?
catfan64 is offline   Reply With Quote
Old 06-24-2012, 07:46 AM   #4119
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,924
Quote:
Originally Posted by catfan64 View Post
I am using KMTTG to copy recordings from a Tivo series 2. The only setting I use is decrypt, which removes the .tivo extension. I can burn the copied recording (.mpg) to a DVD, or copy to a usb thumb drive, and play on my DVD player or laptop, but it doesn't fill the whole screen. Does anyone know the best encode profile to use, that would make it fill the whole screen, without losing any video quality?
What size screen, 4:3 or 16:9?

Is the video 4:3 or 16:9?

Are there black bars all around or just top and bottom or on the sides?

Does the picture look distorted?

What does it look like when you watch it on the TiVo?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 06-24-2012, 08:44 AM   #4120
catfan64
Registered User
 
Join Date: Mar 2002
Location: Louisville KY
Posts: 215
Quote:
Originally Posted by lpwcomp View Post
What size screen, 4:3 or 16:9?

Is the video 4:3 or 16:9?

Are there black bars all around or just top and bottom or on the sides?

Does the picture look distorted?

What does it look like when you watch it on the TiVo?
I want to watch it on 16:9

When i watch the copied file, there are black bars all around.

The picture does not look distorted.

When I watch it on Tivo (on a 16:9 tv) it has black bars at the top and bottom.
catfan64 is offline   Reply With Quote
Old 06-24-2012, 09:16 AM   #4121
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,924
Quote:
Originally Posted by catfan64 View Post
I want to watch it on 16:9

When i watch the copied file, there are black bars all around.

The picture does not look distorted.

When I watch it on Tivo (on a 16:9 tv) it has black bars at the top and bottom.
If the picture is not distorted when you watch it on the TiVo, I assume that these are movies that are wider than 16:9. I also assume that the TiVo and the DVD player are on two different TVs.

While this doesn't directly address your question, have you tried changing the settings on the DVD player or the display mode of the TV?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 06-24-2012, 09:58 AM   #4122
catfan64
Registered User
 
Join Date: Mar 2002
Location: Louisville KY
Posts: 215
I just noticed that in the program info for the show on the Tivo, it notes "letterbox". And if i am viewing it from my tivo, on my HD 16:9 TV, set at "normal", it has black bars all the way around. On "normal", the tivo menus have black bars on the left and right, so I keep it set at "wide", so the tivo menus fill the screen. I guess the recordings are actually being stretched to the left and right. Also note, that these are NOT HD recordings. This is a series 2 Tivo, and I am hooked up to cable, and do NOT have a HD cable converter box, so I assume everything I recieve is in standard definition/format.

Yes, the TiVo and the DVD player are on two different TVs. The TV with the DVD palyer is also a 16:9 HD tv.

I have tried using the ZOOM setting on the tv with the dvd player, and while it fills the screen, it also crops it in a way, that you loose some of the picture, and it degrades the picture quality noticably.

I'm sure this is probably getting real confusing to you now. It's confusing me!!!!




__________________
catfan64 is offline   Reply With Quote
Old 06-24-2012, 10:11 AM   #4123
catfan64
Registered User
 
Join Date: Mar 2002
Location: Louisville KY
Posts: 215
Another thing i just realized. My Series 2 tivo is is hooked up to my HD TV using RCA composite cable (red, white, and yellow), as the Series 2 Tivo does not have HDMI or component outputs. In the TIVO settings for TV Aspect Ratio, I have it set on "Widescreen 16:9, but with the TV set to normal, the tivo menus have a black bars on the left and right. I would think that since the TIVO output is set to Widescreen 16:9, then it would fill the whole screen. Also, I have tried changing the Tivo TV Aspect Ratio to 4:3, and it does not change how it shows on the TV.
catfan64 is offline   Reply With Quote
Old 06-24-2012, 02:26 PM   #4124
warehouse
Registered User
 
Join Date: Aug 2003
Posts: 34
Sorry if this has been asked before but I've searched through this whole thread and can't seem to find the answer. I would like to use kmttg to automatically transfer and encode HD files from my Tivo to a format which I can burn to a DVD. My understanding is that they need to be MPEG-2 in either mpg or avi containers for me to use something like "Windows DVD maker" to author the DVD. Unfortunately none of the installed encoder profiles I've seen in kmttg support this mode. Do I need to somehow create a new profile to support this? Is there an existing profile somewhere I can just add to the profiles directory?
warehouse is offline   Reply With Quote
Old 06-24-2012, 04:18 PM   #4125
droedl
Registered User
 
Join Date: May 2008
Posts: 2
Request for Help: kmttg Fails to Launch with Error. Directs to Console Log for info.

I was unable to find a similar question in search.

I am getting the following when I try to launch kmttg.jar. "The Jave file kmttg.jar could not be launched. Check the Console for details." This is on a machine that I have used the program on before. I did transfer data from one hard disk to another recently, to an SSD. I have a similar configuration running on the same network on a Mac Mini with no issues.

Any tech interpreters out there who can read the tea leaves and explain what the console log is pointing to?


6/24/12 4:14:56.886 PM [0x0-0xfa0fa].com.apple.JarLauncher: Exception
6/24/12 4:14:56.887 PM [0x0-0xfa0fa].com.apple.JarLauncher: in thread "main"
6/24/12 4:14:56.888 PM [0x0-0xfa0fa].com.apple.JarLauncher: java.lang.NoClassDefFoundError: com/tivo/kmttg/main/kmttg
6/24/12 4:14:56.889 PM [0x0-0xfa0fa].com.apple.JarLauncher: Caused by: java.lang.ClassNotFoundException: com.tivo.kmttg.main.kmttg
6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.security.AccessController.doPrivileged(Native Method)
6/24/12 4:14:56.895 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301 )
6/24/12 4:14:56.897 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:247)



Things I have tried:
Downloading and installing a fresh copy.
Making sure java is active and working.
Repairing disk permissions.

Platform: Mac OS X 10.7
MacBook Pro mid 2009
droedl is offline   Reply With Quote
Old 06-24-2012, 04:28 PM   #4126
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,546
Quote:
Originally Posted by warehouse View Post
Sorry if this has been asked before but I've searched through this whole thread and can't seem to find the answer. I would like to use kmttg to automatically transfer and encode HD files from my Tivo to a format which I can burn to a DVD. My understanding is that they need to be MPEG-2 in either mpg or avi containers for me to use something like "Windows DVD maker" to author the DVD. Unfortunately none of the installed encoder profiles I've seen in kmttg support this mode. Do I need to somehow create a new profile to support this? Is there an existing profile somewhere I can just add to the profiles directory?
Use the Decrypt option in KMTTG, that will make them .mpg. You can then use VideoReDo TVSuite (windows only) to edit out commercials and burn to DVD. Its not free but it works.
__________________
TiVo HD 1TB (157 HD Hrs, PLS, "S3HD")
Roamio, Oh Roamio!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 06-24-2012, 04:37 PM   #4127
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,849
Quote:
Originally Posted by droedl View Post
I was unable to find a similar question in search.

I am getting the following when I try to launch kmttg.jar. "The Jave file kmttg.jar could not be launched. Check the Console for details." This is on a machine that I have used the program on before. I did transfer data from one hard disk to another recently, to an SSD. I have a similar configuration running on the same network on a Mac Mini with no issues.

Any tech interpreters out there who can read the tea leaves and explain what the console log is pointing to?


6/24/12 4:14:56.886 PM [0x0-0xfa0fa].com.apple.JarLauncher: Exception
6/24/12 4:14:56.887 PM [0x0-0xfa0fa].com.apple.JarLauncher: in thread "main"
6/24/12 4:14:56.888 PM [0x0-0xfa0fa].com.apple.JarLauncher: java.lang.NoClassDefFoundError: com/tivo/kmttg/main/kmttg
6/24/12 4:14:56.889 PM [0x0-0xfa0fa].com.apple.JarLauncher: Caused by: java.lang.ClassNotFoundException: com.tivo.kmttg.main.kmttg
6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
6/24/12 4:14:56.890 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.security.AccessController.doPrivileged(Native Method)
6/24/12 4:14:56.895 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:306)
6/24/12 4:14:56.896 PM [0x0-0xfa0fa].com.apple.JarLauncher: at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301 )
6/24/12 4:14:56.897 PM [0x0-0xfa0fa].com.apple.JarLauncher: at java.lang.ClassLoader.loadClass(ClassLoader.java:247)



Things I have tried:
Downloading and installing a fresh copy.
Making sure java is active and working.
Repairing disk permissions.

Platform: Mac OS X 10.7
MacBook Pro mid 2009
On a Mac you should launch "kmttg" script not "kmttg.jar". If there is a permissions problem then first do the following from command prompt:
chmod +x kmttg
./kmttg
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 06-24-2012, 05:53 PM   #4128
droedl
Registered User
 
Join Date: May 2008
Posts: 2
re: Request for Help: kmttg Fails to Launch with Error.

Quote:
Originally Posted by moyekj View Post
On a Mac you should launch "kmttg" script not "kmttg.jar". If there is a permissions problem then first do the following from command prompt:
chmod +x kmttg
./kmttg
Well I have been using the .jar file for the past couple years and for some reason it worked, still works on the mini. However, I just used your method and now kmttg is working on the affected machine. I appreciate it. I'm looking forward to doing some decrypting and encoding with the new SSD on the MBPro and seeing what it can do. Thanks!
droedl is offline   Reply With Quote
Old 06-24-2012, 07:21 PM   #4129
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,924
Quote:
Originally Posted by catfan64 View Post
Another thing i just realized. My Series 2 tivo is is hooked up to my HD TV using RCA composite cable (red, white, and yellow), as the Series 2 Tivo does not have HDMI or component outputs. In the TIVO settings for TV Aspect Ratio, I have it set on "Widescreen 16:9, but with the TV set to normal, the tivo menus have a black bars on the left and right. I would think that since the TIVO output is set to Widescreen 16:9, then it would fill the whole screen.
I don't remember and can't currently access my TiVo 2 (also connected to a 16:9 screen) but that is probably normal to avoid distorting the picture. You might try playing with various combinations of TiVo "Aspect Correction Mode" using the "Zoom" or "Window" button on the TiVo remote (if it works on a TiVo 2) and the TV's picture size.

The behavior of the DVD player sounds like the same problem I had when playing back a 16:9 SD recording on Premiere connected to a 16:9 TV. I used to record things like Law&Order from the SD channel on my THD since they would normally be viewed on a 4:3 TV and they are letterboxed. It was so annoying when I ended up watching on my Premiere that I switched to the HD channel. Again though, you might try various combinations of DVD player settings and TV picture size.

Hopefully someone else has encountered your problem and can answer your original question about an encoding profile.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 07-01-2012, 04:22 PM   #4130
range rat
Registered User
 
Join Date: Mar 2007
Posts: 9
Hi, newbie here. I've been encoding some .tivo files to .mp4's and can't seem to get the voice to sync. I'm using the ff_ipad profile and I'm not resorting to taking out commercials just yet. I just need to get 'em off the Premiere's hard disk to make room, but would like to enjoy the vids elsewhere. What am I doin' wrong?

Jon
range rat is offline   Reply With Quote
Old 07-01-2012, 04:46 PM   #4131
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,849
Quote:
Originally Posted by range rat View Post
Hi, newbie here. I've been encoding some .tivo files to .mp4's and can't seem to get the voice to sync. I'm using the ff_ipad profile and I'm not resorting to taking out commercials just yet. I just need to get 'em off the Premiere's hard disk to make room, but would like to enjoy the vids elsewhere. What am I doin' wrong?

Jon
You need to run the QS Fix step either using VideoRedo if you have it else ProjectX.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-01-2012, 04:51 PM   #4132
range rat
Registered User
 
Join Date: Mar 2007
Posts: 9
Thanks, just dug that up. Doin' it now.

Jon
range rat is offline   Reply With Quote
Old 07-01-2012, 10:32 PM   #4133
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Hey moyekj,

I just noticed something. Running a previous version of kmttg under Linux, the CPU usage was very low, except when it was running a demux/decrypt or comskip operation. I recently upgraded to the most recent version of kmttg, and now whenever kmttg is running, java pegs both CPU meters. Do you have any idea what might be the issue? I cannot categorically state it has happened ever since the upgrade, but the upgrade was done only a few days ago, and I noticed the pegged CPUs just the day before yesterday. Looking at it last night and today, top shows java eating up more than 130% of a full CPU load, and the usage meters drop right off when I stop kmttg.
lrhorer is offline   Reply With Quote
Old 07-02-2012, 12:36 AM   #4134
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,849
Quote:
Originally Posted by lrhorer View Post
Hey moyekj,

I just noticed something. Running a previous version of kmttg under Linux, the CPU usage was very low, except when it was running a demux/decrypt or comskip operation. I recently upgraded to the most recent version of kmttg, and now whenever kmttg is running, java pegs both CPU meters. Do you have any idea what might be the issue? I cannot categorically state it has happened ever since the upgrade, but the upgrade was done only a few days ago, and I noticed the pegged CPUs just the day before yesterday. Looking at it last night and today, top shows java eating up more than 130% of a full CPU load, and the usage meters drop right off when I stop kmttg.
Not sure, but obviously that's not normal. The whole program runs a master loop with msecs between operations thus keeping CPU consumption to a minimum for Java stuff. Perhaps in your upgrade you upgraded Java version to 7 or something newer than you had before? Also you should try both in GUI and background/batch modes to see if there is any difference.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-02-2012, 01:20 PM   #4135
range rat
Registered User
 
Join Date: Mar 2007
Posts: 9
task list after interruption - where'd it go?

Hi,

My computer was merrily grinding away at its tasks when it had a hiccup and shut down (I know why; it's old). Restarting kmttg let it resume where it had left off (I had "Automatically restore job queue between sessions" on) and it continues, writing over the last interrupted outputs as expected. However, I can't find the job queue displayed anywhere; it used to be in the middle listbox showing status. Any idea how to bring that up -- I like watching the colored bar get bigger as it goes?



Thanks,

Jon
range rat is offline   Reply With Quote
Old 07-02-2012, 03:17 PM   #4136
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,924
2 related RFEs.

1. Add "pyTivo Push destination" to specific Auto-transfer settings.

2. Add support for push to remote TiVos.

Plus a question: does the communication interface enable the creation of a manual recording?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 07-02-2012, 03:45 PM   #4137
range rat
Registered User
 
Join Date: Mar 2007
Posts: 9
Quote:
Originally Posted by range rat View Post
Hi,

My computer was merrily grinding away at its tasks when it had a hiccup and shut down (I know why; it's old). Restarting kmttg let it resume where it had left off (I had "Automatically restore job queue between sessions" on) and it continues, writing over the last interrupted outputs as expected. However, I can't find the job queue displayed anywhere; it used to be in the middle listbox showing status. Any idea how to bring that up -- I like watching the colored bar get bigger as it goes?



Thanks,

Jon
And another question: If I quit the app while it's working on something, will it resume where it left off in the output files, or will it just restart that task again?
range rat is offline   Reply With Quote
Old 07-02-2012, 03:56 PM   #4138
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,546
Quote:
Originally Posted by range rat View Post
And another question: If I quit the app while it's working on something, will it resume where it left off in the output files, or will it just restart that task again?
Auto-Resume is not supported on the Tivo, it would just start over again.

An alternative is to use the 'Transfer from paused point' option, but you would have separate files, and duplicate filenames, and if you have overwrite files on, with overwrite off, it would not transfer at all.

I have used the 'paused point' transfer method, and simply used the commercial break, to find and join the files using VideoReDo.
__________________
TiVo HD 1TB (157 HD Hrs, PLS, "S3HD")
Roamio, Oh Roamio!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 07-02-2012, 09:12 PM   #4139
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,858
Quote:
Originally Posted by moyekj View Post
Not sure, but obviously that's not normal. The whole program runs a master loop with msecs between operations thus keeping CPU consumption to a minimum for Java stuff. Perhaps in your upgrade you upgraded Java version to 7 or something newer than you had before?
Nope. The only thing I upgraded ws kmttg. I downloaded the newest version.

Code:
RAID-Server:~# java -version
java version "1.6.0_18"
OpenJDK Runtime Environment (IcedTea6 1.8.3) (6b18-1.8.3-2)
OpenJDK 64-Bit Server VM (build 16.0-b13, mixed mode)

Quote:
Originally Posted by moyekj View Post
Also you should try both in GUI and background/batch modes to see if there is any difference.
You mean the -a and -b switch? They don't run, but then I don't have any batches or automatic transfers set up:

Code:
RAID-Server:~# kmttg -a
RAID-Server:~# ERROR: Address already in use
STARTING AUTO TRANSFERS
ERROR: No auto keywords setup
ERROR: No keywords defined in /usr/share/kmttg/auto.ini... aborting
EXITING BATCH MODE
SHUTTING DOWN
RAID-Server:~# kmttg -b
RAID-Server:~# ERROR: Address already in use
STARTING BATCH MODE SINGLE LOOP TRANSFERS
ERROR: No auto keywords setup
ERROR: No keywords defined in /usr/share/kmttg/auto.ini... aborting
EXITING BATCH MODE
SHUTTING DOWN
The "Address already in use" messages are odd, though.
lrhorer is offline   Reply With Quote
Old 07-03-2012, 04:34 PM   #4140
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,849
I run kmttg on a Linux system with CentOS 5.4 (Kernel Version 2.6.18-164.el5) and monitor using htop and java CPU is 0% when just sitting in GUI doing nothing.

/usr/bin/java -version
java version "1.6.0"
OpenJDK Runtime Environment (build 1.6.0-b09)
OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)

Don't know if it has anything to do with problem but perhaps try turning off "Look for Tivos on network" under config-Tivos tab to see if that changes anything.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 07:55 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |