TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 04-17-2012, 12:20 AM   #3991
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,919
I don't distribute any version of ffmpeg myself, and I don't endorse one version or build over another. But yes, the lack of backward compatibility is annoying.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 04-17-2012, 12:55 AM   #3992
Hercules67
TiVo addict
 
Hercules67's Avatar
 
Join Date: Dec 2007
Posts: 312
Quote:
Originally Posted by wmcbrine View Post
I don't distribute any version of ffmpeg myself, and I don't endorse one version or build over another. But yes, the lack of backward compatibility is annoying.
Oh, I know that, I was just relating it to the ffmpeg that's in your pyTiVo branch <aka, fork>.

Sorry for the confusion.

Before KMTTG, I used to try changing TiVo files manually and sending them back with pyTivo. That's when I tried the newest ffmpeg. That was a disaster. I'll never repeat that mistake. I actually had to reload my OS to get its tendrils out of my system.
Hercules67 is offline   Reply With Quote
Old 04-17-2012, 01:31 AM   #3993
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 8,919
But there is no ffmpeg in my fork. That's what I'm saying.

I don't think any version of ffmpeg is going to insinuate itself into your system. You make it sound like TiVo Desktop or something.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 04-17-2012, 09:20 AM   #3994
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by ThAbtO View Post
When I have 'Remove .TiVo files after Decrypt', MetaData and Decrypt are selected, I get .TiVo.txt and .mpg.txt files.

Shouldn't the "Remove .TiVo files" also remove the .TiVo.txt file as well?

Also, when I remove the job for the metadata on .Tivo.txt, KMTTG also removes the subsequent QSFix job.
You must have metadata=all set under config->Program Options. Change metadata=last and only the last file in the set of tasks will be metadata file. i.e. In that case when metadata & decrypt are selected only .mpg.txt should be created.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 04-17-2012, 04:11 PM   #3995
Hercules67
TiVo addict
 
Hercules67's Avatar
 
Join Date: Dec 2007
Posts: 312
Quote:
Originally Posted by wmcbrine View Post
But there is no ffmpeg in my fork. That's what I'm saying.

I don't think any version of ffmpeg is going to insinuate itself into your system. You make it sound like TiVo Desktop or something.
Hmm, then where did I get the ffmpeg that pyTivo uses.... never-mind.

I am confused.

Back to your regularly scheduled programming.
Hercules67 is offline   Reply With Quote
Old 04-17-2012, 05:13 PM   #3996
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,927
Quote:
Originally Posted by Hercules67 View Post
Hmm, then where did I get the ffmpeg that pyTivo uses.... never-mind.

I am confused.

Back to your regularly scheduled programming.
Although you can get the "recommended" version of ffmpeg from http://pytivo.sourceforge.net/forum/download.php?id=323, it is not actually part of the pyTivo package.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 04-18-2012, 12:27 PM   #3997
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Does anyone know if there is an application for the mac that could be used to sync the files downloaded and processed by kmttg into the iTunes folder that auto imports the files into iTunes. (it's in Users/yourusername/Music/iTunes/iTunes Music/Automatically Add to iTunes/) My experience has been that if I select this folder in the kmttg config, iTunes gets confused˙because it sees the files before the complete processing is done by kmttg.
nahtanoj1 is offline   Reply With Quote
Old 04-18-2012, 07:36 PM   #3998
DougD
Registered User
 
Join Date: Apr 2011
Posts: 60
custom command

Quote:
Originally Posted by nahtanoj1 View Post
Does anyone know if there is an application for the mac that could be used to sync the files downloaded and processed by kmttg into the iTunes folder that auto imports the files into iTunes. (it's in Users/yourusername/Music/iTunes/iTunes Music/Automatically Add to iTunes/) My experience has been that if I select this folder in the kmttg config, iTunes gets confused˙because it sees the files before the complete processing is done by kmttg.
Have you tried having kmttg download to a different directory and then have a custom command such as:
move /kmttg/downloads/*.* Users/yourusername/.../Automatically Add to iTunes/.
DougD is offline   Reply With Quote
Old 04-19-2012, 07:46 AM   #3999
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Quote:
Originally Posted by DougD View Post
Have you tried having kmttg download to a different directory and then have a custom command such as:
move /kmttg/downloads/*.* Users/yourusername/.../Automatically Add to iTunes/.
I have not and will set that up as a cron job for early in the morning. Thanks.
nahtanoj1 is offline   Reply With Quote
Old 04-19-2012, 08:00 AM   #4000
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Fairly new to kmttg and have a few problems I'm working through and would appreciate any help y'all could provide.

1. Every few days on my new premier (dual tuner running version 20.2-01-2-746) kmttg is unable to download files from the premier (I get the message ERROR: <h2>Server Busy</h2>) and after I reboot the premier it works again. Is this a known problem with this version of Tivo code or is there something I have enabled that might be causing this?

2. I also am getting audio problems where in most .mp4 files I can hear the audio in the left speaker but clicking or static in the right one and quicktime crashes after just a few moments of playing the files. I'm using ff_h264_high_rate and at this point have yet to be able to use any of my transferred files since the audio problem is so pervasive.

3. Considering the issue above I would like to try moving my auto transfers to a different encoding profile but when I choose one under configure, auto transfers menu and click OK it does not seem to take my change. Must I delete the auto transfer and make a new one?

Thanks for all of your help.
nahtanoj1 is offline   Reply With Quote
Old 04-19-2012, 08:30 AM   #4001
danterner
Not it!
 
danterner's Avatar
 
Join Date: Mar 2005
Location: Greenacres, FL
Posts: 8,957
Quote:
Originally Posted by DougD View Post
Attached are the files I have started using for cover art. I modified the open source scripts created for mythtv to work with tivo metafiles. I then went on line and signed up for keys at the two web sites so we can use the files for the tivo community. At this point I need to put in a plug for the web sites. The art for movies is courtesy of www.themoviedb.org. The art for TV shows is from www.thetvdb.com both depend on user support. I have attached the files to this post. Put the getcovers.py, getcover.py, ttvdb.py and tmdb.py files on your path. Put the two folders in your python path. Oh, I forgot you will need to download and install python. Also you need to download and install fuzzy logic for selecting the best match from http://github.com/seatgeek/fuzzywuzzy.
To test if it works for movies enter
tmdb.py -M Terminator
Then test the shows portion with
ttvdb.py -D "Pan Am" 1 1
once you get this to work try entering
getcover.py "xyz" /file/to/store/covers/
where xyz is the name of one of your movie metafiles and /file/to/store/covers/ is the location to put the jpg files

this is the command to add as a custom command to kmttg.

Once this works you can get the covers for all shows on the computer by entering
cd /
getcovers.py "/folder_for/covers/"

This is all I know and I'm hoping some one else can pick this up and fix it up a bit. You'll have to get some of the Python experts to help if you need more.
Thanks so much for posting these instructions and the files. I don't have it figured out quite yet (I'm stuck on figuring out how to install fuzzywuzzy - not knowing Python at all is certainly hampering my progress), but I haven't given up and I'm encouraged that you've figured it out; at least I know that what I've been striving for is possible.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| Facebook:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| XBOX LIVE gamertag:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| Twitter:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
| Goozex:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
danterner is offline   Reply With Quote
Old 04-19-2012, 09:51 AM   #4002
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by nahtanoj1 View Post
Fairly new to kmttg and have a few problems I'm working through and would appreciate any help y'all could provide.

1. Every few days on my new premier (dual tuner running version 20.2-01-2-746) kmttg is unable to download files from the premier (I get the message ERROR: <h2>Server Busy</h2>) and after I reboot the premier it works again. Is this a known problem with this version of Tivo code or is there something I have enabled that might be causing this?

2. I also am getting audio problems where in most .mp4 files I can hear the audio in the left speaker but clicking or static in the right one and quicktime crashes after just a few moments of playing the files. I'm using ff_h264_high_rate and at this point have yet to be able to use any of my transferred files since the audio problem is so pervasive.

3. Considering the issue above I would like to try moving my auto transfers to a different encoding profile but when I choose one under configure, auto transfers menu and click OK it does not seem to take my change. Must I delete the auto transfer and make a new one?

Thanks for all of your help.
1. Make sure you don't have TiVo Desktop or some other program trying to download from your Premiere while kmttg is running. TiVo web server only likes to serve up 1 file at a time and gets in a bad state if that is violated which only a reboot fixes.
2. That encoding profile you are using keeps AC3 audio in mp4 container which few players can handle. Try VLC VideoLan player for that.
3. You are probably not updating it by clicking on UPDATE button after changing settings. In auto transfers window click on auto transfer in the top table, then adjust Encoding Name, then click on UPDATE button and then OK the window to save changes.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 04-19-2012, 10:15 AM   #4003
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Quote:
Originally Posted by moyekj View Post
1. Make sure you don't have TiVo Desktop or some other program trying to download from your Premiere while kmttg is running. TiVo web server only likes to serve up 1 file at a time and gets in a bad state if that is violated which only a reboot fixes.
2. That encoding profile you are using keeps AC3 audio in mp4 container which few players can handle. Try VLC VideoLan player for that.
3. You are probably not updating it by clicking on UPDATE button after changing settings. In auto transfers window click on auto transfer in the top table, then adjust Encoding Name, then click on UPDATE button and then OK the window to save changes.
1. Can streaming between two tivo's be the process trying to download that would hose up downloads for kmttg until I reboot?
2. I have switched to AppleTV with handbrake and will see how that goes.
3. I should have figured that one out. Thanks.

Last edited by nahtanoj1 : 04-19-2012 at 11:19 AM.
nahtanoj1 is offline   Reply With Quote
Old 04-19-2012, 11:47 AM   #4004
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by nahtanoj1 View Post
1. Can streaming between two tivo's be the process trying to download that would hose up downloads for kmttg until I reboot?
Don't think so, but I haven't tried so maybe.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 04-19-2012, 01:54 PM   #4005
txporter
One sec, almost done
 
Join Date: Sep 2006
Location: Austin, TX
Posts: 666
Quote:
Originally Posted by nahtanoj1 View Post
1. Can streaming between two tivo's be the process trying to download that would hose up downloads for kmttg until I reboot?
I haven't done this on my Premiere, but the few times I tried it on my TivoHDs, the Tivo didn't seem to like both downloading shows to my computer and transferring Tivo to Tivo. From what I remember, the transfer speeds would drop to a crawl or something like that. I haven't done both simultaneously since then so I am not sure if it has been addressed at all.
__________________
Tivo Premiere 2TB WD20EARS (lifetime)
TivoHD 1TB WD10EACS + 1TB WD10EVCS Antec MX-1 (lifetime)
TivoHD 1TB WD10EACS (lifetime)
Series2 540 400GB Seagate DB35 (lifetime)
txporter is offline   Reply With Quote
Old 04-19-2012, 02:09 PM   #4006
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Quote:
Originally Posted by txporter View Post
I haven't done this on my Premiere, but the few times I tried it on my TivoHDs, the Tivo didn't seem to like both downloading shows to my computer and transferring Tivo to Tivo. From what I remember, the transfer speeds would drop to a crawl or something like that. I haven't done both simultaneously since then so I am not sure if it has been addressed at all.
It was not a problem of the download creeping - it just plain broke the ability for a download to happen and only after a reboot would it work again. kmttg was able to get the now playing list etc but not to download the file. Next time it happens I'll check to see if the streaming/transferring capability between premier sis also broken before I reboot.
nahtanoj1 is offline   Reply With Quote
Old 04-19-2012, 03:30 PM   #4007
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by nahtanoj1 View Post
It was not a problem of the download creeping - it just plain broke the ability for a download to happen and only after a reboot would it work again. kmttg was able to get the now playing list etc but not to download the file. Next time it happens I'll check to see if the streaming/transferring capability between premier sis also broken before I reboot.
The "Server Busy" problem is strictly TTG related and has never affected MRV/MRS for me. Part of the problem is when transferring to PC it is a lot more CPU intensive (decrypt, demux, remux, encrypt again) compared to MRV/MRS.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 04-21-2012, 10:41 PM   #4008
DougD
Registered User
 
Join Date: Apr 2011
Posts: 60
Adding getcover to kmttg

I have the getcover.py running on my Linux box but I believe the steps I used for installing python on my windows machine were from the website:
http://www.ehow.com/how_2116627_inst...n-windows.html

and to install fuzzywuzzy on my linux box I used :
git clone git://github.com/seatgeek/fuzzywuzzy.git fuzzywuzzy
cd fuzzywuzzy
python setup.py install
DougD is offline   Reply With Quote
Old 04-22-2012, 02:03 AM   #4009
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 4,927
This question applies equally to pyTivo and probably TD but this thread was currently easier to get to.

Is there some limitation to the .tivo file format that prevents the channel information from being written to it?
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 04-22-2012, 02:33 PM   #4010
chrispitude
Registered User
 
Join Date: Apr 2005
Posts: 450
We recently bought a refurbished 10' Toshiba Thrive tablet to play videos for our 1-year-old son during an upcoming trip. I found kmttg today - absolutely fantastic! This is exactly what I've been looking for. Very cool.
chrispitude is offline   Reply With Quote
Old 04-22-2012, 02:42 PM   #4011
chrispitude
Registered User
 
Join Date: Apr 2005
Posts: 450
Quote:
Originally Posted by Iluvatar View Post
The commands were deprecated with the FFmpeg 0.9 api change. They may finally have been removed on recent Git HEAD revisions but the old commands are still perfectly useable on the latest FFmpeg stable release, 0.10.2 albeit with warnings that you are using deprecated commands.
I also tried the latest ffmpeg, adding/modifying the options as previously noted. File size and visual quality seemed identical, but it was twice as slow (13fps versus 26fps with the ffmpeg 'packaged' with kmttg). Normally I like to be using the latest and greatest, but this time I'll stick with the speed.
chrispitude is offline   Reply With Quote
Old 04-22-2012, 09:15 PM   #4012
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Quote:
Originally Posted by lpwcomp View Post
This question applies equally to pyTivo and probably TD but this thread was currently easier to get to.

Is there some limitation to the .tivo file format that prevents the channel information from being written to it?
If you mean the CHANNEL Number (displayMajorNumber) and CHANNEL Name (callsign) it was recorded from, I don't think so as this is what I have from a recent recording on my Premiere that I transferred using kmttg with metadata checked.

Code:
title : American Icon: Muscle Car
seriesTitle : American Icon: Muscle Car
description : Detroit continues to produce powerful vehicles until the 1970s gas crisis and government regulations bring an end to the muscle-car era. 
time : 2012-04-18T01:00:00Z
isEpisode : true
iso_duration : PT30M
originalAirDate : 2012-04-17T00:00:00Z
episodeTitle : End of an Era
isEpisodic : true
showingBits : 4098
tvRating : x3
episodeNumber : 013
displayMajorNumber : 754
callsign : VEL
seriesId : SH01470291
vProgramGenre : Auto
But, you are correct in that this info gets pulled from the TiVo when kmttg transfers (TTG) the .TiVo file to the PC. The actual .TiVo file on the PC does not contain the channel info in either xml chunk 1 or 2.

Last edited by bwall23 : 04-22-2012 at 09:28 PM. Reason: But,
bwall23 is offline   Reply With Quote
Old 04-22-2012, 09:46 PM   #4013
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Cool

Quote:
Originally Posted by moyekj View Post
v0p8r version released. Contains new authentication code for iPad/RPC remote and some user-supplied enhancements related to auto transfers and 1 bug fix.
Consult release_notes Wiki for details.
Awesome. Thanks so much for the work you put into this indispensable app!

Last edited by bwall23 : 04-29-2012 at 02:18 AM. Reason: splg
bwall23 is offline   Reply With Quote
Old 04-23-2012, 07:04 PM   #4014
Bulldawg9908
Registered User
 
Join Date: Feb 2011
Posts: 46
I'm sure others have had this problem, but I can't find the answer in the 134 page thread.

I upgraded to v0p8r, and I cannot download any shows. It was working before. I also installed the service, but it isn't downloading anything through the service or the GUI.

Here's the error I'm getting:
Code:
>> DOWNLOADING/DECRYPTING TO M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg ...
"C:\Users\xxxxxxxx\Desktop\kmttg\curl\curl.exe" --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar "C:\Users\xxxxxxxx\AppData\Local\Temp\cookie154801004987338897.tmp" --url "http://192.168.0.200:80/download/Army%20Wives.TiVo?Container=%2FNowPlaying&id=1272165&Format=video/x-tivo-mpeg-ts" | "C:\Users\xxxxxxx\Desktop\kmttg\tivodecode\tivodecode.exe" --mak MAK --no-verify --out "M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg" -
M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg: size=0.00 MB elapsed=0:00:04 (0.00 Mbps)
Download failed to file: M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg
Exit code: 10
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    31    0    31    0     0    179      0 --:--:-- --:--:-- --:--:--   179
  0    31    0    31    0     0    179      0 --:--:-- --:--:-- --:--:--     0
  0    31    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0TiVo Private Data : Unmatched Stream ID: No error
ts_handle_tivo_private_data failed: No error
processing frame: No error
Encryption by QUALCOMM ;)


  0    31    0 26446    0     0  14333      0 --:--:--  0:00:01 --:--:-- 39354
curl: (23) Failed writing body (2226 != 4380)
Army Wives - Non-Combatants_(2012_04_23)_609.mpg: Too many failed downloads, GIVING UP!!
mpeg file not found: M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg
Any ideas?
Bulldawg9908 is offline   Reply With Quote
Old 04-23-2012, 07:15 PM   #4015
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by Bulldawg9908 View Post
I'm sure others have had this problem, but I can't find the answer in the 134 page thread.

I upgraded to v0p8r, and I cannot download any shows. It was working before. I also installed the service, but it isn't downloading anything through the service or the GUI.

Here's the error I'm getting:
Code:
>> DOWNLOADING/DECRYPTING TO M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg ...
"C:\Users\xxxxxxxx\Desktop\kmttg\curl\curl.exe" --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar "C:\Users\xxxxxxxx\AppData\Local\Temp\cookie154801004987338897.tmp" --url "http://192.168.0.200:80/download/Army%20Wives.TiVo?Container=%2FNowPlaying&id=1272165&Format=video/x-tivo-mpeg-ts" | "C:\Users\xxxxxxx\Desktop\kmttg\tivodecode\tivodecode.exe" --mak MAK --no-verify --out "M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg" -
M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg: size=0.00 MB elapsed=0:00:04 (0.00 Mbps)
Download failed to file: M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg
Exit code: 10
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    31    0    31    0     0    179      0 --:--:-- --:--:-- --:--:--   179
  0    31    0    31    0     0    179      0 --:--:-- --:--:-- --:--:--     0
  0    31    0     0    0     0      0      0 --:--:--  0:00:01 --:--:--     0TiVo Private Data : Unmatched Stream ID: No error
ts_handle_tivo_private_data failed: No error
processing frame: No error
Encryption by QUALCOMM ;)


  0    31    0 26446    0     0  14333      0 --:--:--  0:00:01 --:--:-- 39354
curl: (23) Failed writing body (2226 != 4380)
Army Wives - Non-Combatants_(2012_04_23)_609.mpg: Too many failed downloads, GIVING UP!!
mpeg file not found: M:\kmttg_convert_tmp\Army Wives\Army Wives - Non-Combatants_(2012_04_23)_609.mpg
Any ideas?
Turn off TS transfers. i.e. Disable the setting: config-Program Options-Download TiVo files in Transport Stream format.
tivodecode can't handle TS TiVo files properly.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 04-24-2012, 07:50 AM   #4016
Bulldawg9908
Registered User
 
Join Date: Feb 2011
Posts: 46
Transport stream was enabled. Now, it's disabled. Still no joy. I restarted kmttg and checked the config.ini--<TSDownload> is set as 0. I also tried turning off "Combine download and tivodecode decrypt" since you indicated that could be a problem. I'm still getting the same error.
Bulldawg9908 is offline   Reply With Quote
Old 04-24-2012, 08:33 AM   #4017
Bulldawg9908
Registered User
 
Join Date: Feb 2011
Posts: 46
I decided to punt and just re-install kmttg.

I can download from my new TiVo, but I still can't download from my old TiVo. I did reboot both TiVos last night, but it failed again after the reboot. When a download fails like this, does something get stuck on the TiVo so that it needs a reboot?

And, since I'm not at home, is there a way to reboot the TiVo through the kmttg GUI?
Bulldawg9908 is offline   Reply With Quote
Old 04-24-2012, 09:02 AM   #4018
nahtanoj1
Registered User
 
Join Date: Nov 2007
Posts: 19
Out of sync audio

First - thanks to all for your continued support as I learn to work with kmttg. My latest question is on out of sync audio. In both iTunes and on my iPad as well as in VLC after choosing the encode of ff_ipad the audio and video are way out of sync...The video is way ahead of the audio - maybe 3 seconds. Any ideas how to fix this and yet still have a format that can be imported to my iPad? I had chosen ff_h264_high_rate but it would not sync to my iPad....
nahtanoj1 is offline   Reply With Quote
Old 04-24-2012, 09:05 AM   #4019
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by Bulldawg9908 View Post
Transport stream was enabled. Now, it's disabled. Still no joy. I restarted kmttg and checked the config.ini--<TSDownload> is set as 0. I also tried turning off "Combine download and tivodecode decrypt" since you indicated that could be a problem. I'm still getting the same error.
Perhaps you have partial failed transfers left over now. Make sure you clean up any past failed transfer files before attempting to download again, or under config->File Settings enable "Overwrite existing files" option such that kmttg won't try and use existing partial files.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 04-24-2012 at 09:13 AM.
moyekj is offline   Reply With Quote
Old 04-24-2012, 09:07 AM   #4020
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by nahtanoj1 View Post
First - thanks to all for your continued support as I learn to work with kmttg. My latest question is on out of sync audio. In both iTunes and on my iPad as well as in VLC after choosing the encode of ff_ipad the audio and video are way out of sync...The video is way ahead of the audio - maybe 3 seconds. Any ideas how to fix this and yet still have a format that can be imported to my iPad? I had chosen ff_h264_high_rate but it would not sync to my iPad....
You should configure kmttg for ProjectX and include "QS Fix" as a task in addition to the encode task. i.e. The mpg file needs to be run through ProjectX before the encoding step to clean up issues with it that are causing the A/V sync problems during encoding.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 01:08 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |