TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 02-21-2012, 05:50 AM   #1291
bareyb
Under Maintenance
 
Join Date: Nov 2000
Location: Silicon Valley, California
Posts: 22,386
TC CLUB MEMBER
Quote:
Originally Posted by Fofer View Post
FWIW I followed bareyb's setup tutorial, and the resulting menu on my TiVo does let me traverse through sub-folders to transfer/watch videos.
Hey that's great! Thank you for trying it out. It's gonna get better...

I just added added YOUR section with the little Applescript App you created too. I think people are going to love it. I really do. Anything that saves time is a good thing.
__________________
Never attribute to malice that which is adequately explained by human error
bareyb is offline   Reply With Quote
Old 02-21-2012, 06:35 AM   #1292
bareyb
Under Maintenance
 
Join Date: Nov 2000
Location: Silicon Valley, California
Posts: 22,386
TC CLUB MEMBER
Quote:
Originally Posted by gteague View Post
sounds like me! anyway, your first draft was more than adequate to get me up and running and the screenshots were the icing on the cake, but i had done most of the steps on my own research a few weeks back. i'm sure we'll find a newbie guinea pig eventually to give it a good, thorough evaluation.

/guy
Too late. We uncovered one loophole already. I just added a line warning folks to change the prefs in TextEdit to save in Plain Text Format. We got bit by that one earlier today.
__________________
Never attribute to malice that which is adequately explained by human error
bareyb is offline   Reply With Quote
Old 02-21-2012, 06:45 AM   #1293
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
never noticed that one because i avoid textedit like the plague. i have at least 6 other editors that would have to quit working before i'd use that one.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Old 02-21-2012, 07:30 AM   #1294
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
gteague. Getting pyTivo to remux and provide faster speeds is the 'next' level up in pyTivo use. Its called pushing a file. If you have downloaded wmcbrines fork, like I said earlier the file must contain compatible codecs (h264/vc1 video, AC-3/AAC audio) to be able to be remuxed or already be in a MP4 format.

Pushing a file happens from the WebAdmin interface. You don't request the file from your TiVo.

You need to add your tivo.com username and password to the settings.

Using the WebAdmin go to --> Web Configuration --> Global Server Settings
and add your tivo.com user name (email usually) to the 'tivo_username' box. Add your tivo.com password to the 'tivo_password' box.

After saving and resetting pyTivo you should see your local video shares show up in the WebAdmin interface. To test pushing a file, open one of your video shares listed and place a check mark in the box next to the video you want. Then at the very bottom of that page select your TiVo from the dropdown box and press 'Send to TiVo'.

Pushing a file does not instantly show up on your TiVo. It has to be either remuxed or transcoded first, then pyTivo has to communicate with the Tivo servers to say 'hey I have a file here that needs to go on this particular TiVo box'. You will eventually see the blue light on your TiVo come on meaning the transfer has started.

-----
To test a remux: Just select a file that has h264 video and AC-3 or AAC audio. Typically these will be MKV or similar files. You will see your log output from pyTivo and FFmpeg going much faster.....like 1000 FPS or more which should complete in a couple minutes. After completing the remux, then pyTivo sends the request to have the file transferred.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 08:19 AM   #1295
rjgibson0066
Registered User
 
rjgibson0066's Avatar
 
Join Date: Feb 2007
Posts: 89
Quote:
Originally Posted by Iluvatar View Post
I'm afraid I didn't follow to well.

Were you saying that you transferred one video successfully but after this your pyTivo video share disappeared from the Now Playing List?

If this is the case your router may have issues with passing multicast packets.

Two things:

Check your router configuration and see if it gives you an option for enabling 'Multicast' or something to that effect.

Add the 'beacon' setting to your pyTivo.conf. You can read its description here.

Something like: beacon = 192.168.1.255 (if your networks IP's are in the 192.168.1.x range)
Did the Beacon but wasn't sure in the router settings what to change.

I wanted to allow pyTivo connections through the firewall but don't know what application to specify. In the pyTivo folder there is no specific application - how can I identify the pyTivo application in the Firewall settings? Lion doesn't allow you to specify connections by port, only application (unless I am missing how to).
rjgibson0066 is offline   Reply With Quote
Old 02-21-2012, 08:23 AM   #1296
pmiranda
Registered User
 
Join Date: Feb 2003
Location: Austin, TX
Posts: 629
One thing that's not clear to me, and I probably just need to try it... can a S3 or S4 accept VC-1 video with a multi-channel audio track (I don't care too much which, just more than 2-channel WMA)?
I have some bluray that are VC-1 with DTS, and transcoding the audio to AC-3 is pretty fast, but if I have to transcode the video to H.264 I'll just keep watching the physical media even though I hate how clunky Cyberlink is compared to TiVo :-(
__________________
- Sony S1 from 2001 with CacheCard+Ethernet
- Series 3 1TB, now with new power supply!
- Premiere
pmiranda is offline   Reply With Quote
Old 02-21-2012, 10:24 AM   #1297
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by pmiranda View Post
One thing that's not clear to me, and I probably just need to try it... can a S3 or S4 accept VC-1 video with a multi-channel audio track (I don't care too much which, just more than 2-channel WMA)?
I have some bluray that are VC-1 with DTS, and transcoding the audio to AC-3 is pretty fast, but if I have to transcode the video to H.264 I'll just keep watching the physical media even though I hate how clunky Cyberlink is compared to TiVo :-(
The only surround channel audio codecs that are native TiVo compatible is AC-3 up to 5.1.

It also supports 2 ch wma and 2 ch AAC LC (technically will play 5.1 AAC but sounds messed up). I believe pyTivo only sends the file as is for VC-1 if it is in a wmv container. I don't have any VC-1 samples so I can't say for sure.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X

Last edited by Iluvatar : 02-21-2012 at 10:34 AM.
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 10:30 AM   #1298
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by gteague View Post
i'm embarrased to admit it, but i was going to use your fork when trying out @bareyb's guide, but i couldn't find the download link on that project page nor at any of the links on the line explaining your build.

/guy
It is a page that lists my recent changes. Use the link in my sig to go to my pyTivo fork page. The top of the 'shortlog' list half way down the page is what you are looking for. The most recent change is always at the top of that list. Look all the way to the right and choose the link to download. Either tar.gz or zip format, doesn't matter.

My last commit was updating to a patch wmcbrine made.......so RIGHT NOW the most recent development in my fork is "24 hours ago William McBrine Allow pushing (again) of MPEG-2 without ffmpeg." However this will change as I continue to add new changes.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 10:33 AM   #1299
pmiranda
Registered User
 
Join Date: Feb 2003
Location: Austin, TX
Posts: 629
Quote:
Originally Posted by Iluvatar View Post
The only surround channel audio codecs that are native TiVo compatible is AC-3 up to 5.1.

It also supports 2 ch wma and 2 ch AAC LC (technically will play 5.1 AAC but sounds messed up)
Is there a legal container for VC-1 video with AC-3 audio? It's easy enough to build a .mkv with this, but I'm not sure that's something legal to push to TiVo...
__________________
- Sony S1 from 2001 with CacheCard+Ethernet
- Series 3 1TB, now with new power supply!
- Premiere
pmiranda is offline   Reply With Quote
Old 02-21-2012, 10:52 AM   #1300
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by pmiranda View Post
Is there a legal container for VC-1 video with AC-3 audio? It's easy enough to build a .mkv with this, but I'm not sure that's something legal to push to TiVo...
I believe TiVo will only accept VC-1 video in a .wmv container. pyTivo requires wmav2 format audio to push file without transcoding. It does not currently remux VC-1 video from a non wmv container. It could though. Putting VC-1 and AC-3 together would be useful. I'll look into doing it, as long as FFmpeg is capable.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 11:51 AM   #1301
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by rjgibson0066 View Post
Did the Beacon but wasn't sure in the router settings what to change.

I wanted to allow pyTivo connections through the firewall but don't know what application to specify. In the pyTivo folder there is no specific application - how can I identify the pyTivo application in the Firewall settings? Lion doesn't allow you to specify connections by port, only application (unless I am missing how to).
In the Firewall settings under advanced menu, uncheck 'Block all incoming connections'.

This worked for me after testing. Showed up right away. Alternately I suppose you could add firewall rules with the command line.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 02:13 PM   #1302
bareyb
Under Maintenance
 
Join Date: Nov 2000
Location: Silicon Valley, California
Posts: 22,386
TC CLUB MEMBER
Wow... You guys aren't going to believe this... Someone or something over at the pyTivo forum just screwed me royally... Every time I try to edit one of my posts, it deletes it now. Look at the first two posts... all that's left are the attachments... When you go into "Edit" the text is all there, but when you hit "submit" it brings up a blank post with all that text missing... Am I screwed or what????

I hate to say it, but I'm feeling like maybe they don't want me over there...

Would anyone have a problem with me moving the thread over here. This is just such BS... I'm furious....
__________________
Never attribute to malice that which is adequately explained by human error
bareyb is offline   Reply With Quote
Old 02-21-2012, 02:31 PM   #1303
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
that's bizarre. you think they objected to the size of the screenshots?

perhaps, if it comes down to it, we could find someone to host the link or you might even put it in a public dropbox folder and put a link in your 'needasig'.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Old 02-21-2012, 02:34 PM   #1304
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
Quote:
Originally Posted by Iluvatar View Post
It is a page that lists my recent changes. Use the link in my sig to go to my pyTivo fork page. <del>
i'm embarrassed to admit it ... [g] but i actually completely forgot about the link being right there in your .sig.

geeeeeesh!

and many thanks for again taking the time to explain in such detail how i can set up the push function. that will be one of my next projects in our ongoing cluster of them here.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Old 02-21-2012, 02:39 PM   #1305
Fofer
༺♥༻
 
Fofer's Avatar
 
Join Date: Oct 2000
Location: Neither here nor there
Posts: 69,792
TC CLUB MEMBER
Quote:
Originally Posted by bareyb View Post
Wow... You guys aren't going to believe this... Someone or something over at the pyTivo forum just screwed me royally... Every time I try to edit one of my posts, it deletes it now. Look at the first two posts... all that's left are the attachments... When you go into "Edit" the text is all there, but when you hit "submit" it brings up a blank post with all that text missing... Am I screwed or what????

I hate to say it, but I'm feeling like maybe they don't want me over there...

Would anyone have a problem with me moving the thread over here. This is just such BS... I'm furious....
I wouldn't have a problem with it. The format over there was clunky and difficult to follow.

In the meantime I've got streambaby running under Lion (thanks to this page) - and am still tinkering, trying to figure out a way to make quitting PyTiVo easy. Hopefully I can manage a double-clickable AppleScript or .command file.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- a list of some favorite browser add-ons that help make TCF even more enjoyable!
Fofer is offline   Reply With Quote
Old 02-21-2012, 02:39 PM   #1306
rjgibson0066
Registered User
 
rjgibson0066's Avatar
 
Join Date: Feb 2007
Posts: 89
Quote:
Originally Posted by Iluvatar View Post
In the Firewall settings under advanced menu, uncheck 'Block all incoming connections'.

This worked for me after testing. Showed up right away. Alternately I suppose you could add firewall rules with the command line.
When I uncheck that it shows a list of three applications/processes that have file sharing permissions. When I click on the plus sign to add pyTivo it takes me to the application folder, but I don't know what to select in the pyTivo folder?
rjgibson0066 is offline   Reply With Quote
Old 02-21-2012, 02:40 PM   #1307
Fofer
༺♥༻
 
Fofer's Avatar
 
Join Date: Oct 2000
Location: Neither here nor there
Posts: 69,792
TC CLUB MEMBER
Quote:
Originally Posted by gteague View Post
that's bizarre. you think they objected to the size of the screenshots?
Probably not, otherwise they wouldn't take everything down and leave the screenshots

I think there forum is funky and some text formatting screwed up the threas somehow. I don't think someone's developed a vendetta against bareyb
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- a list of some favorite browser add-ons that help make TCF even more enjoyable!
Fofer is offline   Reply With Quote
Old 02-21-2012, 02:45 PM   #1308
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
Quote:
Originally Posted by Fofer View Post
I wouldn't have a problem with it. The format over there was clunky and difficult to follow.

In the meantime I've got streambaby running under Lion (thanks to this page) - and am still tinkering, trying to figure out a way to make quitting PyTiVo easy. Hopefully I can manage a double-clickable AppleScript or .command file.
did you see my comment at the bottom of that page? he responded today and said i had an old version of streambaby although i got it right off the page he links and it was at the top and said 'featured download'. now i look closer, it does say '2010', but there is no date on the download at the top which i am downloading right now.

[later: just unzipped it, and the download at that top link has a date of '12/03/2011', so it does seem a year newer. hope it works so i can get away from pytivox although, i will admit, using the manual 'patch' or 'mdns ...' command in conjunction with pytivox is working perfectly for me right now. well, except that it won't seem to play top quality video except at a ratcheted down setting although i doubt anyone could detect any quality difference by the time it reaches the tv screen.]

i've still got your 'quitting pytivo' project in the back of my mind as i work on these things. it's pretty easy to quit using the 'ps -ax' and then the 'kill -9' sequence. or couldn't you just bring up activity monitor and kill it that way until we find a way to automate it?

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien

Last edited by gteague : 02-21-2012 at 02:50 PM.
gteague is offline   Reply With Quote
Old 02-21-2012, 02:56 PM   #1309
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by rjgibson0066 View Post
When I uncheck that it shows a list of three applications/processes that have file sharing permissions. When I click on the plus sign to add pyTivo it takes me to the application folder, but I don't know what to select in the pyTivo folder?
I'm no expert here because I don't normally use it. When I unchecked the box the 'python' service automatically showed up the next time I started pyTivo.

Python is what is running the script. It lives at /usr/bin/python, but you cannot add this using the GUI. I'm certain you could find commands on google to do it manually but like I said it automatically populated for me upon running pyTivo.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 02:59 PM   #1310
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
I don't know what is going wrong for you guys with streambaby. I tested it out and it ran just fine for me...no special commands. I'm on Lion, no firewall, and using this version:

http://code.google.com/p/streambaby/...2.zip&can=2&q=
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 03:14 PM   #1311
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
Quote:
Originally Posted by Iluvatar View Post
I don't know what is going wrong for you guys with streambaby. I tested it out and it ran just fine for me...no special commands. I'm on Lion, no firewall, and using this version:

http://code.google.com/p/streambaby/...2.zip&can=2&q=
i managed to get an old version (0.29) from 2010. the one you link to had a dicey description and no year date when i first examined it and the link i downloaded had the tag 'featured', so i picked the wrong one.

btw, i went 'off script' on the streambaby install because i already have a ffmpeg in my pytivo folder so i modified the streambaby.ini file to point to that ffmpeg rather than actually copy another ffmpeg into the streambaby folder. if i continue to have problems i'll do it by the book just in case that makes a difference.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Old 02-21-2012, 03:25 PM   #1312
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by gteague View Post
i managed to get an old version (0.29) from 2010. the one you link to had a dicey description and no year date when i first examined it and the link i downloaded had the tag 'featured', so i picked the wrong one.

btw, i went 'off script' on the streambaby install because i already have a ffmpeg in my pytivo folder so i modified the streambaby.ini file to point to that ffmpeg rather than actually copy another ffmpeg into the streambaby folder. if i continue to have problems i'll do it by the book just in case that makes a difference.

/guy
It's an updated version by moyekj here at TCF......keary is long gone and moyekj is the only other person with commit rights.

I am using my FFmpeg build from pyTivo as well with the edits to the ini file to make it work.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 03:48 PM   #1313
rjgibson0066
Registered User
 
rjgibson0066's Avatar
 
Join Date: Feb 2007
Posts: 89
Quote:
Originally Posted by Iluvatar View Post
I'm no expert here because I don't normally use it. When I unchecked the box the 'python' service automatically showed up the next time I started pyTivo.

Python is what is running the script. It lives at /usr/bin/python, but you cannot add this using the GUI. I'm certain you could find commands on google to do it manually but like I said it automatically populated for me upon running pyTivo.
EDIT - NEVER MIND - TRIED IT AGAIN AND ALL IS WELL. THANK YOU


Sorry to such a PITA here.

I did as you suggested and sure enough pyTivo did show up in the list as allowing connections. However when I started puTivo I got this error:

Robert-Gibsons-MacBook-ProyTivo robertgibson$ cd /Applications/pyTivo
Robert-Gibsons-MacBook-ProyTivo robertgibson$ ./pyTivo.py
ERRORyTivo:Exception in pyTivo
Traceback (most recent call last):
File "./pyTivo.py", line 80, in <module>
while mainloop():
File "./pyTivo.py", line 74, in mainloop
httpd = setup()
File "./pyTivo.py", line 29, in setup
httpserver.TivoHTTPHandler)
File "/Applications/pyTivo/httpserver.py", line 44, in __init__
RequestHandlerClass)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 408, in __init__
self.server_bind()
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/BaseHTTPServer.py", line 108, in server_bind
SocketServer.TCPServer.server_bind(self)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/SocketServer.py", line 419, in server_bind
self.socket.bind(self.server_address)
File "/System/Library/Frameworks/Python.framework/Versions/2.7/lib/python2.7/socket.py", line 224, in meth
return getattr(self._sock,name)(*args)
error: [Errno 48] Address already in use
Robert-Gibsons-MacBook-ProyTivo robertgibson$

Last edited by rjgibson0066 : 02-21-2012 at 04:49 PM.
rjgibson0066 is offline   Reply With Quote
Old 02-21-2012, 03:50 PM   #1314
bareyb
Under Maintenance
 
Join Date: Nov 2000
Location: Silicon Valley, California
Posts: 22,386
TC CLUB MEMBER
Quote:
Originally Posted by Fofer View Post
Probably not, otherwise they wouldn't take everything down and leave the screenshots

I think there forum is funky and some text formatting screwed up the threas somehow. I don't think someone's developed a vendetta against bareyb
Nah. They don't after all. It was some type of glitch in the post. It's all back and running again. In the mean time it prompted me to get the thread moved over here and that's probably for the best anyway.
__________________
Never attribute to malice that which is adequately explained by human error
bareyb is offline   Reply With Quote
Old 02-21-2012, 03:58 PM   #1315
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
Quote:
Originally Posted by Iluvatar View Post
It's an updated version by moyekj here at TCF......keary is long gone and moyekj is the only other person with commit rights.

I am using my FFmpeg build from pyTivo as well with the edits to the ini file to make it work.
yessssss! successssssss!

i quit absolutely everything having to do with tivo such as kmttg (although that shouldn't apply), pytivo, pytivox, streambaby, and the streambaby 'mdns patch' i was having to employ. configured up the new version of streambaby and bob's your uncle it is working quite nicely.

only quirks on a brief recon are:

1) it still won't stream at 'same' quality, you have to bump it down to 5000kbps or 'high' quality. granted, some of the files i'm streaming are at 10000kbps to begin with and i doubt you could tell the difference by the time it hits the tv screen.

2) wouldn't recognize some .mts video files which i was able to play before somehow. perhaps i transferred one using pytivo and played it? i can't remember. anyway, no big loss there as i usually have to convert those avchd/bluray/mts files to use nearly anywhere else except as a direct burn or in my panasonic dvd player via the sdhc card slot.

3) to my astonishment, i had some ripped dvd files (.vob) and it actually played one of those! of course, since you're doing a single file at a time it'd be a rough way to watch a whole dvd by swapping to a new .vob file every 15 minutes!

many many many thanks to @Iluvatar and all for the help and encouragement getting this to work. at least i knew it was working for you guys under the same circumstances, so the goal was in front of me.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Old 02-21-2012, 05:21 PM   #1316
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:
Originally Posted by rjgibson0066 View Post
EDIT - NEVER MIND - TRIED IT AGAIN AND ALL IS WELL. THANK YOU

error: [Errno 48] Address already in use
Seems like you got it...but for future reference this error means the pyTivo server is already running, or some other software using the same port.
__________________
My
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
- Read link for changes

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
for OS X
Iluvatar is offline   Reply With Quote
Old 02-21-2012, 05:54 PM   #1317
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,074
Quote:
Originally Posted by gteague View Post
i've still got your 'quitting pytivo' project in the back of my mind as i work on these things. it's pretty easy to quit using the 'ps -ax' and then the 'kill -9' sequence.
The correct way to exit pyTivo is to press Control-C in the Terminal, or to send it a SIGINT -- "kill -2", not "kill -9". This is important, because it's the only way pyTivo will Unregister its services, i.e., make them disappear from the TiVo's menus. Otherwise they'll linger there for an indefinite period after pyTivo stops running. (This is the only issue with an improper shutdown, though.)

Or, you could use this GUI wrapper, with "Go" and "Stop" buttons. Still kind of experimental, so I haven't really announced it (although I was hoping for more than zero DLs by now, but I guess it just went unnoticed in that thread).
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 02-21-2012, 06:10 PM   #1318
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
thanks for pointing out my lack of unix skills--i warned you guys i knew exactly enough to be dangerous. [g]

but that does explain why i saw those shares linger despite me thinking i'd killed everything. i just <ass>umed that the tivo software wasn't keeping up. does 'quit' or 'force quit' from the activity monitor stop it correctly?

but, unless i'm missing something (again), this gui seems to be for windows.

and a potential dumb question: what's wrong with using the 'shutdown' button from the web config page? it seems to kill it cleanly. or could someone program an http ?cgi? script that would 'push' the button?

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien

Last edited by gteague : 02-21-2012 at 06:17 PM.
gteague is offline   Reply With Quote
Old 02-21-2012, 06:59 PM   #1319
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,074
Quote:
Originally Posted by gteague View Post
does 'quit' or 'force quit' from the activity monitor stop it correctly?
No.

Quote:
but, unless i'm missing something (again), this gui seems to be for windows.
The GUI wrapper is cross-platform. The mention of Windows in the post is unrelated. You can read the whole thread for context.

Quote:
and a potential dumb question: what's wrong with using the 'shutdown' button from the web config page?
Nothing. It's just so new, I forgot to mention it.

Quote:
or could someone program an http ?cgi? script that would 'push' the button?
http://localhost:9032/TiVoConnect?Co...ainer=Settings

also mentioned in the above thread.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 02-21-2012, 07:47 PM   #1320
gteague
golftango
 
gteague's Avatar
 
Join Date: Apr 2007
Location: dfw (euless)
Posts: 520
apologies for not reading thoroughly. as is obvious, i just went to the link and grabbed the download and mis-interpreted the cues to assume it was windows. it's no surprise that my questions (or some of them at least) occurred to others before me. i was hoping to not have to strain my already flagging brain with more esoteria until i got everything running and i needed specific info.

/guy
__________________
We were somewhere around the Withywindle on the edge of the Old Forest when the drugs began to take hold. ~Hunter S. Tolkien
gteague is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 11:32 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |