TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 01-29-2012, 12:50 AM   #1
ShinySteelRobot
Registered User
 
Join Date: Apr 2010
Location: Seattle, WA
Posts: 62
How to set up Streambaby under Mac OS X Lion

Lots of Mac people use pyTivoX because it has Streambaby support. However, it seems like pyTivoX is getting pretty long in the tooth. It looks like it's been well over a year since the developer last updated it. In order to use the latest & greatest Streambaby on my Mac I went through the process of installing Streambaby under Lion. It took a bit of futzing around to get it to work seamlessly. Once I figured it out, it was actually pretty simple.

There didn't seem to be a single comprehensive guide to installing Streambaby under Lion, so I wrote one. I hope you find it useful.

http://www.logicsector.com/mac/how-t...s-x-lion-10-7/

The same steps may work for 10.6 Snow Leopard, but I don't have an old copy of Snow Leopard to test it with.

Last edited by ShinySteelRobot : 01-29-2012 at 12:56 AM.
ShinySteelRobot is offline   Reply With Quote
Old 01-29-2012, 12:36 PM   #2
timatkn
Registered User
 
Join Date: Oct 2010
Posts: 71
Ive never tried streambaby before. I followed your steps and all of the directories/folders show on the TIVO, but when I click on them they are each empty. There is nothing to stream.

Any ideas where to trouble shoot?

Thanks,

T
timatkn is offline   Reply With Quote
Old 01-29-2012, 04:14 PM   #3
timatkn
Registered User
 
Join Date: Oct 2010
Posts: 71
Never mind I am new to entering things into the terminal. I must have entered something wrong. I had to tweak it a little from what you had to get it to work on my TIVO.

Most videos stream now. Some I get the Oxffff error from my videos I shot from my ipod touch 4g. Assume it is the format it was recorded in?

T
timatkn is offline   Reply With Quote
Old 01-29-2012, 04:46 PM   #4
Dagwood70
Registered User
 
Dagwood70's Avatar
 
Join Date: Jan 2012
Location: OKC
Posts: 7
Got it to work on my Macbook Pro & iMac (both Core 2 Duo running 10.7.2) but I was hoping I could get my old Mini (ppc/10.5.8) so I could still get some service out it. It seems to run fine but when I try to stream from the TiVo I get an error. The output on the computer in Terminal indicates that ffmpeg (I downloaded the Universal one from your link) is quitting.
Dagwood70 is offline   Reply With Quote
Old 01-29-2012, 05:27 PM   #5
timatkn
Registered User
 
Join Date: Oct 2010
Posts: 71
Thanks BTW for post/link. Very simple instructions even a noob like me could follow

T
timatkn is offline   Reply With Quote
Old 01-29-2012, 05:42 PM   #6
ShinySteelRobot
Registered User
 
Join Date: Apr 2010
Location: Seattle, WA
Posts: 62
Quote:
Originally Posted by timatkn View Post
Most videos stream now. Some I get the Oxffff error from my videos I shot from my ipod touch 4g. Assume it is the format it was recorded in?
Not sure what causes that error, I'm pretty new to Streambaby myself. I get the Oxffff on videos that are likely to be copy protected, such as a few of the *.mov files I downloaded from Apple. Other *.mov files seem to stream just fine. So, I'm not sure if Oxffff is a copy protection error or if a few specific files are not compatible with Streambaby/FFmpeg.

If it's the format it was recorded in, you can try transcoding it to another format using Handbrake. The MKV format seems to stream well on my system.

Last edited by ShinySteelRobot : 01-29-2012 at 05:57 PM.
ShinySteelRobot is offline   Reply With Quote
Old 01-29-2012, 05:52 PM   #7
ShinySteelRobot
Registered User
 
Join Date: Apr 2010
Location: Seattle, WA
Posts: 62
Quote:
Originally Posted by Dagwood70 View Post
I was hoping I could get my old Mini (ppc/10.5.8) so I could still get some service out it. It seems to run fine but when I try to stream from the TiVo I get an error. The output on the computer in Terminal indicates that ffmpeg (I downloaded the Universal one from your link) is quitting.
Hmm, try using a different FFmpeg that's PowerPC compatible. There are some G5 builds linked in this post:
http://pytivo.sourceforge.net/forum/...t468.html#3558

Direct download link:
http://pytivo.sourceforge.net/forum/download.php?id=221

The downside is they are built on ffmpeg 0.9 so I don't know if they'll work with Streambaby.

Hope it works for you!
ShinySteelRobot is offline   Reply With Quote
Old 01-29-2012, 09:28 PM   #8
Iluvatar
Registered User
 
Iluvatar's Avatar
 
Join Date: Jul 2006
Posts: 377
Quote:

The downside is they are built on ffmpeg 0.9 so I don't know if they'll work with Streambaby.

Hope it works for you!
It's built from SVN r19249 which is from FFmpeg 0.5 era I believe.
Iluvatar is offline   Reply With Quote
Old 01-13-2013, 07:47 PM   #9
cur1ous
Registered User
 
Join Date: Oct 2004
Location: San Francisco, Ca
Posts: 1
Help! StreamBaby Installation Issues on a Mac

ShinySteelRobot, Used your wonderful detailed instructions and: On a Mac running 10.8.2., pyTivoX runs fine (and has for years), StreamBaby not so good. Experiencing the same problem as Andy Grant: "I was able to follow the instructions above to get Stream, Baby, Stream to appear in my Tivo Menu, and I can navigate the directories of my movies folder(s) with no problem.
HOWEVER…
When I make that final step to “Play” the selected file, I get the grey screen with red text:
“Failed to open stream” "


streambaby.ini

dir.1=/Users/cur1ous/Movies dir.1.name=StreamBaby? com.unwiredappeal.tivo.vm.ffjava.FFmpegJavaVideoModule=false ffmpeg.path=/Applications/streambaby/ffmpeg

Contents of streambaby folder:

assets cache extra ffmpegX ffmpegXbinaries20060307 jbin lib native scripts simplelog.properties streambaby streambaby.bat streambaby.ini streambaby.log stylesheets

(I don't have "streambaby.ini.ORIG" in my streambaby folder. You have it listed in your response to Andy Grant and I don't know what it is.)

streambaby.log

01/13/13 14:26:45 Listener: added factory 01/13/13 14:26:45 Main: streambaby ready & listening. 01/13/13 14:32:50 Listener: 192.168.1.101 icon.png HTTP GET - to factory /streambaby/ 01/13/13 14:33:00 Factory: HME receiver connected 01/13/13 14:34:13 Listener: connection to receiver closed 01/13/13 14:34:13 Factory: HME receiver disconnected 01/13/13 14:48:17 Listener: 192.168.1.101 icon.png HTTP GET - to factory /streambaby/ 01/13/13 14:48:36 Factory: HME receiver connected 01/13/13 14:49:17 Listener: connection to receiver closed 01/13/13 14:49:17 Factory: HME receiver disconnected 01/13/13 14:55:02 Listener: 192.168.1.101 icon.png HTTP GET - to factory /streambaby/ 01/13/13 14:55:09 Factory: HME receiver connected 01/13/13 14:55:53 Listener: connection to receiver closed 01/13/13 14:55:53 Factory: HME receiver disconnected 01/13/13 14:55:55 Listener: 192.168.1.101 icon.png HTTP GET - to factory /streambaby/ 01/13/13 16:51:37 Listener: 192.168.1.101 icon.png HTTP GET - to factory /streambaby/ 01/13/13 16:51:46 Factory: HME receiver connected 01/13/13 16:52:14 Listener: connection to receiver closed 01/13/13 16:52:14 Factory: HME receiver disconnected

Appreciate any help! From anyone! Please!
cur1ous is offline   Reply With Quote
Old 03-31-2013, 10:14 PM   #10
TimothyGraham
Registered User
 
Join Date: Mar 2013
Posts: 4
Hmm

Quote:
Originally Posted by ShinySteelRobot View Post
Lots of Mac people use pyTivoX because it has Streambaby support. However, it seems like pyTivoX is getting pretty long in the tooth. It looks like it's been well over a year since the developer last updated it. In order to use the latest & greatest Streambaby on my Mac I went through the process of installing Streambaby under Lion. It took a bit of futzing around to get it to work seamlessly. Once I figured it out, it was actually pretty simple.
I'm curious, what's the benefit of your approach if my pyTivoX is working? Will this offer additional options or a better outcome?
TimothyGraham is offline   Reply With Quote
Old 11-10-2013, 01:08 AM   #11
ba2991
Registered User
 
Join Date: Feb 2011
Posts: 50
Streambaby and Mavericks

Hello
Thinking of giving Streambaby go but was wondering if anyone has tried it on Mavericks witch I intend to download in a couple of weeks.

Cheers
ba2991 is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVo® is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 10:26 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |