TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 07-02-2011, 06:31 PM   #3211
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,656
Can you add in a keystroke, say Ctrl-R, for 'Reset Tivo Web Server'? I tend to use it alot.

Thanks Moyekj.
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 07-02-2011, 06:41 PM   #3212
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by ThAbtO View Post
Can you add in a keystroke, say Ctrl-R, for 'Reset Tivo Web Server'? I tend to use it alot.

Thanks Moyekj.
Added for next release. Still not convinced that URL actually does anything though.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-02-2011, 07:58 PM   #3213
orangeboy
yes, I AM orangeboy!
 
Join Date: Apr 2004
Location: Moline, IL
Posts: 4,075
Quote:
Originally Posted by moyekj View Post
"channelUpdate" is not a valid/available RPC command unfortunately. I get:
ERROR: RPC error response: The active partner ID does not have access to the operation.
Aw rats! I think that function came out of this list: http://www.tivocommunity.com/tivo-vb...68#post8574568
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
orangeboy is offline   Reply With Quote
Old 07-02-2011, 08:00 PM   #3214
innocentfreak
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 8,467
Since the iPad app doesn't have the functionality it may not be active yet. I imagine this might be something more for the Q/Preview so you could do it channel listings from the Preview.
__________________
1 - TiVo Roamio Pro
2 - TiVo Premiere XL

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
innocentfreak is offline   Reply With Quote
Old 07-02-2011, 10:06 PM   #3215
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by orangeboy View Post
Aw rats! I think that function came out of this list: http://www.tivocommunity.com/tivo-vb...68#post8574568
Yes, I think I tried most of the ones in that list a while back and a lot of them are not available/valid.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-03-2011, 12:13 PM   #3216
tlc
Registered User
 
Join Date: May 2002
Posts: 431
comcut produces audio only ?

I'm new to kmttg and having an issue with comcut. The file produced is way to small and appears (in vlc) to be the audio with a single frame of video. If it matters, I'm running on linux and comskip was run via wine.

Here's the edl file for a 1/2 hour show:

Spoiler:
494.69 654.92 0
905.77 1089.35 0
1363.20 1528.43 0

Here's the kmttg log for comcut:

Spoiler:
>> Running comcut on /home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011).mpg ...
/usr/bin/mencoder "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011).mpg" -edl "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011).edl" -oac copy -ovc copy -of mpeg -vf harddup -o "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011)_cut.mpg"
comcut job completed: 0:00:30
---DONE--- job=comcut output=/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011)_cut.mpg

I ran the mencoder line by hand and got the following output. The end of the log shows that it's recognized a sizable video stream.

Spoiler:
$ /usr/bin/mencoder "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011).mpg" -edl "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011).edl" -oac copy -ovc copy -of mpeg -vf harddup -o "/home/media/Videos/FromTivo/House Hunters International - Apartment in Argentina (01_27_2011)_cut.mpg"
MEncoder 1.0rc4-4.4.5 (C) 2000-2010 MPlayer Team
success: format: 0 data: 0x0 - 0xd33c2742
MPEG-PS file format detected.
VIDEO: MPEG2 1920x1080 (aspect 3) 29.970 fps 16000.0 kbps (2000.0 kbyte/s)
[V] filefmt:2 fourcc:0x10000002 size:1920x1080 fps:29.970 ftime:=0.0334
============================================================ ==============
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[ac3 @ 0x182b680]frame sync error
AUDIO: 48000 Hz, 2 ch, s16le, 384.0 kbit/25.00% (ratio: 48000->192000)
Selected audio codec: [ffac3] afm: ffmpeg (FFmpeg AC-3)
============================================================ ==============
PACKET SIZE: 2048 bytes, deltascr: 245760
videocodec: framecopy (1920x1080 24bpp fourcc=10000002)
audiocodec: framecopy (format=2000 chans=2 rate=48000 bits=16 B/s=48000 sample-1)
Limiting audio preload to 0.4s.
Increasing audio density to 4.
Read 3 EDL actions.
Writing header...
INITV: 0.200, 0.167, fps: 29.970
Pos: 0.5s 15f ( 0%) 0.00fps Trem: 0min 0mb A-V:-0.047 [0:0]
BUFFER UNDEFLOW at stream 0, raising muxrate to 1980 kb/s, delta_scr: 223418

ERROR: scr 1.334, dts 0.000, pts 0.300

BUFFER UNDEFLOW at stream 1, raising muxrate to 2178 kb/s, delta_scr: 203107

ERROR: scr 1.643, dts 0.000, pts 0.364

ERROR: scr 1.778, dts 0.000, pts 0.396

...

Pos:1017.8s 30491f (84%) 1362.24fps Trem: 0min 58mb A-V:0.068 [15508:384]
Skipping frame!
Pos:1032.2s 30923f (85%) 1359.49fps Trem: 0min 58mb A-V:0.067 [15511:384]
Skipping frame!
Writing index...47f (100%) 1313.23fps Trem: 0min 62mb A-V:0.016 [15503:384]

Overhead: 1.578% (1010702 / 64052210)
Writing header...

Video stream: 15503.418 kbit/s (1937927 B/s) size: 2499645539 bytes 1289.855 secs 38647 frames

Audio stream: 384.000 kbit/s (48000 B/s) size: 61884954 bytes 1289.270 secs

But the output file is about 63M, while the source mpg file was about 3.3G.

Thanks for any help,
tlc
tlc is offline   Reply With Quote
Old 07-03-2011, 04:43 PM   #3217
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
edl file looks reasonable. Looks like mencoder is having hard time with video/audio muxing & cutting. Probably source video from TiVo has timestamp problems. Only fix I know is using VideoRedo instead which doesn't run under Linux.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-05-2011, 10:40 PM   #3218
bwall23
Registered User
 
Join Date: Jun 2009
Posts: 73
Smile Awesome...!!!

Just wanna say thanks for all the works! Love it, especially the <> feature which we won't talk about. VOTED BEST APP FOR THE TIVO!!! If it wan't for all of these user apps, the TiVo would be second-rate! I sure wish TiVo Corp. would listen to it's users instead of it's Marketing wanna-bees and Lawyers.
Bang-Away!!!
bwall23 is offline   Reply With Quote
Old 07-06-2011, 02:49 AM   #3219
mattack
Registered User
 
Join Date: Apr 2001
Location: sunnyvale
Posts: 16,783
I'm the one who asked for the # of NPL fetches feature, and use it a lot.

However, I realized that an even better way of doing it would be if you could interact with it while it fetched the now playing list.. Or maybe automatically fetch one page, then when you started a download, then automatically fetch the full NP list. (Since you can get the now playing list while downloading.)

(I also just found out about the no-verify option, and I have at least one show that fails very near the end of decrypting.. one of the Star Wars Family Guy episodes I think. I don't THINK I downloaded it with a different program yet, so I'll try that if I still have it.)
mattack is offline   Reply With Quote
Old 07-07-2011, 11:40 PM   #3220
tlc
Registered User
 
Join Date: May 2002
Posts: 431
I'm trying a bunch of things to find a workable, automated, linux-only solution. I'm willing to give up on comcut, but I don't want VideoReDo (Windows).

I downloaded 4 episodes of a show. The mpeg 2 files are all about 3.5G and play fine in VLC. I tried 4 encodings and checked them in VLC.
  • 'hb_tivo_hd', 1.27G, In sync in VLC
  • 'ff_h264_high_rate', 1.02G, Won't play in VLC
  • 'ff_h264_med_rate', 540M, Out of sync in VLC
  • 'ff_tivo_hd', 1.89G, Out of sync in VLC

Ok, I thought. The HandBrake encoding is in sync!

Then I PUSHED it to the TiVo with pyTivo, where it was badly out of sync.
Then I PULLED it to the TiVo with pyTivo (ffmpeg transcode to mpeg2), where it was in sync. Also, it transcoded/transferred slower than anything I've ever seen. (And I use pyTivo a lot.)

Anyone have a linux solution?
Anyone have the technical details of "the timestamp problem"?

Thanks,
tlc

Last edited by tlc : 07-08-2011 at 06:40 AM.
tlc is offline   Reply With Quote
Old 07-09-2011, 01:15 PM   #3221
hairywookie
Registered User
 
Join Date: Jul 2011
Posts: 1
lurking

Hello I have been lurking for a while now, and just want to say thanks for all the help. And that I am loving kmttg.

Second, is there a way to get around the ten post limit, for viewing links and sending PM's? I find most of my answers through searches and don't like to post on any board unless its necessary, so the ten post requirement seems weirdly counterproductive and high.

Thanks

Bill
hairywookie is offline   Reply With Quote
Old 07-09-2011, 01:32 PM   #3222
Stuxnet
Alien Infidel
 
Stuxnet's Avatar
 
Join Date: Feb 2011
Posts: 356
Quote:
Originally Posted by hairywookie View Post
is there a way to get around the ten post limit, for viewing links and sending PM's?
Easy. Go over to the Happy Hour - General Chit-Chat area and make some quick comments on the postings there... You can easily run up your post count in about ten minutes.
Stuxnet is offline   Reply With Quote
Old 07-09-2011, 04:20 PM   #3223
spudnic
Registered User
 
spudnic's Avatar
 
Join Date: Jul 2004
Posts: 42
Greetings!

I'm having trouble auto-transferring news programs. First off, I'm using XBMC as my primary video device having relegated the TiVo with the lifetime subscription to do all of my cable recording, then using kmttg to move the contents over to XBMC where I have much more control over the experience.

I have three auto-transfer lines, one that gets everything, .*, and one each for the two news shows I want recorded and do have "Treat each recording as unique" selected for those two. The title keyword match hits, but then nothing happens. It's been set up this way for a couple of weeks. Everything else is coming through fine.





Any ideas?

2011_07_08_12:26:44 Title keyword match: '.*' found in 'fox 40 news at 6'
2011_07_08_12:26:44 (ProgramId=SH011785410000 already processed => will not download)
2011_07_08_12:26:44 Title keyword match: 'fox 40 news at 6' found in 'fox 40 news at 6'
2011_07_08_12:26:44 Title keyword match: '.*' found in 'indoors out'
spudnic is offline   Reply With Quote
Old 07-09-2011, 04:51 PM   #3224
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Not enough details given on the matching portion of the log, but from the one line shown the .* match didn't download because ProgramId is already in auto.history file. News shows typically don't have unique ProgramId's, so you have to use the "Treat each recording as unique" setting to get them.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-09-2011, 05:01 PM   #3225
spudnic
Registered User
 
spudnic's Avatar
 
Join Date: Jul 2004
Posts: 42
The first two lines are from the first Title keyword match. I understand it skips because it has the ProgramId in the auto.history file. The third line hits the on the Title keyword match which DOES have "Treat each recording as unique" selected. It doesn't follow with an "already processed" but it doesn't download, either. It just moves on to the next match.

2011_07_08_12:26:44 Title keyword match: '.*' found in 'fox 40 news at 6'
2011_07_08_12:26:44 (ProgramId=SH011785410000 already processed => will not download)
2011_07_08_12:26:44 Title keyword match: 'fox 40 news at 6' found in 'fox 40 news at 6'
2011_07_08_12:26:44 Title keyword match: '.*' found in 'indoors out'

Is there some other portion of the log file that would be more helpful?

Last edited by spudnic : 07-09-2011 at 05:13 PM.
spudnic is offline   Reply With Quote
Old 07-10-2011, 11:24 AM   #3226
lawdawg
Registered User
 
Join Date: Oct 2003
Posts: 11
Tivo to AppleTV 2 conversion question

Hey everyone, I recently decided to drop DirecTV and bought a Tivo Premiere to record OTA HD. I am using kmttg to grab and decrypt recordings from the TiVo and would now like to convert them for use on the Apple TV. My usual handbrake profile will convert the mpg files to m4vs, and they look really nice, but a 1 hour 720p show is taking ~5 hours to complete. This is the same profile I have been using to convert DVD rips for use on my AppleTV.

I do not care about compressing the file size at all 4.57GB can stay 4.57 GB, I'm not going to keep these for archival purposes, I just want to be able to watch something I record upstairs on the TiVo downstairs on my AppleTV2 and have the quality nearly the same, or acceptable when viewed on a projector. The main thing I am looking for here is speed and quality vs size. Can someone recommend what settings I would use to accomplish this, or if handbrake is not the tool to accomplish this is there a better way to perform a fast, nearly lossless, MPG2 to M4V conversion?

Thanks,
lawdawg is offline   Reply With Quote
Old 07-10-2011, 01:30 PM   #3227
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by spudnic View Post
The first two lines are from the first Title keyword match. I understand it skips because it has the ProgramId in the auto.history file. The third line hits the on the Title keyword match which DOES have "Treat each recording as unique" selected. It doesn't follow with an "already processed" but it doesn't download, either. It just moves on to the next match.

2011_07_08_12:26:44 Title keyword match: '.*' found in 'fox 40 news at 6'
2011_07_08_12:26:44 (ProgramId=SH011785410000 already processed => will not download)
2011_07_08_12:26:44 Title keyword match: 'fox 40 news at 6' found in 'fox 40 news at 6'
2011_07_08_12:26:44 Title keyword match: '.*' found in 'indoors out'

Is there some other portion of the log file that would be more helpful?
I would guess that what is happening is since the ".*" matches the program and is rejected, then that show is put in reject bucket (not to process) for any subsequent matches. To test that you can temporarily disable the ".*" auto transfer and then fire up auto transfers in GUI mode to see what happens.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-16-2011, 06:17 PM   #3228
ljiminez
Registered User
 
Join Date: Jun 2007
Posts: 10
Quote:
Originally Posted by lawdawg View Post
Can someone recommend what settings I would use to accomplish this, or if handbrake is not the tool to accomplish this is there a better way to perform a fast, nearly lossless, MPG2 to M4V conversion?

Thanks,
I use kmttg to convert the .tivo file to .mpg file that is saved onto a NAS.

My computer uses Intel Q6600 cpu and Nvidia GT240 gpu.

Source file spec - 1920x1080 resolution, 59.94 frame rate

I use the Apple TV profile because my cellphone has 960x540 native resolution.

Conversion to Apple TV spec via Handbrake runs ~22fps, 100% cpu. Handbrake *estimates* this 1 hour HD show will take 80 min to finish. I didn't actually do the transcode because I wanted to continue using the computer.

Conversion to Apple TV spec via Badaboom2 ran 33fps, 35% cpu. It took 46 min to finish.

Transcoded file looks acceptable on cellphone, netbook, and 65 inch HDTV.
ljiminez is offline   Reply With Quote
Old 07-16-2011, 07:06 PM   #3229
mattack
Registered User
 
Join Date: Apr 2001
Location: sunnyvale
Posts: 16,783
I'm seeing 0p8c hang when I try to cancel a download. I ran into it twice today. Since it's java, simply sampling it won't be useful, right? Is there a way to get useful java-y info about where it's hung?

This is 0p8c as I said, on a Mac, on 10.5.8. (yeah yeah, upgrade)

whatever version I was using before, I never had a problem of cancelling a download hanging.
mattack is offline   Reply With Quote
Old 07-16-2011, 08:48 PM   #3230
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by mattack View Post
I'm seeing 0p8c hang when I try to cancel a download. I ran into it twice today. Since it's java, simply sampling it won't be useful, right? Is there a way to get useful java-y info about where it's hung?

This is 0p8c as I said, on a Mac, on 10.5.8. (yeah yeah, upgrade)

whatever version I was using before, I never had a problem of cancelling a download hanging.
Nothing has changed with code to kill jobs in a long time so I doubt it's anything different in 0p8c causing issue. What download method are you using? curl or java? Are you combining download & decrypt as one? If using curl then you can use try using command line "kill" to terminate the curl job. (Not familiar with Mac but since it's unix like you can use "ps" command line to find the curl pid and then "kill pid" or "kill -9 pid" to kill it). You can also use "top" to find running curl command and kill it. Since it's Mac there's likely some GUI to kill jobs available as well I would guess...
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-16-2011, 09:03 PM   #3231
ThAbtO
TiVoholic by the bay
 
ThAbtO's Avatar
 
Join Date: Apr 2000
Location: SF Bay Area
Posts: 4,656
Quote:
Originally Posted by mattack View Post
I'm seeing 0p8c hang when I try to cancel a download. I ran into it twice today. Since it's java, simply sampling it won't be useful, right? Is there a way to get useful java-y info about where it's hung?

This is 0p8c as I said, on a Mac, on 10.5.8. (yeah yeah, upgrade)

whatever version I was using before, I never had a problem of cancelling a download hanging.
I don't have any problems canceling jobs on 0p8c on Win XP. Is your Java up to date?
__________________
Series 2 (PLS, sold)
TiVo HD 1TB (157 HD Hrs, PLS, "652")
Roamio! Oh, wait, Its Juliet!

~~~~~

The TiVo Apocalypse begins on Sat 2013 Feb 16 00:00 GMT!
ThAbtO is offline   Reply With Quote
Old 07-17-2011, 01:11 PM   #3232
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
v0p8d version released

v0p8d version just released. Highlight of the release is a new Season Premieres tab in the iPad remote control GUI. This is a utility to search for new upcoming season & series premieres. There is also option to schedule season passes for resulting entries displayed in the table.

Other enhancement of note is addition of Record button in the Will Not Record tab so that you can schedule to record entries on selected TiVos. Useful if you have more than 1 Premiere - you can now get list of entries that will not record on 1 Premiere and optionally schedule to record selected entries on another Premiere.

Consult release_notes Wiki page for all the details of changes in this new release.

Consult remote_control Wiki page for details on the new Season Premieres tab of the remote.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-27-2011, 07:11 PM   #3233
innocentfreak
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 8,467
I am having some issues lately with some of my actual TiVo recordings and I am trying to narrow down if it is signal related or if the drive might be going.

I recorded Franklin & Bash and when my friend went to watch it, it was all pixelated and blocky. I figured I would see if KMTTG could transfer it and also to see if it played fine on my PC though I don't know why.

It transferred 30 minutes of the hour show and decrypted what transferred. Here is the odd thing. The TiVo recording is really broken up and unviewable. The stripped MPG plays fine without issues. Any ideas?

I figured if the .TiVo file had issues the .MPG would also, but was surprised when it didn't.
__________________
1 - TiVo Roamio Pro
2 - TiVo Premiere XL

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
innocentfreak is offline   Reply With Quote
Old 07-27-2011, 08:15 PM   #3234
L David Matheny
Registered User
 
Join Date: Jan 2011
Location: SE Ohio
Posts: 1,187
Quote:
Originally Posted by innocentfreak View Post
I am having some issues lately with some of my actual TiVo recordings and I am trying to narrow down if it is signal related or if the drive might be going.

I recorded Franklin & Bash and when my friend went to watch it, it was all pixelated and blocky. I figured I would see if KMTTG could transfer it and also to see if it played fine on my PC though I don't know why.

It transferred 30 minutes of the hour show and decrypted what transferred. Here is the odd thing. The TiVo recording is really broken up and unviewable. The stripped MPG plays fine without issues. Any ideas?

I figured if the .TiVo file had issues the .MPG would also, but was surprised when it didn't.
Very interesting. Is the TiVo running hot? Memory problems would probably cause more catastrophic strangeness. It could be a failure of the decoder hardware in the TiVo. Or maybe the TiVo is unable to stream the data from the drive to the decoder fast enough. Possible reasons could be drive problems (inadequate throughput? re-seeks?), excessive file fragmentation (should be unlikely with DVR file systems), insufficient hardware buffering (assumes fragmentation; could be tested by cloning to a drive with more cache), and ... what else?
L David Matheny is online now   Reply With Quote
Old 07-27-2011, 10:11 PM   #3235
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
v0p8e version released

v0p8e version just released. Highlights include addition of full virtual remote with buttons and keyboard support in addition to the advanced navigation buttons and some "combo" buttons:


Another highlight is ability to re-prioritize Season Passes.
Also new configuration option under *Tivos* tab to not initiate download of NPL lists automatically for each TiVo on kmttg startup.

See release_notes for details and consult remote_control Wiki for updated documentation on the iPad remote control.

NOTE: If upgrading from a previous version of kmttg note that this release contains a new "rc_images" folder as part of zip file which must be in same folder as kmttg.jar. The icons in that folder are used by the updated Remote Control.

Special thanks to "innocentfreak" for help testing this version.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-29-2011, 02:33 PM   #3236
caddyroger
Registered User
 
caddyroger's Avatar
 
Join Date: Mar 2005
Location: Some where out west
Posts: 1,619
This may not belong but It the closes I believe. I am using kmttg latest build. I have it set to automatically download programs using videoredo quickstream fix. It downloads the tivo programs ok but when the QS is done the program size is 0. what could be causing this?
__________________
Caddy
caddyroger is offline   Reply With Quote
Old 07-29-2011, 03:44 PM   #3237
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by caddyroger View Post
This may not belong but It the closes I believe. I am using kmttg latest build. I have it set to automatically download programs using videoredo quickstream fix. It downloads the tivo programs ok but when the QS is done the program size is 0. what could be causing this?
What version of VRD are you using? Does it happen for every show or just particular ones? If you have the "Enable VideoRedo QS Fix video dimension filter" option enabled what is kmttg reporting as the video dimension it is giving VRD to use? If you bring up VRD GUI manually and run QS Fix with video filter enabled is the issue still there?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-29-2011, 04:03 PM   #3238
Joe54
Registered User
 
Join Date: Jul 2011
Location: Florida
Posts: 7
Auto Transfer Service Problem

I just started using this application yesterday and I am very pleased with what it allows me to do. It saves me many hours trying to manage the programs I have amassed. The GUI is very good and I am deep in decoding and cutting commercials out of my movie library.

I've only found had one problem and it is likely I missed something in the setup. I am running Windows 7 and I downloaded kmttg_v0p8e.zip 10 hours after you posted it. The problem is in setting up the auto transfer. It works fine when I do a dry run in GUI but when I try to install the service, I get a path not specified. Which is correct as I do not have a service\win32 folder in the Temp1_kmttg_v0p8e.zip directory (where Windows installed the application).

Thinking it might be an oversite on the new release (I apologize in advance for thinking this was possible), I downloaded version d and found the same problem. I even did a search on *.bat for all my drives and none of the service.bat files you list are on my machine.

I found no reference to this on the last 5 forum pages, so this must be something I did wrong. What am I missing?
Joe54 is offline   Reply With Quote
Old 07-29-2011, 04:48 PM   #3239
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,012
Quote:
Originally Posted by Joe54 View Post
I just started using this application yesterday and I am very pleased with what it allows me to do. It saves me many hours trying to manage the programs I have amassed. The GUI is very good and I am deep in decoding and cutting commercials out of my movie library.

I've only found had one problem and it is likely I missed something in the setup. I am running Windows 7 and I downloaded kmttg_v0p8e.zip 10 hours after you posted it. The problem is in setting up the auto transfer. It works fine when I do a dry run in GUI but when I try to install the service, I get a path not specified. Which is correct as I do not have a service\win32 folder in the Temp1_kmttg_v0p8e.zip directory (where Windows installed the application).

Thinking it might be an oversite on the new release (I apologize in advance for thinking this was possible), I downloaded version d and found the same problem. I even did a search on *.bat for all my drives and none of the service.bat files you list are on my machine.

I found no reference to this on the last 5 forum pages, so this must be something I did wrong. What am I missing?
I just downloaded kmttg_v0p8e.zip and unzipped it to a fresh folder and I verified that "service" folder at same level as kmttg.jar with "conf" and "win32" sub-folders are extracted out of it. There are also other required folders at same level as kmttg.jar namely "VRDscripts", "rc_images" and "encode". If that's not what you are seeing perhaps use a different unzip program.
NOTE: It almost sounds like perhaps you are running kmttg.jar directly from within the zip file or something? If that is so don't do that. You should unzip everything to a new folder and the double-click on kmttg.jar to run it.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-29-2011, 06:43 PM   #3240
caddyroger
Registered User
 
caddyroger's Avatar
 
Join Date: Mar 2005
Location: Some where out west
Posts: 1,619
Quote:
Originally Posted by moyekj View Post
What version of VRD are you using? Does it happen for every show or just particular ones? If you have the "Enable VideoRedo QS Fix video dimension filter" option enabled what is kmttg reporting as the video dimension it is giving VRD to use? If you bring up VRD GUI manually and run QS Fix with video filter enabled is the issue still there?
The day before 1 out of 5 did not QF. Last night 3 out 3 did not QF. I am using vrdtvsh264-4-20-6-691a. Do not know what you mean by what is kmttg reporting as the video dimension it is giving VRD to use. how do i check that?
did not try the manual gui will try now.
__________________
Caddy
caddyroger is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 08:36 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |