TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 05-11-2010, 07:54 PM   #2311
LynnL999
Registered User
 
Join Date: Oct 2002
Location: Irvine, California
Posts: 288
Hi -- I'm pretty new to this program. If I wanted to get Video Redo to encode with kmttg, do I need the whole TV Suite, or is Plus adequate?

Thanks!
LynnL999 is offline   Reply With Quote
Old 05-11-2010, 10:04 PM   #2312
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by LynnL999 View Post
Hi -- I'm pretty new to this program. If I wanted to get Video Redo to encode with kmttg, do I need the whole TV Suite, or is Plus adequate?

Thanks!
Plus does not have encoding capabilities, you need TV Suite for that. Or you can just stick to the free ffmpeg, handbrake, x264 encoders and go with VRD Plus for the invaluable Quick Stream Fix capability + mpeg2 video editing.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-13-2010, 09:32 PM   #2313
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
v0p7k version released

v0p7k version just released. Highlight is new Auto Transfers > Loop in GUI option to run Auto Transfers continuously in GUI mode.

Consult release notes for all details of this update:
http://code.google.com/p/kmttg/wiki/release_notes
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-13-2010, 10:01 PM   #2314
innocentfreak
Registered User
 
Join Date: Aug 2001
Location: Florida
Posts: 8,442
Very cool. Thanks.
__________________
1 - TiVo Roamio Pro
2 - TiVo Premiere XL

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
innocentfreak is offline   Reply With Quote
Old 05-14-2010, 07:25 AM   #2315
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
I'm having trouble with the auto transfer when it gets to the addetect section. I am using VideoReDo, and I do have it configured properly - as the VRD QS Fix is running through the auto transfer service fine. When it trys to run Ad Detect, it just hangs. VideoReDo.exe is running, as is the csscript.exe but it never ends (I left it on overnight and nothing) usually this process takes 10 mins max. Any suggestions?

Also - will the auto transfer still bring up the Video ReDo window to review the ad detect results before applying ad cut, or does that only work with the GUI?
wireman121 is offline   Reply With Quote
Old 05-14-2010, 10:21 AM   #2316
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
My guess is VRD Ad Detect is having trouble with that video. Try using comskip instead to detect commercials. i.e. Uncheck option under VideoRedo tab of configuration: "Use VideoRedo AdScan instead of comskip".

If running auto transfers in service mode then "vrdreview" step (visual inspection of commercials) is skipped. You may want to try running auto transfers from GUI instead if you want that part of your flow.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-14-2010, 10:13 PM   #2317
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
If I run ad detect on the same video from the GUI it gets through it fine, so its definately something with the service calling it - Regardless, I think what I'm looking for is to have the GUI do what the auto transfer service does on its own. I like the "Run in GUI" option, but if that would be a on/off toggle, so that when turned on (or checked in the menu) it would automatically check the tivo in the interval I programmed into the auto transfer options - and just do it all within the GUI instead of through the service. What I'm looking to have it do is automatically download, decrypt, and ad detect everything in the auto transfer list and then bring it up for review in VideoReDo so that when I get home, all I need to do it review it and then it will continue.....make sense?
wireman121 is offline   Reply With Quote
Old 05-14-2010, 10:23 PM   #2318
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
If you upgrade to latest version released yesterday there is a "Loop in GUI" option which does exactly what you are asking for. For reviewing detected commercials using VideoRedo make sure you enabled the option under VideoRedo tab: "Use VideoRedo GUI to review detected commercials"
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-15-2010, 09:04 AM   #2319
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
hah awesome!
wireman121 is offline   Reply With Quote
Old 05-15-2010, 09:49 AM   #2320
epstewart
Registered User
 
Join Date: Mar 2003
Posts: 188
Status of transport stream downloads?

Hi,

I'm using kmttg v0p7k on Mac OS X 10.5.8. I use 2 TiVo HDs and 1 older Series3.

I'm trying out 2 of the new wireless-N network adapters, 1 on the bedroom Series3 and 1 on the living room TiVo HD. (The other TiVo HD is in the basement and has a wireless-G adapter.) I have the N adapters networked via an 802.11 router.

My questions are about the kmttg program option to download TiVo files in transport stream format.

The reason I ask them is that I want to archive HD downloads on my Mac and use TivoToComeBack (in any of its forms, including TiVo Desktop and pyTivoX/StreamBaby) to upload and immediately view the programs. I would like, if possible, to avoid buffering pauses when I do this.

So far, I have found no way to avoid the buffering pauses. The process is almost fast enough, but not quite.

Elsewhere, I have read that the need to translate between program streams (PS) on the computer and transport streams (TS) on the TiVo slows things down, and that TiVo-to-TiVo multi-room viewing (MRV) avoids that by using TS exclusively.

So I thought I might be able to do the same with TiVo-to-computer downloads, by using kmttg's option to "download TiVo files in transport stream format."

I tried that with one of the HD movies I've been testing with. The original download some weeks ago was (I think — at one point I was trying "download TiVo files in transport stream format" with an earlier version of kmttg and gave up on it as causing my TiVo HD to stop communicating) in PS form. The new download, which seemingly worked fine, apparently used "download TiVo files in transport stream format."

However, it produced an output file of exactly the same size as the old download, and the MediaInfo app says it is MPEG-PS. Plus, the new download uploads to the Series3 TiVo (using TiVo Desktop) at exactly the same pause-ridden rate as the old download did.

I wonder if the new download turned out to be a PS, not an honest-to-goodness TS, and if so, why wasn't it really a PS? (I rechecked, and I definitely had "download TiVo files in transport stream format" on in kmttg config when I did the new download.)

And while I'm on the subject ... if I ever do manage to get an honest-to-goodness TS download to my computer ... will I actually be able to upload or stream it back to any of my TiVos, using TiVo Desktop, pyTivoX, StreamBaby, or whatever other interface would do the trick?

I thank any of you experts in advance for any help you can give.
__________________
Eric Stewart
Catonsville, MD
epstewart is offline   Reply With Quote
Old 05-15-2010, 11:09 AM   #2321
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
epstewart, TS downloads are only possible with "Premiere" or Australia/NZ TiVo units. For Series 3 USA units the specification for TS download format has no effect and you end up with PS mpeg2 files same as always. That info is in kmttg documentation & the tooltip that pops up when you put mouse over the kmttg config option.
In any case it appears like TS downloads at least from Premiere units are still buggy so best avoided. Premiere units even for PS format are supposedly faster for downloading/uploading compared to S3 units (especially if you stick to SD interface) so may accomplish what you want.

One more thing to keep in mind about Streambaby uploads:
There is still a 1.1GB TiVo imposed buffer limit after which the stream must be re-started (to clear the buffer). Streambaby can do this fine for unencrypted mpeg2 & H.264 formats but for .TiVo format it will simply stop & restart from beginning - i.e. You shouldn't use .TiVo formats for files > 1.1GB with streambaby.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-15-2010, 11:51 AM   #2322
epstewart
Registered User
 
Join Date: Mar 2003
Posts: 188
Quote:
Originally Posted by moyekj View Post
epstewart, TS downloads are only possible with "Premiere" or Australia/NZ TiVo units. For Series 3 USA units the specification for TS download format has no effect and you end up with PS mpeg2 files same as always. That info is in kmttg documentation & the tooltip that pops up when you put mouse over the kmttg config option.
Ok, thanks, I missed the tooltip, but it's clear now that I didn't really get a TS download, and why.

Quote:
Originally Posted by moyekj View Post
TS downloads at least from Premiere units are still buggy so best avoided.
The problem is with the Premiere software, right, not kmttg?

Quote:
Originally Posted by moyekj View Post
Premiere units even for PS format are supposedly faster for downloading/uploading compared to S3 units (especially if you stick to SD interface) so may accomplish what you want.
Yes, I'm definitely looking into the Premiere, and have downloaded bkdtv's Premiere tech review, which I'm about to read. I notice that he (she?) put a lot of information in it concerning time considerations for downloading recorded files and computer video transfers.

Quote:
Originally Posted by moyekj View Post
One more thing to keep in mind about Streambaby uploads:
There is still a 1.1GB TiVo imposed buffer limit after which the stream must be re-started (to clear the buffer). Streambaby can do this fine for unencrypted mpeg2 & H.264 formats but for .TiVo format it will simply stop & restart from beginning - i.e. You shouldn't use .TiVo formats for files > 1.1GB with streambaby.
Yes, I've run into the 1.1 GB buffer limit on non-.TiVo files, as I've been using such decoded files, not the originals. I'll keep what you said in mind if I ever try to use StreamBaby for .TiVo files.

Thanks for your help and for the excellent kmttg program.
__________________
Eric Stewart
Catonsville, MD

Last edited by epstewart : 05-15-2010 at 12:06 PM.
epstewart is offline   Reply With Quote
Old 05-15-2010, 02:21 PM   #2323
SoBayJake
Registered User
 
SoBayJake's Avatar
 
Join Date: Feb 2002
Location: Los Angeles, CA
Posts: 407
Quote:
Originally Posted by epstewart View Post
Hi,

I'm using kmttg v0p7k on Mac OS X 10.5.8. I use 2 TiVo HDs and 1 older Series3.
I think only the Premiere and Tivos in Australia/New Zealand can output transport streams.

If you are in the U.S. with TiVo HDs and S3s, you are going to get Program Streams regardless of the preference in kmttg. The TiVo won't send out Transport Streams, so when kmttg requests a TS, the TiVo ignores the flag, and sends out a PS.

EDIT: Nevermind, I was late to the party! epstewart's message was the last on the page, and I didn't realize I wasn't at the end of the thread!
__________________

Nonunsed Series 2s
Series 3 - 1 TB drive (lifetime)
TiVo HD - 1 TB drive (lifetime)
Premiere XL (lifetime)
Verizon FiOS with CableCARDs

Last edited by SoBayJake : 05-15-2010 at 02:22 PM. Reason: Late to the party.
SoBayJake is offline   Reply With Quote
Old 05-15-2010, 02:52 PM   #2324
wireman121
Registered User
 
Join Date: Nov 2008
Posts: 78
Now all I need to figure out is how to make pytivo delete the mpg and txt file after the push and its all set haha
wireman121 is offline   Reply With Quote
Old 05-15-2010, 05:14 PM   #2325
orangeboy
yes, I AM orangeboy!
 
Join Date: Apr 2004
Location: Moline, IL
Posts: 4,075
Quote:
Originally Posted by wireman121 View Post
Now all I need to figure out is how to make pytivo delete the mpg and txt file after the push and its all set haha
Check out this post discussing the hack of plugins/video/video.py, in the pyTivo forum: http://pytivo.sourceforge.net/forum/...fers-t131.html

I log all my transfers to a text file using that hack, then as part of the kmttg "custom command" that can run after each set of jobs, I parse that text and delete any successfully transferred files, using "IF EXIST" logic in the custom command .bat file I wrote.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
orangeboy is offline   Reply With Quote
Old 05-15-2010, 08:30 PM   #2326
jk5598224
Registered User
 
Join Date: Jan 2003
Location: Bay Area, CA
Posts: 312
Audio Problems

I was using this program for transfers fine, but from some reason the audio now sounds like the chipmunks sqeeking. Is this the wrong encoding profile being used?

I am transfering from Tivo HD AND Sony SVR3000 to a Lenovo Thinkpad. Any tips appreciated.
jk5598224 is offline   Reply With Quote
Old 05-16-2010, 07:09 AM   #2327
epstewart
Registered User
 
Join Date: Mar 2003
Posts: 188
Quote:
Originally Posted by SoBayJake View Post
I think only the Premiere and Tivos in Australia/New Zealand can output transport streams.

If you are in the U.S. with TiVo HDs and S3s, you are going to get Program Streams regardless of the preference in kmttg. The TiVo won't send out Transport Streams, so when kmttg requests a TS, the TiVo ignores the flag, and sends out a PS.

EDIT: Nevermind, I was late to the party! epstewart's message was the last on the page, and I didn't realize I wasn't at the end of the thread!
SoBayJake,

Thanks, anyway!
__________________
Eric Stewart
Catonsville, MD
epstewart is offline   Reply With Quote
Old 05-16-2010, 08:13 AM   #2328
richklein
Registered User
 
Join Date: Feb 2001
Posts: 89
I am having an issue. I am in the middle of a project that is keeping me away from watching TV due to being to busy. So i am trying to move some shows so i can watch them later.

Anyway, I have the options set as: Metadata, Decrypt, QS Fix

If I que up more than two shows at a time to download, it crashes the second show.

If I only pick two at a time, it seems to work.

Thanks,
Rich

Code:
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--   198
  0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 2 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie7862338643140377077.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--  1174
  0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 3 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie8991614487978055852.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--  1021
  0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 4 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie2898269932603719347.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--   959
  0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 5 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie1950304797418644820.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--  1382
  0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Too many failed downloads, GIVING UP!!
tivodecode job completed: 00:06:39

richklein is offline   Reply With Quote
Old 05-16-2010, 08:13 AM   #2329
AgtScully
Registered User
 
Join Date: May 2009
Posts: 10
Windows 7 and kmttg

I'm having a problem installing the kmttg service onto the Windows 7 32-bit Ultimate version.
When I select "Service" then "Install", the GUI just hangs.
I first tried v0p7j(since it worked well in XP SP3) but it would never install.
The task manager will list it as "running" but no response from the GUI.
So I tried v0p7k but it also will not install.
But I have no problem running the "Loop in GUI" option.

I'm still learning the ropes of Windows 7 so I would greatly appreciate anyone's help in solving this problem.

Thanks.

Last edited by AgtScully : 05-16-2010 at 09:13 AM.
AgtScully is offline   Reply With Quote
Old 05-16-2010, 09:01 AM   #2330
orangeboy
yes, I AM orangeboy!
 
Join Date: Apr 2004
Location: Moline, IL
Posts: 4,075
Quote:
Originally Posted by richklein View Post
I am having an issue. I am in the middle of a project that is keeping me away from watching TV due to being to busy. So i am trying to move some shows so i can watch them later.

Anyway, I have the options set as: Metadata, Decrypt, QS Fix

If I que up more than two shows at a time to download, it crashes the second show.

If I only pick two at a time, it seems to work.

Thanks,
Rich

Code:
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--   198
  0    47    0    47    0     0    198      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 2 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie7862338643140377077.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--  1174
  0    47    0    47    0     0   1174      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 3 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie8991614487978055852.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--  1021
  0    47    0    47    0     0   1021      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 4 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie2898269932603719347.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--   959
  0    47    0    47    0     0    959      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Download attempt # 5 scheduled in 10 seconds.
>> DOWNLOADING H:\Pytivo\Hook (05_04_2010).TiVo ...
C:\Users\Rich\Documents\kmttg_v0p7j\curl\curl.exe --retry 3 --anyauth --globoff --user tivo:MAK --insecure --cookie-jar C:\Users\Rich\AppData\Local\Temp\cookie1950304797418644820.tmp --url http://192.168.1.107:80/download/Hook.TiVo?Container=%2FNowPlaying&id=206959&Format=video/x-tivo-mpeg-ts --output "H:\Pytivo\Hook (05_04_2010).TiVo" 
H:\Pytivo\Hook (05_04_2010).TiVo: size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
<h2>Resource Not Found</h2>
Download failed to file: H:\Pytivo\Hook (05_04_2010).TiVo
Exit code: 0
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed

  0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--  1382
  0    47    0    47    0     0   1382      0 --:--:-- --:--:-- --:--:--     0
Hook (05_04_2010).TiVo: Too many failed downloads, GIVING UP!!
tivodecode job completed: 00:06:39
That "<h2>Resource Not Found</h2>" error occurred last evening for me. I have changed my download retry wait time (found in program options) from 10 seconds to 3600, which may be a bit extreme, but the error only occurred once. The next attempt an hour later was successful, and kmttg didn't have to give up.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
orangeboy is offline   Reply With Quote
Old 05-16-2010, 09:05 AM   #2331
orangeboy
yes, I AM orangeboy!
 
Join Date: Apr 2004
Location: Moline, IL
Posts: 4,075
Quote:
Originally Posted by AgtScully View Post
I'm having a problem installing the kmttg service onto the Windows 7 32-bit Ultimate version.
When I select "Service" then "Install", the GUI just hangs.
I first tried v0p7j(since it worked well in XP SP3) but it would never install.
The task manager will list it as "running" but no response from the GUI.
So I tried v0p7k but it also will not install.
But I have no problem running the "Loop in GUI" option.

I'm still learning the roops of Windows 7 so I would greatly appreciate anyone's help in solving this problem.

Thanks.
You may want to try running "\kmttg\service\win32\install-kmttg-service.bat" manually as administrator. I don't know if that will help or not, but it may do it.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
orangeboy is offline   Reply With Quote
Old 05-16-2010, 09:16 AM   #2332
AgtScully
Registered User
 
Join Date: May 2009
Posts: 10
Quote:
Originally Posted by orangeboy View Post
You may want to try running "\kmttg\service\win32\install-kmttg-service.bat" manually as administrator. I don't know if that will help or not, but it may do it.
UGH!! So simple, a cavewoman could do it

Thank you orangeboy!!
AgtScully is offline   Reply With Quote
Old 05-16-2010, 10:55 AM   #2333
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by jk5598224 View Post
I was using this program for transfers fine, but from some reason the audio now sounds like the chipmunks sqeeking. Is this the wrong encoding profile being used?

I am transfering from Tivo HD AND Sony SVR3000 to a Lenovo Thinkpad. Any tips appreciated.
Most likely a codec and/or player issue on Thinkpad. What encoding profile are you using? If it's one with H.264 with AC3 audio there aren't too many players that can handle playback of that properly, but VLC media player can.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-16-2010, 11:24 AM   #2334
jk5598224
Registered User
 
Join Date: Jan 2003
Location: Bay Area, CA
Posts: 312
Quote:
Originally Posted by moyekj View Post
Most likely a codec and/or player issue on Thinkpad. What encoding profile are you using? If it's one with H.264 with AC3 audio there aren't too many players that can handle playback of that properly, but VLC media player can.
I only click the decrypt button, not sure if I need to click encode as well. Seems more of a problem with WinDVD 5.x. I am discovering that it works with Msft Player. Of course it used with work with WinDVD 5.x, so I am trying to figure out 'what changed'
jk5598224 is offline   Reply With Quote
Old 05-17-2010, 04:36 PM   #2335
abnersnell
Registered User
 
Join Date: Mar 2002
Posts: 18
How is everyone handling interlaced content?

I was curious if anyone is handling interlaced content transferred from TiVo in a "custom" manner?

I have cobbled together a "custom" script after the transfer, decode, streamfix, ad detect, and ad cut steps. I skip encode and handle 1920x1080@29.97 interlaced HDTV with avisynth(deinterlace, resize) and x264.exe for encoding.

Anyone else doing anything special with interlaced content? Or just compressing interlaced straight away with FFMEG?

Abner
abnersnell is offline   Reply With Quote
Old 05-18-2010, 12:35 AM   #2336
NYHeel
Registered User
 
Join Date: Oct 2003
Posts: 1,171
I've run kmttg twice with metadata, decrypt, ad detect, ad cut, and push all checked. Eventually I'll want to have this encoding for my ipod but I was just testing the commercial skip feature for now. Everything seems to run great (including the push, really cool by the way) except the Ad cut part gets all of these errors and eventually quits. It leaves a file that's about 20 minutes long and doesn't quite work right. Unfortunately I closed kmttg before saving out the log. Does anyone have any ideas what the problem could be? The ad detect ran fine but the ad cut part bombed. Is there another program I need?

Thanks for the help and again really cool program, especially with the pytivo push integration.
NYHeel is offline   Reply With Quote
Old 05-18-2010, 08:55 AM   #2337
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by NYHeel View Post
I've run kmttg twice with metadata, decrypt, ad detect, ad cut, and push all checked. Eventually I'll want to have this encoding for my ipod but I was just testing the commercial skip feature for now. Everything seems to run great (including the push, really cool by the way) except the Ad cut part gets all of these errors and eventually quits. It leaves a file that's about 20 minutes long and doesn't quite work right. Unfortunately I closed kmttg before saving out the log. Does anyone have any ideas what the problem could be? The ad detect ran fine but the ad cut part bombed. Is there another program I need?

Thanks for the help and again really cool program, especially with the pytivo push integration.
VideoRedo is really a necessary addition if you see those kinds of problems. VRD QuickStream Fix cleans up glitches in the original recordings and will also be used to make the cuts instead of mencoder if you have it configured in kmttg and those kinds of problems go away. The $50 Plus version is really all you need if you don't care about VRD encoding, H.264 editing & DVD burning capabilities. It's also useful to be able to review detected commercials with VRD and clean up the cut points if necessary. There is a fully functional trial version if you wish to try it out before buying. Of course it only runs on Windows currently which is an issue for some.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-18-2010, 10:31 AM   #2338
janry
Registered User
 
Join Date: Jan 2003
Location: Nashville, TN
Posts: 17,688
I have installed kmttg on two previous computers (XP & Vista) with limited issues. I recently installed it on a Windows 7 computer and for love nor money, I cannot get auto transfers to work. It's like it never even attempts to transfer. And yes, I do have the transfer "enabled" under the latest verson.

Manual tranfers work great.

Any ideas of what I've done wrong?
janry is offline   Reply With Quote
Old 05-18-2010, 11:54 AM   #2339
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,852
Quote:
Originally Posted by janry View Post
I have installed kmttg on two previous computers (XP & Vista) with limited issues. I recently installed it on a Windows 7 computer and for love nor money, I cannot get auto transfers to work. It's like it never even attempts to transfer. And yes, I do have the transfer "enabled" under the latest verson.

Manual tranfers work great.

Any ideas of what I've done wrong?
It's probably a service permissions issue. First make sure you get the transfers working properly via GUI. In latest version there's both "Run Once in GUI" and "Loop in GUI" options. It's also useful to use the "Dry Run Mode" option to test your auto transfers setup without having kmttg actually initiate downloads. If/once you get that working then focus on getting service mode to work. Consult the Wiki page:
http://code.google.com/p/kmttg/wiki/auto_transfers
Pay particular attention to the section entitled "RUNNING THE AUTO TRANSFERS PROGRAM AS A SERVICE IN WINDOWS". Ultimately it boils down to permissions issues where you need to use same account you use to run GUI when running the service.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-18-2010, 12:24 PM   #2340
NYHeel
Registered User
 
Join Date: Oct 2003
Posts: 1,171
Quote:
Originally Posted by moyekj View Post
VideoRedo is really a necessary addition if you see those kinds of problems. VRD QuickStream Fix cleans up glitches in the original recordings and will also be used to make the cuts instead of mencoder if you have it configured in kmttg and those kinds of problems go away. The $50 Plus version is really all you need if you don't care about VRD encoding, H.264 editing & DVD burning capabilities. It's also useful to be able to review detected commercials with VRD and clean up the cut points if necessary. There is a fully functional trial version if you wish to try it out before buying. Of course it only runs on Windows currently which is an issue for some.
Thanks for the recomendation. I'll give it a try. Do you think the VRD commercial cuts are "better" than the comskip/comcut that kmttg uses (assuming the quickstream fix part runs first)?
NYHeel is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVo® is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 06:13 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |