TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 11-03-2009, 12:42 AM   #1651
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Quote:
Originally Posted by t1c4l View Post
Is anyone able to provide me with a smallish .mp4 file (under 10MB) with an .mp4.fmt file that has been verified to work on Streambaby outside of Australia and New Zealand? This way I can try and use these same files to try on my Aussie TiVo to see if it works.

Because if I find that it doesn't work, then this could point to something entirely different than just a change from program to transport streams.
Here you go - this has been verified to work for a long time now and has been used by many for testing purposes. mp4 container, H.264 video, AAC audio:
http://tivostream.googlecode.com/files/test.mp4
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-03-2009, 04:21 AM   #1652
t1c4l
Registered User
 
Join Date: Apr 2009
Posts: 15
Thanks mokeyj.

Have you tried playing this file as .raw on Streambaby with a .raw.fmt file in the same folder? If you can please rename the .mp4 to .raw and then create a text file with .raw.fmt extension then Streambaby won't use ffmpeg to stream to TiVo. In .raw.fmt file please add video/mp4 on first line and leave second line blank.

I'll test this file out as soon as I get home tonight.

Cheers.
t1c4l is offline   Reply With Quote
Old 11-03-2009, 06:35 AM   #1653
t1c4l
Registered User
 
Join Date: Apr 2009
Posts: 15
Arrow

Looks like playing of raw mp4 files doesn't work. Streambaby log is below.
They must have completely changed the way video data needs to be sent to the TiVo. I don't think there is going to be an easy way to work out how to send it to the TiVo properly.

Code:
11/03/09 20:29:08 VideoModuleHelper: GetVidInfo: file:/C:/Downloads/VIDEOS/test.raw
11/03/09 20:29:08 VideoModuleHelper: Guessing bitrate for file:/C:/Downloads/VIDEOS/test.raw to: -115663312
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 VideoModuleHelper: quality setting is above quality of video, streaming normally
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0
11/03/09 20:29:08 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:08 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:08 VideoModuleHelper: quality setting is above quality of video, streaming normally
11/03/09 20:29:10 ButtonScreen: action=right
11/03/09 20:29:10 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0
11/03/09 20:29:10 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 ViewScreen: Desc: test.raw
11/03/09 20:29:10 PreviewWindow: pWidth: 1280
11/03/09 20:29:10 PreviewWindow: preview parent=BView[#2616,bounds=0,0,1280x720]
11/03/09 20:29:10 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0
11/03/09 20:29:10 HostContext: key=mpos:file:/C:/Downloads/VIDEOS/test.raw value=0applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
11/03/09 20:29:10 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 HostContext: compKey=XXXXXXXXXXXXXXXXXX-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
11/03/09 20:29:10 ViewScreen: goto position: 0, vidlen: -1
11/03/09 20:29:10 ViewScreen: Position not in buffer, starting new stream
11/03/09 20:29:11 Application: Already initialized, not re-initing.
11/03/09 20:29:11 ViewScreen: Openening stream at position: 0(0 secs)
11/03/09 20:29:11 VideoModuleHelper: Bitrate for quality: 2916
11/03/09 20:29:11 VideoModuleHelper: quality setting is above quality of video, streaming normally
11/03/09 20:29:11 RawStreamingModule: opening raw file with mimeType: video/mp4, contentType: video/mp4
11/03/09 20:29:11 NamedStream: Registering named stream: 659c0916-bda4-49eb-b137-63ab6c655649.stream
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:11 ViewScreen: error=ERROR: 0xffff test.raw
11/03/09 20:29:15 Listener: 
11/03/09 20:29:15 Listener: connection to receiver closed
11/03/09 20:29:15 Listener: 
11/03/09 20:29:15 Factory: HME receiver disconnected

t1c4l is offline   Reply With Quote
Old 11-03-2009, 09:34 AM   #1654
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Quote:
Originally Posted by t1c4l View Post
Thanks mokeyj.

Have you tried playing this file as .raw on Streambaby with a .raw.fmt file in the same folder? If you can please rename the .mp4 to .raw and then create a text file with .raw.fmt extension then Streambaby won't use ffmpeg to stream to TiVo. In .raw.fmt file please add video/mp4 on first line and leave second line blank.

I'll test this file out as soon as I get home tonight.

Cheers.
Yes, I just tried with streambaby in .raw form to be sure and it worked. I already knew it was compatible (note that it already also has moov atom at the front of the file as well as required by TiVo).

Perhaps you can try a testcase using mpeg2 transport stream container instead of mp4 container and see if it works that way (leave test.raw.fmt as video/mp4):
http://tivostream.googlecode.com/files/test.ts
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-03-2009, 03:34 PM   #1655
AussieMark
Registered User
 
Join Date: Oct 2009
Posts: 8
TiVo in Australia are claiming they have requested TiVO USA to liaise directly with Keary to provide him with the information needed in order to get this fixed. Keary, have you had any contact directly from TiVo on this?
AussieMark is offline   Reply With Quote
Old 11-03-2009, 03:47 PM   #1656
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Quote:
Originally Posted by AussieMark View Post
TiVo in Australia are claiming they have requested TiVO USA to liaise directly with Keary to provide him with the information needed in order to get this fixed. Keary, have you had any contact directly from TiVo on this?
That would be a first... The capability to stream to Tivos was uncovered by wmcbrine and some reverse engineering. TiVo has not updated HME SDK to officially support streaming and in fact have removed all references to SDK from their web site which to me signals they have little to no interest in providing help for 3rd party software and if anything are discouraging further development.
There are some major hurdles such as the ~1.1GB stream buffer limit which could really benefit from some help by TiVo to overcome but I wouldn't hold my breath on getting any input from TiVo on this.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-03-2009, 03:54 PM   #1657
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by moyekj View Post
That would be a first... The capability to stream to Tivos was uncovered by wmcbrine and some reverse engineering. TiVo has not updated HME SDK to officially support streaming and in fact have removed all references to SDK from their web site which to me signals they have little to no interest in providing help for 3rd party software and if anything are discouraging further development.
There are some major hurdles such as the ~1.1GB stream buffer limit which could really benefit from some help by TiVo to overcome but I wouldn't hold my breath on getting any input from TiVo on this.
Yup, I've been wrong before but I would be (pleasantly) amazed if TiVo actually did reach out the open source community...

This is a new scenario however-- This is the first time that I can think of that TiVo customers have had to pay for an extra option (I believe getting access to networked applications cost an extra AUD 99 in Australia) and then removed rather quickly what I believe (being very biased ;-) is the main benefit of the extra cost.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 11-03-2009, 05:26 PM   #1658
t1c4l
Registered User
 
Join Date: Apr 2009
Posts: 15
Quote:
Originally Posted by moyekj View Post
Perhaps you can try a testcase using mpeg2 transport stream container instead of mp4 container and see if it works that way (leave test.raw.fmt as video/mp4):
http://tivostream.googlecode.com/files/test.ts
No luck. Same issue again. Error 0xffff.

Tried leaving it as video/mp4 as suggested, no go. Changed it to video/mpeg, no go as well.

I did some beta testing for TiVo Australia when it first started, I will try and contact someone there to see if they can point us in the right direction.
t1c4l is offline   Reply With Quote
Old 11-03-2009, 06:06 PM   #1659
AussieMark
Registered User
 
Join Date: Oct 2009
Posts: 8
Quote:
Originally Posted by kearygriffin View Post
Yup, I've been wrong before but I would be (pleasantly) amazed if TiVo actually did reach out the open source community...
I hope you're wrong. This is what one of the TiVo staff (NB. Hybrid is the local TiVo operation in AU/NZ) posted on the Australian Whirlpool forum in response to the Streambaby issue ....

"Craig- Hybrid writes...
We have asked the TiVo US team to engage directly with the US Streambaby group in the hope they can provide assistance."
AussieMark is offline   Reply With Quote
Old 11-04-2009, 02:54 AM   #1660
madimoo
Registered User
 
Join Date: Feb 2009
Posts: 10
Quote:
Originally Posted by kearygriffin View Post
(I believe getting access to networked applications cost an extra AUD 99 in Australia)
Try $199.

(although you can get it for $99 if you ask around nicely, or for free if you buy two TiVo's)

The problem Hybrid have is that the Streambaby not working issue is starting to create some considerable negative publicity for TiVo, in a PVR market that is quite competitive. I'm sure Hybrid would love the situation to be resolved, but are a bit at the mercy of the US TiVo engineers.

I saw a post where someone suggested to Hybrid that they pay to fly Keary down to Oz for a few days, share a few beers, shrimp on the BBQ or two, and work out a fix. Sounds like the go.
madimoo is offline   Reply With Quote
Old 11-04-2009, 06:41 AM   #1661
dm_
Registered User
 
Join Date: Nov 2009
Posts: 19
Sigh. Another .au user here getting the 0xffff error. Happy to do some testing/debugging etc. I'm reasonably handy with tcpdump if that helps

Actually - don't they use the streaming for doing the movies by broadband thing? Or does that use a different mechanism?
dm_ is offline   Reply With Quote
Old 11-04-2009, 12:30 PM   #1662
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
For you Aussie users does YouTube streaming still work with the new 11.3 software?
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-04-2009, 02:52 PM   #1663
angusj
Registered User
 
Join Date: Jul 2009
Location: Sydney
Posts: 5
Quote:
Originally Posted by moyekj View Post
For you Aussie users does YouTube streaming still work with the new 11.3 software?
YouTube has never been available on Aussie TiVos.
angusj is offline   Reply With Quote
Old 11-04-2009, 04:34 PM   #1664
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Quote:
Originally Posted by angusj View Post
YouTube has never been available on Aussie TiVos.
This application essentially mimics what Tivo did to stream YouTube content to Tivos - that is where the reverse engineering came from which is why I asked. Perhaps if you guys request YouTube streaming capability then as a side effect you will get streambaby functionality back as well.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-04-2009, 05:30 PM   #1665
AussieMark
Registered User
 
Join Date: Oct 2009
Posts: 8
Quote:
Originally Posted by moyekj View Post
Perhaps if you guys request YouTube streaming capability then as a side effect you will get streambaby functionality back as well.

YouTube streaming has been requested many times in Australia. The official reply from the head of Hybrid (Tivo's AU/NZ company) is that YouTube are not willing to do a deal with Tivo for the AU/NZ market.
AussieMark is offline   Reply With Quote
Old 11-04-2009, 05:52 PM   #1666
t1c4l
Registered User
 
Join Date: Apr 2009
Posts: 15
Quote:
Originally Posted by AussieMark View Post
YouTube streaming has been requested many times in Australia. The official reply from the head of Hybrid (Tivo's AU/NZ company) is that YouTube are not willing to do a deal with Tivo for the AU/NZ market.
This is because TiVo in Australia is under license by Channel 7. Channel 7 have a long standing deal with Yahoo where Yahoo provides all their online services. YouTube is owned by Google so I see it being very difficult for Yahoo and Google to both go into the mix in Australia.

Quote:
I did some beta testing for TiVo Australia when it first started, I will try and contact someone there to see if they can point us in the right direction.
I've got an official reply from a TiVo representative I contacted this morning:

We're giving it a go to try and find out this information for you from TiVo Inc. We're right in the middle of preparations for launch, so I would wager a guess it won't be until next week that any remote form of answer will emerge. Will keep you posted and thanks for contacting us! We're really hoping to get Streambaby back online.

t1c4l is offline   Reply With Quote
Old 11-04-2009, 08:35 PM   #1667
AussieMark
Registered User
 
Join Date: Oct 2009
Posts: 8
Quote:
Originally Posted by t1c4l View Post
I've got an official reply from a TiVo representative I contacted this morning:

We're giving it a go to try and find out this information for you from TiVo Inc. We're right in the middle of preparations for launch, so I would wager a guess it won't be until next week that any remote form of answer will emerge. Will keep you posted and thanks for contacting us! We're really hoping to get Streambaby back online.
Was this from Tivo US or a Hybrid staff member in AU?
AussieMark is offline   Reply With Quote
Old 11-04-2009, 11:01 PM   #1668
Ink Noise
Registered User
 
Join Date: Jan 2005
Location: Santa Barbara, CA
Posts: 20
I'm having a similar issue that net had earlier relating to Java except on Linux.

When running the command to start the Streambaby script, an error is returned "./streambaby: line 3: java: command not found".

The content of the script to start is...

PHP Code:
#!/bin/bash
DIRNAME=`dirname $0`
java -Djava.net.preferIPv4Stack=true -Xmx256m -jar "$DIRNAME/jbin/streambaby.jar" $@ 
This of course, happened when I updated to Ubuntu 9.10 which I assume either updated, changed or moved Java. I'm just not sure how to update its location or the command to start the program.
Ink Noise is offline   Reply With Quote
Old 11-04-2009, 11:55 PM   #1669
t1c4l
Registered User
 
Join Date: Apr 2009
Posts: 15
Quote:
Originally Posted by AussieMark View Post
Was this from Tivo US or a Hybrid staff member in AU?
It was an AU staff member I dealt with during the Raptor beta testing stages. It was nice of her to reply. I wasn't expecting any reply
t1c4l is offline   Reply With Quote
Old 11-05-2009, 07:22 AM   #1670
windracer
joined the 10k club
 
windracer's Avatar
 
Join Date: Jan 2003
Location: St. Pete, FL
Posts: 11,239
Quote:
Originally Posted by Ink Noise View Post
When running the command to start the Streambaby script, an error is returned "./streambaby: line 3: java: command not found".

This of course, happened when I updated to Ubuntu 9.10 which I assume either updated, changed or moved Java. I'm just not sure how to update its location or the command to start the program.
Hmmm ... I upgraded my server to Karmic over the weekend and haven't had any problems. java is still under /usr/bin where it was before.

If you do a 'which java' at the command-line, it should show you were it is in the path. If it's not found, you might want to try re-installing java.
__________________
840~Roamio Pro (TA, MoCA) + two A92~Minis, 758~Premiere XL4 (TA, MoCA)
S/old: 746~S4, 658~HDXL, 648~OLED S3, 565~TX20, 230~S2, 140~S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
windracer is offline   Reply With Quote
Old 11-06-2009, 02:36 AM   #1671
pmd
Registered User
 
Join Date: Dec 2004
Posts: 32
Quote:
Originally Posted by t1c4l View Post
Looks like playing of raw mp4 files doesn't work.
The 'Push' feature still works OK, so the Aussie Tivo can *play* compatible h264 MP4 files - it's definitely just the streaming that's broken.

I tried using the raw.fmt method to stream back a .ts Program Stream I downloaded from the Tivo via the nowplaying webpage, but that doesn't work either.
pmd is offline   Reply With Quote
Old 11-06-2009, 05:09 AM   #1672
Ink Noise
Registered User
 
Join Date: Jan 2005
Location: Santa Barbara, CA
Posts: 20
Quote:
Originally Posted by windracer View Post
Hmmm ... I upgraded my server to Karmic over the weekend and haven't had any problems. java is still under /usr/bin where it was before.

If you do a 'which java' at the command-line, it should show you were it is in the path. If it's not found, you might want to try re-installing java.
That did it, thanks
Ink Noise is offline   Reply With Quote
Old 11-06-2009, 08:12 AM   #1673
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Aussie users, since .TiVo files are now supposedly in transport stream format for your systems there must be a different DirectShow filter as part of Tivo Desktop. Could you please attach the following file from your installation here in a zip file?:

C:\Program Files\Common Files\TiVo Shared\DirectShow\TiVoDirectShowFilter.dll
(or C:\Program Files (x86)\Common Files\TiVo Shared\DirectShow\TiVoDirectShowFilter.dll)
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-06-2009, 03:44 PM   #1674
angusj
Registered User
 
Join Date: Jul 2009
Location: Sydney
Posts: 5
Quote:
Originally Posted by moyekj View Post
Could you please attach the following file from your installation here in a zip file?
Sorry, can't do attachments (yet) but here's a mangled url ...
http[colon]//angusj.com/temp/tivodirectshowfilter.zip

HTHs
angusj is offline   Reply With Quote
Old 11-06-2009, 04:25 PM   #1675
dm_
Registered User
 
Join Date: Nov 2009
Posts: 19
The inbuilt webserver on my .au tivo allows you to download either a transport stream or a program stream. I can't remember if it did that before the update, but I don't think so (think it was PS only). Anyone else confirm/deny?
dm_ is offline   Reply With Quote
Old 11-06-2009, 06:24 PM   #1676
madimoo
Registered User
 
Join Date: Feb 2009
Posts: 10
Quote:
Originally Posted by dm_ View Post
Anyone else confirm/deny?
I think it started after the recent TiVo firmware update, not the TiVo desktop 2.8 update.
madimoo is offline   Reply With Quote
Old 11-06-2009, 06:32 PM   #1677
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Quote:
Originally Posted by dm_ View Post
The inbuilt webserver on my .au tivo allows you to download either a transport stream or a program stream. I can't remember if it did that before the update, but I don't think so (think it was PS only). Anyone else confirm/deny?
For USA systems the Tivo web server only shows PS version as a link. However, one is able to get the TS version by adding the following to the URL:
&System=ts
TS version downloads quite a bit faster than the PS version because it negates the need to remux into PS, so it would be great to use TS version if possible.
However, DirectShow filter is not able to play back the TS version from my experiments, and tivodecode can't handle it either. The TiVoDirectShowFilter.dll posted above is identical to the one I have. Perhaps if I install the latest TD 2.8 I will get a different one that may actually be able to handle the TS version. Will have to give that a shot.

I'm curious, if you download the TS version for Aussie Tivos are you able to play it back on your PC?
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-06-2009, 06:34 PM   #1678
madimoo
Registered User
 
Join Date: Feb 2009
Posts: 10
.
madimoo is offline   Reply With Quote
Old 11-06-2009, 06:52 PM   #1679
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Followup: Installed TD 2.8 and it didn't make any difference - I can't play .TiVo files downloaded as TS. They play all garbled in WMP. So now I'm really curious if Aussie users are able to play TS files via WMP?
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-06-2009, 07:02 PM   #1680
dm_
Registered User
 
Join Date: Nov 2009
Posts: 19
Ahh. Just discovered tivodecode chokes on the TS stream. I don't have tivodesktop installed anywhere so I can't test that right now (I'll try and remember to install it on the gaming box at some point and test - I don't normally use windows). Dumb question - can WMP normally handle TS files?
dm_ is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 11:03 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |