TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 05-12-2009, 08:15 AM   #1171
jcthorne
Registered User
 
Join Date: Jan 2002
Location: Houston
Posts: 1,868
Quote:
Originally Posted by BJezz View Post

I agree that imposing DRM restrictions on content streamed from our own machines is pointless, but at the same time I am always going to treat the PC copy as the master anyway, so it doesn't actually cause a problem for me. But I admit that even when I've downloaded free web videos through the TiVo, I've been puzzled as to why they are restricted when I can typically pull the same video through the web-site with no restrictions on it.
Are you guys referring to the copy restricition on files pushed to the tivo? This is not actually Tivo's doing. The copy restricted setting is selected by the application pushing the file, in this case pyTivo or Streambaby. Unforturnatly, the unducumented calls being used to implement the push came from trapping data exchange beteween tivo and the pc that happened to be copy restricted. There have been no unrestricted pushed media examples to capture and correct this since. Its a reverse engineering problem, not tivo doing evil DRM deals. The Tivo thinks the file being sent is requesting copy protection.
__________________
Current : Roamio Base with 2TB drive and 2 Premieres, OTA. kmttg, pyTivo, running with a Synology 1511 NAS....serving up the world.

Setup help for pytivo under windows:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jcthorne is offline   Reply With Quote
Old 05-13-2009, 04:30 PM   #1172
BJezz
Registered User
 
Join Date: Jan 2009
Posts: 68
That actually makes a lot more sense than it simply being the default position taken on all Internet downloads. I appreciate that the push uses technology not really meant for community development, though it would be great if TiVo did update their SDK. I also wonder why Internet shows are protected that are freely available to download anyway.

Actually to get more on topic, I've noticed a small bug with Streambaby. Go into a file with enough metadata to permit scrolling up/down to view it all. Then play the file. When you return from the video to the previous screen (i.e. the one with metadata at top and play/quality/push at the bottom) then the metadata is displayed twice at the top but overlayed on each other, one version you can scroll up and down and the other is fixed. If the two don't line up it is probably unreadable. If it makes a difference, this is on a series 3 in HD.

But excellent program so thank you! It is great to be able to stream things directly without having to transfer first. It's also great to be able to skip to a scene in a film without having to wait for the film to transfer first.
BJezz is offline   Reply With Quote
Old 05-13-2009, 04:53 PM   #1173
MighTiVo
TiVotarian
 
Join Date: Oct 2000
Location: Nashville, TN
Posts: 2,380
Quote:
Originally Posted by BJezz View Post
That actually makes a lot more sense than it simply being the default position taken on all Internet downloads. I appreciate that the push uses technology not really meant for community development, though it would be great if TiVo did update their SDK. I also wonder why Internet shows are protected that are freely available to download anyway.
Drives me nuts that I can not MRV the free VOD programs.
I would like to have a single TiVo configured to download and organize these programs then watch from any TiVo in the house instead of having them set up everywhere.
MighTiVo is offline   Reply With Quote
Old 05-13-2009, 05:00 PM   #1174
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by MighTiVo View Post
Drives me nuts that I can not MRV the free VOD programs.
I would like to have a single TiVo configured to download and organize these programs then watch from any TiVo in the house instead of having them set up everywhere.
Ah! Now I get it. I couldn't figure out why people cared in the least that a video they just pushed to their tivo *from* their PC was copy protected or not. They obviously already had a non-copy protected version.

Having only a single TiVo here, I never thought about possibly wanting to move it from the living room TiVo to the bedroom TiVo... (And if was mentioned before it went right over my head)

Having said that, there's not much we can do at the moment. The only examples of unprotected TivoCast videos I have seen mentioned (which we could use to reverse engineer) are now defunct (at least as far as transfer to TiVo goes...)
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 05-14-2009, 12:24 PM   #1175
txporter
One sec, almost done
 
Join Date: Sep 2006
Location: Austin, TX
Posts: 666
Quote:
Originally Posted by MighTiVo View Post
Drives me nuts that I can not MRV the free VOD programs.
I would like to have a single TiVo configured to download and organize these programs then watch from any TiVo in the house instead of having them set up everywhere.
While not a solution that everyone can use, I get around DRM protection by outputting my component video from my main TivoHD to a component amp/distribution box and send it to all of my other TVs. I can watch anything stored on my main TivoHD on any TV in my house regardless of whether or not it is protected. In case of recording conflicts, I record anything that cannot be transferred on my main HD and all of the network stuff on the other one.

Jason
__________________
Tivo Premiere 2TB WD20EARS (lifetime)
TivoHD 1TB WD10EACS + 1TB WD10EVCS Antec MX-1 (lifetime)
TivoHD 1TB WD10EACS (lifetime)
Series2 540 400GB Seagate DB35 (lifetime)
txporter is offline   Reply With Quote
Old 05-14-2009, 11:11 PM   #1176
trashjunkid
Registered User
 
Join Date: Jan 2009
Posts: 20
Great Application. Love the fast forwarding plus streaming capabilities- and the ability to play srt subtitles.


Two questions:
1) Can the font size of the closed captions/subtitles be increased. I have a 1080p tv, and the font is rather smallish. I have tried bumping up the font numbers in the meta-720.css file, and the meta-480.css for good measure, to no avail or obvious effect.

2) The subtitles work great with an external srt file, but I have DVD ISO's that play from a virtual drive (so VOB files) and it does not recognize/display the embedded captions there. Any possibility of getting the subtitles to display under these circumsatnces?

Thanks again- great application,
Trashjunkid
trashjunkid is offline   Reply With Quote
Old 05-14-2009, 11:20 PM   #1177
bkdtv
Registered User
 
Join Date: Jan 2003
Location: DC Metro Area
Posts: 7,902
Is MPG file playback limited to MPEG-2 on the TiVo?

Among PS3 users, the mkv2vob is a popular utility that will remux MKV videos into MPEG-4 MPGs. It has the option to automatically re-encode DTS tracks and 640Kbps DD tracks into 448Kbps DD.
bkdtv is offline   Reply With Quote
Old 05-15-2009, 12:19 AM   #1178
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by trashjunkid View Post
Great Application. Love the fast forwarding plus streaming capabilities- and the ability to play srt subtitles.


Two questions:
1) Can the font size of the closed captions/subtitles be increased. I have a 1080p tv, and the font is rather smallish. I have tried bumping up the font numbers in the meta-720.css file, and the meta-480.css for good measure, to no avail or obvious effect.

2) The subtitles work great with an external srt file, but I have DVD ISO's that play from a virtual drive (so VOB files) and it does not recognize/display the embedded captions there. Any possibility of getting the subtitles to display under these circumsatnces?

Thanks again- great application,
Trashjunkid
1) Put following in streambaby.ini
cc.fontsize=value
(value can be medium, small, tiny or an integer. small is default value)

2) Not supported, but you can pretty easily create srt files from VOB/mpeg files using t2extract.

P.S. Not all options are documented, but run streambaby --help to get full list of options.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-15-2009, 12:30 AM   #1179
trashjunkid
Registered User
 
Join Date: Jan 2009
Posts: 20
Hope Somebody's up:

I monkeyed around with the ini file, including specifying the ffmpeg path to a different version on my computer....

Anyway, something I did broke streambaby. I tried deleting and opening streambaby up again and it did not fix it.

Whenever I go to play a file I get an error on-screen: Resource unavailable.

(This all started because streambaby, as I installed it with the default settings, wasn't seeing or playing flv files.... so I added the extensions=....,flv and found that didn't do it, though the files did show up they did not play, and so set off to specify a different version of ffmpeg...)

I think it's not finding the right ffmpeg, but I don't know.

There is one error message on the cmd screen: "Unable to rename first-run script."

Help.

And thanks by the way- I look forward to bigger subtitles when I get streambaby unbroken.

-Trashjunkid

(I'm on windows vista, for what it's worth)
trashjunkid is offline   Reply With Quote
Old 05-15-2009, 12:56 AM   #1180
trashjunkid
Registered User
 
Join Date: Jan 2009
Posts: 20
Well, I ended up rebooting my computer and restarting the tivo. Between those two steps I got streambaby back again.

Still not sure why streambaby can't see/stream flv.
For future reference, what ffmpeg is downloaded by the automated script and where does it put the file? Is there a better more comprehensive ffmpeg I could be using?

-Trashjunkid
trashjunkid is offline   Reply With Quote
Old 05-15-2009, 01:28 AM   #1181
Kershek
Registered User
 
Join Date: Oct 2002
Location: Mesa, AZ
Posts: 122
Unfortunately, I still cannot see StreamBaby on my TiVo even though I'm running TiVo Desktop with no issues. Can anyone help? I posted debug information when requested on post #1104.
Kershek is offline   Reply With Quote
Old 05-15-2009, 07:15 AM   #1182
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
Hi,

I am having trouble with seeing my video files they are on my external L: Drive,

is this the correct Config File:

#
# ./streambaby --help for more configuration file options
#

#dir.1=L:\
#dir.1.name=\TIVO-RECORDINGS
#dir.2=L:\
#dir.2.name=L:\TIVO-RECORDINGS
# Ip address to bind to
# most people don't need to change this.
#ip=192.168.1.37
# port to use
#port=7290

Thanks for the help!!!
mphtrilogy is offline   Reply With Quote
Old 05-15-2009, 07:41 AM   #1183
trashjunkid
Registered User
 
Join Date: Jan 2009
Posts: 20
You've got to remove the # from the top of the lines that you've altered in order for them to be implemented.
Here's what your streambaby.ini ought to look like with your changed lines:

Code:
#
# ./streambaby --help for more configuration file options
#

dir.1=L:\
dir.1.name=\TIVO-RECORDINGS
dir.2=L:\ 
dir.2.name=L:\TIVO-RECORDINGS
# Ip address to bind to
# most people don't need to change this. 
#ip=192.168.1.37
# port to use
#port=7290

trashjunkid is offline   Reply With Quote
Old 05-15-2009, 09:14 AM   #1184
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by trashjunkid View Post
Well, I ended up rebooting my computer and restarting the tivo. Between those two steps I got streambaby back again.

Still not sure why streambaby can't see/stream flv.
For future reference, what ffmpeg is downloaded by the automated script and where does it put the file? Is there a better more comprehensive ffmpeg I could be using?

-Trashjunkid
In the streambaby.ini add:
extensions=mp4,mpeg,vob,mpg,mpeg2,mp2,avi,wmv,asf,mkv,tivo,m 4v,raw,3gp,mov,flv

This should enable streambaby to "see" FLV files. The above is also the default for latest SVN version of streambaby:
http://streambaby.googlecode.com/fil...y-svn-r235.zip

The ffmpeg downloaded is "ffmpeg-r15986-gpl-shared-win32.tar.bz2 " from the streambaby google-code site. (originally from the http://ffmpeg.arrozcru.org/builds/ web site)

It is downloaded into the native subdirectory of streamabby.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 05-15-2009, 09:22 AM   #1185
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by Kershek View Post
Unfortunately, I still cannot see StreamBaby on my TiVo even though I'm running TiVo Desktop with no issues. Can anyone help? I posted debug information when requested on post #1104.
Hi Kershek,

Everything looked pretty normal in the log, so I am really not sure. Do you have any routers/etc between your TiVo and the PC running streambaby? The most common cause for something like this is some device not passing the mDNS (bonjour/zeroconf) messages between the PC and the TiVo (not passing multicast packets). The problem with this theory is that I *think* TiVo Desktop would have similar issues if this was the problem.

Also, you may want to make sure you are using the latest SVN version of streambaby:
http://streambaby.googlecode.com/fil...y-svn-r235.zip
and make sure you are running it with the streambaby.bat file and not as a service. This version has some extra settings to disable IPV6 which can also cause problems with the TiVo finding streambaby.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 05-15-2009, 10:07 AM   #1186
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
Quote:
Originally Posted by trashjunkid View Post
You've got to remove the # from the top of the lines that you've altered in order for them to be implemented.
Here's what your streambaby.ini ought to look like with your changed lines:

Code:
#
# ./streambaby --help for more configuration file options
#

dir.1=L:\
dir.1.name=\TIVO-RECORDINGS
dir.2=L:\ 
dir.2.name=L:\TIVO-RECORDINGS
# Ip address to bind to
# most people don't need to change this. 
#ip=192.168.1.37
# port to use
#port=7290
Thank you very much it worked great!

I am raw with this stuff.
mphtrilogy is offline   Reply With Quote
Old 05-16-2009, 06:52 PM   #1187
jasa
Registered User
 
jasa's Avatar
 
Join Date: Nov 2008
Location: Earth
Posts: 23
just tried out new .27 work great thanks keary
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jasa is offline   Reply With Quote
Old 05-17-2009, 11:19 PM   #1188
BJezz
Registered User
 
Join Date: Jan 2009
Posts: 68
I've added OGM to my list of extensions and streamed videos without issue.
BJezz is offline   Reply With Quote
Old 05-19-2009, 12:30 AM   #1189
granroth
Registered User
 
Join Date: Jun 2002
Posts: 6
Question Acceptable range of "native" TiVo values?

I realize that streambaby checks the existing parameters of a given video file and if it determines that it is not natively playable by the TiVo, then it will transcode it. My question is this: What checks is streambaby doing, exactly? As in, what is the actual acceptable range of "native" values?

I ask because I cannot seem to find those values through trial and error. No matter how I encode my files (within the h.264 realm), it always ends up being transcoded while streaming. One of the tests included the Handbrake example on the streambaby wiki... and I still saw ffmpeg pegged at 100% CPU while streaming it. My processors apparently aren't fast enough to do this in real-time for an HD source and so I want to "pre-encode" them.

Charts? Tables? Links to source files? Anything will be appreciated.
granroth is offline   Reply With Quote
Old 05-19-2009, 07:39 PM   #1190
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by granroth View Post
I realize that streambaby checks the existing parameters of a given video file and if it determines that it is not natively playable by the TiVo, then it will transcode it. My question is this: What checks is streambaby doing, exactly? As in, what is the actual acceptable range of "native" values?

I ask because I cannot seem to find those values through trial and error. No matter how I encode my files (within the h.264 realm), it always ends up being transcoded while streaming. One of the tests included the Handbrake example on the streambaby wiki... and I still saw ffmpeg pegged at 100% CPU while streaming it. My processors apparently aren't fast enough to do this in real-time for an HD source and so I want to "pre-encode" them.

Charts? Tables? Links to source files? Anything will be appreciated.
The ffmpeg & handbrake samples given in the wiki page should produce natively streamable mp4 files if encoding from most common mpeg2 sources with AC3 audio. Maybe you should start with a video that is known to stream natively such as:
http://tivostream.googlecode.com/files/test.mp4
Try that out and see what happens in your environment.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-21-2009, 02:02 AM   #1191
pmd
Registered User
 
Join Date: Dec 2004
Posts: 32
Quote:
Originally Posted by kearygriffin View Post
And just to note, in streambaby there is an INI setting:
tivo.mind=
Which defaults to:
tivo.mind=mind.tivo.com:8181

Which points streambaby to the "mind" server to use.

Keary
Somewhat magically, MP4 push is now working on Australian TiVos, using the symind server I mentioned previously and wmcbrine's pyTivo (after changing mind.py).

But, it's not working in streambaby

I captured the network traffic to confirm that the config option is working properly - it's talking to symind.tivo.com - but the streambaby log says that the login failed. It's using the correct username and password.

There must have been some subtle change in porting the code from Python (perhaps a 'simplification' ;-) ). Is there a way to get more debug information about the push - like pyTivo's dumping of the XML it sends?
pmd is offline   Reply With Quote
Old 05-21-2009, 02:14 AM   #1192
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,859
Quote:
Originally Posted by pmd View Post
Is there a way to get more debug information about the push - like pyTivo's dumping of the XML it sends?
Enable debug mode as detailed in debugging_problems then examine/post the streambaby.log
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 05-21-2009, 05:10 AM   #1193
pmd
Registered User
 
Join Date: Dec 2004
Posts: 32
Quote:
Originally Posted by moyekj View Post
Enable debug mode as detailed in debugging_problems then examine/post the streambaby.log
Here's my log, running streambaby-0.27 on OS X 10.5.7 on an Australian TiVo HD with the networking package enabled:

Code:
05/21/09 19:25:11 StreamBabyConfig: WorkingDir: /Users/pauld/Downloads/streambaby-0.27
05/21/09 19:25:11 StreamBabyConfig: StreamBabyDir: /Users/pauld/Downloads/streambaby-0.27
05/21/09 19:25:11 StreamBabyConfig: CurDir: /Users/pauld/Downloads/streambaby-0.27
05/21/09 19:25:11 FFmpegJavaConfig$1: Loading avutil, default: avutil
05/21/09 19:25:11 FFmpegJavaConfig$1: Error attempting toload ffmpeg libraries: Unable to load library 'avutil': dlopen(libavutil.dylib, 1): image not found
05/21/09 19:25:11 FFmpegJavaVideoModule: Unable to load FFmpeg native libraries
05/21/09 19:25:11 FFmpegExeVideoModule: FFmpegPath: ffmpeg
05/21/09 19:25:11 FFmpegExeVideoModule: FFmpegExeModule: Loaded
05/21/09 19:25:11 StreamBabyMain: STARTING StreamBaby v0.27...
05/21/09 19:25:11 Main: args= start=true
05/21/09 19:25:11 Main: args= loader=sun.misc.Launcher$AppClassLoader@33056f
2009-05-21 19:25:12.139 java[2527:c0b] Can't open input server /Library/InputManagers/Smart Crash Reports
05/21/09 19:25:12 Listener: config=com.tivo.hme.host.util.Config@940b84 logger=com.unwiredappeal.tivo.utils.Log$ILoggerImpl@8041e0
05/21/09 19:25:12 Listener: factoryList=[StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]]
05/21/09 19:25:12 Listener: factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]
05/21/09 19:25:12 Listener: name=/streambaby/
05/21/09 19:25:12 Listener: 
05/21/09 19:25:12 Listener: added factory
05/21/09 19:25:12 Main: factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream]
05/21/09 19:25:12 Main: MDNS: http://192.168.1.2:7290/streambaby/
05/21/09 19:25:12 Main: streambaby ready & listening.
05/21/09 19:25:12 Main: mdns_type=_tivo-hme._tcp.local. factory=StreamBabyStreamFactory[/streambaby/,Stream, Baby, Stream] port=7290
05/21/09 19:25:17 TiVoListener: addService: DVR-21FD
05/21/09 19:25:17 TiVoListener: Updating service: _http._tcp.local. (DVR-21FD)
05/21/09 19:25:17 TiVoListener: resolveService: _http._tcp.local. (DVR-21FD)
05/21/09 19:25:17 TiVoListener: jmDns found TiVo: DVR-21FD, tsn: 6**********21FD
...
...
05/21/09 19:25:48 VideoModuleHelper: GetVidInfo: file:/Volumes/Store/Video/demnow.mp4
05/21/09 19:25:48 FFmpegExeVideoModule: FFmpegCmd: ffmpeg -i /Volumes/Store/Video/demnow.mp4
05/21/09 19:25:49 FFmpegExeVideoModule: ChannelStr to parse: stereo, s16
05/21/09 19:25:49 FFmpegExeVideoModule: VideoInfo:
uri: file:/Volumes/Store/Video/demnow.mp4, Container: mp4, Duration: 3545.15 seconds
Video: h264 320x240 14.98 fps
  PixAspect: 1.0, Aspect: 1.3333334
Audio: aac 32000HZ 0 channels
05/21/09 19:25:49 HostContext: key=mpos:file:/Volumes/Store/Video/demnow.mp4 applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
05/21/09 19:25:49 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
05/21/09 19:25:49 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
05/21/09 19:25:49 HostContext: compKey=6**********21FD-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
05/21/09 19:25:49 VideoModuleHelper: quality setting is above quality of video, streaming normally
05/21/09 19:25:49 HostContext: key=mpos:file:/Volumes/Store/Video/demnow.mp4 applicationId=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
05/21/09 19:25:49 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream applicationGlobal=false
05/21/09 19:25:49 HostContext: applicationIdStr=com.unwiredappeal.tivo.streambaby.StreamBabyStream
05/21/09 19:25:49 HostContext: compKey=6**********21FD-and-com.unwiredappeal.tivo.streambaby.StreamBabyStream
05/21/09 19:25:49 VideoModuleHelper: quality setting is above quality of video, streaming normally
05/21/09 19:25:52 ButtonScreen: action=down
05/21/09 19:25:53 ButtonScreen: action=down
05/21/09 19:25:56 ButtonScreen: code=6 rawcode=16778246
05/21/09 19:25:56 InternalPush: intPush: file:/Volumes/Store/Video/demnow.mp4, tivo: DVR-21FD
05/21/09 19:25:56 VideoModuleHelper: quality setting is above quality of video, streaming normally
05/21/09 19:25:57 InternalPush: Failed to login to tivo-push-control: user@mydomain.***, mypassword
05/21/09 19:25:57 PlayScreen$pushTivoButtonHandler$1: Push Failed: demnow.mp4->DVR-21FD
And here's the streambaby.ini I'm using:

Code:
#
# ./streambaby --help for more configuration file options
#

dir.1=/Volumes/Store/Video
dir.1.name=My Videos
#dir.2=/media/disk
#dir.2.name=External Drive
# Ip address to bind to
# most people don't need to change this. 
ip=192.168.1.2
# port to use
#port=7290

tivo.mind=symind.tivo.com:8181
tivo.username=user@mydomain.***
tivo.password=mypassword
When I choose Push to DVR-21FD, streambaby thinks for a second or so, then says 'Push failed'. As I said previously, pyTivo works OK using symind.tivo.com.

I think this will need more code to log the login transaction. Thanks for any help.
pmd is offline   Reply With Quote
Old 05-21-2009, 10:10 AM   #1194
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
Hi,

It seems to be working well, but all my videos stop midway through..

Any suggestions?
mphtrilogy is offline   Reply With Quote
Old 05-21-2009, 10:49 AM   #1195
BJezz
Registered User
 
Join Date: Jan 2009
Posts: 68
Do they stop completely, or do they pause for a few seconds with a rebuffering message, then carry on?

If it's the latter, it's currently unavoidable using this software as the TiVo has a fixed buffer size, so once it is full it will pause at the end of the buffer while it starts a new buffer running. To avoid this, you can use something like pyTivo to copy larger videos to the Now Playing List instead of streaming them. This way they are copied to the TiVo's hard disk and not subject to the buffer limitations.

If they stop completely we may need some more information. How long are the videos and how far do you get before they stop? What format are the videos in? You may also need to post your log files.
BJezz is offline   Reply With Quote
Old 05-21-2009, 10:54 AM   #1196
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
Quote:
Originally Posted by BJezz View Post
Do they stop completely, or do they pause for a few seconds with a rebuffering message, then carry on?

If it's the latter, it's currently unavoidable using this software as the TiVo has a fixed buffer size, so once it is full it will pause at the end of the buffer while it starts a new buffer running. To avoid this, you can use something like pyTivo to copy larger videos to the Now Playing List instead of streaming them. This way they are copied to the TiVo's hard disk and not subject to the buffer limitations.

If they stop completely we may need some more information. How long are the videos and how far do you get before they stop? What format are the videos in? You may also need to post your log files.

It's not a Buffer issue, they stop completely.

This is from the notepad of my last session:
05/15/09 11:22:34 Listener: added factory
05/15/09 11:22:34 Main: streambaby ready & listening.
05/15/09 11:22:36 Factory: HME receiver connected
05/15/09 11:23:36 Listener: 192.168.1.5 83c71053-32e9-4ec7-975e-6538f21c4865.stream HTTP GET - to factory /streambaby/
05/15/09 11:24:12 Listener: 192.168.1.5 I/O Exception handling HTTP GET 83c71053-32e9-4ec7-975e-6538f21c4865.stream: Connection reset by peer: socket write error
05/15/09 11:29:48 Listener: connection to receiver closed
05/15/09 11:29:48 Factory: HME receiver disconnected
05/15/09 12:30:39 Listener: 192.168.1.5 icon.png HTTP GET - to factory /streambaby/
05/15/09 12:30:44 Factory: HME receiver connected
05/15/09 12:32:19 Listener: 192.168.1.5 0f30b6bd-a58d-43d5-ae7c-f0c4f1b495b0.stream HTTP GET - to factory /streambaby/
05/15/09 12:42:33 Listener: 192.168.1.5 I/O Exception handling HTTP GET 0f30b6bd-a58d-43d5-ae7c-f0c4f1b495b0.stream: Connection reset by peer: socket write error
05/15/09 12:42:59 Listener: connection to receiver closed
05/15/09 12:42:59 Factory: HME receiver disconnected
05/15/09 12:43:03 Listener: 192.168.1.5 icon.png HTTP GET - to factory /streambaby/
05/15/09 17:04:48 Listener: 192.168.1.5 icon.png HTTP GET - to factory /streambaby/
05/15/09 17:05:01 Factory: HME receiver connected
05/15/09 17:06:39 Listener: 192.168.1.5 0757db4d-578f-475e-b88e-69126d60a39a.stream HTTP GET - to factory /streambaby/
05/15/09 17:26:11 Listener: 192.168.1.5 I/O Exception handling HTTP GET 0757db4d-578f-475e-b88e-69126d60a39a.stream: Connection reset by peer: socket write error
05/15/09 17:50:28 Listener: 192.168.1.5 658f922d-3c17-4ca8-8dc0-abec356461dc.stream HTTP GET - to factory /streambaby/
05/15/09 17:50:46 Listener: 192.168.1.5 I/O Exception handling HTTP GET 658f922d-3c17-4ca8-8dc0-abec356461dc.stream: Connection reset by peer: socket write error
05/15/09 17:51:20 Listener: 192.168.1.5 acde7637-6b54-4c71-897f-6f7f1a45f4be.stream HTTP GET - to factory /streambaby/
05/15/09 17:51:35 Listener: 192.168.1.5 I/O Exception handling HTTP GET acde7637-6b54-4c71-897f-6f7f1a45f4be.stream: Connection reset by peer: socket write error
05/15/09 17:51:54 Listener: 192.168.1.5 9c85faa8-6767-432e-a419-4f5ff36e9057.stream HTTP GET - to factory /streambaby/
05/15/09 18:12:01 Listener: 192.168.1.5 I/O Exception handling HTTP GET 9c85faa8-6767-432e-a419-4f5ff36e9057.stream: Connection reset by peer: socket write error
05/15/09 19:10:19 Listener: 192.168.1.5 0a4fb177-4250-4b65-9c9d-b6efdf596f29.stream HTTP GET - to factory /streambaby/
05/15/09 19:12:16 Listener: 192.168.1.5 I/O Exception handling HTTP GET 0a4fb177-4250-4b65-9c9d-b6efdf596f29.stream: Connection reset by peer: socket write error
05/15/09 19:12:16 Listener: 192.168.1.5 c8727d7a-1178-4a8f-8fd2-01020e58ce2d.stream HTTP GET - to factory /streambaby/
05/15/09 19:12:44 Listener: 192.168.1.5 I/O Exception handling HTTP GET c8727d7a-1178-4a8f-8fd2-01020e58ce2d.stream: Connection reset by peer: socket write error
05/15/09 19:12:45 Listener: 192.168.1.5 d71fa44d-9204-45db-9057-69c13ed6417a.stream HTTP GET - to factory /streambaby/
05/15/09 19:13:01 Listener: 192.168.1.5 I/O Exception handling HTTP GET d71fa44d-9204-45db-9057-69c13ed6417a.stream: Connection reset by peer: socket write error
05/15/09 19:13:16 Listener: 192.168.1.5 decad463-e6e7-4dd5-b482-e8b30fd0e8c9.stream HTTP GET - to factory /streambaby/
05/15/09 19:14:01 Listener: 192.168.1.5 I/O Exception handling HTTP GET decad463-e6e7-4dd5-b482-e8b30fd0e8c9.stream: Connection reset by peer: socket write error
05/15/09 19:14:02 Listener: 192.168.1.5 885fe81b-4f74-401e-b9e4-3f290b579644.stream HTTP GET - to factory /streambaby/
05/15/09 19:14:40 Listener: 192.168.1.5 I/O Exception handling HTTP GET 885fe81b-4f74-401e-b9e4-3f290b579644.stream: Connection reset by peer: socket write error
05/15/09 19:15:06 Listener: 192.168.1.5 08e4755d-daec-4b3d-baa7-5e85ebc77e69.stream HTTP GET - to factory /streambaby/
05/15/09 19:37:05 Listener: 192.168.1.5 I/O Exception handling HTTP GET 08e4755d-daec-4b3d-baa7-5e85ebc77e69.stream: Connection reset by peer: socket write error
05/15/09 19:48:49 Listener: connection to receiver closed
05/15/09 19:48:49 Factory: HME receiver disconnected
05/15/09 19:48:50 Listener: 192.168.1.5 icon.png HTTP GET - to factory /streambaby/
05/15/09 19:49:08 Listener: 192.168.1.5 icon.png HTTP GET - to factory /streambaby/
mphtrilogy is offline   Reply With Quote
Old 05-21-2009, 11:37 AM   #1197
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by mphtrilogy View Post
It's not a Buffer issue, they stop completely.
That looks very similar to an old bug related to timeouts that was fixed a few months ago. Which version of streambaby are you using? And are you using any network firewalls or is your router configured to reset connections after a while?
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Old 05-21-2009, 12:37 PM   #1198
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by pmd View Post
Somewhat magically, MP4 push is now working on Australian TiVos, using the symind server I mentioned previously and wmcbrine's pyTivo (after changing mind.py).

But, it's not working in streambaby
Could you try the new SVN version I just uploaded:
http://streambaby.googlecode.com/fil...y-svn-r237.zip

It seems that symind.tivo.com is using a self-signed SSL certificate so streambaby would reject the connection. I've added some code to accept self-signed SSL certificates.

I've also activated some more debugging that got lost when I was integrating moyekj's port of mind.java with streambaby.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
kearygriffin is offline   Reply With Quote
Old 05-21-2009, 12:39 PM   #1199
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
I'm using .25, I just noticed .27 is up, let me try that and see if it solves the issue

Thanks
mphtrilogy is offline   Reply With Quote
Old 05-21-2009, 01:33 PM   #1200
mphtrilogy
Registered User
 
Join Date: May 2007
Posts: 49
I just installed .27, and the problem still persists after about 1hour of standard def video.

You think its my router settings?

what should the router be set at?
mphtrilogy is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 05:43 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |