TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 02-05-2009, 07:44 PM   #361
windracer
joined the 10k club
 
windracer's Avatar
 
Join Date: Jan 2003
Location: St. Pete, FL
Posts: 11,197
Quote:
Originally Posted by bakerja View Post
I am considering this for space saving anyway. Any recomendations on an easy batch render app for windows?
I used WinFF, based on the instructions in this thread.
__________________
840~Roamio Pro (TA, MoCA) + two A92~Minis
S/old: 746~Premiere, 658~HDXL, 648~OLED S3, 565~TX20, 230~S2, 140~S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
windracer is offline   Reply With Quote
Old 02-05-2009, 08:39 PM   #362
cmontyburns
Excellent.
 
Join Date: Nov 2001
Location: Houston, TX
Posts: 8,843
Finally got around to trying out StreamBaby. Works well (although I haven't looked at getting it to load ffmpeg on my Mac yet) but I have the bigger problem that anytime I exit watching a video stream on my TiVoHD, the TiVo restarts itself.
cmontyburns is offline   Reply With Quote
Old 02-05-2009, 09:20 PM   #363
gilbreen
Registered User
 
Join Date: Sep 2007
Posts: 66
Just a note to thanks kearygriffin (and moyekj for tivostream and wmcbrine for HME/VLC Streamer) for StreamBaby. I have it installed on my Mac via pyTivoX (http://www.tivocommunity.com/tivo-vb...d.php?t=412802) that Yoav has developed which adds StreamBaby to his implementation of armoo's pyTivo program . As a former ReplayTV user, I have missed streaming media files to my TV versus copying the files.

StreamBaby brings to Tivo even greater functionality. Now, I can access our media library on our NAS and not worry about multiple copies of movies be transferred to the Tivo's hard drive when our kids watch one of their shows.

Thanks to all those involved!
gilbreen is offline   Reply With Quote
Old 02-06-2009, 12:17 AM   #364
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Hey Keary,
I just updated to the latest svn snapshot. streambaby shows up under the showcases menu, but as soon as I select it, I get "An error occured while running the application. HTTP failure (Http connection error: 0x50005)
I am attaching the log. There's some sort of java null pointer exception but it's not clear to me what's going on. Before trying to debug it i figured I'd ask in case it's something obvious:

update : looks like the null is because the 'selection screen' / direntry is trying to call "GetFilename" on itself, where filename is null... Lets see why ...
Attached Files
File Type: txt log.txt (11.2 KB, 10 views)
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by Yoav : 02-06-2009 at 12:32 AM.
Yoav is offline   Reply With Quote
Old 02-06-2009, 01:10 AM   #365
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by Yoav View Post
Hey Keary,
I just updated to the latest svn snapshot. streambaby shows up under the showcases menu, but as soon as I select it, I get "An error occured while running the application. HTTP failure (Http connection error: 0x50005)
I am attaching the log. There's some sort of java null pointer exception but it's not clear to me what's going on. Before trying to debug it i figured I'd ask in case it's something obvious:

update : looks like the null is because the 'selection screen' / direntry is trying to call "GetFilename" on itself, where filename is null... Lets see why ...
Thanks Yoav-- I had toplevel.skip=true in my INI which was hiding this problem.

I just pushed a new version that should fix it-- The new push also includes moyekj's closed captioning code.

Let me know how the new version does-- If it works OK I'll probably upload a new release this weekend.
kearygriffin is offline   Reply With Quote
Old 02-06-2009, 01:37 AM   #366
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by kearygriffin View Post
Thanks Yoav-- I had toplevel.skip=true in my INI which was hiding this problem.

I just pushed a new version that should fix it-- The new push also includes moyekj's closed captioning code.

Let me know how the new version does-- If it works OK I'll probably upload a new release this weekend.
Works like a charm. (I havent tested CC or anything.. I don't have subtitle videos)
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Old 02-07-2009, 09:11 AM   #367
rfryar
My Media, My Way
 
Join Date: Feb 2008
Location: Cottage Grove, MN
Posts: 199
This is a bit off topic but I thought this crowd would be the best place to ask this..

I want to convert my HD MPGs pulled off my tivos to MP4, but I want to retain the same resolution. Any suggestions? I heard about WinFF, but it does not have a good option to leave the resolution intact. So basically does anyone have a script for FFMPEG for this? Or another tool they recommend. I am on Windows XP BTW.

Thanks,

Rick
rfryar is offline   Reply With Quote
Old 02-07-2009, 10:57 AM   #368
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by rfryar View Post
This is a bit off topic but I thought this crowd would be the best place to ask this..

I want to convert my HD MPGs pulled off my tivos to MP4, but I want to retain the same resolution. Any suggestions? I heard about WinFF, but it does not have a good option to leave the resolution intact. So basically does anyone have a script for FFMPEG for this? Or another tool they recommend. I am on Windows XP BTW.

Thanks,

Rick
A few posts up in this thread I posted a ffmpeg recipe for converting to H.264 + audio copy (AC3):
http://www.tivocommunity.com/tivo-vb...11#post7049311
Resolution is preserved but it's up to you to determine bit rate. The one used in above recipe is perhaps too high at 8000k so if the goal is space savings you may want to reduce that a little.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-07-2009, 11:07 AM   #369
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by moyekj View Post
A few posts up in this thread I posted a ffmpeg recipe for converting to H.264 + audio copy (AC3):
http://www.tivocommunity.com/tivo-vb...11#post7049311
Resolution is preserved but it's up to you to determine bit rate. The one used in above recipe is perhaps too high at 8000k so if the goal is space savings you may want to reduce that a little.
With the recipe you post:
Code:
ffmpeg -y -i INPUTFILE -vcodec libx264 -coder 0 -level 31 -r 29.97 -sameq -g 300 -bufsize 14745k -b 8000k -maxrate 16000k -bug "+autodetect+ms" -me epzs -trellis 2 -mbd 1 -acodec copy -f mp4 OUTPUTFILE

I actually think if you just drop the "-b 8000k -maxrate 16000k" the script should convert to the same quality as the original, as I believe the -sameq (which is in your recipe) will tell ffmpeg to use whatever bitrate it needs to have the same quality as the original.

In fact I thought that when I tried it, having -sameq on the same line as bitrate rate parameters actually ended up overriding the bitrate parameters anyway.

Edit: I also think dropping the "-r 29.97" would be a good idea, as it will then preserve the frame rate of the original. (which is usally what you want I think)
kearygriffin is offline   Reply With Quote
Old 02-07-2009, 01:45 PM   #370
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
I just tried it on a short clip to confirm and indeed the bitrate argument does affect bitrate when used in conjunction with -sameq:
With -b 2000k my resulting encoding ends up as:
Size=8MB
Overall bit rate=2277 Kbps

With -b 8000k my resulting encoding from same source ends up as:
Size=29.7MB
Overall bit rate=8297 Kbps

For framerate from my experience something other than 29.97 fps doesn't always play nice on Tivo (but that may be for mpeg2 only) which is why I put that in.

P.S. I just tried same source mpeg encoding with only -sameq and dropping all bitrate parameters and result was:
Size=5.2MB
Overall bit rate=1156 Kbps

Playing back all 3 via streambaby it was clear that the higher bitrate encodings looked better with the -sameq only lowest bitrate encoding being the worst.

(source was a 1280x720p mpeg2 with 12 Mbps overall bitrate and size of 44MB)
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 02-07-2009 at 02:02 PM.
moyekj is offline   Reply With Quote
Old 02-07-2009, 02:35 PM   #371
kas25
Registered User
 
Join Date: Mar 2003
Location: NJ
Posts: 411
I just installed it via pytivox and my folders show up on the correct screen but when I try to open the folder i get frozen on the "Please Wait". Any help would be appreciated.
kas25 is offline   Reply With Quote
Old 02-07-2009, 03:28 PM   #372
windracer
joined the 10k club
 
windracer's Avatar
 
Join Date: Jan 2003
Location: St. Pete, FL
Posts: 11,197
Quote:
Originally Posted by Yoav View Post
your ffmpeg is linked statically to the ffmpeg libraries ( libavutil, libavcodec, etc are not listed as shared libraries to find -- ergo they are statically linked into the ffmpeg binary). you will need to get those shared libs from somewhere to make it work.
Well, I rebuilt ffmpeg yesterday using the latest SVN code and --enabled-shared. So now ffmpeg looks like this:
Code:
FFmpeg version SVN-r17019, Copyright (c) 2000-2009 Fabrice Bellard, et al.
  configuration: --prefix=/usr --enable-gpl --enable-postproc --enable-libvorbis --enable-libtheora --disable-debug --enable-libmp3lame --enable-libfaad --enable-libfaac --enable-pthreads --enable-libx264 --disable-ffplay --disable-ffserver --enable-libxvid --enable-shared
  libavutil     49.14. 0 / 49.14. 0
  libavcodec    52.13. 0 / 52.13. 0
  libavformat   52.25. 0 / 52.25. 0
  libavdevice   52. 1. 0 / 52. 1. 0
  libpostproc   51. 2. 0 / 51. 2. 0
  built on Feb  6 2009 08:58:52, gcc: 4.3.2
And it works! I get preview thumbnails during FF'ing now, sweet.

Of course, the ffmpeg binary is now a lot smaller since all the libraries aren't statically linked. I should have realized that the last time I built it.
__________________
840~Roamio Pro (TA, MoCA) + two A92~Minis
S/old: 746~Premiere, 658~HDXL, 648~OLED S3, 565~TX20, 230~S2, 140~S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
windracer is offline   Reply With Quote
Old 02-07-2009, 07:11 PM   #373
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by kas25 View Post
I just installed it via pytivox and my folders show up on the correct screen but when I try to open the folder i get frozen on the "Please Wait". Any help would be appreciated.
I replied in the pyTivoX thread already but will re-post here for benefit of others who may have "Please Wait" freezes with latest build from SVN:
With the latest streambaby build from SVN I was having this problem too. The solution is to put the following in tivostream.ini:
use.title=false
sort.filename=true
With those settings I think streambaby won't try and parse your video files upfront which is where it seems like it hangs up at times. I already notified Keary of problems I was having and those settings were what he recommended and worked for me.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-09-2009, 11:20 AM   #374
rfryar
My Media, My Way
 
Join Date: Feb 2008
Location: Cottage Grove, MN
Posts: 199
PyTivo style .txt file additions

Ok, now this is a bit rough around the edges.. Chalk that up to the fact I just started looking at the Tivo HME stuff today.

I have modified two files, the DirEntry.java and the PlayScreen.java.

Basically now when a file is loaded by DirEntry it will also load all the .txt entries into a Map. I updated DirEntry to also return the real title if it exists instead of the filename through the getStrippedFilename method. This will allow the real title to show up on all the selection screens instead of the filename.

The playScreen will show an optional image of the movie.. This is a new meta element in the .txt files:
img.cover : C:\\Share\\Movies\\Jokes\\EnronParty.png

The path needs to be Java escaped as this is a first draft effort on my part. The image will be reduced down to 150,150 and placed in the upper right corner of the playscreen.

Currently only the title, description, and movieYear, and the image are displayed. If I was to continue this development I would allow some sort of template approach to be used to layout the metainfo on the screen.

But I just wanted to throw this out there since I know others have started this effort and I do not want to step on anyone's toes.

Rick

The two Java files should be attached in a ZIP file.
Attached Images
File Type: jpg preview.jpg (71.0 KB, 31 views)
Attached Files
File Type: zip RawJavaUpdates.zip (7.6 KB, 1 views)

Last edited by rfryar : 02-09-2009 at 11:22 AM. Reason: Added screenshot
rfryar is offline   Reply With Quote
Old 02-09-2009, 11:45 AM   #375
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by rfryar View Post
Basically now when a file is loaded by DirEntry it will also load all the .txt entries into a Map. I updated DirEntry to also return the real title if it exists instead of the filename through the getStrippedFilename method. This will allow the real title to show up on all the selection screens instead of the filename.

The playScreen will show an optional image of the movie.. This is a new meta element in the .txt files:
img.cover : C:\\Share\\Movies\\Jokes\\EnronParty.png
Thanks rfryar, I'll try to take a look at this a bit later (just took a quick glance).

I haven't had time to put together documentation and upload a release (but the code is in SVN) to talk about the new metadata handling, but I think what you are looking for with your new code is already in streambaby (but may not be readily apparent, as it is partially disabled for performance reasons).

The titles should be read from the metadata and used in the selection screen if they are already cached. (They are always read when you select a movie and go to the selection screen). They are cached in one of two ways:
1) If you select a movie go to the "play" screen the metadata is read, displayed, and title cached. If you go back to the selection screen (immediately or anytime later, as it is cached on disk), then the real title will be displayed
2) Pressing the ENTER button while looking at the selection screen will read and cache (and redisplay) all of titles using the metadata.

You can also make streambaby use metadata even if it is not cached by setting:
use.title.cachedonly=false

The metadata is parsed using XSLT templates and has the ability to extract and display images. (However image display is only implemented currently for MP4 embedded thumbnails.)

To support your new img.cover tag, you would need to do the following:
1) Add the following line in the streambaby.ini:
xsl.pytivo=pytivo-html.xsl
(The default is pytivo-text.xsl which outputs the parsed metadata as pure text. Switching to pytivo-html.xsl outputs HTML which can contain images)
2) edit stylesheets/pytivo-html.xsl (or create a new xsl file and use the appropriate name in step 1) to parse the img.cover tag and output HTML containing the image. You can look at meta-html.xsl for an example, as it is the template for MP4 metadata and looks for the artwork tag and uses it as a thumbnail)

The XSL templates I provide are very basic (I'm no good with XSL) and need some work, so if anyone is willing to play around ;-)
kearygriffin is offline   Reply With Quote
Old 02-09-2009, 12:38 PM   #376
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Keary, is it possible to add a config entry for font size when in file browser mode? The default font size is too big for my liking resulting in few lines per screen and some long file names being truncated. Not a big deal but if it's easy enough to add would be appreciated. Thanks.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-09-2009, 12:42 PM   #377
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Does this mean that my .txt metadata files in the directories SHOULD be being used? I am using PyTivoX 1.1b14 that includes the changes at least up to and including the changes from moyekj on 2/7/2009?



I really hate that I cannot see the metadata when using streambaby!

TIA
jannlinder is offline   Reply With Quote
Old 02-09-2009, 01:15 PM   #378
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by jannlinder View Post
Does this mean that my .txt metadata files in the directories SHOULD be being used? I am using PyTivoX 1.1b14 that includes the changes at least up to and including the changes from moyekj on 2/7/2009?



I really hate that I cannot see the metadata when using streambaby!

TIA
I believe there are some streambaby.ini flags that need to be set for it to try using them? keary? I'm happy to turn those on if you tell me what

Right now I do add
Code:
use.title=false
sort.filename=true
(per moyekj) to work around some sort of bug that was causing stalling. That might turn off the metadata parsing... Can I take those lines out now?
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Old 02-09-2009, 01:22 PM   #379
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Yoav,

Did you get my PM about allowing us to add our own lines to the .ini file?

J
jannlinder is offline   Reply With Quote
Old 02-09-2009, 01:31 PM   #380
rfryar
My Media, My Way
 
Join Date: Feb 2008
Location: Cottage Grove, MN
Posts: 199
I did not see any my .txt files being loaded, although I did see the new enhancements in the SVN (My code was based on a pull from the SVN on Sunday night). But I did not see them being loaded until I put my own code in.

Regardless I would be happy with anything that allowed them to be used, so will look into the XSL approach.

What needs to be set in the ini to use this XSL metadata feature?

Thanks,

Rick
rfryar is offline   Reply With Quote
Old 02-09-2009, 01:35 PM   #381
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by Yoav View Post
I believe there are some streambaby.ini flags that need to be set for it to try using them? keary? I'm happy to turn those on if you tell me what

Right now I do add
Code:
use.title=false
sort.filename=true
(per moyekj) to work around some sort of bug that was causing stalling. That might turn off the metadata parsing... Can I take those lines out now?
As of last night's SVN it should be ok to leave out both of those INI settings. (It was definitely a good idea to have them before). Now it will only used meta-titles in the selection screen if the title has already has been cached. (It is cached via two mechanisms, either by selecting the movie, or by pressing the enter key on the remove when in the selection screen, which will generate meta-titles for all files in that directory).

I'm not sure which versions of streambaby people are using, but are people who are using SVN versions that need the above INI files at least seeing the metadata information when they select the movie to play (on the play screen) or when pressing the info button when playing? If not, I need to figure out why because even with those ini settings, that part of the metadata code should still be active.

EDIT: I just saw rfryar's message about not seeing the metadata, so I guess some people are having issues. I'll need to do some more testing tonight, but it should look for the metadata either as:
filename.ext.txt (in the same directory as the original file)
or
.meta/filename.ext.txt (so in a subdirectory of the directory the original file was in called .meta)

I've been testing 95% of the time with the files in the .meta directory, so it's possible I broke it for files that aren't in there. I'll need to check. It could also be many other things (linux vs windows line terminators, etc.) I'll post if I figure anything more out.
kearygriffin is offline   Reply With Quote
Old 02-09-2009, 01:39 PM   #382
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Quote:
Originally Posted by kearygriffin View Post
I'm not sure which versions of streambaby people are using, but are people who are using SVN versions that need the above INI files at least seeing the metadata information when they select the movie to play (on the play screen) or when pressing the info button when playing? If not, I need to figure out why because even with those ini settings, that part of the metadata code should still be active.
I saw no metadata with PyTivoX 1.1b10 but I never knew I had to press enter on the remote or whatever...

Is there a particular reason why? Is there a default we can add to ensure that we don't have to do that? I subdirectory-divide my TV by show then season...ie:

Reba
- Season 01
- Season 02

So there should not be enough .txt files to read that it should slow down StreamBaby by that much... (20-25 files max)

EDIT: My .txt are in the same dir as the original file. I do not use the .meta dir
J

Last edited by jannlinder : 02-09-2009 at 01:41 PM. Reason: Adding Location of .txt files
jannlinder is offline   Reply With Quote
Old 02-09-2009, 01:42 PM   #383
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
Quote:
Originally Posted by moyekj View Post
Keary, is it possible to add a config entry for font size when in file browser mode? The default font size is too big for my liking resulting in few lines per screen and some long file names being truncated. Not a big deal but if it's easy enough to add would be appreciated. Thanks.
This is definitely on the agenda, but I didn't find it quite so easy when I initially tried. I struggled a bit (I'd never used HME before streambaby) with hme/bananas/bananas-plus to get it to work. The issue wasn't the font (I can easily make the font smaller), but the selection bar and hint arrows.

I also at some people need to make streambaby work at higher resolutions. It's hard coded at 640x480 at the moment. Again, something I toyed with in the beginning but gave up and decided I would look at it in the future.
kearygriffin is offline   Reply With Quote
Old 02-09-2009, 02:22 PM   #384
Yoav
Registered User
 
Join Date: Jan 2007
Posts: 1,048
Quote:
Originally Posted by kearygriffin View Post
This is definitely on the agenda, but I didn't find it quite so easy when I initially tried. I struggled a bit (I'd never used HME before streambaby) with hme/bananas/bananas-plus to get it to work. The issue wasn't the font (I can easily make the font smaller), but the selection bar and hint arrows.

I also at some people need to make streambaby work at higher resolutions. It's hard coded at 640x480 at the moment. Again, something I toyed with in the beginning but gave up and decided I would look at it in the future.
+1 vote for higher resolution!!

Also, would it make sense to change the following defaults:
ffmpegexe.transcode.sameqargs=-sameq -ab 384k
quality.highestabr=384
quality.highres=1080

192 for audio is pretty low, and I suspect most HD's out there by now are 1080?
__________________
Don't pay for Tivo Desktop / Roxio on the mac:
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
and
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
.

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
Yoav is offline   Reply With Quote
Old 02-09-2009, 02:23 PM   #385
kearygriffin
Registered User
 
Join Date: Jan 2008
Posts: 346
re: Metadata

It looks like there are some problems under windows (not sure what it is yet). Depending on what the issue is, it could conceivably be a problem on the Mac also. I'll see what I can do an post when I push a new version to SVN.

And to jannlinder, once I get the issues worked out as to why metadata isn't working at for most people at the moment, setting this in your INI
use.title.cachedonly=false

Will tell streambaby to always parse the metadata so it can use the title on the selection screen.
kearygriffin is offline   Reply With Quote
Old 02-09-2009, 02:24 PM   #386
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Thx!



J
jannlinder is offline   Reply With Quote
Old 02-09-2009, 02:31 PM   #387
rfryar
My Media, My Way
 
Join Date: Feb 2008
Location: Cottage Grove, MN
Posts: 199
Quote:
Originally Posted by kearygriffin View Post
As of last night's SVN it should be ok to leave out both of those INI settings. (It was definitely a good idea to have them before). Now it will only used meta-titles in the selection screen if the title has already has been cached. (It is cached via two mechanisms, either by selecting the movie, or by pressing the enter key on the remove when in the selection screen, which will generate meta-titles for all files in that directory).
I can not get metadata to show up at all. I used the 20beta, as well as the code from the SVN from Sunday night. I have tried in the simulator of hitting "e", or "i" on the play screen. On my lastest SVN when hitting e on the selection screen I get an Array Index OUt Of Bounds exception:

02/09/09 14:30:12 Listener: Unexpected error: java.lang.ArrayIndexOutOfBoundsExc
eption: 0

Can you release another beta build just to ensure I have everything packaged correctly?

Thanks,
Rick.
rfryar is offline   Reply With Quote
Old 02-09-2009, 07:16 PM   #388
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Quote:
Originally Posted by rfryar View Post
I can not get metadata to show up at all.
Can you release another beta build just to ensure I have everything packaged correctly?

Thanks,
Rick.
I am now getting metadata from .txt file in the main dir (same dir as the file).

Knowing that the information is limited (as this is a beta) we are getting title and description so far.

I would LOVE to have all the logic that is available in the meta files to be used (as in: show the episode name if IsEpisode is true, etc)

Anyway, thanks to whomever implemented this feature.

PS: I love the black foreground with the blue surround around the text box. Nice touch.

Next thing i would love is that streambaby could pull titles from the files to display so we do not have to read the filename and guess what the file is (no, i dont expect miracles from betas...just hoping!!!)

J
jannlinder is offline   Reply With Quote
Old 02-09-2009, 07:22 PM   #389
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by jannlinder View Post
Next thing i would love is that streambaby could pull titles from the files to display so we do not have to read the filename and guess what the file is (no, i dont expect miracles from betas...just hoping!!!)

J
If you mean while in file browser mode I wouldn't want that, so perhaps it would have to be a config option. In some cases I have different encodings of same file name (same file name, different extensions) so I like to see full file name & extension in file browser to know which one I am playing back.
Also, some titles are too long which would not make for a nice visual while browsing.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 02-09-2009 at 07:31 PM.
moyekj is offline   Reply With Quote
Old 02-09-2009, 08:13 PM   #390
jannlinder
Registered User
 
Join Date: Oct 2004
Location: San Jose, CA
Posts: 106
Quote:
Originally Posted by moyekj View Post
If you mean while in file browser mode I wouldn't want that, so perhaps it would have to be a config option. In some cases I have different encodings of same file name (same file name, different extensions) so I like to see full file name & extension in file browser to know which one I am playing back.
Also, some titles are too long which would not make for a nice visual while browsing.
So, for instance browsing your library using PyTivoX is not good for you (just wondering cos this is the exact option I would LOVE for StreamBaby.

It will not pass the "Spouse Test" without this option (in my opinion).
jannlinder is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 07:54 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |