TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 02-02-2009, 11:37 AM   #481
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by jangelj View Post
moyekj,
So far I LOVE kmttg.

I want to put it on my wife's PC to have her shows archived/encoded for her mp4 player, and I'd like it on my PC to do the same for my shows. Do you know if the tivo will support connections from 2 PCs running kmttg at the same time? Not that they will always be downloading shows at the exact same time, but it could happen.

Thanks!
John
John, yes it should be no problem if you take care to avoid simultaneous downloads from same Tivos. Both can obtain listings from the Tivo at the same time for sure. As far as downloading more than 1 show at a time from same Tivo last I checked that generally does not work, however I think there have been instances where it sometimes does work so I can't say for sure if it's an issue as I haven't tried it lately. In any case that situation should be avoided (too much load for Tivo to handle) but the worse that can happen is one of the downloads will fail.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 02-02-2009 at 11:44 AM.
moyekj is offline   Reply With Quote
Old 02-02-2009, 06:06 PM   #482
jangelj
Registered User
 
Join Date: Oct 2002
Posts: 54
Thanks Yoav and Moyekj,
I'll just be sure to schedule kmttg's to run at different times to avoid simultaneous downloads.

John
jangelj is offline   Reply With Quote
Old 02-04-2009, 07:24 AM   #483
abnersnell
Registered User
 
Join Date: Mar 2002
Posts: 18
Quote:
Originally Posted by moyekj View Post
Had some discussions with Dan and we narrowed it down to an issue with VideoRedo not being able to run this function in service mode, however I don't think it's high on priority list to be resolved so I wouldn't expect a fix anytime soon. Perhaps if Dan is monitoring this thread he can comment further.
Just curious if this was ever resolved or if there was a workaround?

Thanks for a wonderful program!

Abner
abnersnell is offline   Reply With Quote
Old 02-04-2009, 09:36 AM   #484
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by abnersnell View Post
Just curious if this was ever resolved or if there was a workaround?

Thanks for a wonderful program!

Abner
Nope. It's really out of my hands at this point. One workaround which would probably work is to run kmttg as a repeated scheduled batch job instead of a service. ("perl kmttg.pl -b" runs a single auto download loop and then exits)
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-05-2009, 12:24 PM   #485
berkshires
Registered User
 
Join Date: Feb 2007
Posts: 440
Some requests:

1. In the config window pasting text over highlighted existing text appends instead of replaces.

2. Could you make the episode # 3 digits with leading 0's... ie. ep 3 is 003?

3. Could you make the file naming fields conditional; ie. if there is an episode number use this text plus the number in creating the name?

4. Could you make fields for original air date - this would make sorting a rerun series easier if it is run randomly by the network and has no episode #'s.
berkshires is offline   Reply With Quote
Old 02-07-2009, 12:48 PM   #486
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 57
apostrophes in program titles

Seems like there's a problem with kmttg when a program title contains an apostrophe... in the particular case I'm looking at, the title is:

Damages - I Agree, It Wasn't Funny

the curl command and the rest of the commands all try to handle the name:

Damages - I Agree, It Wasnt Funny

which of course doesn't work at all, as that's not what's on the TiVo.
ehagberg is offline   Reply With Quote
Old 02-07-2009, 01:31 PM   #487
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by ehagberg View Post
Seems like there's a problem with kmttg when a program title contains an apostrophe... in the particular case I'm looking at, the title is:

Damages - I Agree, It Wasn't Funny

the curl command and the rest of the commands all try to handle the name:

Damages - I Agree, It Wasnt Funny

which of course doesn't work at all, as that's not what's on the TiVo.
Dropping apostrophe is intentional, but everything still works since the apostrophe is dropped starting with the .TiVo file name. When downloading from Tivo it drops the apostrophe already if there is one in the name and from then on the other steps just use name without apostrophe. I have that title on one of my Tivos and just tried it to confirm. Here's from the console (I have download plus metadata enabled). Notice how the curl output file drops apostrophe and the metadata file also doesn't have apostrophe.

Damages - I Agree, It Wasn't Funny
Recorded Wed 2/4/2009 10:00 PM on 17=FXP, Duration = 61 mins
Patty begins to question Ellen's motives for returning to the firm; Patty tries to stop a corporate merger that she thinks is connected to Christine Purcell's murder.
>> CREATING C:\home\dvd\Damages - I Agree, It Wasnt Funny.mpg.txt ...
"c:\home\kmttg testing\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar "C:\Users\Kevin\AppData\Local\Temp\cookies3380" --url "https://192.168.1.101:443/TiVoVideoDetails?id=2467539" --output "C:\home\dvd\Damages - I Agree, It Wasnt Funny.mpg.txt_tmp"
--DONE--
>> DOWNLOADING c:\home\dvd\Damages - I Agree, It Wasnt Funny.TiVo ...
"c:\home\kmttg testing\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar "C:\Users\Kevin\AppData\Local\Temp\cookies3380" --url "http://192.168.1.101:80/download/Damages.TiVo?Container=%2FNowPlaying&id=2467539" --output "c:\home\dvd\Damages - I Agree, It Wasnt Funny.TiVo"
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-07-2009, 02:51 PM   #488
AudioNutz
Registered User
 
Join Date: Nov 2008
Posts: 289
Good catch.

I've also noticed issues with shows that have other special characters in their titles, like the $ dollar sign character. It seems to download the .TiVo file, but it truncates the name, and the remaining steps don't know what the new truncated name is.
AudioNutz is offline   Reply With Quote
Old 02-07-2009, 03:30 PM   #489
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 57
Quote:
Originally Posted by moyekj View Post
Dropping apostrophe is intentional, but everything still works since the apostrophe is dropped starting with the .TiVo file name. When downloading from Tivo it drops the apostrophe already if there is one in the name and from then on the other steps just use name without apostrophe. I have that title on one of my Tivos and just tried it to confirm. Here's from the console (I have download plus metadata enabled). Notice how the curl output file drops apostrophe and the metadata file also doesn't have apostrophe.

Damages - I Agree, It Wasn't Funny
Recorded Wed 2/4/2009 10:00 PM on 17=FXP, Duration = 61 mins
Patty begins to question Ellen's motives for returning to the firm; Patty tries to stop a corporate merger that she thinks is connected to Christine Purcell's murder.
>> CREATING C:\home\dvd\Damages - I Agree, It Wasnt Funny.mpg.txt ...
"c:\home\kmttg testing\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar "C:\Users\Kevin\AppData\Local\Temp\cookies3380" --url "https://192.168.1.101:443/TiVoVideoDetails?id=2467539" --output "C:\home\dvd\Damages - I Agree, It Wasnt Funny.mpg.txt_tmp"
--DONE--
>> DOWNLOADING c:\home\dvd\Damages - I Agree, It Wasnt Funny.TiVo ...
"c:\home\kmttg testing\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar "C:\Users\Kevin\AppData\Local\Temp\cookies3380" --url "http://192.168.1.101:80/download/Damages.TiVo?Container=%2FNowPlaying&id=2467539" --output "c:\home\dvd\Damages - I Agree, It Wasnt Funny.TiVo"
In my case it didn't work, as the download failed:

>> DOWNLOADING I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.TiVo ...
"C:\Documents and Settings\Eric.TALTOS\Desktop\kmttg\curl\curl.exe" --retry 3 --anyauth --user tivo:MAK --insecure --cookie-jar "C:\DOCUME~1\ERIC~1.TAL\LOCALS~1\Temp\cookies1756" --url "http://192.168.1.5:80/download/Damages.TiVo?Container=%2FNowPlaying&id=468054" --output "I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.TiVo"
I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.TiVo size=0.00 MB elapsed=00:00:02 (0.00 Mbps)
--DONE--
>> DECRYPTING I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.TiVo ...
"C:\Documents and Settings\Eric.TALTOS\Desktop\kmttg\tivodecode\tivodecode.exe " --mak MAK --out "I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.mpg" "I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.TiVo"
I:\kmttg\Damages - I Agree, It Wasnt Funny_Wed_Feb_04.mpg size=0.00 MB elapsed=00:00:00 (0.00 Mbps)
*ERROR* tivodecode failed (exit code: 9) - check above C:\Documents and Settings\Eric.TALTOS\Desktop\kmttg\tivodecode\tivodecode.exe command
read chunk data: No error
seek: No error
Encryption by QUALCOMM

Perhaps something else went wrong, but 4 other shows (one before and 3 after) worked fine all as part of the same batch. Only the Damages download failed.

Running it again alone, the download seems to be going fine.
ehagberg is offline   Reply With Quote
Old 02-07-2009, 03:42 PM   #490
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Something else must have happened as the console shows it was done with size 0 and it happened very quickly. Since download is working now I guess problem solved.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-07-2009, 03:45 PM   #491
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by AudioNutz View Post
Good catch.

I've also noticed issues with shows that have other special characters in their titles, like the $ dollar sign character. It seems to download the .TiVo file, but it truncates the name, and the remaining steps don't know what the new truncated name is.
I already have a bunch of special characters that can cause problems taken care of including:
/ * " ' : ; ! ? & \
I could see where $ may cause a problem so should probably add it to the list.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-08-2009, 10:03 AM   #492
jlbarr
Registered User
 
Join Date: Mar 2008
Posts: 2
When having auto transfer do a quick fix or encode after download it is failing. Processing the same file through the gui however completes normally. Anyone else having this trouble?
jlbarr is offline   Reply With Quote
Old 02-08-2009, 10:21 AM   #493
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by jlbarr View Post
When having auto transfer do a quick fix or encode after download it is failing. Processing the same file through the gui however completes normally. Anyone else having this trouble?
Yes, it's a known issue with VRD that VRD QuickStream Fix doesn't run in service mode - look up starting at post 483 for given workaround.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-08-2009, 09:04 PM   #494
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by berkshires View Post
Some requests:

1. In the config window pasting text over highlighted existing text appends instead of replaces.

2. Could you make the episode # 3 digits with leading 0's... ie. ep 3 is 003?

3. Could you make the file naming fields conditional; ie. if there is an episode number use this text plus the number in creating the name?

4. Could you make fields for original air date - this would make sorting a rerun series easier if it is run randomly by the network and has no episode #'s.
1. Don't know how to get Perl Tk to do that easily. Hit backspace to delete selection and then do the paste as a workaround.
2. Made change for next release
3. Not sure what you want. If you have [EpisodeNumber] as part of your File Naming template then it will put the number there if available, empty string if not.
4. Original air date is only available in extended details for a show which requires additional html calls for each individual show to obtain, so it's really not practical to make a bunch of extra calls to gather extended details for each show when gathering Tivo playlist (would slow down the process a lot).
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-09-2009, 03:02 PM   #495
berkshires
Registered User
 
Join Date: Feb 2007
Posts: 440
Quote:
Originally Posted by moyekj View Post
1. Don't know how to get Perl Tk to do that easily. Hit backspace to delete selection and then do the paste as a workaround.
2. Made change for next release
3. Not sure what you want. If you have [EpisodeNumber] as part of your File Naming template then it will put the number there if available, empty string if not.
4. Original air date is only available in extended details for a show which requires additional html calls for each individual show to obtain, so it's really not practical to make a bunch of extra calls to gather extended details for each show when gathering Tivo playlist (would slow down the process a lot).
For 3 I am looking for text conditional on a field being non-NULL, ie. Star Trek ep# 003 - The Corbomite Maneuver ... "ep#" needs to be conditional upon [EpisodeNumber] not being NULL.

Thanks for 2
berkshires is offline   Reply With Quote
Old 02-12-2009, 06:18 PM   #496
nvt
Registered User
 
Join Date: Aug 2003
Location: MD
Posts: 58
Love the program and works well except encoding
Run it with Comskip and Comcut and then select encode using the iPod Hi and Low res options
Both produce an encoded file but the audio gets out of synch. I can take the output from the comcut and encode using anther tool (Videora) and no synch problem
I'd appreciate any thoughts/feedback
nvt is offline   Reply With Quote
Old 02-12-2009, 06:40 PM   #497
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by nvt View Post
Love the program and works well except encoding
Run it with Comskip and Comcut and then select encode using the iPod Hi and Low res options
Both produce an encoded file but the audio gets out of synch. I can take the output from the comcut and encode using anther tool (Videora) and no synch problem
I'd appreciate any thoughts/feedback
Running the source mpeg2 file through VideoRedo before encoding sometimes fixes the sync issue introduced following an encode. If Videora has batch capabilities then you can setup your own encoding profile in kmttg using it instead of ffmpeg. Consult the kmttg documentation or the existing .enc files under encode folder as examples of how to set it up, or list how to do it batch mode with Videora and I can create a .enc file for you.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-12-2009, 07:41 PM   #498
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by berkshires View Post
For 3 I am looking for text conditional on a field being non-NULL, ie. Star Trek ep# 003 - The Corbomite Maneuver ... "ep#" needs to be conditional upon [EpisodeNumber] not being NULL.

Thanks for 2
I'll need to think about this some more as it can get complicated depending what you are asking for. Without thinking too much about it yet I'm thinking something generic like [xxx=keyword] means include xxx only if keyword exists. So in your example to achieve what you want then you would have the following as part of the file name template:
[ep#=EpisodeNumber][EpisodeNumber]
Hence for above you would get something like "ep#101" if EpisodeNumber exists and you would get empty string otherwise. Of course these things always sound easier in English than in a program so I'll have to see how easy that would be to implement, but before I bother is that the kind of thing you are looking for?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-13-2009, 09:58 AM   #499
berkshires
Registered User
 
Join Date: Feb 2007
Posts: 440
Yes. How about making the format ["TEXT1" EpisodeNumber "TEXT2"] so TEXT1, TEXT2 and the episode number would only appear if there is an episode number...you already make the field conditional on its existence I believe...so then you could make the whole thing conditional altogether.

"TEXT1" and "TEXT2" params would be optional, so [EpisodeNumber] would still work as it always has.
berkshires is offline   Reply With Quote
Old 02-14-2009, 08:13 PM   #500
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by berkshires View Post
Yes. How about making the format ["TEXT1" EpisodeNumber "TEXT2"] so TEXT1, TEXT2 and the episode number would only appear if there is an episode number...you already make the field conditional on its existence I believe...so then you could make the whole thing conditional altogether.

"TEXT1" and "TEXT2" params would be optional, so [EpisodeNumber] would still work as it always has.
OK, I've got a working prototype of this and probably will release an update with this enhancement tomorrow (along with some other fixes).
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-15-2009, 10:22 AM   #501
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 57
I've now seen the behavior - twice - where a show isn't downloaded, but it appears that curl and kmttg think that all's fine and the program tries to do further operations on the truncated (I believe it's either zero-length or very small) file, which of course fail.

I've only ever seen this happen when doing a batch of something like 5 or 7 shows all at once, and selecting all checkboxes except for metadata and encode. And I'm using VRD.

Unfortunately, I don't have the truncated/zero length files to inspect and see whether there's a good indication of what went wrong when curl attempted to download.

I also had a case this morning, while trying to reproduce this problem, where the downloads from the TiVo all worked, but when kmttg went to run adcut, it got this error:

>> CUTTING COMMERCIALS IN I:\kmttg\CSI Crime Scene Investigation - Deep Fried and Minty Fresh_Thu_Feb_12.mpg ...
"C:\WINXP\system32\cscript.exe" //nologo "C:\Program Files\VideoReDoPlus\\vp.vbs" "I:\kmttg\CSI Crime Scene Investigation - Deep Fried and Minty Fresh_Thu_Feb_12.VPrj" "I:\kmttg\CSI Crime Scene Investigation - Deep Fried and Minty Fresh_Thu_Feb_12_cut.mpg" /t1 /d /q /na
*ERROR* adcut failed (exit code: 3) - check above command
*ERROR* video file not given or non-existent: I:\kmttg\CSI Crime Scene Investigation - Deep Fried and Minty Fresh_Thu_Feb_12_cut.mpg

even though the source file to generate the *_cut.mpg and the .VPrj file were both there, and worked fine when I re-ran the same command against the files by hand.
ehagberg is offline   Reply With Quote
Old 02-15-2009, 10:41 AM   #502
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
ehagberg, if you go to FILES mode in kmttg and repeat just the comcut step again starting with the same .mpg file do you get the same error again?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-15-2009, 10:49 AM   #503
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
new version posted

------------------
v0.5i (02/15/2009)
------------------
ENHANCEMENTS
* Added capbility for advanced, conditional keywords in file naming template.
Thus for example one can now define something like:
[mainTitle]["_Ep#" EpisodeNumber]_[wday]_[month]_[mday]
In this example "_Ep#xxx" will be included in file name only if EpisodeNumber
exists, otherwise "_Ep#" is not included in the file name.
Consult the html documentation for more details.

FIXES
* Remove special character '$' for file names originating from Tivos.
Files with that character got truncated in steps subsequent to download
leading to problems.
* Ensure Episode Number is always 3 digits.
* For metadata creation no longer include episodeTitle as part of title since
the metadata parsing issue has now been fixed in recent versions of pyTivo.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-15-2009, 11:52 AM   #504
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 57
Quote:
Originally Posted by moyekj View Post
ehagberg, if you go to FILES mode in kmttg and repeat just the comcut step again starting with the same .mpg file do you get the same error again?
Starting with the same file, it works just fine.

As far as the failing downloads from the TiVo, I got another one to happen and this time checked the content of the file. It has this:

<h2>Bad Request</h2>
Unable to initialize videomgr pipeline: err 0x1d0012

So it appears that something goes wrong, but curl doesn't realize it and kmttg is only checking for "html" "busy" or "failed" in that file to detect failure. Of course, even if "bad request" were checked for, it would only allow the failure to be detected and wouldn't cause a retry, so I'd still be re-running the download again and wondering why it doesn't "just work."
ehagberg is offline   Reply With Quote
Old 02-15-2009, 12:58 PM   #505
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
I very rarely get a failure to download. If you are getting that problem frequently perhaps a Tivo reboot is in order if you have not already tried that.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-20-2009, 07:42 PM   #506
nvt
Registered User
 
Join Date: Aug 2003
Location: MD
Posts: 58
Quote:
Originally Posted by moyekj View Post
Running the source mpeg2 file through VideoRedo before encoding sometimes fixes the sync issue introduced following an encode. If Videora has batch capabilities then you can setup your own encoding profile in kmttg using it instead of ffmpeg. Consult the kmttg documentation or the existing .enc files under encode folder as examples of how to set it up, or list how to do it batch mode with Videora and I can create a .enc file for you.
Thanks for the feedback....it turns out that Videora uses ffmpeg...so creating a batch file is based around this tool
This forum thread had a suggested batch file
http://www.redkawa.com/forums/showthread.php?t=4246
But this was directed at VOB files

If I understand how this works I am using the same tool in kmttg as in Videora just a different interface so they should both produce the same result assuming version etc are the same?
nvt is offline   Reply With Quote
Old 02-20-2009, 07:59 PM   #507
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by nvt View Post
Thanks for the feedback....it turns out that Videora uses ffmpeg...so creating a batch file is based around this tool
This forum thread had a suggested batch file
http://www.redkawa.com/forums/showthread.php?t=4246
But this was directed at VOB files

If I understand how this works I am using the same tool in kmttg as in Videora just a different interface so they should both produce the same result assuming version etc are the same?
Then it could just be a matter of the particular ffmpeg version being used. Note that you can configure path to ffmpeg in kmttg so you can grab the ffmpeg.exe used by Videora. It could also be the particular encoding arguments which make a difference. If you can find out the particular ffmpeg recipe used by Videora that's working for you then it would be trivial to create a .enc file for kmttg that does the same.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-21-2009, 02:44 PM   #508
jadekitten
Registered User
 
Join Date: Feb 2009
Posts: 4
i am about as new at this as i can possibly be but can i setup encoding to divx/xvid? also i'd like to say thanks cuz galleon refuses to see my tivo, but kmttg does, if anyone knows why let me know, i put my gateway into dmz so it isn't that, also it seems the outputted mpg file is still only 480x480 which is why i hate tivo desktop, can i set it higher somehow?

Last edited by jadekitten : 02-21-2009 at 03:11 PM.
jadekitten is offline   Reply With Quote
Old 02-21-2009, 05:02 PM   #509
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,014
Quote:
Originally Posted by jadekitten View Post
i am about as new at this as i can possibly be but can i setup encoding to divx/xvid? also i'd like to say thanks cuz galleon refuses to see my tivo, but kmttg does, if anyone knows why let me know, i put my gateway into dmz so it isn't that, also it seems the outputted mpg file is still only 480x480 which is why i hate tivo desktop, can i set it higher somehow?
The ipod_high_res encoding profile is 640x480 xvid 1500 Kbps video with aac audio. If that's not good enough quality you can make a copy of ipod_hig_res.enc to a different name ending in .enc and change the resolution (-s 640x480) and the bitrate (-b 1500k). Then next time you start kmttg your encoding name will show up in the list.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-21-2009, 05:08 PM   #510
jadekitten
Registered User
 
Join Date: Feb 2009
Posts: 4
that's perfect thianks
jadekitten is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 01:36 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |