TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Home Media Features & TiVoToGo
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 10-28-2008, 04:57 PM   #361
menos
Registered User
 
Join Date: Nov 2007
Location: Moore, OK
Posts: 60
I think I may have figured it out. When the service is running its current directory is set to windows\system32. For all of the commands that use relative paths, those will fail. We may need to call the commands using their full path. For example I changed the following line in tivostream_hd.enc and it seems to work.
Code:
PERL tivo_mp4_encode.pl -h FFMPEG INPUT OUTPUT
to
Code:
PERL "c:\program files\kmttg\tivo_mp4_encode.pl" -h FFMPEG INPUT OUTPUT
Now I'm getting an error trying to run qt-faststart, but I think the problem is similar. I'm gonna look at that next.
menos is offline   Reply With Quote
Old 10-28-2008, 06:22 PM   #362
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by menos View Post
I think I may have figured it out. When the service is running its current directory is set to windows\system32. For all of the commands that use relative paths, those will fail. We may need to call the commands using their full path. For example I changed the following line in tivostream_hd.enc and it seems to work.
Code:
PERL tivo_mp4_encode.pl -h FFMPEG INPUT OUTPUT
to
Code:
PERL "c:\program files\kmttg\tivo_mp4_encode.pl" -h FFMPEG INPUT OUTPUT
Now I'm getting an error trying to run qt-faststart, but I think the problem is similar. I'm gonna look at that next.
Sorry I didn't replay earlier but yes that is the problem. In next version I've already added another keyword called PWD in the tivostream encoding templates which gets replaced with appropriate full path so this will no longer be an issue. Will probably be a few days until next release however as I'm tied up with my real job lately.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-29-2008, 09:04 PM   #363
menos
Registered User
 
Join Date: Nov 2007
Location: Moore, OK
Posts: 60
Crap.. For some reason I'm running about a 50-75% failure rate on ffmpeg encodes. This is the error I'm seeing in the auto.log. I'm also getting a windows application crash.

Code:
Wed 10/29/2008 08:37 PM >> ENCODING TO FILE G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4 ...
Wed 10/29/2008 08:37 PM "C:\Perl\bin\perl.exe" "c:\program files\kmttg\tivo_mp4_encode.pl" "C:\Program Files\kmttg\ffmpeg\ffmpeg.exe" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-I Want Cake.mpg" "G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4"
Wed 10/29/2008 08:44 PM G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4 size=160.52 MB elapsed=00:07:21 (3.05 Mbps)
Wed 10/29/2008 08:44 PM *ERROR* encoder failed (exit code: 255) - check above C:\Perl\bin\perl.exe command
Wed 10/29/2008 08:44 PM *ERROR* command failed: "C:\Program Files\kmttg\ffmpeg\ffmpeg.exe" -y -i "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-I Want Cake.mpg" -v 0 -vcodec libx264 -coder 0 -level 31 -r 29.97 -sameq -g 300 -bufsize 14745k -b 2000k -maxrate 16000k -bug "+autodetect+ms" -me epzs -trellis 2 -mbd 1 -acodec copy -f mp4 "G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4"

menos is offline   Reply With Quote
Old 10-29-2008, 09:27 PM   #364
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by menos View Post
Crap.. For some reason I'm running about a 50-75% failure rate on ffmpeg encodes. This is the error I'm seeing in the auto.log. I'm also getting a windows application crash.

Code:
Wed 10/29/2008 08:37 PM >> ENCODING TO FILE G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4 ...
Wed 10/29/2008 08:37 PM "C:\Perl\bin\perl.exe" "c:\program files\kmttg\tivo_mp4_encode.pl" "C:\Program Files\kmttg\ffmpeg\ffmpeg.exe" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-I Want Cake.mpg" "G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4"
Wed 10/29/2008 08:44 PM G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4 size=160.52 MB elapsed=00:07:21 (3.05 Mbps)
Wed 10/29/2008 08:44 PM *ERROR* encoder failed (exit code: 255) - check above C:\Perl\bin\perl.exe command
Wed 10/29/2008 08:44 PM *ERROR* command failed: "C:\Program Files\kmttg\ffmpeg\ffmpeg.exe" -y -i "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-I Want Cake.mpg" -v 0 -vcodec libx264 -coder 0 -level 31 -r 29.97 -sameq -g 300 -bufsize 14745k -b 2000k -maxrate 16000k -bug "+autodetect+ms" -me epzs -trellis 2 -mbd 1 -acodec copy -f mp4 "G:\tivo_tv\Sid the Science Kid/Sid the Science Kid-I Want Cake.mp4"
To get more details on the failure bring up kmttg in GUI mode, select FILES mode and add the above .mpg and then setup the encode. Once it starts running select the job in job monitor and then "ctrl-s" on keyboard will bring up a window with ffmpeg output. This will allow you to see full details of the ffmpeg output and associated error messages.

Or perhaps easier, run the above ffmpeg command directly from a CMD window.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-29-2008, 09:45 PM   #365
menos
Registered User
 
Join Date: Nov 2007
Location: Moore, OK
Posts: 60
These are the last few lines in the output before the crash. I've set -v to 3 trying to get as much info as possible.

Code:
[libx264 @ 003EFC90]frame=15916 QP=28.41 NAL=2 Slice:P Poc:390 I:95  P:707  SKIP:518  size=8675 bytes SSIM Y:0.94434
[libx264 @ 003EFC90]frame=15917 QP=27.63 NAL=2 Slice:P Poc:392 I:995  :107  SKIP:218  size=27788 bytes SSIM Y:0.96117
[libx264 @ 003EFC90]frame=15918 QP=27.70 NAL=2 Slice:P Poc:394 I:182 P:625  SKIP:513  size=16558 bytes SSIM Y:0.95208
[libx264 @ 003EFC90]frame=15919 QP=28.07 NAL=2 Slice:P Poc:396 I:214  :658  SKIP:448  size=18829 bytes SSIM Y:0.95080
[libx264 @ 003EFC90]frame=15920 QP=27.19 NAL=2 Slice:P Poc:398 I:168 P:751  SKIP:401  size=12077 bytes SSIM Y:0.95314
[libx264 @ 003EFC90]frame=15921 QP=29.32 NAL=2 Slice:P Poc:400 I:152 P:806  SKIP:362  size=12733 bytes SSIM Y:0.95211
[libx264 @ 003EFC90]frame=15922 QP=28.14 NAL=2 Slice:P Poc:402 I:212 P:726  SKIP:382  size=14339 bytes SSIM Y:0.95263
timestamp discontinuity -64000, new offset= 88214611
I'm getting the timestamp discontinuity error all over the place though, not just right before it dies.
menos is offline   Reply With Quote
Old 10-29-2008, 11:37 PM   #366
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by menos View Post
These are the last few lines in the output before the crash. I've set -v to 3 trying to get as much info as possible.

Code:
[libx264 @ 003EFC90]frame=15916 QP=28.41 NAL=2 Slice:P Poc:390 I:95  P:707  SKIP:518  size=8675 bytes SSIM Y:0.94434
[libx264 @ 003EFC90]frame=15917 QP=27.63 NAL=2 Slice:P Poc:392 I:995  :107  SKIP:218  size=27788 bytes SSIM Y:0.96117
[libx264 @ 003EFC90]frame=15918 QP=27.70 NAL=2 Slice:P Poc:394 I:182 P:625  SKIP:513  size=16558 bytes SSIM Y:0.95208
[libx264 @ 003EFC90]frame=15919 QP=28.07 NAL=2 Slice:P Poc:396 I:214  :658  SKIP:448  size=18829 bytes SSIM Y:0.95080
[libx264 @ 003EFC90]frame=15920 QP=27.19 NAL=2 Slice:P Poc:398 I:168 P:751  SKIP:401  size=12077 bytes SSIM Y:0.95314
[libx264 @ 003EFC90]frame=15921 QP=29.32 NAL=2 Slice:P Poc:400 I:152 P:806  SKIP:362  size=12733 bytes SSIM Y:0.95211
[libx264 @ 003EFC90]frame=15922 QP=28.14 NAL=2 Slice:P Poc:402 I:212 P:726  SKIP:382  size=14339 bytes SSIM Y:0.95263
timestamp discontinuity -64000, new offset= 88214611
I'm getting the timestamp discontinuity error all over the place though, not just right before it dies.
If you haven't already you should run the .mpg file through VideoRedo QuickStream fix before trying to encode it.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-29-2008, 11:58 PM   #367
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Awesome news for streaming fans - streaming from Netflix coming soon:
http://www.engadget.com/2008/10/30/n...oming-to-tivo/

Best part is no additional fees assuming you have at least $8.99/m plan from Netflix. This will certainly make me re-subscribe to Netflix.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 10-30-2008, 08:49 PM   #368
menos
Registered User
 
Join Date: Nov 2007
Location: Moore, OK
Posts: 60
OK.. If I run the file through quickstream fix it seems to fix it. However, I can't get the quickstream fix to run under the service. If I paste that exact command into a command prompt, it runs. But it won't when called from the service.

Code:
Thu 10/30/2008 07:52 PM "C:\WINDOWS\system32\cscript.exe" //nologo "C:\Program Files\VideoReDoTVSuite\vp.vbs" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-My Shrinking Shoes.mpg" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-My Shrinking Shoes.mpg.qsfix" /t1 /d /q /na
Thu 10/30/2008 07:55 PM *ERROR* qsfix failed (exit code: 0) - check above qsfix command
Thu 10/30/2008 07:55 PM C:\Program Files\VideoReDoTVSuite\vp.vbs(45, 2) WScript.CreateObject: Could not create object named "VideoReDo.VideoReDoSilent".

Grrrr... Almost there....
menos is offline   Reply With Quote
Old 10-30-2008, 11:53 PM   #369
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by menos View Post
OK.. If I run the file through quickstream fix it seems to fix it. However, I can't get the quickstream fix to run under the service. If I paste that exact command into a command prompt, it runs. But it won't when called from the service.

Code:
Thu 10/30/2008 07:52 PM "C:\WINDOWS\system32\cscript.exe" //nologo "C:\Program Files\VideoReDoTVSuite\vp.vbs" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-My Shrinking Shoes.mpg" "C:\Program Files\kmttg\temp\Sid the Science Kid/Sid the Science Kid-My Shrinking Shoes.mpg.qsfix" /t1 /d /q /na
Thu 10/30/2008 07:55 PM *ERROR* qsfix failed (exit code: 0) - check above qsfix command
Thu 10/30/2008 07:55 PM C:\Program Files\VideoReDoTVSuite\vp.vbs(45, 2) WScript.CreateObject: Could not create object named "VideoReDo.VideoReDoSilent".

Grrrr... Almost there....
Don't worry about the auto mode and path related problems for the tivostream encoding profiles. I will be fixing those to use full paths so those problems cannot arise in next release. However I've been extremely busy with my real job lately so may be a few more days before I get the next released finished.

For the QSFix not running in service mode, I had the exact same problem but not sure how to deal with it. If you select "Run in GUI" option then it works fine. Only as a service the QSFix will not run for some reason... I'll send a PM to Dan to see if he knows a fix for it.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-03-2008, 12:56 PM   #370
tpintsch
Registered User
 
Join Date: Mar 2008
Posts: 3
thank you

First, I wanted to post a thank you for such a great program. It does everything I want it to do.

Over the past weekend I ran into a problem trying to transfer videos from my Tivo Series 3. The video transfer from the tivo would crawl, after 10 minutes I got 3 megabytes down.

I tried everything, rebooting the computer, rebooting the tivo and the router, what fixed it for me was running both the computer running kmttg and the tivo through the same switch.

I have a 28 port 10/100 and an 8 port 10/100/1000. Since the computer has gigabit and the tivo does not, I have the two switches uplinked and the tivo was in the 10/100 and the kmttg machine was in the gigabit. Hooking them together on the gigabit made all of the difference which leads me to believe that the Tivo does not like having two switches or more between it and the TTG computer and itself.

Has anyone else experienced this?

Thanks,

tim.
tpintsch is offline   Reply With Quote
Old 11-03-2008, 02:12 PM   #371
Philipp5
Registered User
 
Join Date: Mar 2008
Posts: 19
I've got the Tivo connected to a 4 port 10/100 which in turn connects to my Verizon Fios router. The PC running kmttg is connected to the Fios router. Kmttg works great. Awesome program & THANK YOU Moyekj!
Philipp5 is offline   Reply With Quote
Old 11-03-2008, 02:16 PM   #372
tpintsch
Registered User
 
Join Date: Mar 2008
Posts: 3
Wow Phil, That is most interesting indeed. I wonder if I installed a second network card in my windows box for 10/100 and set the kmttg for that if it was just the Gigabit Switch that was doing it. I am pretty sure the Verizon routers are also 10/100.

I'm not home and not in front of it right now, but I think on a separate network card, kmttg can be used exclusively for that network card. Just thinking out loud, I really don't want to use any more of my precious Gigabit links then I have to.

Thanks,

tim.
tpintsch is offline   Reply With Quote
Old 11-08-2008, 07:24 PM   #373
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
new release

------------------
v0.5e (11/08/2008)
------------------
ENHANCEMENTS:
* Added option to check for low disk space (user can specify min desired space).
Option is disabled by default but can be enabled under configuration.
With option enabled, jobs will not run if there is not sufficient disk
space available according to specified minimum.
* Forward slash in show name replaced with underscore to avoid undesired
sub-folders.
* In auto transfer mode .TiVo files are now not re-downloaded if they already
exist in destination dir.

FIXES:
* tivostream profiles changed to use full paths instead of relative paths
such that they still work if running in windows service mode.
This change affected files under encode directory and tivo_mp4_encode.pl
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-15-2008, 12:55 PM   #374
bluraven
Registered User
 
Join Date: Dec 2005
Posts: 10
This script looks like it's exactly what I need for what I want to setup on my home network. Thanks for your hard work on this. I've read through every post in this thread and all the documentation. I have a question though. I'd like to set it up to auto-download every single show on the tivo and cut commercials, re-encode etc, not just my favorite shows. Does the auto-download feature accept a wildcard (*) for title and can download everything automatically? Would there be a way to have it delete the shows on the PC server when it notices they are no longer on the tivo? Even better, have it set an amount of days of when to delete from the computer after it has been deleted from the tivo? Also, does anyone have good encoder settings for high quality and small file size for playback on a wireless network with windows media player?

Thanks
bluraven is offline   Reply With Quote
Old 11-15-2008, 01:21 PM   #375
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by bluraven View Post
This script looks like it's exactly what I need for what I want to setup on my home network. Thanks for your hard work on this. I've read through every post in this thread and all the documentation. I have a question though. I'd like to set it up to auto-download every single show on the tivo and cut commercials, re-encode etc, not just my favorite shows. Does the auto-download feature accept a wildcard (*) for title and can download everything automatically? Would there be a way to have it delete the shows on the PC server when it notices they are no longer on the tivo? Even better, have it set an amount of days of when to delete from the computer after it has been deleted from the tivo? Also, does anyone have good encoder settings for high quality and small file size for playback on a wireless network with windows media player?

Thanks
If you setup a title match with keywords set to .* this will match all titles.

There is no option for deleting titles on your computer not on the Tivo(s). That seems a little dangerous to me. Note that kmttg will not re-download .TiVo files already present on your PC.

h264_med_rate profile is probably a good choice for good quality encoding while keeping a relatively small file size (compared to mpeg2).
EDIT: h264_med_rate profile will keep audio as AC3 and many players still can't handle H.264 video & AC3 audio. So if you want something that plays with Windows Media Player you should pick the ps3 or xbox360 profiles which use AAC audio.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 11-15-2008 at 02:27 PM.
moyekj is offline   Reply With Quote
Old 11-15-2008, 03:25 PM   #376
bluraven
Registered User
 
Join Date: Dec 2005
Posts: 10
I'll try that, thank you so much for the quick reply
bluraven is offline   Reply With Quote
Old 11-20-2008, 01:01 AM   #377
AudioNutz
Registered User
 
Join Date: Nov 2008
Posts: 273
Quote:
Originally Posted by Tim Winders View Post
...Nothing to discover. Can't seem to get Tk working in perl. I guess it wasn't meant to be. Need to clean up my system and try again another day.

Will have to stick with kmttg on a Windows box.

Hopefully I helped someone (not waste their time) and if anyone gets it up and going on Mac OS X, they can post specific steps to do so...
Tim,
After reading all of your trials and testing, I was able to get this to work on a Macintosh. Don't give up now...

I'm not sure if my "word" is enough proof, so see the screenshot below showing time and date. If you're still interested, I could document the process of getting KMTTG to work on a Mac if anyone wants, but I received 100% of the information in this tread. (And the links posted in this thread)

I'm not a programmer, just an average Joe fooling around with Perl, X11, and Tk-804.028...


AudioNutz is online now   Reply With Quote
Old 11-20-2008, 01:07 AM   #378
AudioNutz
Registered User
 
Join Date: Nov 2008
Posts: 273
Disclaimer: I have not tested every single feature on the Mac...
AudioNutz is online now   Reply With Quote
Old 11-20-2008, 01:41 AM   #379
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
New release

------------------
v0.5f (11/19/2008)
------------------
ENHANCEMENTS:
* Added percentage complete for ffmpeg encodes (previously only time was displayed)

FIXES:
* Auto transfers were not working properly with cached data
* Fixed problem with auto run in GUI with cached data
* In auto transfers configuration GUI the list type & keywords fields were
not updated when using UPDATE button to change type or keywords
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-20-2008, 09:50 AM   #380
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
AudioNutz, great work on getting things going on Mac. I think a summary of steps to get things working would be great and perhaps something I can include in documentation and/or website. Also, perhaps a zip package of the 3rd party binaries would be helpful as well?
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-20-2008, 07:02 PM   #381
AudioNutz
Registered User
 
Join Date: Nov 2008
Posts: 273
moyekj,
Go ahead and add this to your documentation: (If you would like to give me credit for this part of your docs, I'm ok with that too.)

MACINTOSH INSTALLATION INSTRUCTIONS
1. INSTALL XCODE TOOLS
The Tk module for the Perl GUI will need the X11 environment to be compiled, installed, and executed. Locate your Mac OS X installation DVD, and install the XCode Tools.

2. INSTALL PERL (ONLY IF NEEDED)
Most Macs with “Tiger” (Mac OS X 10.4.x) or “Leopard” (Mac OS X 10.5.x) already have Perl 5.8.x installed, so you can skip to the part below where you install the Tk module

Kmttg is written in Perl and uses the Tk module for GUI. Perl versions 5.8.x is confirmed to work as long as you have the proper Tk module.
Note that Macintosh ActivePerl version does not include Tk module by default and therefore requires more work to install – see details below.

If by some miracle your Macintosh does not have Perl installed:
http://www.activestate.com/Products/activeperl/
Click on Get ActivePerl
Click on Download by free download version
Click on Continue
For 5.8.x version (on right side) scroll down and find the relevant installation file for your system
Download and install on your system. NOTE: This step can vary depending on your system so is not documented here.
INSTALLING Tk MODULE USING Terminal and X11
http://search.cpan.org/~ni-s/Tk-804.027/
If you are using Safari, make sure that your browser is not set to “Open safe files after downloading.
Download the latest release.
Move the Tk-804.028.tar.gz to your /System/Library/Perl/lib folder I suppose you can put it anywhere you like. I just put it here to keep things tidy.
Change permissions of this folder, so that you have rights to install software here. (Make a note as to what the permissions were, as you will want to change them back later)
Open a Terminal window, and execute the following commands: (May differ if you’ve changed the install location)
BUILD EXAMPLE
cd /System/Library/Perl/lib
tar -zxvpf Tk-804.028.tar.gz
cd Tk-804.028
perl Makefile.PL
make
Now go to your “Utilities” folder on your Hard Drive, and open an X11 window.
In the X11 window, type the following commands :
Cd /System/Library/Perl/lib/Tk-804.028
make test
(Stand back and watch this happen)
sudo make install
Perl and Tk are now ready. Change the permissions for “/System/Library/Perl/lib” back to what they were when you began. (This step may not be necessary, but I like to keep my Mac tidy)

STARTING KMTTG
Macintosh
Simplest way to run:
perl path/kmttg.pl
BUILD AND INSTALL 3rd PARTY TOOLS
Macintosh is exactly the same as Linux instructions that are already published.
AudioNutz is online now   Reply With Quote
Old 11-20-2008, 07:51 PM   #382
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Thanks AudioNut. I added an html document with your instructions (with credit given to you) to the Google project area.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 11-21-2008, 09:26 AM   #383
kevinmtu
Registered User
 
Join Date: Sep 2008
Posts: 4
Thanks AudioNutz for the Mac instructions! I will give it a try on my Mac later today and let you know how it goes.
kevinmtu is offline   Reply With Quote
Old 11-22-2008, 02:27 AM   #384
AudioNutz
Registered User
 
Join Date: Nov 2008
Posts: 273
UPDATE on the Mac instructions...

Mac OS X 10.5.x (Leopard) is working great, but I haven't been able to get mencoder to play nice with comskip with Mac OS X 10.4.x (Tiger)

If anyone would like to volunteer a (working with comskip) version of mencoder, I would appreciate it...
AudioNutz is online now   Reply With Quote
Old 11-27-2008, 11:04 AM   #385
bigbopper
Registered User
 
Join Date: Feb 2005
Posts: 19
Fyi WinXP SP3

I installed kmttg v0p5f and ActivePerl 5.10 and could not get kmttg to launch. I SUSPECT the problem to be that ActivePerl 5.10 installed Tkx, not TK. I uninstalled AP5.10 and installed AP5.8.8, which installed Tk. Bingo, kmttg launched on the first try.
bigbopper is offline   Reply With Quote
Old 12-02-2008, 09:01 PM   #386
citivolus
Registered User
 
Join Date: Jul 2002
Posts: 93
Quote:
Originally Posted by moyekj View Post
For the QSFix not running in service mode, I had the exact same problem but not sure how to deal with it. If you select "Run in GUI" option then it works fine. Only as a service the QSFix will not run for some reason... I'll send a PM to Dan to see if he knows a fix for it.
just want to say that I too am having this exact problem and am eagerly awaiting a fix!

great program btw!
citivolus is offline   Reply With Quote
Old 12-02-2008, 11:45 PM   #387
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by citivolus View Post
just want to say that I too am having this exact problem and am eagerly awaiting a fix!

great program btw!
Had some discussions with Dan and we narrowed it down to an issue with VideoRedo not being able to run this function in service mode, however I don't think it's high on priority list to be resolved so I wouldn't expect a fix anytime soon. Perhaps if Dan is monitoring this thread he can comment further.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 12-05-2008, 06:20 AM   #388
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 53
closed caption extraction?

Any chance adding closed caption data extraction to kmttg has been considered?

t2sami can do it, but with all the automated functionality already integrated in kmttg, it would get that last step done all at once, rather than leaving another manual piece to the video download/commercial-cut/re-encode process.
ehagberg is offline   Reply With Quote
Old 12-05-2008, 07:38 AM   #389
ehagberg
Registered User
 
Join Date: Dec 2004
Location: Montclair, NJ
Posts: 53
comcut failure on some HD shows

So far I've only seen this when trying to cut commercials from "Chuck" and not other HD shows (though I've not tried this on too many other HD shows), but it consistently fails at the comcut stage with this error:

I:\kmttg\Chuck - Chuck Versus the Sensei_Mon_Dec_01_cut.mpg size=66.22 MB elapsed=00:01:00 (9.26 Mbps)
*ERROR* comcut failed (exit code: 5) - check above C:\Documents and Settings\Eric.TALTOS\Desktop\kmttg\mencoder\mencoder.exe command
Using SSE optimized IMDCT transform
Using MMX optimized resampler
Limiting audio preload to 0.4s.
Increasing audio density to 4.

1 duplicate frame(s)!
(...snip...)

The error window then fills with thousands of errors, mostly of the "1 duplicate frame(s)" type, though occasionally with messages like "ERROR: scr 0.556, dts 0.000, pts 0.300" or "Warning! FPS changed 23.976 -> 29.970 (-5.994005) [4]".

The original 1-hour show takes 5.something Gb. Eventually the comcut bit fails with:

Couldn't realloc frame buffer(idx), abort


PARSE_MPEG12: add_frames(69108) failed, exit

And leaves just 67Mb or so in the cut file.

Anyone else have this sort of problem?
ehagberg is offline   Reply With Quote
Old 12-05-2008, 09:58 AM   #390
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 8,499
Quote:
Originally Posted by ehagberg View Post
Any chance adding closed caption data extraction to kmttg has been considered?

t2sami can do it, but with all the automated functionality already integrated in kmttg, it would get that last step done all at once, rather than leaving another manual piece to the video download/commercial-cut/re-encode process.
If there is a batch tool that can do it starting from a .mpg or .TiVo file then it should be possible. If you can supply an example of how to do it I can look into it.
__________________
Roamio Pro (GigE)
Elite (MoCA)
Premiere (MoCA adapter)
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVo® is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 01:01 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |