TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Stream
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 07-20-2014, 05:23 PM   #1
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
An unknown error occured

Was on vacation far from home the last 2 weeks so got ample opportunities to try OOH streaming. Must say it got very annoying at times. I got this infamous error more times than I care to count:
Problem Streaming
An unknown error occured.

What makes it more annoying is right after getting the error I'd go back and start stream right away again and it would continue without issue for a while but then eventually give me the error again.
Also, most of the time the video quality was only 2 or 3 bars giving me a fuzzy picture. Switching to Slingbox using the same connection would give me much better picture quality after letting the stream buffer for 30 seconds or so. But using Slingbox trick play to skip commercials was very annoying as well due to the latency involved, but at least the Slingbox was reliable in terms of connection and video quality unlike the Stream.

So overall I was quite disappointed with OOH Stream and glad I had Slingbox available as an alternative. I wish my experience had been more favorable but there you have it. I could almost tolerate/forgive the fuzzy picture over shaky connections, but the "Unknown error" made it unbearable.

P.S. I did also try using downloads instead of streaming on a couple of occasions, however the download speeds @medium quality were < 1 Mbps and estimated download time for a 1 hour show was on the order of 1.5 hours, so that wasn't really practical.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.

Last edited by moyekj : 07-20-2014 at 05:28 PM.
moyekj is offline   Reply With Quote
Old 07-21-2014, 09:48 AM   #2
Bulldawg9908
Registered User
 
Join Date: Feb 2011
Posts: 46
I share your frustrations.

I don't have an answer for the "unknown error occurred" issue as I have the same problem and haven't figured out what triggers it, but I know why streaming quality is so poor and why downloading when out of the home is so painful.

All OOH streaming and downloading goes through a TiVo proxy server which limits bandwidth to less than 2 Mb/s. This bandwidth isn't adequate for Stream to do on-the-fly encoding and give you a good quality picture. I've e-mailed TiVo about why they do it this way and they've blown me off saying it's not a bug and they're not going to do anything about it.

I've got 60 Mb/s down where I usually stream from and a steady 20 Mb/s up at home, so I should be able to stream and download anything I want at high quality and not notice that I'm not home, but because TiVo insists on all traffic going through their proxy servers, we're stuck with this mess.

Needless to say, I'm unhappy with this situation, but there is little I can do to change it. TiVo is ignoring me, and short of becoming TiVoMargaret's most annoying follower on Twitter, I can't get their attention on this issue.
Bulldawg9908 is offline   Reply With Quote
Old 07-21-2014, 01:55 PM   #3
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
Yes, I know all about the proxy and the ~1.85 Mbps limit on OOH download speeds as documented in the More detailed HLS statistics thread. I actually would have been happy to get 1.8 Mbps, but was getting < 1 Mbps which made it even worse.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-23-2014, 03:37 PM   #4
MacBrian
Registered User
 
MacBrian's Avatar
 
Join Date: Feb 2002
Location: Kansas
Posts: 83
Quote:
Originally Posted by moyekj View Post
An unknown error occured.
SAME error here -- just as often at home within my own wifi as outside my network.

I've applied all sorts of voodoo -- rebooting the iOS device (iPad 2 or iPhone 5s), restarting the TiVo Stream both by unplugging and restarting at the Stream's web page, and restarting the wireless services on my AT&T 2-Wire router. I also have a Netgear Extender which occasionally gets the same voodoo-reboot treatment.

Nothing is consistent. Some days the experience between iOS and the TiVo Stream is unbearably frustrating, and on other days there's rarely a problem. I've played with using different wireless "channels" and that was inconclusive as well.

During all of this, my Slingbox Solo is able to provide a MUCH more reliable experience...as long as I can tolerate the poor audio "in-a-tin-can" sound.

I share your frustration. Wish we could come up with a stable alternative. My next stab at resolving the inconsistent performance is to shut down the AT&T 2-Wire router's WIFI and use a brand new Apple Airport Extreme 6th Gen that I have sitting in a box waiting for some free time to install it. Maybe THAT will make a better experience???
__________________
2011: First Tivo Premiere (Ethernet)
2012: Second Tivo Premiere (Ethernet)
2012 Tivo Stream
2011 Slingbox Solo
Series 2 Humax DRT800 (Still in use for VHS->DVD)
Series 1 Philips (Retired)
MacBrian is offline   Reply With Quote
Old 07-23-2014, 04:50 PM   #5
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,095
For in home use I never seem to get this problem, but I'm usually situated very close to wireless router and thus have solid connection from iPad to wireless router. Looks to me like the Stream is not very robust and tolerant of network glitches which are especially common in public WiFi connections.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 07-23-2014, 05:02 PM   #6
MacBrian
Registered User
 
MacBrian's Avatar
 
Join Date: Feb 2002
Location: Kansas
Posts: 83
Quote:
Originally Posted by moyekj View Post
For in home use I never seem to get this problem

<sigh>

I'm usually within 20' of my wifi router at home...
__________________
2011: First Tivo Premiere (Ethernet)
2012: Second Tivo Premiere (Ethernet)
2012 Tivo Stream
2011 Slingbox Solo
Series 2 Humax DRT800 (Still in use for VHS->DVD)
Series 1 Philips (Retired)
MacBrian is offline   Reply With Quote
Old 07-25-2014, 04:59 PM   #7
JWhites
Registered User
 
Join Date: May 2013
Posts: 907
Quote:
Originally Posted by moyekj View Post
For in home use I never seem to get this problem, but I'm usually situated very close to wireless router and thus have solid connection from iPad to wireless router. Looks to me like the Stream is not very robust and tolerant of network glitches which are especially common in public WiFi connections.
I have noticed that if I sit near my router and set it to 5GHz that I get rock solid performance without a hiccup and if I go onto 2.4GHz mode and get farther away with a weaker signal a more inconsistent experience occurs. Personally I can't wait for TiVo to ditch the proxy and do port forwarding which I hope will give my out of home streaming experience the same picture and audio quality I get with in home streaming.
JWhites is offline   Reply With Quote
Old 08-13-2014, 03:57 PM   #8
MacBrian
Registered User
 
MacBrian's Avatar
 
Join Date: Feb 2002
Location: Kansas
Posts: 83
Quote:
Originally Posted by MacBrian View Post
My next stab at resolving the inconsistent performance is to shut down the AT&T 2-Wire router's WIFI and use a brand new Apple Airport Extreme 6th Gen that I have sitting in a box waiting for some free time to install it. Maybe THAT will make a better experience???
Just an update. I finally got the 5th Gen Airport Extreme installed. I've "dumbed-down" the AT&T 2-Wire router (as much as possible, that is) and am using the Airport Extreme in it's place for all my wired and wireless needs.

Performance and reliability is now ROCK SOLID on my two iPhone 5s phones AND on my two 2nd Generation iPads. I've watched several hours of Tivo recordings from either one of my Premiere boxes, both at home and away from home, with no issues.

Lesson learned for me: If you stick with Apple..."it just works."



--Brian
__________________
2011: First Tivo Premiere (Ethernet)
2012: Second Tivo Premiere (Ethernet)
2012 Tivo Stream
2011 Slingbox Solo
Series 2 Humax DRT800 (Still in use for VHS->DVD)
Series 1 Philips (Retired)
MacBrian is offline   Reply With Quote
Old 08-21-2014, 01:42 AM   #9
JWhites
Registered User
 
Join Date: May 2013
Posts: 907
I've noticed that if I make a partial recording like if I record the last 20 minutes of a show then stream that recording after the show ends, most of the time at the end of the program I get a "Problem Streaming: An unknown error occurred" message instead of the "delete/keep" message.

Last edited by JWhites : 08-27-2014 at 01:29 AM.
JWhites is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 03:42 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |