TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Stream
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 06-13-2014, 09:10 AM   #1
cwoody222
Registered User
 
cwoody222's Avatar
 
Join Date: Nov 1999
Location: Buffalo, NY
Posts: 11,007
Why downloads so slow, incomplete?

My TiVo Stream downloads have gotten extremely slow lately. I got my stream for Christmas and it seems to be worse than it used to be. I have a basic Premiere unit with ~15MB download speed Time Warner Cable. My TiVo is hardwired and I'm transferring to an iPhone 5.

Typically an hour-long download takes 20-30 minutes when the TiVo "estimates" it should only take a fraction of that time.

2 out of my last 3 downloads were also incomplete in that the video just stops playing at a certain point in the video. Repeated downloads of the same episode has the same behavior.

I tried downloading the same show that took ~20 minutes at home yesterday in my office this morning (on WiFi) and it's up to 50 minutes so far.

I rebooted my Stream last night and that didn't seem to help much.

Any suggestions?
__________________
--Chris
cwoody222 is offline   Reply With Quote
Old 06-13-2014, 09:14 AM   #2
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,299
Out of home downloads go through a TiVo proxy server that from my experiment limits download speeds to ~1.85 Mbps:
http://www.tivocommunity.com/tivo-vb...d.php?t=511445

i.e. For out of home downloads, assuming your ISP uploads > 2 Mbps it's the TiVo proxy server that's limiting your speeds. For in home downloads the proxy server is not used and hence don't have that limitation.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 06-13-2014, 11:23 AM   #3
eboydog
Just TiVo'ing.....
 
eboydog's Avatar
 
Join Date: Mar 2006
Posts: 904
Have you ran any Internet speed checks on your home Internet connection to confirm that your home upstream speed is decent and you are getting the speeds your provider has established for your home Internet connection? It's not unusual for home ISP 's to have issues causing sudden lower speeds than they are suppose to offer, you have to have a healthy upload capacity before it hits TiVo's proxy servers otherwise it will only get slower.

A couple months ago I had Netflix problems and found my cable provider had serious headend issues, my Internet worked but had less than a third of it normal speed. It wasn't until I reported that the problem and kept on them, did they finally find the problem was theirs outside my house and not in my house.
__________________
TiVo Roamio Pro
TiVo Roamio Plus (3tb)
TiVo Mini (three)
TiVo Premiere

eboydog is offline   Reply With Quote
Old 06-14-2014, 02:17 AM   #4
Austin Bike
Registered User
 
Join Date: Feb 2003
Posts: 571
Also try rebooting your home router. I have found that mine gets a little flaky after a few weeks of heavy use and a reboot fixes that
Austin Bike is offline   Reply With Quote
Old 06-16-2014, 09:38 PM   #5
cwoody222
Registered User
 
cwoody222's Avatar
 
Join Date: Nov 1999
Location: Buffalo, NY
Posts: 11,007
What about slow IN HOME downloads. I'm talking like an hour to download an hour show.

How should I troubleshoot that?
__________________
--Chris
cwoody222 is offline   Reply With Quote
Old 06-17-2014, 01:13 AM   #6
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,299
Reboot everything, especially router & TiVo/Stream.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 06-25-2014, 01:59 AM   #7
ADent
Registered User
 
Join Date: Jan 2000
Location: Denver, CO
Posts: 2,103
Mine is useless.

It got really slow in home, then many to most shows get a glitch in them and it stops transferring at that point.

It is much more reliable to export via KTTMG and then encode with Handbrake.
ADent is offline   Reply With Quote
Old 07-06-2014, 09:39 AM   #8
Bulldawg9908
Registered User
 
Join Date: Feb 2011
Posts: 46
Quote:
Originally Posted by moyekj View Post
Out of home downloads go through a TiVo proxy server that from my experiment limits download speeds to ~1.85 Mbps:
http://www.tivocommunity.com/tivo-vb...d.php?t=511445

i.e. For out of home downloads, assuming your ISP uploads > 2 Mbps it's the TiVo proxy server that's limiting your speeds. For in home downloads the proxy server is not used and hence don't have that limitation.
This is ridiculous. I have a steady 20 mbit/s up at home and typically have 60+ down where I download, but I can't even watch a show while it downloads because it's so slow. Why is TiVo taking on the extra expense of running a proxy server when the only effect is to limit the speed we can achieve? Why can't the proxy hand it off to a direct connection once the connection is made?

Has anyone had any luck tricking their iPad into thinking it's on the home network using a VPN or a tunnel of some sort?

BTW, I've seen slow speeds when downloading at home too. Resetting my iPad fixed it.
Bulldawg9908 is offline   Reply With Quote
Old 08-02-2014, 05:19 AM   #9
ADent
Registered User
 
Join Date: Jan 2000
Location: Denver, CO
Posts: 2,103
Here is another show. Haven't used this in awhile, thought I would give it a try.

This one did download over the internet. But it has a "Problem Playing Recording, An unknown error occurred." 38 min into the 60 min show.

As soon as I hit play on the phone the error box pops up - so no fast forward or scrubbing past the bad bit.

Uggh.
ADent is offline   Reply With Quote
Old 08-11-2014, 05:24 PM   #10
erugar
Registered User
 
Join Date: Apr 2010
Posts: 2
Quote:
Originally Posted by ADent View Post
Here is another show. Haven't used this in awhile, thought I would give it a try.

This one did download over the internet. But it has a "Problem Playing Recording, An unknown error occurred." 38 min into the 60 min show.

As soon as I hit play on the phone the error box pops up - so no fast forward or scrubbing past the bad bit.

Uggh.
I've been running into this frequently as of late with shows I've downloaded to my iPad in-home. I've rebooted everything multiple times to no avail. Easily 60-70% of the shows I try to watch after downloading to my iPad have this problem.

I don't know if it's a coincidence or not, but I feel like the majority of the time that it happens is when I'm hitting the 30 second skip button to go through commercials. It'll be playing fine, commercials will start and I'll start skipping forward and then I get this infuriating error.

Download speeds, while sucky, haven't been as bad as others have seen. I think I typically see ~20 minutes for an hour show.
erugar is offline   Reply With Quote
Old 08-11-2014, 05:28 PM   #11
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,299
Quote:
Originally Posted by erugar View Post
Download speeds, while sucky, haven't been as bad as others have seen. I think I typically see ~20 minutes for an hour show.
That's in home downloads which have improved over last couple of TiVo and/or iOS software updates. As pointed out above, out of home downloads go through a proxy server that limits downloads to about ~1.8 Mbps which means at best quality way over 1 hour of download time per 1 hour of show.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 08-12-2014, 11:46 AM   #12
dso
Registered User
 
Join Date: Aug 2014
Posts: 1
Very Slow

Streaming seems to work great both in-home and away, where I run into problems is downloading content, 1 hour programs usually run over 2 hours to transfer, I run a gigabit backbone, and a brand new airport extreme, I dont get it, I can get the same if not better download speeds from away from home.
dso is offline   Reply With Quote
Old 08-13-2014, 12:13 PM   #13
cwoody222
Registered User
 
cwoody222's Avatar
 
Join Date: Nov 1999
Location: Buffalo, NY
Posts: 11,007
I recently replaced my Premiere/Stream setup with a Roamio and I'm now getting around 20mins to download an hour show in-home.
__________________
--Chris
cwoody222 is offline   Reply With Quote
Old 08-24-2014, 01:27 AM   #14
morac
Cat God
 
morac's Avatar
 
Join Date: Mar 2003
Location: NJ
Posts: 6,666
Quote:
Originally Posted by cwoody222 View Post
I recently replaced my Premiere/Stream setup with a Roamio and I'm now getting around 20mins to download an hour show in-home.
At what quality?

I'm currently downloading an hour long HD program at medium quality from my Roamio Pro in home using it's internal stream and it's been going at least 10 minutes and it's only about half done, it's about 20 minutes at medium quality. Looking at my router's bandwidth meter the transfer maxes out at about 6 Mbps.

That doesn't mesh with the 9 minutes TiVo estimates for medium and the 16 minutes for best.

I am unable to download to my iPad and stream to my iPhone at the same time. I get a bandwidth too low error.
morac is offline   Reply With Quote
Old 08-24-2014, 08:37 AM   #15
cwoody222
Registered User
 
cwoody222's Avatar
 
Join Date: Nov 1999
Location: Buffalo, NY
Posts: 11,007
I was downloading basic quality.
__________________
--Chris
cwoody222 is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 07:38 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |