TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Underground Playground > Developers Corner
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 04-16-2013, 10:50 PM   #661
cweb
Registered User
 
Join Date: May 2004
Posts: 99
Got it. It works just fine. I just didn't know what it was failing at.

Thanks.
cweb is offline   Reply With Quote
Old 04-24-2013, 07:51 PM   #662
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
I just uploaded a new version - 2.2b. I added a new value to the groupby parameter for virtual shares. If you specify groupby=alpha, it will create folders in the virtual share for each starting letter (or number) of the title item. So for example, if you have a virtual share of actors, it is potentially very large. With this groupby option, it will create up to 37 sub-groups (26 alpha, 10 digits, 1 OTHER) with only the actors that start with that character in the sub-folder. This makes navigation of large groups easier.

As a side result of this, I now allow a list to be the grouping item. Previously this had been disallowed.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 05-09-2013, 05:34 PM   #663
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
Version 2.2c has been uploaded to GIT. This version fixes a bug that caused a crash if the sortroot option was set to True and a virtual share sorted ahead of a physical share. While I was in there, I changed the savepushdate setting to savepushdata and I also save the tivo names that have been pushed to in addition to the push date. The name savepushdate is still supported for backward compatibility, but both mean the same thing.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 06-15-2013, 10:39 AM   #664
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
Version 2.2d is now up on GIT. There was a lingering bug from the previous fix regarding the sorted position of virtual shares. Should be OK now
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 04-09-2014, 06:42 PM   #665
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
I had to rebuild my server and I can't get vidmgr to work. Every time it tries to start vidmgr it says
Code:
Skipping: vidmgr - No module named Image
I know that this means I should install the python imaging library and I have done so, but I am still getting this error. Do you have any ideas?
__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 04-09-2014, 06:52 PM   #666
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
You're absolutely right - it means the PIL hasn't been installed. Perhaps you didn't install it correctly??

There's really nothing I can do because my code isn't really coming active. This error occurs at load time.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 04-09-2014, 06:56 PM   #667
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
Quote:
Originally Posted by jbernardis View Post
You're absolutely right - it means the PIL hasn't been installed. Perhaps you didn't install it correctly??

There's really nothing I can do because my code isn't really coming active. This error occurs at load time.
Can you confirm if pyhme is compatible with the latest version of pillow? Or know of some way to test it?

I'm running fedora and have done a yum install of python-imaging. I've tried re-installing it too.

My python is version 2.7-5.9.fc19
My Python-pillow is: 2.0.0-12-gitd1c6db8.fc19
__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 04-09-2014, 07:01 PM   #668
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
I don't know about overall compatibility, but this is having an issue just loading the package. You can go into python interactively and just type "import Image" and see if you get an error.

You ARE talking about python 2.x (I'm using 2.7) and not 3.0. My program is not compatible with 3.0. You also need to be sure you downloaded PIL for your version of 2.x and not 3.0.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 04-09-2014, 07:21 PM   #669
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
I figured it out. It took me a while before I even posted and then I figured it out pretty quick.

I actually had to run the following command
Code:
easy_install pillow-pil

__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 04-25-2014, 02:19 AM   #670
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,869
I've never really looked into the sort=titleNumber meta value, but now I have some TV series on DVD with multiple titles on each DVD, I want to be able to sort by title number. When I put

Code:
sort=titleNumber
into vidmgr.ini, I get the following error when I attempt to run Buildcache:

Code:
Processing DVD share DVD
177 DVD Videos found
Processing video share RAID Server
2028 Videos found
Processing video share Unverified
53 Videos found
Browse Series (grouped by Series Title) count: 692 videos in 16 groups
Traceback (most recent call last):
  File "/usr/share/pyhme/vidmgr/BuildCache.py", line 30, in <module>
    c.build(verbose)
  File "/usr/share/pyhme/vidmgr/VideoCache.py", line 336, in build
    nd = h.getNode()
  File "/usr/share/pyhme/vidmgr/Meta.py", line 56, in getNode
    self.nodeMap[n].sort()
  File "/usr/share/pyhme/vidmgr/Node.py", line 139, in sort
    s = sorted(self.videoList, cmpVidNodes)
  File "/usr/share/pyhme/vidmgr/Node.py", line 118, in cmpVidNodes
    tb = b.formatSortText(self.opts['sortopt'])
  File "/usr/share/pyhme/vidmgr/VideoFile.py", line 197, in formatSortText
    result += data
TypeError: cannot concatenate 'str' and 'int' objects
The sort directive is in the general config body, because the DVD share is real, not virtual, so there is no virtual section in which to place it.

Also, when attempting to get the metadata info on a DVD title (either a single-title or multi-title DVD), I get an error:

Code:
An error occurred while running the application.  The application closed during a read (0x50006).
From the log:

Code:
Traceback (most recent call last):
  File "/usr/lib/python2.7/SocketServer.py", line 593, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib/python2.7/SocketServer.py", line 334, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/share/pyhme/start.py", line 142, in __init__
    client_address, server)
  File "/usr/lib/python2.7/SocketServer.py", line 649, in __init__
    self.handle()
  File "/usr/lib/python2.7/BaseHTTPServer.py", line 340, in handle
    self.handle_one_request()
  File "/usr/lib/python2.7/BaseHTTPServer.py", line 328, in handle_one_request
    method()
  File "/usr/share/pyhme/start.py", line 233, in do_GET
    self._page(True)
  File "/usr/share/pyhme/start.py", line 187, in _page
    appinst.mainloop()
  File "/usr/share/pyhme/hme.py", line 1134, in mainloop
    while self.active and self.get_event():
  File "/usr/share/pyhme/hme.py", line 1187, in get_event
    handle(keynum, rawcode)
  File "/usr/share/pyhme/vidmgr/__init__.py", line 238, in handle_key_press
    self.vwInfo.loadmetadata(meta)
  File "/usr/share/pyhme/vidmgr/InfoView.py", line 195, in loadmetadata
    self.addline(m, meta[m])
  File "/usr/share/pyhme/vidmgr/InfoView.py", line 123, in addline
    for w in dstring.split(' '):
AttributeError: 'int' object has no attribute 'split'
default.txt
Code:
title : JAG
seriesTitle : JAG
movieYear : 1995
description : Harmon Rabb, a former F-14 pilot in the Navy now works as a lawyer for the Navy Judge Advocate General.
Title 0: Ignore
Title 1: A New Life
Title 2: Ignore
Title 3: Shadow
Title 4: Desert Son
Title 5: Ignore
starRating : x5
mpaaRating : N8
vProgramGenre : Action
vProgramGenre : Adventure
vProgramGenre : Crime
vProgramGenre : Drama
vProgramGenre : Series
vProgramGenre : War
vDirector : Donald P. Bellisario
vWriter : Donald P. Bellisario
vActor : David James Elliott
vProgramGenre : Action
vProgramGenre : Adventure
vProgramGenre : Crime
vProgramGenre : Drama
vProgramGenre : Series
vProgramGenre : War
__T01.mpg.txt:
Code:
seriesTitle : JAG
episodeNumber : 001
description : Series Pilot.  Lt. Harmon "Harm" Rabb, a JG Lawyer who investigates and litigates crimes committed by Navy and Marine personnel, looks into the mysterious death of a female pilot aboard an aircraft carrier. Harm is convinced the female pilot who fell overboard didn't commit suicide, but was actually pushed, with all the suspects aboard the aircraft carrier.
seriesId : SH151366
title : A New Life
vWriter : Donald P. Bellisario
What am I doing wrong?
lrhorer is offline   Reply With Quote
Old 04-26-2014, 07:44 PM   #671
telemark
Registered User
 
Join Date: Nov 2013
Posts: 627
Either the sort routine is not robust or you have bad/mixed metadata.

With a large number of files is easy to have some bad metadata. Try the same thing but with a single file at a time.

And then do the same thing but with pairs of files.

PS: Is this legal? It sounds alot like what the error is complaining about.
Code:
Title 0: Ignore
Title 1: A New Life
Title 2: Ignore
Title 3: Shadow
Title 4: Desert Son
Title 5: Ignore

__________________
Premiere 2 tuner & SiliconDust
on Comcast-CableCard + OTA
telemark is offline   Reply With Quote
Old 04-27-2014, 01:14 AM   #672
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 5,159
Quote:
Originally Posted by telemark View Post
PS: Is this legal? It sounds alot like what the error is complaining about.
Code:
Title 0: Ignore
Title 1: A New Life
Title 2: Ignore
Title 3: Shadow
Title 4: Desert Son
Title 5: Ignore
Definite possible source of the problem. Maybe he should try it with no space between Title and the number, i.e. Title1, Title2, etc.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 04-28-2014, 09:10 AM   #673
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,869
It doesn't help with the information error. It will take me rather a long time to edit all the default.txt files to see if it fixes the sort error.
lrhorer is offline   Reply With Quote
Old 05-01-2014, 01:10 AM   #674
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,869
I removed all the default.txt files except 1, and in that file I eliminated the space between the Title parameter and the title number. The error when running Buildcache went away, but the sort still does not work properly, and the error when attempting to display the metadata remains.
lrhorer is offline   Reply With Quote
Old 05-05-2014, 05:07 PM   #675
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
Version 2.2e has been posted on github. I fixed 3 separate bugs, all found by lrhorer. He was also most helpful in testing and debugging.

The problems were:
- fixed improper handling of integer metadata - specifically the episode number of a DVD title
- fixed DVD Share sorting - it now properly sorts on the sort specification instead of the display spec
- fixed improper parsing of Virtual Shares - was not recognizing 'display' settings
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 05-18-2014, 03:14 PM   #676
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
I just updated GIT again - version 2.2f. The major change is that I added a new ini file option - metamergeparent (default false). When this is set to True (and metamergefiles is true) vidmgr will work UP the directory tree from the current location and merge any default.txt files it finds before reading and adding in the normal metadata. This allows, for example, for you to have a default.txt file that contains the cast for a series of programs in the parent directory, and not have it duplicated in each local metadata file.

In addition to this, I fixed a bug that allowed for metadata entries that are lists to have duplicated entries. I now make sure the entries in these lists are unique.

As usual, follow the v2 link in my signature.

Thanks again to lrhorer for testing and for inspiring the feature.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 05-31-2014, 02:19 AM   #677
lrhorer
Registered User
 
Join Date: Aug 2003
Location: San Antonio, Texas, USA
Posts: 6,869
And thanks to Jeff for his exemplary continued support of this product.

I would like to expand on the new feature just a bit. Its greatest use is probably with the ripped DVD application available with pyTivo, but if one chooses to organize one's directory structure in a hierarchical fashion based probably on series season, this can be very handy for ordinary video files, as well. So, for example, I have the first four seasons of JAG on DVD stored on the server. The structure is like this:

Code:
JAG => Season => Disk # => Episode
Now David James Elliot and Patrick Labyorteaux, for example are both in every single episode, so the top directory has a default.txt file in it with both of their names as vActor. Neither appears in any of the subdirectory metafiles, but they both show up in every single video listing for JAG. Tracy Needham, however, was only in season 1, so her name appears in the default.txt file for JAG => Season One. Catherine Bell was in every episode startng with Season Two, so her name appears in every Season default.txt file starting with Season Two. John M Jackson is in every Season directory except the first and the last, etc. Bell also starred in one episode of Season One, so her name appears in the metadata file for that particular episode. Trevor Goddard first appeared half-way through Season Four, so his name appears in the default.txt files in JAG => Season 4 => Disk 3, 4, 5, and 6.

Using this feature, I was able to quickly and easily place each of the major cast members in their appropriate videos without having to fiddle endlessly with each and every metafile. This means not only does each episode show the proper cast list, but when searching by vActor, each video for a particular cast member shows up under their name. Thus, for the virtual share:

Code:
[Browse by Actor]
tags = vActor vGuestStar
groupby=alpha
David James Elliot shows up in 219 episodes, Catherine Bell shows up in 203 videos, including 198 episodes of JAG, Steven Culp shows up in 32 episodes, etc.

Last edited by lrhorer : 05-31-2014 at 02:44 AM.
lrhorer is offline   Reply With Quote
Old 07-27-2014, 09:34 PM   #678
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
Does VIDMGR handle .nfo files? I know pyTivo incorporated this, but it seems that VIDMGR isn't reading my .nfo files.
__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 07-27-2014, 11:14 PM   #679
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
I don't know what .nfo files are. If you could give me some information, I'll see what I'd be willing to do.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 07-28-2014, 06:11 AM   #680
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
Quote:
Originally Posted by jbernardis View Post
I don't know what .nfo files are. If you could give me some information, I'll see what I'd be willing to do.
They are hybrid xml files that have become the standard for this sort of metadata.

http://wiki.xbmc.org/index.php?title=NFO_files/movies

Sent from my HTC6525LVW using Tapatalk
__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 07-28-2014, 08:31 AM   #681
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,043
I dunno what you're doing for metadata, but feel free to just import metadata.py from pyTivo.

("Hybrid XML" is a sick concept. But anyway, we've already dealt with it in metadata.py.)
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 07-28-2014, 07:29 PM   #682
jbernardis
Registered User
 
Join Date: Oct 2003
Location: Princeton NJ
Posts: 1,064
Thanks Bill. I was already planning on doing that. I used your code previously, although I altered it for what I needed. I've already isolated the portions of metadata.py that deal with nfo files and was simply planning on merging that into my existing code.

I don't anticipate any issues, but I'm not going to be able to get to it for a few days. The soonest would be after the weekend.
__________________
2 Series 3
1 HDTivo
1 Series 1 (Lifetime)
1 Win7 HTPC with Ceton Quad Tuner


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jbernardis is offline   Reply With Quote
Old 08-03-2014, 05:44 PM   #683
jeepguy_1980
Unregistered User
 
Join Date: Mar 2008
Location: Newport News, VA
Posts: 250
Quote:
Originally Posted by jbernardis View Post
Thanks Bill. I was already planning on doing that. I used your code previously, although I altered it for what I needed. I've already isolated the portions of metadata.py that deal with nfo files and was simply planning on merging that into my existing code.

I don't anticipate any issues, but I'm not going to be able to get to it for a few days. The soonest would be after the weekend.
Were you able to get to it this weekend?

Sent from my HTC6525LVW using Tapatalk
__________________
TiVo Elite
TiVo S3 with WD10EVCS 1TB Drive
TiVo Stream
TiVo Mini

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
jeepguy_1980 is offline   Reply With Quote
Old 09-12-2014, 04:21 PM   #684
cweb
Registered User
 
Join Date: May 2004
Posts: 99
Vidmgr no longer working ...

I had a working setup that was doing great for the longest time on my Mac running 10.9.4. I just recently noticed that it stopped working and I can't figure out why. I'm sure I must have changed something, but don't know what. The terminal output is as follows:

cd '/Applications/hme-python/' && '/usr/local/bin/pythonw' -S '/Applications/hme-python/start.py' && echo Exit status: $? && exit 1
HME Server for Python 0.20
Not using Zeroconf: No module named zeroconf
Skipping: vidmgr - No module named Image
Sun Sep 7 10:21:26 2014 Server Starts

Any help would be appreciated.
cweb is offline   Reply With Quote
Old 09-12-2014, 04:50 PM   #685
lpwcomp
Registered User
 
Join Date: May 2002
Location: John's Creek, Georgia
Posts: 5,159
Quote:
Originally Posted by cweb View Post
I had a working setup that was doing great for the longest time on my Mac running 10.9.4. I just recently noticed that it stopped working and I can't figure out why. I'm sure I must have changed something, but don't know what. The terminal output is as follows:

cd '/Applications/hme-python/' && '/usr/local/bin/pythonw' -S '/Applications/hme-python/start.py' && echo Exit status: $? && exit 1
HME Server for Python 0.20
Not using Zeroconf: No module named zeroconf
Skipping: vidmgr - No module named Image
Sun Sep 7 10:21:26 2014 Server Starts

Any help would be appreciated.
First thing to do is make sure you are running the latest versions of vidmgr and pyTivo.
__________________
James L. Sutherland
"You know TiVo users. Bunch of b****y little girls" TiVoAxe

"Jessica Fletcher visits Midsomer. Carnage ensues!"
lpwcomp is offline   Reply With Quote
Old 09-12-2014, 05:28 PM   #686
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,043
Quote:
Originally Posted by cweb View Post
Skipping: vidmgr - No module named Image
This says that you don't have the Python Imaging Library installed.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 09-12-2014, 11:07 PM   #687
cweb
Registered User
 
Join Date: May 2004
Posts: 99
Quote:
Originally Posted by wmcbrine View Post
This says that you don't have the Python Imaging Library installed.
What is PIL installed as part of? Hme-python? Vidmgr? OS? something else?

It use to work. What may have broken it? This may not be relayed, but pytivo and strambaby still work.

Thanks.

Last edited by cweb : 09-12-2014 at 11:35 PM.
cweb is offline   Reply With Quote
Old 09-13-2014, 12:19 AM   #688
Allanon
Registered User
 
Join Date: Nov 2005
Posts: 526
Quote:
Originally Posted by cweb View Post
What is PIL installed as part of? Hme-python? Vidmgr? OS? something else?

It use to work. What may have broken it? This may not be relayed, but pytivo and strambaby still work.

Thanks.
PIL is an image processing module for Python. Might try re-installing it.
Allanon is online now   Reply With Quote
Old 09-13-2014, 12:25 AM   #689
wmcbrine
Resistance Useless
 
wmcbrine's Avatar
 
Join Date: Aug 2003
Posts: 9,043
Quote:
Originally Posted by cweb View Post
What is PIL installed as part of? Hme-python? Vidmgr? OS? something else?
It's not part of anything. It's a separate package.

Quote:
It use to work. What may have broken it?
I'm guessing (based on that "/usr/local/bin") that it broke when you installed a new version of Python.

Nowadays you probably want to use Pillow.
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
wmcbrine is offline   Reply With Quote
Old 09-13-2014, 09:17 PM   #690
cweb
Registered User
 
Join Date: May 2004
Posts: 99
I just installed Pillow and the log seems to look better and it appears that vidmgr now gets loaded. However I am still not seeing vidmgr on the Tivos. Also, I still am getting the Zeroconf error.

log:
~ cliff$ cd '/Applications/hme-python/' && 'python' '/Applications/hme-python/start.py' && echo Exit status: $? && exit 1
HME Server for Python 0.20
Not using Zeroconf: No module named zeroconf
Sat Sep 13 18:30:57 2014 PyTivo Video Manager version 2.2f module initializing
Loading thumbnail cache
100 thumbnails loaded from cache
Sat Sep 13 18:30:58 2014 Server Starts

Any additional thoughts? Thanks in advance.
cweb is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 12:08 AM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |