TiVo Community
TiVo Community
TiVo Community
Go Back   TiVo Community > Main TiVo Forums > TiVo Stream
TiVo Community
Reply
Forum Jump
 
Thread Tools
Old 12-10-2013, 10:29 PM   #1
RustySTL
Registered User
 
Join Date: Feb 2007
Posts: 64
Streaming Stops just before end

I've had the same issue since I started streaming with my Roamio Plus, when I stream a recorded show from the Roamio to my iPad, the show stops 1 to 2 minutes before the end of the recording. I know there is more time left if I go check the recording on the TiVo, I can watch the last minute.
Anyone else had this happen?
RustySTL is offline   Reply With Quote
Old 12-11-2013, 01:05 AM   #2
Dan203
Super Moderator
 
Dan203's Avatar
 
Join Date: Apr 2000
Location: Nevada
Posts: 25,224
Does it just freeze and never offer up the delete dialog? If so then yes, I see this ALL THE TIME.
__________________
Dan Haddix
Super Moderator
Developer for VideoReDo
Dan203 is offline   Reply With Quote
Old 12-11-2013, 08:54 AM   #3
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,181
I haven't noticed problems specifically at the end of recordings. But I have had problems with freezes where beyond a certain point I can't play back the recording at all. Looks to me like sometimes the Stream encoder just doesn't properly encode recordings.

My speculation is that for some HD channels there are resolution changes when switching from show to commercials (for example 720p to 1080i) and perhaps that is messing up the Stream encoder at times. VideoRedo has trouble with those as well but can deal with them by running QS Fix with video filter enabled to select the desired primary resolution. Next time I run into this problem I'll have to investigate further along these lines. Lately though, I haven't had much need for out of home viewing on my iPad so haven't been using the Stream.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 12-11-2013, 09:25 AM   #4
windracer
joined the 10k club
 
windracer's Avatar
 
Join Date: Jan 2003
Location: St. Pete, FL
Posts: 11,240
Quote:
Originally Posted by moyekj View Post
My speculation is that for some HD channels there are resolution changes when switching from show to commercials (for example 720p to 1080i) and perhaps that is messing up the Stream encoder at times.
That makes sense ... I see evidence of these resolution changes while fast-forwarding through commercials: sometimes the FF will be smooth, and then some commercials get "jerky" (only certain frames displayed).

It does make for a frustrating OOH streaming experience with all these freezes, random "finished" messages in the middle, having to restart all the time, etc.
__________________
840~Roamio Pro (TA, MoCA) + two A92~Minis, 758~Premiere XL4 (TA, MoCA)
S/old: 746~S4, 658~HDXL, 648~OLED S3, 565~TX20, 230~S2, 140~S2

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
windracer is offline   Reply With Quote
Old 12-11-2013, 02:36 PM   #5
Dan203
Super Moderator
 
Dan203's Avatar
 
Join Date: Apr 2000
Location: Nevada
Posts: 25,224
Quote:
Originally Posted by moyekj View Post
I haven't noticed problems specifically at the end of recordings. But I have had problems with freezes where beyond a certain point I can't play back the recording at all. Looks to me like sometimes the Stream encoder just doesn't properly encode recordings.

My speculation is that for some HD channels there are resolution changes when switching from show to commercials (for example 720p to 1080i) and perhaps that is messing up the Stream encoder at times. VideoRedo has trouble with those as well but can deal with them by running QS Fix with video filter enabled to select the desired primary resolution. Next time I run into this problem I'll have to investigate further along these lines. Lately though, I haven't had much need for out of home viewing on my iPad so haven't been using the Stream.
While that may be the case for some of your recordings that is not true for mine. When I have this problem it's almost always frozen somewhere on the show itself. Typically a minute or so before the end. I also edit a lot of stuff with VRD, and as you know we don't support multi-resolution video very gracefully, so I'd know if any of my shows actually had multiple resolutions.
__________________
Dan Haddix
Super Moderator
Developer for VideoReDo
Dan203 is offline   Reply With Quote
Old 12-11-2013, 08:06 PM   #6
RustySTL
Registered User
 
Join Date: Feb 2007
Posts: 64
Quote:
Originally Posted by Dan203 View Post
Does it just freeze and never offer up the delete dialog? If so then yes, I see this ALL THE TIME.
This is exactly what I'm experiencing. It just never plays the last minute or so and the delete dialog never pops up. It just freezes, and this happens on every single video I stream.
RustySTL is offline   Reply With Quote
Old 12-11-2013, 09:46 PM   #7
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,181
Quote:
Originally Posted by RustySTL View Post
This is exactly what I'm experiencing. It just never plays the last minute or so and the delete dialog never pops up. It just freezes, and this happens on every single video I stream.
If you download instead of stream does playback freeze at same point?
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 12-11-2013, 09:51 PM   #8
RustySTL
Registered User
 
Join Date: Feb 2007
Posts: 64
Quote:
Originally Posted by moyekj View Post
If you download instead of stream does playback freeze at same point?
I haven't tried that yet.

Now today the streaming doesn't work at all. It starts then stops every few seconds. I'll have to try to restart it to see if that fixes anything.
RustySTL is offline   Reply With Quote
Old 12-12-2013, 02:36 AM   #9
Dan203
Super Moderator
 
Dan203's Avatar
 
Join Date: Apr 2000
Location: Nevada
Posts: 25,224
That's the same thing I've been seeing ever since the update following iOS7. I even tried eliminating the problem by using a standalone Stream that had not yet been updated and I was still having the problem, so I'm 99% sure it's the app causing the problem.
__________________
Dan Haddix
Super Moderator
Developer for VideoReDo
Dan203 is offline   Reply With Quote
Old 02-18-2014, 05:34 PM   #10
Rodney
TiVo'd since 9/17/01
 
Join Date: Jan 2002
Location: Houston, Texas
Posts: 90
My wife is having this same issue, with the stream stopping a minute or two before the end. It just freezes, never offering up the delete dialog. This happens with all the shows.
Normally it isn't an issue when the ending is just commercials, but for shows that go right to the end it is a hassle, because now she has to go to the TiVo to watch the last minute or so of each program. Defeats the purpose of the stream.

-Rodney
__________________
1 Sony SVR2000 w/lifetime
1 Toshiba RS-TX20
1 Tivo HD w/lifetime
3 TiVo Premieres expanded to 318 HD hours
1 Roamio Pro w/lifetime
Rodney is offline   Reply With Quote
Old 02-18-2014, 07:49 PM   #11
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,181
I ran into the freezing several times over the weekend (in home streaming). Exiting the iOS App and then starting it over allowed me to continue playback. So that makes me think that problem is with the iOS video player decoder freezing, not the Stream Encoder messing up. Further evidence of that is that for 1 video I was able to do a download from pause point for the rest of the show at the point it froze which I decided to try instead of restarting the app. Though I was then able to play the download while still downloading and without having to restart the app. But my download was medium quality vs when doing in home streaming it's high quality, so I think the quality level factors into the freeze problem as well.

For those having freezes, is it always during in home streaming (which uses high quality)? That seems to have been my experience so far.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-19-2014, 12:15 AM   #12
Dan203
Super Moderator
 
Dan203's Avatar
 
Join Date: Apr 2000
Location: Nevada
Posts: 25,224
Still happens to me all the time. Very annoying.
__________________
Dan Haddix
Super Moderator
Developer for VideoReDo
Dan203 is offline   Reply With Quote
Old 02-19-2014, 12:20 AM   #13
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,181
Quote:
Originally Posted by Dan203 View Post
Still happens to me all the time. Very annoying.
Streaming or downloading? I haven't found a case where a medium quality download has frozen on my during playback yet. Seems like all cases have been streaming (which uses high quality when in home).
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 02-19-2014, 01:16 AM   #14
Dan203
Super Moderator
 
Dan203's Avatar
 
Join Date: Apr 2000
Location: Nevada
Posts: 25,224
Streaming. I don't really have a need to download.
__________________
Dan Haddix
Super Moderator
Developer for VideoReDo
Dan203 is offline   Reply With Quote
Old 02-19-2014, 07:01 AM   #15
moyekj
Registered User
 
Join Date: Jan 2006
Location: Mission Viejo, CA
Posts: 9,181
Quote:
Originally Posted by Dan203 View Post
Streaming. I don't really have a need to download.
Right. But I think you may find that if you download @ medium quality and start playing while downloading, you won't run into the freeze issue, at least that's my experience so far. If we can narrow down the freeze problem as being related to high quality streaming that may be a good data point for TiVo about this problem.
__________________
Roamio Pro, Elite, Premiere
Cox - Motorola CableCards & TAs
Slingbox 350 via TiVo Mini & TiVo Stream for remote viewing

To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 posts.
moyekj is offline   Reply With Quote
Old 03-20-2014, 11:46 AM   #16
RustySTL
Registered User
 
Join Date: Feb 2007
Posts: 64
I've downloaded several shows as medium quality and almost every one of them stops 2 min from the end. At that point you can't do anything with the show except restart and it still stops before the end. A little frustrating since I'm out of the country with an iPad full of shows that I'm missing the last 2 minutes off.
RustySTL is offline   Reply With Quote
Old 04-05-2014, 08:39 AM   #17
stfuqua
Registered User
 
Join Date: Dec 2006
Posts: 1
Hi All,
I haven't been here in 7 years according to my profile. Glad this forum is still around. It was very helpful in the past.

I came back because I too am having issues with Stream downloads freezing during playback.

My probs are all with Downloads, I seldom view streaming video. 1 hour programs freeze during playback about 3/4 the way thru viewing. Frustrating!

I think this is exclusively when I download with Basic quality. As I never had this prob until they added the Basic d/l option. I really like the quick d/l time for a 1 hour program the morning after it is recorded by the TiVo. (when will they add auto streaming d/l's to iPhone!?)

My d/l's are all HD programs.

I was sure hoping to find a fix for this problem, but I suppose it will take a firmware or App update.

This is with my Premier XL4 and the Stream box, and viewed on my iPhone 5S.


----------
TiVo Premiere XL4 -Lifetime service July 2012
TiVo Stream -Sept. 2012
Series2 DT -Oct. 2006 still active
TiVo Series2 -Nov. 2004 still active

Last edited by stfuqua : 04-05-2014 at 08:57 AM.
stfuqua is offline   Reply With Quote
Old 04-17-2014, 01:28 PM   #18
ddonohue
Registered User
 
Join Date: Dec 2003
Location: Eastern PA
Posts: 78
Hallelujah, I thought it was just me.

I have taken to adding extra minutes to my recordings to make up for the fact that the app will rarely make it to the final minute or two. Just like everyone else, it just locks up with no "delete?" message ever displayed.

I've never tried this out-of-home, only on my own wifi. I originally assumed it was a streaming issue but was shocked to learn that it also occurs on downloaded shows just as often.

I was certain that there had to be a workaround, so I sat and fiddled with a bad downloaded show one time for about an hour. Quit the show, quit the app, powered off the iPad, reset the iPad, restarted the show a million times, fast-forwarded close to the end, every thing I could think of. No luck.

And it's not consistent - it will freeze AROUND the same spot, but not exactly the same. When it happens I can hit done and restart watching it, and fast-forward to around the spot where it froze and maybe get a few more seconds or a few less. But I've never found a way to watch the end. And once a recording has developed this problem, it will always be that way as far as I can tell.

I only stream or download HD quality, so SD might make a difference. I've also never seen it happen on a show that's less than an hour, FWIW.

This is using a Premiere and a Stream to an iPad 2. A fix would be awesome.
ddonohue is offline   Reply With Quote
Reply
Forum Jump




Thread Tools


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Advertisements

TiVo Community
Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
vBulletin Skins by: Relivo Media

(C) 2013 Magenium Solutions - All Rights Reserved. No information may be posted elsewhere without written permission.
TiVoŽ is a registered trademark of TiVo Inc. This site is not owned or operated by TiVo Inc.
All times are GMT -5. The time now is 06:33 PM.
OUR NETWORK: MyOpenRouter | TechLore | SansaCommunity | RoboCommunity | MediaSmart Home | Explore3DTV | Dijit Community | DVR Playground |