PDA

View Full Version : bananasplus on hme 1.4


KevinG
10-23-2008, 03:05 PM
Dave,

I see r69 says: "Backport to HME 1.4 since HME 1.4.1e has serious issues".

Do you plan on releasing this as a jar anytime soon? I'm about to start work on a project and I'd like to use the BShuttleBarPlus widget...

Thanks.
-Kevin

KevinG
10-24-2008, 06:54 PM
Well, now I've got eclipse svn pointing at the archive on google-code...

Can anyone tell me how to pull down the right thing (it's the head revision), and build it as a jar file?

Thanks.
-Kevin

*Edit - nevermind...got it working, and integrated into my app, all is well.

s2kdave
10-24-2008, 09:33 PM
yeah, I never throroughly tested it. It does compile and run for the most part in 1.4 though. If you know how to run maven 1.x (apache) you can just do "maven jar" and it should download dependencies and build the jar. Otherwise you can create a project in eclipse with the jar dependencies listed in the project.xml.

I didn't want to release a jar that I don't know is working or not. It's been a while since I made those changes. I built a snapshot of the jar so you can use the current state it is in if you want. http://www.almilli.com/maven/tivo/jars/bananas-plus-SNAPSHOT.jar

*EDIT* -- oops didn't notice your EDIT until after this post