PDA

View Full Version : Help Encoding files for GoBack on linux


sgtstadanko
09-15-2005, 04:07 PM
Hey All,

I am looking for any cli commands on linux to encode files for goback. I cannot seem to get either ffmpeg, vlc, or mencoder to produce a workable file. Please share you command line args as I am wanting to script this, not use a gui.

Cheers,

SgtStadanko

csitko
09-15-2005, 11:29 PM
This ffmpeg command produces files that work fine for me:

ffmpeg -i input.avi -vcodec mpeg2video -f vob -s 720x480 -r 30000/1001 -b 4000 -aspect 4:3 -ab 128 -bufsize 512 -maxrate 9800 Output.mpg

sgtstadanko
09-16-2005, 09:17 AM
sweet! thanks.

tvon
10-08-2005, 12:09 PM
This ffmpeg command produces files that work fine for me:

ffmpeg -i input.avi -vcodec mpeg2video -f vob -s 720x480 -r 30000/1001 -b 4000 -aspect 4:3 -ab 128 -bufsize 512 -maxrate 9800 Output.mpg

Thanks for this.

A few notes after using GoBack for a week:

1- 720x480 is a bit choppy/jerky on my 540, but at 704x480 everything is smooth and looks great.

2- For letterbox, use the -padtop and -padbottom options. For example, I had a movie that was 576x240 so I left the size unchanged and added '-padtop 120 -padbottom 120' giving a total size of 576x480 (even though it is not listed as being supported, this played fine).

scubabri
10-11-2005, 09:15 PM
This ffmpeg command produces files that work fine for me:

ffmpeg -i input.avi -vcodec mpeg2video -f vob -s 720x480 -r 30000/1001 -b 4000 -aspect 4:3 -ab 128 -bufsize 512 -maxrate 9800 Output.mpg

When I use ffmpeg with the above options to transcode a VOB, I get audio, and video that is severly pixalated, but tivo accepts it.

The video is pixalated if I play the mpeg with MediaPlayer, any ideas?

I am doing this on a Mac running 10.4

sb

csitko
10-11-2005, 10:55 PM
2- For letterbox, use the -padtop and -padbottom options. For example, I had a movie that was 576x240 so I left the size unchanged and added '-padtop 120 -padbottom 120' giving a total size of 576x480 (even though it is not listed as being supported, this played fine).

You can also change the aspect argument from "4:3" to "16:9" or whatever your videos aspect ratio is rather than padding the video. Also, in my case, setting the aspect ratio to 4:3 for a widescreen video displays the video correctly when expanded on my widescreen TV.

tvon
10-11-2005, 11:49 PM
You can also change the aspect argument from "4:3" to "16:9" or whatever your videos aspect ratio is rather than padding the video. Also, in my case, setting the aspect ratio to 4:3 for a widescreen video displays the video correctly when expanded on my widescreen TV.

That doesnt work for me, though from reading some other threads I think it is due to the model of tivo I have (540).

-Tom

electroph4ge
02-08-2006, 12:54 AM
ffmpeg -i input.avi -vcodec mpeg2video -f vob -s 720x480 -r 30000/1001 -b 4000 -aspect 4:3 -ab 128 -bufsize 512 -maxrate 9800 Output.mpg
Encoding with the above command causes annoying stutters during playback on my SA2 (540) running 7.2.1 The following works beautifully:

ffmpeg -i input.avi -target ntsc-dvd -s 480x480 -aspect 4:3 -ab 160 output.mpg

(debian testing with ffmpeg 20060101-0.3 from debian-marillat repository)

kb7oeb
07-07-2006, 06:29 PM
This script might be of interest if you want to use mencoder

http://www.stellman-greene.com/astellman/mencoder_tivo/

EwanG
07-07-2006, 08:21 PM
What works for me (after a LOT of experimentation) is:

ffmpeg -i "input.avi" -hq -target ntsc-dvd -acodec mp2 -ab 192 -ac 2 -ar 48000 -b 4096 -r 29.97 -s 720x480 -vcodec mpeg2video "output.mpg"

FWIW,
Ewan