1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zipper'd HR10-250, can't make daily call over eth?

Discussion in 'TiVo Underground' started by NickCat, Sep 17, 2006.

  1. Sep 18, 2006 #21 of 102
    HUGE2U

    HUGE2U New Member

    120
    0
    Jun 28, 2002

    The rc.sysinit is a big file (realative to therc.sysinit.author file). So there is much more to it than what you have cut and paste. It is over 600 lines. You need to page down to line 532 and look for the line to edit. Good luck.


    HUGE
     
  2. Sep 18, 2006 #22 of 102
    BigBearf

    BigBearf New Member

    231
    0
    Aug 17, 2005
    Huge,
    I used terminal in a Mac and issued rw command to make the system read/write then I changed to the cd /etc/rc.d and found the rc.sysinit file. I then typed Joe rc.sysinit and the output is what I got.
    Is there another rc.sysinit file or am I just off-base.
    Thanks,
    BigBearf
     
  3. Sep 18, 2006 #23 of 102
    agzela

    agzela New Member

    35
    0
    Aug 13, 2006
    Denver, CO

    Use PAGE/DOWN on your keyboard
     
  4. Sep 18, 2006 #24 of 102
    agzela

    agzela New Member

    35
    0
    Aug 13, 2006
    Denver, CO
    If you are getting Negotiating and then failed in the Call status what could be going wrong I have changed all of the paramaters
     
  5. Sep 18, 2006 #25 of 102
    Gunnyman

    Gunnyman Just a boring dude

    30,748
    2
    Jul 10, 2003
    !Texas
    sees people modifying rc.sysinit
    backs away from the thread slowly....
     
  6. Sep 18, 2006 #26 of 102
    David Platt

    David Platt !Texas TCF Club

    10,467
    7
    Dec 13, 2001
    Portland, OR
    Hehehe. My thoughts exactly. I made a backup of it first, and I was STILL nervous messing with it. ;)
     
  7. Sep 18, 2006 #27 of 102
    BigBearf

    BigBearf New Member

    231
    0
    Aug 17, 2005
    Gunny,
    Good to hear from you. I got the Joe editor to work.

    I made a backup of the files first and did find the false parameter and changed it to true.

    I will try and call out using the ,#401 and then go to the author file and "#out" the route add lines if needed.
    I'm just not familiar with Joe editor but I'm willing to learn. Do I need to reboot the tivo or not?
    Thanks,
    BigBearf
    PS Let me know if I'm about to brick my tivo, however if all else fails I have the original drive for safekeeping as per your instructions.
     
  8. Sep 18, 2006 #28 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    Never mind. I needed to reboot after changing the debug_board setting and getting to to dial with ,#401
     
  9. Sep 18, 2006 #29 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    Ok, back to a problem. I have made the debug_board change, rebooted, added the ,#401 prefix and now it gets pase dialing, but attempts to negotiate for a while, and then fails with "failed while negotiating". Any ideas?
     
  10. Sep 18, 2006 #30 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Did you remove the loopback routes in your author file? Is your tivo connected to your network?
     
  11. Sep 18, 2006 #31 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    No and yes.

    Ok, I guess I need to search on loopback routes now.

    Do I understand this correctly, that I can't just dial out via the phone?
     
  12. Sep 18, 2006 #32 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003

    Code:
    route add -host 204.176.49.2 gw 127.0.0.1
    route add -net 204.176.49.0 gw 127.0.0.1 netmask 255.255.255.0
    
    insmod /lib/modules/usbcore.o
    insmod /lib/modules/ax8817x.o
    sleep 60
    ifconfig eth0 192.168.1.102 netmask 255.255.255.0
    route add default gw 192.168.1.1
    ec
    Ok, those seem to be the three route add liness in rc.sysinit.author

    Do I remove all of them? Can these lines be commented out, or do they have to be deleted?
     
  13. Sep 18, 2006 #33 of 102
    cheer

    cheer Registered Offender

    1,406
    0
    Nov 13, 2005
    Gurnee, IL
    Don't remove the default gateway route. The other two can just be commented out, yes.
     
  14. Sep 18, 2006 #34 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    How do you comment? What character? Is is just the "#" symbol, or something else?
     
  15. Sep 18, 2006 #35 of 102
    100Tbps

    100Tbps New Member

    63
    0
    May 12, 2006
    So once the lines:
    route add -host 204.176.49.2 gw 127.0.0.1
    route add -net 204.176.49.0 gw 127.0.0.1 netmask 255.255.255.0

    are commented out, the TIVO rebooted, the ,#401 added to the dial prefix, the machine will actually use the modem or ethernet to make the daily call when I force it via the TV GUI? Sorry, I've been trying to follow along and gotten confused.

    Separately, I can ping my default gw (which I had to manually add in my HD unit but my SD unit had it - both zippered the same day actually) but cannot ping a URL or the IP of said URL. I have a feeling once I do all the hubbub up top, things may still won't work (unless it's just a ping thing and wget or whatever Tivo's going to do may work).

    Is there something I can check or verify? I've been googling for two hours but can't figure out what I should be checking. Closest I got was iptables and decided I should ask and risk the flame since iptables were discussed recently as part of all of this.
     
  16. Sep 18, 2006 #36 of 102
    100Tbps

    100Tbps New Member

    63
    0
    May 12, 2006
    Yep, that's it. I had to invoke this first:
    mount -o remount,rw /

    then cd /etc/rc.d
    vi rc.sysinit.author
    prefix the two lines with the #

    and I plan to reboot after 11 PM ET tonight. Of course I picked prime time and recording time to have to wait to reboot. I can't even get the ,#401 to take because I haven't rebooted since marking the debug board to yes.
     
  17. Sep 18, 2006 #37 of 102
    bxs122

    bxs122 New Member

    117
    0
    Aug 11, 2004

    What is the best way to back it up?
     
  18. Sep 18, 2006 #38 of 102
    bxs122

    bxs122 New Member

    117
    0
    Aug 11, 2004
    I am getting similar, I don't get an error but on (Negotiating...) it fails after a few minutes.

    Any chance that ,#401 no longer works?

    Just read about the loopback items in rc.sysinit.author file. Will comment these out.

    SUCCESS ... my zippered HR10-250 can now phone home using the network connection. Thanx all.

    So now as I understand it the Tivo unit will phone home only when I tell it to?
    What becomes of caller id and fakecall? Will these still function? Is fakecall really needed?
     
  19. Sep 18, 2006 #39 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    Ok, I just went through this.

    You need to edit the rc.sysinit.author file and comment out two lines that should look something like this:

    So once the lines:
    route add -host 204.176.49.2 gw 127.0.0.1
    route add -net 204.176.49.0 gw 127.0.0.1 netmask 255.255.255.0

    by putting a # in front, so they look like

    #route add -host 204.176.49.2 gw 127.0.0.1
    #route add -net 204.176.49.0 gw 127.0.0.1 netmask 255.255.255.0

    I don't know for sure that there will only be two, but there were two in my system. You then need to reboot, and then the ,#401 should work.
     
  20. Sep 18, 2006 #40 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    Is it confirmed that DEBUG_BOARD= doesn't need to be changed back to false after forcing the call?

    Also, now that I have made a successful call to see if that triggers the 6.3 slice download, should I uncomment the to route add lines?
     

Share This Page