1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Zipper'd HR10-250, can't make daily call over eth?

Discussion in 'TiVo Underground' started by NickCat, Sep 17, 2006.

  1. Sep 17, 2006 #1 of 102
    NickCat

    NickCat New Member

    75
    0
    Feb 17, 2004
    Rowley, MA
    Hey Guys,
    I've been searching the site, as well as google, for the better part of a day now, and I can't come up with a solid answer why I can't get my HR10-250 to make a daily call over eth.

    I already removed the null routes from rc.sysinit.author, but that didn't seem to change a thing. It seems as though the box is still trying to use the modem even though I've put in the ,#401 dialing prefix.

    Networking is working flawlessly otherwise. I can telnet, tivoweb into the machine, I can ping and resolve IPs from inside the machine out.

    I might also just be a bit fried, I've been working on the box for the last 18 hours straight after slicer took me down and the 3.1.5f instakecake wouldn't cooperate because my two 300GB drives HAD to be on seperate IDE channels for mfsadd to work. So I kept getting reboot loops and GSODs until I found a thread here.

    As of this point I have everything else working just fine, I just want to be able to make a daily call if I need to, and yes I want to be able to so I can get the 6.3 slices again. I already had them when slicer when ary during a reboot.

    Any help would be greatly appreciated.

    EDIT: Forgot to add, I have two HR10s and both were able to make the daily call no problem. The one I built today with my virgin image and zipper just won't connect. The other one which I hacked months ago with the HDTIVO MOD HOW TO from the yahoo group still connects fine. And I can't for the live of me remember what I did on that machine differently, other than all the having to install all hacks by hand.
     
  2. Sep 18, 2006 #2 of 102
    NickCat

    NickCat New Member

    75
    0
    Feb 17, 2004
    Rowley, MA
    As a follow up I checked my other HR10, and I did have the ,#401 dialing prefix in there, but I can completly remove it and it still makes it's call out over the network. It doesn't even say dialing, or says it so fast I can't see it, It just goes straight to negotiating.

    Could I have hacked something to tell it to ignore the modem entirely and only seek outside access over the eth?

    I wish I remember what directions I followed on the other machine, but it was back when there was a messy collection of hacks to get stuff working on it.

    This is a snip from the tclient log file I'm getting on the box that won't use the eth.

    Code:
    Sep 18 13:24:24 (none) comm[136]: CallService: Start err 0
    Sep 18 13:24:24 (none) comm[136]: CallStatusReporter: Phase: Dial, Status In Progress
    Sep 18 13:24:24 (none) comm[136]: CallStatusReporter: sending message "CL|30"
    Sep 18 13:24:24 (none) comm[136]: ##### Initial dial prefix = ',#401'
    Sep 18 13:24:24 (none) comm[136]: ##### backdoor code = 4, value = 1
    Sep 18 13:24:24 (none) comm[136]: ##### NEW dial prefix buf = ''
    Sep 18 13:24:24 (none) comm[136]: Backdoor code 4, enable calls via broadband
    Sep 18 13:24:24 (none) comm[136]: After ,# final dialstring is ''
    Sep 18 13:24:24 (none) comm[136]: CallStatusReporter: Turning off-hook LED on
    Sep 18 13:24:24 (none) comm[136]: Opening device
    Sep 18 13:24:24 (none) comm[136]: Initializing modem
    Sep 18 13:24:25 (none) comm[136]: ATZ
    Sep 18 13:24:25 (none) comm[136]: OK
    Sep 18 13:24:26 (none) comm[136]: Set up modem and check for availability
    Sep 18 13:24:26 (none) comm[136]: AT\Q3\T12
    Sep 18 13:24:26 (none) comm[136]: OK
    Sep 18 13:24:27 (none) comm[136]: AT:U70,A100
    Sep 18 13:24:27 (none) comm[136]: ATQ0S0=0
    Sep 18 13:24:27 (none) comm[136]: OK
    Sep 18 13:24:27 (none) comm[136]: SETTING MODEM TO V34 MODE
    Sep 18 13:24:27 (none) comm[136]: OK
    Sep 18 13:24:27 (none) comm[136]: Modem set up and onhook.
    Sep 18 13:24:27 (none) comm[136]: Turning off dial tone detection
    Sep 18 13:24:27 (none) comm[136]: ATV1S6=8S7=50%C0&H2X4
    Sep 18 13:24:27 (none) comm[136]: ATX3
    Sep 18 13:24:27 (none) comm[136]: OK
    Sep 18 13:24:27 (none) comm[136]: Setting extension pickup detection
    Sep 18 13:24:27 (none) comm[136]: AT:U76,3240
    Sep 18 13:24:27 (none) comm[136]: AT:U77,8D10,8050
    Sep 18 13:24:27 (none) comm[136]: OK
    Sep 18 13:24:27 (none) comm[136]: Trying to connect
    Sep 18 13:25:26 (none) comm[136]: OK
    Sep 18 13:25:26 (none) comm[136]: ATDT2193713
    Sep 18 13:25:26 (none) comm[136]: NO CARRIER
    Sep 18 13:25:26 (none) comm[136]: Failed to get a connection.  No Carrier.
     
  3. Sep 18, 2006 #3 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    You have to modify a variable called DEBUG_BOARD in your rc.sysinit file (not rc.sysinit.author).
     
  4. Sep 18, 2006 #4 of 102
    NickCat

    NickCat New Member

    75
    0
    Feb 17, 2004
    Rowley, MA
    Thanks...

    So do I just make the following change?

    Code:
    echo "Look for debug board ..."
    export DEBUG_BOARD=[color=red][b][i]true[/i][/b][/color]
    
    if checkEther ; then
      PATH=/bin:/sbin:/tvbin:/devbin
      export PATH
      echo "Starting network ..."
      configGateway
    
      export TMK_DEBUGGER=sleep
      export DEBUG_BOARD=true
      echo "Starting Telnet Listener..."
      if [ -x /bin/bash ] ; then
        tnlited 23 -r 9911 /bin/bash -login &
      else
        export TIVOSH_POOLSIZE=800000
        tnlited 23 -r 9911 /tvbin/tivosh -login &
      fi  
    
      echo "Starting /proc Listener..."
      procd 
    fi
    
    echo "Enabling local route..."
    ifconfig lo 127.0.0.1 up
    
    EDIT: I checked the other machines rc.sysint and that was the change I had made.
     
  5. Sep 18, 2006 #5 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Yep, that's it.
     
  6. Sep 18, 2006 #6 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    To clarify, if you want to force a call, you need to do two things:

    1. Add the ,#401 dialing prefix to your phone options.
    2. Edit the DEBUG_BOARD variable as shown above. It's on line 532 in case your searching for it with vi.
     
  7. Sep 18, 2006 #7 of 102
    NickCat

    NickCat New Member

    75
    0
    Feb 17, 2004
    Rowley, MA
    Thanks. I got it working after I found the code on the other machine. The odd part is I can't seem to find the previous directions that told me to change it. So I'm stumped as to when I hacked it before.

    However I have it working, even after I removed the ,#401 as the dialing prefix.

    Is it just not necessary anymore maybe?

    I also quoted all that stuff in my other posts in hopes of helping someone else with the similar issue to find their solution faster.
     
  8. Sep 18, 2006 #8 of 102
    slydog75

    slydog75 Not all that sly

    9,199
    0
    Jul 8, 2004
    Warminster, PA
    I'm guessing we want to switch this option back to false after we force a call?
     
  9. Sep 18, 2006 #9 of 102
    NickCat

    NickCat New Member

    75
    0
    Feb 17, 2004
    Rowley, MA
    I don't think you need to.

    If you have zippered the unit I don't think it will matter, it would only make a real call out if you force the call.

    I'm just guessing... but I think that's what were looking at.
     
  10. Sep 18, 2006 #10 of 102
    tnedator

    tnedator New Member

    208
    0
    Dec 3, 2003
    I usually rely on other people to do the hard work and just download and install, so I am not clear on how to edit the files.

    Do I FTP the file to my machine, edit it in notepad and FTP it back, or do I need to edit it via Telnet. If it is via telnet, then how do I do it?
     
  11. Sep 18, 2006 #11 of 102
    HUGE2U

    HUGE2U New Member

    120
    0
    Jun 28, 2002
    I have this wokring on one machine, but it will not on the other. Both are HR10's. The rc.ysinit file is edited in both. Is there some other parameter I should be checking or somehting I forgot to turn off?

    HUGE
     
  12. Sep 18, 2006 #12 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    No! That would kill your tivo. You can ftp it to your PC, but you'll have to use a unix editor (many are free) to edit the file. Otherwise use vi to edit it though telnet. Search for vi here or "there" and you'll find plenty of info.
     
  13. Sep 18, 2006 #13 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    How about the loopback routes in your author file? Maybe the call prefix setting?
     
  14. Sep 18, 2006 #14 of 102
    HUGE2U

    HUGE2U New Member

    120
    0
    Jun 28, 2002
    the call prefix is ",#401" on both. What is a loopback setting? COuld fake call be doing anything to mess with it?


    HUGE
     
  15. Sep 18, 2006 #15 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    The loopback routes start with "route add", usually placed in your author file to block access to tivo - see the OP of this thread. Fakecall has nothing to do with it.
     
  16. Sep 18, 2006 #16 of 102
    JDAWG11

    JDAWG11 New Member

    27
    0
    Jun 3, 2003
    KANSAS
    I have a zippered hr10 and I am trying to make a daily call over the phone line. I keep getting an error during negotiation. Anyone know why this could be? TIA
     
  17. Sep 18, 2006 #17 of 102
    rbautch

    rbautch User

    3,629
    0
    Feb 5, 2004
    Chicago, IL
    Check out the other thread discussing this issue.
     
  18. Sep 18, 2006 #18 of 102
    JDAWG11

    JDAWG11 New Member

    27
    0
    Jun 3, 2003
    KANSAS
    Do you have a link or a thread title?
     
  19. Sep 18, 2006 #19 of 102
    HUGE2U

    HUGE2U New Member

    120
    0
    Jun 28, 2002

    That was it.

    thanks

    HUGE
     
  20. Sep 18, 2006 #20 of 102
    BigBearf

    BigBearf New Member

    231
    0
    Aug 17, 2005
    Tried to edit the file rc.sysinit and this is what I see on my HR 10 using Joe editor. I do not see the variable DEBUG-BOARD.
    Any suggestions, Here is the contents of my file.

    function fixmodem 30
    {
    typeset MAXTRIES=3

    if test -z "$MODEM_TYPE" ; then
    echo "fixmodem: no modem name"
    return
    fi

    typeset PATCHER=/tvlib/modem/patches/$MODEM_TYPE/ram/expect_script

    if test ! -r $PATCHER ; then
    echo "fixmodem: no patcher: $PATCHER"
    return
    fi

    #
    # There is a patcher.
    # Let's see how many times we have tried to use it.
    # The file is supposed to consist of a single line; the number
    # of characters on that line is the number of tries so far.
    #
    typeset FLAGFILE=/var/persist/modem_patch_tries
    ** Joe's Own Editor v2.9.8-pre1 ** Copyright (C) 2001 **

    Thanks,
    BigBearf
     

Share This Page