1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Xfinity OnDemand on TiVo Premiere 4

Discussion in 'HD Comcast TiVo DVR (Archive)' started by constablerc, Oct 29, 2012.

  1. constablerc

    constablerc New Member

    4
    0
    Oct 29, 2012
    I'm at wits end and I'm about ready to cancel service. Has anyone had success with Xfinity OnDemand with a Premiere 4? I bought a new Premiere 4 12 days ago. Got the cable card from Comcast, hooked it all up. I love the TiVo interface, capacity, 4-channels, etc. But the Xfinity has NEVER worked. I've now spent 12 days on the phone with Comcast tech support and TiVo tech support. Both support groups say everything is good on their side so it must be the other side's problem.

    I can access the Xfinity menu. I can browse through the shows/movies. I can select a show and it will start. But EVERY time, it freezes at 6 seconds. The time bar keeps on rolling along, but the picture stays frozen.

    I've switched out the cable card. I've re-paired them multiple times. Comcast sent the "signal" multiple times. Comcast opened a network ticket with engineering. Then Comcast told me the Premiere 4 isn't compatible with Xfinity (of course TiVo says BS). Comcast has reset new "rate codes" whatever those are. All of this and still no luck on Xfinity.

    I'm fed up. I'm within my 30 day money back window. I'm on the verge of cancelling TiVo and Comcast and switching to DirecTV and the new Genie system.

    Has anyone else fought this TiVo/Comcast battle? Did you get success? What was the secret?
     
  2. jrtroo

    jrtroo User

    4,059
    5
    Feb 4, 2008
    Have you worked through all of the steps outlined on the tivo website?
     
  3. constablerc

    constablerc New Member

    4
    0
    Oct 29, 2012
  4. SNJpage1

    SNJpage1 Active Member

    3,686
    11
    May 25, 2006
    Atlantic...
    When I had a problem with Comcast I called Tivo support and he called Comcast and we had a three way phone call. The Tivo tech basicly walked the Comcast tech thru the steps to fix everything.
     
  5. constablerc

    constablerc New Member

    4
    0
    Oct 29, 2012
    We've done that twice. The problem is Comcast always has to "research" and call me back. Which means the three-way call is dropped and when Comcast calls back it's just me and them again.
     
  6. Nov 1, 2012 #6 of 14
    constablerc

    constablerc New Member

    4
    0
    Oct 29, 2012
    Just coming back to give an update.....

    As of today I have Xfinity On Demand on the TiVo. It took 15 days, daily phone sessions with tech support and a tech visit but they finally got it fixed. After they fixed it I asked them what the final fix was. He said they had to change rate codes. The in-home tech had done that last Friday but apparently there were either multiple rate codes or multiple places where they needed to be changed. Today they finally got them all in sync and my On-Demand is working.

    Very frustrating experience. They did say that this is a new product and there aren't many techs who know how to deal with it.

    So that's the resolution to my situation. Wanted to update you all in case anyone else is having the same issue.
     
  7. habibrobert

    habibrobert New Member

    15
    0
    Nov 16, 2012
    Thanks for the update. I'm having the exact same problem! I'm very glad there is a solution to it... I've learned that a problem with Tivo is usually a dead end street especially with comcast as your cable provider. Do you have to have a tech service guy come to your house in our to fix these "rate codes"? Or can they do it over the phone?
     
  8. muerte33

    muerte33 New Member

    87
    0
    Jul 4, 2008
  9. mlyth

    mlyth New Member

    2
    0
    Nov 26, 2012
    We had the same problem. The error code on the screen was SRM-8013. When I looked it up online it said: SRM-8013 eRsnItvRfNotAvailable Subscriber attempted to watch a VOD video, however the converter determined the carrier lock is missing. Therefore, could not go on with the streaming session.

    This is what I told Comcast and the rep was able to put in the correct codes immediately. Works like a charm now.
     
  10. mkrsw

    mkrsw New Member

    6
    0
    Apr 16, 2002
    I'm stuck in GSM-7 hell. I'm in New Jersey and I can't find a Comcast rep who has a clue. Today a supervisor decided I need a 2-way Cablecard. We know that's wrong. Getting ready to give up.
     
  11. mkrsw

    mkrsw New Member

    6
    0
    Apr 16, 2002
    update: after working with many comcast techs, they finally got the correct software loaded in their servers yesterday and xfinity on-demand is finally working on my box.
     
  12. slisinger

    slisinger New Member

    1
    0
    Feb 19, 2013
    mkrsw, can you provide any more context around this server update? I am struggling with the exact same on demand problems you were having and am getting the usual support runaround. There are many tivo owners who seem to be having this problem but I have still not seen any sort of definitive explanation of how this is getting fixed for some users.

    Thanks.
     
  13. ryboone

    ryboone New Member

    2
    0
    Mar 28, 2013
    Was it tech or billing that had to update the rate code? Thanks.
     
  14. leenga

    leenga New Member

    8
    0
    Sep 21, 2007
    For some reason I just started getting this problem on my Roamio.

    Contacted comcast to fix it via chat. Told that it has the correct rate code. Then told to power cycle. Same problem. Sent refresh signal, then power cycle again. New error CL-13. Claimed this is good and it may take 45 minutes for everything to work again. Still freezing!

    Contacted another person in chat (Erolle). Told them the same things. They said that the rate code was wrong! They fixed it and now everything is working!!!
     
    Last edited: Sep 22, 2015

Share This Page