1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

WinMFS failure to create 2TB TiVo drive

Discussion in 'TiVo Upgrade Center' started by Thos19, Nov 2, 2012.

  1. Thos19

    Thos19 Member

    169
    0
    Dec 31, 2002
    Rockland, MA
    I posted before in the Series 3 forum about my Series 3 OLED Model 648250b) failing to boot. With a little handholding from unitron in replacing the capacitors on the power supply and diagnostics on the 2TB WD20EADS drive (no errors), I concluded the software was at fault and the drive needed to re-imaged.

    I purchased the drive from a vendor on ebay back in March with the software pre-loaded and it worked fine for the following 6 months. I contacted him and let him know it no longer worked.

    He offered to reimage the drive for $30, and I have been trying to reach him again for shipping and payment instructions. No luck.

    Anyway, since people on this forum have reported being successful in formating 2TB drives on their own with full capacity on the 648250 using WinMFS, I decided to do it myself since I used WinMFS successfully in the past.

    I downloaded unitron's WinMFS back-up file "648250b.tbk" and attempted to restore it onto my 2TB drive. I successfully selected the drive. I left all the defaults the same for the process, but the restore failed after partition 12 (status bar about 45% done).

    The message is "Error writing media inode 1"

    I tried again, this time using the delete format function prior to the restore, but received the same result.

    Does anyone know what this means? Maybe the drive is bad after all? Any advice?

    Thanks,

    Thos.
     
  2. lessd

    lessd Active Member

    7,695
    5
    Jan 23, 2005
    CT
    It takes a special image to make up a 2Tb drive for your TiVo, there is/was a place to download that image about 2 years ago in this form somewhere, don't know if it still there. You can only restore that image using WinMFS to a 2Tb drive, a backup of that image using WinMFS will not work.
     
  3. unitron

    unitron Active Member

    16,389
    2
    Apr 28, 2006
    semi-coastal NC
    If you meant to link to a specific comment, it didn't work, you only linked to the thread about using jmfs on the Premiere, and the OP has an original OLED S3.

    As far as I know, jmfs only works for S4s and the later S3s, the HD and HD XL (and there's a separate jmfs for the S3 HD thread), but not for the original S3.

    If that special image is discussed in a specific comment in that thread, perhaps you could locate it more quickly than the rest of us?
     
  4. Thos19

    Thos19 Member

    169
    0
    Dec 31, 2002
    Rockland, MA
    I had read recent success stories for this upgrade provided the back up image
    was software version 11.x. I'll look again for the posts.

    Thos.
     
  5. MikeAndrews

    MikeAndrews Registered abuser

    14,222
    1
    Jan 17, 2002
    Northern...
    Oh. OK. Right. The OLED S3 is limited to using 1.3TB on a 1.5TB or larger drive.
     
  6. Thos19

    Thos19 Member

    169
    0
    Dec 31, 2002
    Rockland, MA
    Here is the story behind my attempt(s):

    I exchanged PM's with "snowjay" after reading that he had successfully used WinMFS and a 2TB WD20EURS to make a drive for his S3 OLED. He remarked to me:

    "I think the key to being able to recognize all of the 2TB is having 11.x software on the TiVo.

    Then when you restore the truncated backup in WinMFS you answer "Yes" to the question if you want to use the extra space and then you also need to turn "supersize" on.

    Other than that I'm not sure, I don't think I did anything special."


    I did not have success, however. When trying to restore 648250b.tbk, WinMFS would return the error message "Error writing media inode 1". So this method, for me at least, failed.


    I recently found this post from "Lussie":

    http://www.tivocommunity.com/tivo-vb/showthread.php?p=9168233#post9168233

    He upgraded his S3 OLED from a 1TB drive with 11.x software to a 2TB Hitachi drive using WinMFS along with iBored. He copied the entire drive to the 2TB drive rather than create then restore a truncated back-up.

    I had my original S3 OLED drive, put it back in my TiVo, did a "clear and delete everything" then upgraded the software from 9.x to 11.k.

    I then used WinMFS to copy the drive from the original 250GB drive to my 2TB WD20EADS drive. It copied considerably quicker than Lussie's attempt, most likely since my Tivo drive had no shows to copy. I got as far as step 3:

    Start WinMFS again (Right-Click "Run as Administrator")

    Select Tools->MFSadd

    You will get a warning about Tivo not handling partitions greater than 1 TB, but just ignore it (hopefully, you have Tivo Software version 11.0 on your tivo)


    The warning wanted me to answer yes or no about the >1TB question. When I answered yes, WinMFS crashed (this program has encountered an error and must close). Ugh...

    2TB does work for the S3 OLED. People have gotten around the 1.3/1.5TB limitation. I had one bought from "uoph" that worked fine for 6 months until it got stuck in a reboot loop. Too bad he is so difficult to contact; at this point it would be worth the $30 to have him replace/reimage. :(

    Is it possible that the WD20EADS drive is defective despite diagnostics returning "no errors"?
    Could something else is wrong in the Tivo itself, despite me replacing 11 capacitors on the power supply, and older, smaller S3 OLED drives working fine?
    Could something left over from "uoph's" original image on the 2TB drive that is causing problems in WinMFS when I try to create a new image on the drive and create partitions?

    Ah well, I can get by with my 1TB drive, but this really bugs me...

    Thos.
     
  7. lrhorer

    lrhorer Active Member

    6,924
    0
    Aug 31, 2003
    San...
    There is a way to create a 2T drive for an S3, but no one has released any of the tools required to do it. Dvr_Dude over on E-bay will sell you a 2T hard drive pre-imaged for your TiVo, or he also will sell you a 2T hard drive and attempt to copy over your old drive for an additional fee.

    You can also attempt to copy the old drive over to a new drive using dd_rescue.

    Using a 2T drive with Win_MFS has nothing to do with the software version. It requires a hacked kernel, which can only be installed if the PROM on the TiVo has been replaced with a hacked PROM.
     

Share This Page