1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

when will tivo fix "program info will runout on 7-18-2011 connect to tivo" problem

Discussion in 'TiVo Series3 HDTV DVRs' started by tootal2, Jul 13, 2011.

  1. pninen

    pninen New Member

    103
    0
    Jun 25, 2003
    I found another forum with a thread on this exact same subject.

    We are not alone!

    Tivocommunity has an automated spam filter which prohibits me from showing you the URL of this other thread.

    Go to google, and type in

    "force garbage collection & guide indexing"

    and you'll find it immediately.
     
  2. WO312

    WO312 Active Member

    1,372
    0
    Jan 24, 2003
    Finger...
    Yes, I have found that unplugging the TA usually causes a fairly quick GC. Can't remember how long though.

    Another way is to do the channel fix. When in the channel lineup screen, press "enter". This causes something similar to guided setup and includes a GC. But it can take a long time for the GC to complete, and it does it during the "preparing to connect" phase of downloading data.
     
  3. DougJohnson

    DougJohnson Member

    225
    0
    Dec 11, 2006
    I have an original OLED S3 with 1TB and a Motorola TA. On Friday Oct 14th, I started getting the "Program info will run out" message for the first time. I found that the last GC was Oct 5th and the last indexing and cache were about that old, though I don't remember exactly.

    Based on comments here, I rebooted, which caused the indexing and cache to be updated, but not the GC. The program info message went away.

    On Saturday, the 15th, I set my router to deny Internet access to the TiVo. The calls for update started failing with "Service not found".

    This morning, the 17th, GC had completed. I have just turned Internet access back on and forced an update successfully.

    Thanks,
    Doug
     
  4. Teeps

    Teeps Active Member

    1,664
    4
    Aug 16, 2001
    Torrance,Cal...
    Do you have a Tuning Adapter?
    If so; when did it go on line?

    Stock HDD or upgraded?

    Make a trouble ticket with TiVo.
    Point them to this thread.


    When did the T/A go on line?

    Stock HDD or upgraded?

    Make a trouble ticket with TiVo.
    Point them to this thread.
     
  5. sushikitten

    sushikitten 143 down, ??? to go! TCF Club

    29,821
    27
    Jan 27, 2005
    DC-ish Suburbia
    This is ridiculous.

    My tivo says it hasn't connected since 10/7 and program data runs out today...but there are things in the to do list until 10/20 and I know for sure it connected since 10/7.

    :mad:

    Starting a reboot process again for the umpteenth time.
     
  6. WO312

    WO312 Active Member

    1,372
    0
    Jan 24, 2003
    Finger...
    I don't think rebooting is going to help anything. For a (relatively) quick fix, do the channel fix.

    This is how mine first started back in May or so. If you don't get the GC to update, you will eventually get the S03 error, which is not fun to fix. Or at least was not for me. Maybe there are easier ways to fix now - I'd have to go back and read recent posts to know for sure.
     
  7. [NG]Owner

    [NG]Owner New Member

    299
    0
    Dec 19, 2006
    Kansas City
    This thread has been a wealth of information, thank you.

    I, too, just used the "block Tivo at the router" trick to get GC to update. But it appears now that the 26+ hours between regular Tivo contact to the mothership is not enough time for GC to update on its own. GC last completed on Friday, October 14, at 9AM, and not again since.

    Now I know that I can set the router to allow Tivo access to the mothership only three days a week (which would be one way to fix the problem). But that only addresses the symptom, not the cause.

    How do you get GC to once again complete within the time between two guide updates? Or is that just not possible?

    BTW, only one of my two identical TivoHDs is exhibiting this behavior. Both are used equally often. Baffling.

    [NG]Owner
     
  8. Teeps

    Teeps Active Member

    1,664
    4
    Aug 16, 2001
    Torrance,Cal...
    When did the problem start for you?

    Are both TiVos' connected to a Tuning Adapter?
     
  9. [NG]Owner

    [NG]Owner New Member

    299
    0
    Dec 19, 2006
    Kansas City
    I think I may have been one of the first to bring this issue up. Here's my initial post about this from over two years ago. Since then, I've been able to take care of the issue by either rebooting the Tivo, or just letting the Tivo "run out" of guide data. At some point after that "run out" date the Tivo resets itself without any reboot. I presume that GC updates itself at that point (I never checked because I never knew to at the time).

    TWC. Cisco Tuning Adapters on both since acquisition. Both have shown this issue intermittently over those two years. Now affecting the basement TivoHD. Family Room HD doing fine. Both upgraded twice, first to 500GB then to 1TB. Behavior only started after second upgrade.

    [NG]Owner
     
  10. ravingfans

    ravingfans New Member

    48
    0
    Jan 11, 2009
    I'm curious whether the number of season passes might affect the problem? I noticed that after repartitioning my 2TB/2GB swap drive and adding 100 season passes to fill up the drive for testing purposes, the "loading" time took a very long time --approx 1 hour and started reminding me of the S03 issue. The connection completed successfully for me. My thought is during the loading phase, the TiVo must be trying to resolve all the season passes and wishlist entries against the channel guide it just downloaded, and this might temporarily require a large amount of memory or swap?

    Should we take an informal poll of how many season passes we have in our systems? Before the S03 problem on my original drives, I had about 15 give or take.
     
  11. [NG]Owner

    [NG]Owner New Member

    299
    0
    Dec 19, 2006
    Kansas City
    Basement TivoHD: 22
    Family Room TivoHD:19

    Neither of these include AutoRecord Wishlists, as I am at work and can only see Season Passes online. I figure each one has at least 3-5 AutoRecording Wishlists to add to those totals.

    [NG]Owner
     
  12. trackie999

    trackie999 New Member

    89
    0
    Sep 14, 2009
    Can you check tuning adapter firmware versions? Who knows maybe they are different... (just being hopeful)

     
  13. trackie999

    trackie999 New Member

    89
    0
    Sep 14, 2009
    On Monday, I set up tivoHD #2 with a 2.5 GB swap space to see if that makes a difference. So far GC keeps aborting after a few hours with eMfsTooFast exit codes. I will let it bake for a few days to collect some data.
     
  14. wtherrell

    wtherrell Member

    467
    1
    Dec 23, 2004
    Huntersville...
    My last GC was with Channel line up fix on October 15 and my GC date never updates on its own. Monday morning Oct. 17 I was installing new Premiere Elite as a companion to my THD. TWC supplied TA USB cable for the new Cisco 1520 was bad so I unplugged the TA USB from the THD set up and switched it to the Elite. This was around 10:30 AM. I took the bad cable to local TWC office and they swapped it out. Returned and put the new USB cable to the TA THD set-up. This was about 12:30 PM. Next day I was checking System Info on the THD and it showed GC completed 7:52 PM Monday evening Oct. 17. I am pretty sure that unplugging the TA USB connection for that time caused the GC to complete. So I think that instead of running Channel fix for a while I am going to try disconnecting the TA USB to THD connection for a while. I have no idea how long I need to leave it disconnected but I think I will start with 2 hours and work my way down to shorter times to see whether this will be reliable.

    Slow but steady progress.
     
  15. WO312

    WO312 Active Member

    1,372
    0
    Jan 24, 2003
    Finger...
    My first internet disconnect resulted in a GC update in 53 hours. I just had my second update, this one took 72 hours.

    I agree with wtherrell - I've been thinking of trying the same thing. I'm thinking that leaving the TA disconnected overnight might be sufficient, and convenient for me. And better than waiting days for a GC update.
     
  16. pninen

    pninen New Member

    103
    0
    Jun 25, 2003
    Today I left the tuning adapter unplugged, and this afternoon GC completed.

    I've seen this a couple of times now. Two or three days with internet unplugged while TA is plugged in does NOT produce a GC, but unplug the TA and GC completes within a day.

    I'm pretty convinced that the TA is the source of all evil.
     
  17. tootal2

    tootal2 New Member

    1,252
    0
    Oct 14, 2005
    I hope this problem is fixed in the fall update, if there is a fall update this year.


     
  18. VinceA

    VinceA New Member

    1,086
    0
    May 13, 2002
    Bayonne, NJ
    I'm at 111 Season Passes right now.
     
  19. WO312

    WO312 Active Member

    1,372
    0
    Jan 24, 2003
    Finger...
    I'm not sure we're going to see any more updates. All new efforts are on the Premier family, Series 4.

    I hope I'm wrong.
     
  20. questors

    questors Member

    79
    1
    Jun 4, 2009
    My experience:
    Time Warner Cable
    Tuning Adapter
    2 TB HD from Weaknees

    I got the warning message, GC date 10/2. I unplugged the internet and GC updated to current date on the second day (10/18).
     

Share This Page