1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Want to play nearly ANY video file on your TiVo?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by pipakin, Jan 23, 2007.

  1. greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    Mine worked for awhile, then stopped, then started again on one of my tivo. Always worked on the other. The only thing that has been changing has been the free space on my Tivo... I think the problem is related to that somehow. :confused:
     
  2. ourdoc

    ourdoc Tivo Hawaiian Style

    801
    0
    Jul 25, 2002
    Tropical...
    I don't believe TiVo would do this, and mine continues to work as it has since I installed it. It has it's problems, but it does work with all of my S2 TiVos. I would imagine the author also has RL things to attend to.
     
  3. Chew

    Chew New Member

    284
    0
    Jan 22, 2003
    I give up. :mad:

    In addition to the earlier problems, when I actually did get it to work: it took a 45 minute show three times that length to transfer (I have a 3ghz processor, I would hope conversion speed isn't the issue there). I have a 16:9 TV and when I had it set for 16:9, it came out impossible to watch. I set it for 4:3 and it plays fine, but when you have a 16:9 TV show on a 16:9 TV....you kinda want to have it fill the screen.

    So it's back to 1:1 transfer time with standard GoBack and the Videora TiVo Converter (which fills the 16:9 screen nicely).
     
  4. cdf12345

    cdf12345 New Member

    16
    0
    Jun 21, 2005

    Hmm I now believe you're on to something there. I deleted a bunch of shows on my Humax DVD-R 800 tivo and blammo! it suddenly is transfering shows without problem again. I think the confusion is that if Tivo.net cant find enough space, it sends the message to the tivo that something else is already in the transfer queue. We assume it's a bad error message, but it might be the only error message Tivo.net has the ability to display.

    So if you're having the problem of nothing in your transfer queue, but tivo telling you it'll transfer your show after the others have finished, cancel the transfer, delete some shows then try to transfer it again.

    Worked for me!

    On a serious note, I dont know pipkin at all, has anyone been in contact with him at all recently. I understand that real life does suck us away from time to time, but with it being this long, I'm starting to worry about him.

    Anyone heard from him at all?
     
  5. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Unfortunately, no. He hasn't been around on his own forums either. He had some RL water issues, so it's possible those are still keeping him busy.
     
  6. dlfl

    dlfl Cranky old novice

    6,997
    18
    Jul 6, 2006
    Near...
    Taking nothing away from Pipakin and his admirable effort, if you are having trouble with Tivo.Net and don't want to wait for improvements, give pyTivo a look. It has undergone major improvements in the last several weeks, including:

    1. Lists .tivo files and tivo-compatible mpeg2 files and transfers them without re-encoding.
    2. What appears to be a true solution to the file size estimate/end of transfer issue.
    3. Just launch it with a shortcut. It automatically scans all eligible files into the NPL for as many directories (and automatically, subdirectories) as you care to enter into its simple config file.

    It does require you to install Python but that's simple, easy and free.
    If you decide to try it, get the latest version (173 as of this writing) and look at the last few posts in the thread for the latest info.
     
  7. A@ron

    A@ron New Member

    113
    0
    Jul 18, 2003
    I could not make heads nor tales on how to get pyTivo working on my mac... yes I installed python it looks like it may be working but does not show on the tivo's NPL. I also dislike having to run it from not only the CLI but worse... the python's environment (IDLE).
     
  8. cdf12345

    cdf12345 New Member

    16
    0
    Jun 21, 2005
    i've noticed some of my video files show up as 0:00 under duration in the Tivo program information page. And I cannot transfer these videos. As far as i know these are Divx or Xvid files, and I have other divx and xvid that work fine. When I try to transfer these I get the "has been queued / will transfer when other transfers finish" even though I have no other transfers.

    Anyone else have this problem?
     
  9. A@ron

    A@ron New Member

    113
    0
    Jul 18, 2003
    I bet ffmpeg is not liking those files and hence why they show up with 0:00 duration. AVI is simply a container format and the internal video track and audio track can be a lot of different file types. So that's my guess... any pattern or anything special with those AVIs with 0:00 duration?
     
  10. Chew

    Chew New Member

    284
    0
    Jan 22, 2003
    pyTiVo never installed for me. I tried three times and the install got about 80% done and....stopped.
     
  11. dlfl

    dlfl Cranky old novice

    6,997
    18
    Jul 6, 2006
    Near...
    Don't want to make this a pyTivo thread. I suggest any problems with pyTivo be posted on the pyTivo thread -- and if you haven't tried it within the last couple of weeks, things may be different now.
     
  12. pufftissue

    pufftissue New Member

    17
    0
    Jan 4, 2005
    1. Can you do this on a series 3?
    2. What is the video quality like? Does the Tivo have some type of deinterlacing and other stuff to spruce up the pic?
     
  13. Fofer

    Fofer XenForo Rocks! TCF Club

    82,142
    306
    Oct 29, 2000
    No, the Series 3 doesn't support this kind of video transfer (TiVo To Go and GoBack)...at least not yet.
     
  14. cdf12345

    cdf12345 New Member

    16
    0
    Jun 21, 2005
  15. cmtk05

    cmtk05 New Member

    33
    0
    Feb 1, 2005
    I have heard that the dtv h20 has networking enabled. Anyone know if this is true? I would love to go to sat but i need the tivo to go function.
     
  16. akaye

    akaye New Member

    290
    0
    Jan 2, 2004
    Hmm...Interesting stuff here. I've been away from this forum for too long it seems....
    Would one these tools let me, say, watch a (virtual) DVD that I have on the computer on my Tivo?

    thx,
    AK
     
  17. Stirfry714

    Stirfry714 New Member

    13
    0
    Oct 31, 2004
    Okay, I got this installed, and I see the Tivo.NET server on my Tivo. But no videos are in the directory I selected.... and I made sure they were supported - .avi files.

    Had to use the TiVoDotNet-0.9.7a (2007-02-20 16:05) .msi installer, the "-fixed" one gave Cabinet errors.

    It says on the Tivo screen "The Tivo.Net Server.... has no recordings..."

    I noticed in the error log these messages (I moved the directory around a bit to see if that would help, but no dice):

    Source Message
    mscorlib Could not find a part of the path 'C:\Program Files\Pipkin Technologies\TiVo.Net\Videos'.
    mscorlib Could not find a part of the path 'Z:\Archive\Video'.

    The severity on both is "Minor". But if it can't find the path, that seems like a pretty big issue.

    Any ideas?
     
  18. BoyScout

    BoyScout New Member

    226
    0
    Aug 9, 2002
    Utah

    Yes, it does. However, the VOBs show up as their actual name that they are saved on your PC. If you rename to something meaningful and combine them on the PC, you have something pretty useful.
     
  19. ciscokidinsf

    ciscokidinsf New Member

    60
    0
    Jan 26, 2007
    Allright!! New Project for me. I got my 24" Imac today. I shall embark on a new dangerous trip as I attempt to run Tivodotnet in both OS X (10.4, as my friend A@ron required, I'll send you the bill soon) and in Windows XP via Parallels. Let's see, so far:

    - Wife got mad at the purchase, but its my B'day next week!
    - Got the latest OSX update 10.4.9
    - Installed Parallels latest build
    - Installed Windows XP
    - Got Mono
    - Got Aaron's Pref Pane working
    - Streaming an .avi to the Tivo as I type this. All seems well
    - Installing MS Framework 2.0

    More to come soon. I hope it works both ways:

    To Do:

    Try to run TDN pointing to a Samba Server Network Attached Storage
    If that fails, connect via USB Drive (windows and Mac)

    Long way to go, but the night is young. Wish me luck! Updates as I lose my sanity bit by bit in my quest.

    Pipakin, whenever you are, thanks dude and I hope the water damage is fixed. We miss you!

    A@ron, I bet $100 I'll be bugging you soon!

    Update #1: 9.7 failed to install (the CAB error message) 9.1a seems to have installed. Plus no one tells you the right-click does NOT work in Windows using the Apple Mighty Mouse. I gotta figure it out.

    Update #2: Windows shows TDN active, The webpage opens fine, the log shows the 2 test files, but the Windows TDN is not showing in the 'Now Playing' list... BUT, I have the Mac transferring a file right now, I wonder if the Tivo can only handle ONLY ONE instance of Tivodotnet at a time. I'll try later shutting down the Mac version and running the Windows one by itself tomorrow. Bummer, I was hoping to see the two connections hand by hand. Has anyone run two instances of TDN at at time, from different computers? (or maybe TDN is tied to IP address, and it would be only one address despite running Mac and Windows in parallels)

    Update #3: As an aside My old G4, 10.3 Imac couldn't handle TivoDecodeManager, but now it works! Sweeet!

    Update#4: No Joy (yet) The network went down last night. (IP conflict?) I lost a partial download completely from the Mac. This morning I installed TivoDesktop on Windows but it can't see the Tivos. Trying to open the connections within WIndows to the Tivos
     
  20. windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Make sure you've got the trailing slash on each folder.
     

Share This Page