1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Want to play nearly ANY video file on your TiVo?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by pipakin, Jan 23, 2007.

  1. Jan 23, 2007 #41 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
    Ok, think I've got enough to release version 0.3.0a, with the following fixes:

    - There's now a list of allowed extensions (defaults to ".avi,.mpg,.mpeg,.mov,.flic").
    - Files with odd characters in them shouldn't confuse the TiVo anymore.
    - Some other minor cosmetic/internal fixes.

    And I'll build and post it after I take the wife to dinner. Be back soon. If you're adventurous, you can get the Source from CVS and build it yourself ;)
     
  2. Jan 23, 2007 #42 of 1740
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    I can see the admin interface, and my TiVo sees the TiVo.Net NPL, but any transfer I try ends up with the "program was not transferred because the file was not found" generic error message in my Recording History.
     
  3. Jan 23, 2007 #43 of 1740
    ubuntop

    ubuntop oxymoron

    10
    0
    Jan 23, 2007
    Austin, TX
    Deadpan,


    run 'nslookup localhost'

    It should return two IP addresses, one will be your LAN IP (private IP) and the other will be 127.0.0.1.

    If you dont see 127.0.0.1, your host file is messed up (easy fix).

    so try both of those.
    hxxp://127.0.0.1:9033


    And for your WAN IP to work, you would need to setup port forwarding on your router, which is probably not smart due to there not being any security on the admin page yet.

    Hope this helps.
     
  4. Jan 23, 2007 #44 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
    I imagine that's the files with odd characters (things like spaces and commas). I'll get that new version up after dinner and it should fix it.
     
  5. Jan 23, 2007 #45 of 1740
    supasta

    supasta New Member

    2,976
    0
    May 6, 2006
    Colorado
    I will definitely be in on this ASAP, mabye after the release stabilizes.
     
  6. Jan 23, 2007 #46 of 1740
    dumbdiety

    dumbdiety New Member

    27
    0
    Feb 10, 2005
    Still getting the 'file not found' generic error. Here's the XML

    <?xml version="1.0" encoding="ISO-8859-1" ?>
    - <TiVoContainer>
    <ItemStart>0</ItemStart>
    <ItemCount>1</ItemCount>
    - <Details>
    <Title>Video</Title>
    <ContentType>x-container/tivo-videos</ContentType>
    <SourceFormat>x-container/folder</SourceFormat>
    <TotalItems>1</TotalItems>
    </Details>
    - <Item>
    - <Details>
    <Title>Test</Title>
    <ContentType>video/x-tivo-mpeg</ContentType>
    <SourceFormat>video/x-tivo-mpeg</SourceFormat>
    <SourceSize>0</SourceSize>
    </Details>
    - <Links>
    - <Content>
    <ContentType>video/x-tivo-mpeg</ContentType>
    <AcceptsParams>No</AcceptsParams>
    <Url>/Video/Test.mpeg</Url>
    </Content>
    - <CustomIcon>
    <ContentType>video/*</ContentType>
    <AcceptsParams>No</AcceptsParams>
    <Url>urn:tivo:image:save-until-i-delete-recording</Url>
    </CustomIcon>
    </Links>
    </Item>
    </TiVoContainer>
     
  7. Jan 23, 2007 #47 of 1740
    ubuntop

    ubuntop oxymoron

    10
    0
    Jan 23, 2007
    Austin, TX
    Have a nice dinner pipakin. Good work.
     
  8. Jan 23, 2007 #48 of 1740
    Deadpan Science

    Deadpan Science New Member

    22
    0
    Jan 21, 2007
    Thanks for your help, there's no result for 127.0.0.1, What's the easy fix?

    EDIT: I found the hosts file, but it only contains one line:

    EDIT2:
     
  9. Jan 23, 2007 #49 of 1740
    ubuntop

    ubuntop oxymoron

    10
    0
    Jan 23, 2007
    Austin, TX

    Here are a couple more things that I noticed.
    1.
    ----------------------------------------------------------------------------------------------
    Source Message Severity User Host User IP
    System The specified network name is no longer available Fatal Error
    System The specified network name is no longer available Fatal Error

    On both of these, I have to restart the service for Tivo to see it again. It may by good to write in a restart on fatal errors.

    2.
    ----------------------------------------------------------------------------------------------
    It does not seem to enumerate folders starting with an underscore; which I have a lot of.

    3.
    ----------------------------------------------------------------------------------------------
    This may be hard to explain, I should try to recreate it. My Tivo Now playing is in the Group format (folders). After going into the Tivo.net, then back out, it would get stuck on the Video folders (from tivo net). Also, I was no longer able to page down, it would simply refresh the screen.
    This may be a result of the special characters that are in my folder names _-(),


    4.
    ----------------------------------------------------------------------------------------------
    Got this error as well.
    ContextCallback Unknown Url: /favicon.ico Medium Error mce 127.0.0.1

    Not sure where the favicon is coming from.


    Thanks
    Ubuntop
     
  10. Jan 23, 2007 #50 of 1740
    ubuntop

    ubuntop oxymoron

    10
    0
    Jan 23, 2007
    Austin, TX
    EDIT: I just noticed your edit. So scratch all of this. Hmmm.



    Find your host file and make a backup copy (right click copy, then paste in same folder).
    Its at C:\WINDOWS\system32\drivers\etc

    You need to have this line in your host file.
    127.0.0.1 localhost

    You may want to type it out, I believe that it requires a tab between 127.0.0.1 and localhost. Or copy paste may work.

    Oh and if you see a bunch of junk in your existing host file, it my be infected, which is to say that whatever infected it may just overwrite the change we make above. If that it the case, you will need to copy the file out of the folder, add the line above, then set it to read only, then copy it back in. Oh and if there is a bunch of junk in it (URLs and such) give me a sample and I will tell you if its a bug (bad) or an ad removal entry (good).

    Ubuntop
     
  11. Jan 23, 2007 #51 of 1740
    windracer

    windracer joined the 10k club

    11,580
    3
    Jan 3, 2003
    St. Pete, FL
    Ah, yeah probably ... missed that part.

    edit: hmmm ... even after renaming the file, same thing. I'll wait for the next release.
     
  12. Jan 23, 2007 #52 of 1740
    goldfndr

    goldfndr New Member

    36
    0
    Dec 22, 2001
    Bellevue WA
    Tabs and spaces are treated the same.
    http://en.wikipedia.org/wiki/Hosts_file#Syntax
     
  13. Jan 23, 2007 #53 of 1740
    Deadpan Science

    Deadpan Science New Member

    22
    0
    Jan 21, 2007
    So, my hosts file has a single line with "127.0.0.1 localhost", however, nslookup localhost gives me

    Any ideas?
     
  14. Jan 23, 2007 #54 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
    Yeah, this was it failing when trying to get the current version number from my webserver. I've put a catch in for this.

    Seems to be fixed in the current version.

    yeah, I'm not sure where to look for this one. Happened to me once (I'm not in the group format), and itturned out to be my computer was to busy to send info to the TiVo in a timely manner.

    That's the little icon firefox and opera display up at the top. If you query the xml manually you'll see that. it's an ignorable message.

    I'm getting the release put together now. I'll post here when it's uploaded.
     
  15. Jan 23, 2007 #55 of 1740
    jmace57

    jmace57 Large Member

    1,129
    0
    Nov 30, 2002
    Bellaire, TX
    I see that your priorities are all screwed up!
    :D

    Jim
     
  16. Jan 23, 2007 #56 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
  17. Jan 23, 2007 #57 of 1740
    djmath

    djmath New Member

    2
    0
    Jan 23, 2007
    getting the following error
    System A socket operation was attempted to an unreachable host Fatal Error
    System A socket operation was attempted to an unreachable host Fatal Error
    also, if i change the video directory, I can no longer access admin page
    80 hr series 2
    thanks
    dan
     
  18. Jan 23, 2007 #58 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
    Which version you running? What are you trying to change the directory to? Can your TiVo see the server? Do you have a personal firewall? Is it set to allow 9032 and 9033 through?

    Just trying to be thorough :)
     
  19. Jan 23, 2007 #59 of 1740
    A@ron

    A@ron New Member

    113
    0
    Jul 18, 2003
    shame it's written in C#... I'd like to see a Mac OS X version ;)
     
  20. Jan 23, 2007 #60 of 1740
    pipakin

    pipakin New Member

    315
    0
    Jan 22, 2007
    Probably wouldn't be that bad to port it into another language/os. I used C# because I'm most familiar with it and it allowed me to avoid all the nasty windows internals (plus I use it at work).
     

Share This Page