1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Want to fix TiVo Desktop codec issues?

Discussion in 'TiVo Home Media Features & TiVoToGo' started by ggieseke, May 30, 2008.

  1. Apr 21, 2009 #81 of 221
    wolfwithdances

    wolfwithdances New Member

    1
    0
    Apr 21, 2009
    Greg,

    Another satisfied and grateful user here. Since I installed Adobe Creative Suite, my TiVo files had all been going to Adobe's MainConcept filter, and it had kept me from playing the files (it'd show the first still frame and refuse to play). I had to manually decode the files, which took up a lot of time and space, but your utility worked like a charm the first time.

    Long story short, bravo, sir.

    -Jeff
     
  2. Jun 16, 2009 #82 of 221
    mblynn

    mblynn New Member

    1
    0
    Mar 30, 2009
    I have played around with TDCM some and installed AC3 codec and I am still having issues with Audio and Video being out of sync on conversions for IPOD. The files before conversion play fine on WMP but are out of sync when converted for IPOD. Am I missing something. I think I browsed the posts pretty thoroughly before adding this one but did not notice same problem. Thanks.
     
  3. Jun 17, 2009 #83 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    What version of Desktop Plus are you using, and can you post an actual file somewhere that I can look at? You can send me a Private Message with the location if you do.

    You might also want to take a look at KMTTG.
     
  4. Jun 17, 2009 #84 of 221
    alexander123

    alexander123 New Member

    11
    0
    Jun 1, 2002
    Greg,

    Okay, I just want to say that you rock. Thanks for the tool.

    I will admit that although I am a computer programmer, I had a hard time figuring out that the preferred filter screen was not just "read only" :)

    I am running Vista 64, and I read somewhere in the thread that that is why the help doesn't work.

    One minor, I mean really minor suggestion would be to put some instructions on the top of the page, something like select codec that you want to be the default below, or something like that for others that are as brainless as me.

    Also, for some reason on my screen, the selected filter isn't too easily discerned.

    Also the graph shoes codecs that aren't selectable, so if they were correct, i just left things as "none", and only had to change the video codec, so that it stopped using Adobe's MainConcept filter.

    Once again, thanks a bunch!!! Had a HBO/Cinemax free weekend, tivo'd 20 or so movies, and have to archive them onto the Computer to make room.
     
  5. Jun 18, 2009 #85 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    Thanks. If I update it again I will try to address some of the suggestions. I attached a .DOC version of the .HLP file in post #65 if that helps.

    In the Settings dialog, your preferred selections will be pre-highlighted when you open the dialog. On the graph screen they will be labeled in red. Leaving anything you don't have to change set to "none" is the best way to go. If it ain't broke.....

    Enjoy.
     
  6. Jul 7, 2009 #86 of 221
    prowler27708

    prowler27708 New Member

    4
    0
    Jul 7, 2009
    And another thank you from another programmer. Beautiful bit of code and impressive commitment to helping out. Now I can get what I paid for out of my Tivo HD.
     
  7. Jul 7, 2009 #87 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    Thanks Prowler, and welcome to the forum.
     
  8. Jul 11, 2009 #88 of 221
    dougdingle

    dougdingle HD Tech

    623
    0
    Jul 4, 2007
    West Coast
    Brilliant! Fixed my problem in about 10 seconds. Thanks very much.
     
  9. Jul 13, 2009 #89 of 221
    moorek

    moorek New Member

    16
    0
    Jan 10, 2005
    Thanks for TDCM. It is helping me solve my playback problems.

    I must have installed something over the past 6 months or so as my CODECs seem to be whacked. Tivo files were always "squished" horizontally on play back. I ran TDCM and now when I play the Tivo files using TD/WMP, they play correctly (4:3). Now I want to use Direct Show Dump Utility to get them to an editable MPG file but when I do that and play the "dumped" file, the horizontal aspect is squished again. My guess is that I have another CODEC setting somewhere hosing me but I can't figure it out. Ugh. It is giving me a headache. This all used to work flawlessly.

    If anyone has a guess as to what I should be looking at I would appreciate it. I set the Direct Show video codec to be Microsoft MPEG-2 Video Decoder and that seems to work correctly.


    Thanks,

    Kevin
     
  10. Jul 14, 2009 #90 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    TDCM only affects the playback of .TiVo files, and the squashed look is typical of codecs that ignore the aspect ratio setting within the video stream. Once you convert them to another format, DirectShow's standard method of building filter graphs takes over and the only way to change it is to modify the Merit settings of your codecs manually (the highest merit value wins). TDCM can also be used to open other file types to look at the filter graph they will use - it just won't control them.

    Use the Settings dialog in TDCM and write down all of the video codecs and their merit value. Then run DirectShow Filter Manager from http://www.softella.com/dsfm/index.en.htm and use it to change the merit of the Microsoft codec to something higher than the one being used to play .MPG files. You could also just uninstall the offending codec if it's not part of another program that you use.

    Warning: You can 'break' other programs by doing this, so backup your PC or take a System Restore snapshot before making any changes. I would also document the changes you make just in case.
     
  11. Jul 14, 2009 #91 of 221
    moorek

    moorek New Member

    16
    0
    Jan 10, 2005
    Following your steps (kind of), I found that Nero DVD Decoder had control of all playbacks except for TIVO files. I tried to change the merit value but it had no effect. I increased the Microsoft MPEG-2 Video Decoder and still nothing. I ended up unregistering the Nero DVD Decoder and I can finally playback MPG files with WMP and make edits with Window Movie Maker.

    Thanks for your help!
     
  12. Jul 14, 2009 #92 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    I had a hunch it might be Nero (I have it too). You may be able to keep all of the Nero software functional and still play MPEG-2 files properly by increasing the merit value of the Microsoft MPEG-2 Demultiplexer - once the Nero Splitter grabs hold of the initial stream it tends to prefer its own codecs. I have Desktop Plus and its demuxer has a higher default value than either Nero or Microsoft, so it wasn't an issue on my system and Nero still works fine.

    In any case, glad you got it working.
     
  13. Sep 21, 2009 #93 of 221
    xxray5

    xxray5 New Member

    2
    0
    Sep 20, 2009
    i have a working video and audio codec and im using the TDCM program to play the video, the the audio and video don't line up, any way i can fix this? im using a audio and video codec i know for a fact works because i got them from this site
     
  14. Sep 22, 2009 #94 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    Can you post the exact demuxer, audio & video codecs it's using? The file version numbers of each (right-click the codec & choose Properties) and a screenshot of your filter graph would also help.
     
  15. Sep 22, 2009 #95 of 221
    Kablemodem

    Kablemodem Get the ketchup.

    19,274
    3
    May 26, 2001
    Sherman...
    I was able to get the video working, but I don't get any audio. I am running TiVo Desktop 2.7 on WinXP and I have a S3. The program gives me two audio codecs from which to choose, and neither works.
     
  16. Sep 23, 2009 #96 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    If you have a Series 3 or HD, you are probably missing a Dolby codec. Google ac3filter for a good one.
     
  17. Sep 23, 2009 #97 of 221
    Kablemodem

    Kablemodem Get the ketchup.

    19,274
    3
    May 26, 2001
    Sherman...
    And now it works! Thanks!


    I used to have ac3filter installed, but I probably uninstalled at one point forgetting what it was for.
     
  18. Sep 26, 2009 #98 of 221
    tgorton

    tgorton New Member

    1
    0
    Sep 26, 2009
    just wanted to post another thank-you to ggieseke -- like so many others, many months of .tivo-playing issues solved in seconds.

    many thanks!
     
  19. Nov 7, 2009 #99 of 221
    jbonfilio

    jbonfilio New Member

    2
    0
    Sep 12, 2003
    Trenton, NJ
    Ok, a lot of this stuff is over my head. I transferred a TiVo program to TiVo Desktop on my laptop (XP Pro). There is no audio when I play back the TiVo file in Windows Media Player. I downloaded your TDCM and I was able to get the audio when selecting ArcSoft codec, but only when I play it back within the TDCM window. When I play the same file in Windows Media, no audio. I converted this program to an mpg file with the Direct Show Dump Utility, which is awesome, but no audio there either.

    Can anyone help? Also, if i share this program with someone, will they have the same problem with audio, or is that problem associated with each computer? Thank you in advance.
     
  20. Nov 8, 2009 #100 of 221
    ggieseke

    ggieseke Active Member

    4,028
    12
    May 30, 2008
    TDCM only affects .TiVo files, so once you convert them to MPEG it has no effect. Try setting your preferred audio codec back to (none) and install ac3filter (http://ac3filter.net/). That codec does the trick for most people.
     

Share This Page