1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Video on Demand Problems

Discussion in 'TiVo Premiere DVRs' started by dave13077, Jul 5, 2012.

  1. dave13077

    dave13077 Member

    278
    0
    Jan 11, 2009
    I have an Elite (XL4) and regular Premier. Last night I tried to watch Netflix with my Elite. When I tried to go into "Video on Demand" the screen went black for about 20 seconds then the blue screen with the Tivo logo in the upper left hand side. Nothing would load just the "please wait" on the screen. This went on for 5 minutes until I hit the Tivo button and the Tivo menu loaded. I rebooted the unit and the same thing happened. I also tried the regular Premier and the same thing was happening. After a couple more attempts the Video on Demand menu loaded (took a couple of minutes of please wait) and we could load Netflix. Anyone else have any issues with this the past couple of days?
     
  2. S3-2501

    S3-2501 New Member

    205
    0
    Jun 2, 2007
    FWIW, I had a similar situation with an S3 and TivoHD yesterday. It took muck longer than usual to load the VOD menu. I figured the servers were busier than usual due to the holiday.
     

Share This Page