1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Update glitch, sound and no app store?

Discussion in 'TiVo Premiere DVRs' started by drweb, Jan 12, 2014.

  1. drweb

    drweb TiVo User & Lover

    65
    0
    Sep 17, 2008
    California
    Greetings,
    TiVo Premiere here. I had already gotten the Fall update, I do believe, but two days ago, there was an update pending and it was set to reboot at 2AM. I had to reboot the system because I was having a sound hiccup issue, and somehow, I think it messed up whatever update was there. I'm not sure it installed okay. I tried connecting 3 times or more to get it again, but no luck.

    I don't have the App store on the menu, although the panels say I got an update for Netflix app etc. I looked at Netflix, and it's the same UI. I tried rebooting the UI, with Thumbs-down, Thumbs-up, Play, Play, but same HD UI appears, and no App store.

    Anyone have a clue how to fix this to get the store UI and new Netflix app, or is it something Support will have to help with?

    Best,
    DrWeb
     
  2. lgnad

    lgnad Pantless Mofo

    691
    0
    Feb 14, 2013
    Massachusetts
    what version of the software are you running?

    Settings & Messages -> Account & System Info -> System Information
    Third item down "Software Version"

    If its 20.3.8 you are running the latest version.

    The new features dont always show up right away. When I got 20.3.8 it took almost a week for the app store, new netflix app to appear, and many other folks have commented on here the same thing. I tried forcing a few connections for updates, HDUI resets and reboots of the whole system and they didnt help.
     
  3. drweb

    drweb TiVo User & Lover

    65
    0
    Sep 17, 2008
    California
    Thanks, Ignad.. I knew I couldn't be the only one. The thing that was odd was TiVo started taping a show just as I hit the connect for restart, so I thought maybe I had done something wrong.
    I'll just wait a bit.. and yes, it says 20.3.8 in the software information.

    Thanks for the help,
    DrWeb
     
  4. shamilian

    shamilian Member

    442
    0
    Mar 26, 2003
    NJ
    go into settings
    channels
    providers.

    deselect youtube, netflix.

    go out to tivo central

    go back to settings
    channels
    providers

    select youtube, netflix
     
  5. drweb

    drweb TiVo User & Lover

    65
    0
    Sep 17, 2008
    California
    Thanks, tried that.. no change. I didn't reboot it after...

    Best,
    DrWeb
     

Share This Page