1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tvlog - help with errors

Discussion in 'TiVo Underground' started by TK2006, Dec 19, 2006.

  1. TK2006

    TK2006 New Member

    15
    0
    Nov 17, 2006
    Chicago, IL
    I have noticed my tvlog located at /var/logs is getting quite large. It is at 45 MB and rapidly increasing in size.

    It seems like every 10 seconds the log writes the following error:
    Dec 19 17:45:52 (none) ApgCamInterfaceBase[226]: FindServerObject: scanner found nothing at A00000000, err = 0x0
    Dec 19 17:45:52 (none) ApgExprEvaluator[226]: DoEvaluate() returned err = errDbNotFound, setting result to zero

    Does anyone know what this is or how to correct it? I have been searching these forums for a few hours and can't find anything.

    Thanks for any help.
     
  2. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    if you haven't done so, I'd reboot (tivo will probably clear the log, so if you think there's important info in there, you could ftp it off, first)

    if the messages continue, you may want to force a gsod to see if there's an issue in MFS
     
  3. cheer

    cheer Registered Offender

    1,406
    0
    Nov 13, 2005
    Gurnee, IL
    There's a thread over at DDB about this. This is happening to a lot of people, and nobody is sure why as of yet.

    And if you don't reboot, Tivo will, because at the rate these pile up, it doesn't take long for /var to fill. Of course, /var will get wiped when that happens...
     
  4. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    actually, var shouldn't be wiped... it purges logs first, and that should bring the space in var back within acceptable limits, so it shouldn't have to perform a wipe. (ymmv)

    edit: I just checked and all 3 of my HDVR2s running 6.2 have this showing up. But it's not causing a tivo reboot, apparently syslogd is smart enough to auto-purge a runaway log if it gets too big.
     
  5. TK2006

    TK2006 New Member

    15
    0
    Nov 17, 2006
    Chicago, IL
    I tried the reboot option and the problem still occurs.

    I saw that thread over at DDB too. I just decided to add a cron job to wipe the tvlog file daily. Can't figure out the root cause, but at least it won't fill up var and cause issues that way.
     
  6. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Any chance you could give a hint as to what the command portion of your cron job looks like? I would like to do this also as well as a cron job to restore a backup of my favorite channels.
     
  7. TK2006

    TK2006 New Member

    15
    0
    Nov 17, 2006
    Chicago, IL
    First, I would make a backup of your "root" file located here:
    /var/spool/cron/crontabs/

    Then edit the "root" file

    I added these lines to mine:
    # Delete the tvlog file if it exists every day at 10:05am cst
    05 16 * * * rw; rm /var/log/tvlog; ro; echo "`date` tvlog wiped" >> /var/log/cronlog-main

    This sets the file system to read/write, deletes the log file, then sets it back to read-only. Also write a quick line to the cronlog to make sure it's working.
     
  8. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Thanks! Now that I see the command you used I should have taken a few minutes to try and write it myself because it is fairly obvious and easy. :) I'll try not to be so lazy next time. :eek:
     
  9. BTUx9

    BTUx9 back?

    1,596
    0
    Nov 13, 2003
    Rockport, MA
    of course, if you're doing that, you might as well just have it remove the log at bootup, rather than cron, because by using rm on a log, it stops logging to that file (untill the next reboot)... to clear the log but allow it to continue logging, use
    Code:
    cp /dev/null /var/log/tvlog
     
  10. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Thanks for the linux lesson. :) Will use that instead.
     
  11. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    That seems to work. This log fills up fast!!!

    If I wanted to wipe these 3 times a day instead of once per day, how would I do that? Like this?
    Code:
    05 */3 * * *
     
  12. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    I'm not sure if this helps or not but I have noticed that I am getting this on a subbed unit:
    Code:
    Dec 22 00:15:07 (none) ApgCamInterfaceBase[227]: FindServerObject: scanner found nothing at A00000000, err = 0x0
    Dec 22 00:15:07 (none) ApgExprEvaluator[227]: DoEvaluate() returned err = errDbNotFound, setting result to zero
    And this on an unsubbed unit:
    Code:
    Dec 22 00:20:18 (none) ApgStateMachine[188]: Transition from state ACQUIRE_MARKER to ACQUIRE_MARKER
    Dec 22 00:20:20 (none) ApgFrameIter[244]: ApgFrameIter in red dye mode!
    Dec 22 00:20:20 (none) ApgFrameIter[244]: reporting redDye: 0x00cf631c 0x00cf6470 0x00cfad84 0x00cfa400 0x013a706c 0x013ce190 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 
    Dec 22 00:20:20 (none) ApgSmartSorter[244]: Sorter detected red dye frame--clearing filters 
    Dec 22 00:20:20 (none) ApgSmartSorter[189]: reporting redDye: 0x00cfc54c 0x00d1dbfc 0x00d1db78 0x00d04bfc 0x00d0386c 0x00d03760 0x013a706c 0x013ce190 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 0x00000000 
    Dec 22 00:20:20 (none) ApgReader[189]: Reader detected red dye frame, clearing filters 
    Dec 22 00:20:20 (none) ApgRunlet[188]: Runlet detected red dye
    Dec 22 00:20:59 (none) Recorder[242]: Adding check schedule task
    Dec 22 00:21:59 (none) Recorder[242]: Adding check schedule task
    Dec 22 00:23:59 (none) last message repeated 2 times
    Dec 22 00:25:59 (none) last message repeated 2 times
    Both repeat over and over.
     
  13. Dmtalon

    Dmtalon I love Tivo...

    194
    0
    Dec 27, 2003
    West...
    If your not going to save off / monitor the logs you could also just comment out the line in your /etc/syslog.conf file that relates to tvlog and reboot.

    No more tvlog 'logging' that is what I did until this 'problem' is resolved.

    From:
    local0.info;local0.!err -/var/log/tvlog

    To:
    #local0.info;local0.!err -/var/log/tvlog
     
  14. sk33t3r

    sk33t3r New Member

    498
    0
    Jul 9, 2003
    Houston, TEXAS
    I just finished a download and install and I was at 3.1.5f and now im at 6.3 A!!!! Damnit, I wanted 6.3 B. Well time to wipe it out and put my 3.1.5f image back on.
     
  15. Luv2DrvFst

    Luv2DrvFst New Member

    186
    0
    Nov 7, 2005
    I know a better solution for the tvlog problem has been proposed, but I thought I'd point out that /var is always mounted rw so there is no need for this portion of the command. Also, I'm fairly confident that "rw" and "ro" aliases don't work in a line in the crontab. You have to use the full command of "mount -o remount,rw" or "mount -o remount,ro". Just my experience.
     
  16. SteelersFan

    SteelersFan "On Welfare"

    819
    0
    Sep 6, 2004
    Saugus, CA
    Good point about the ro and rw. I've changed my job to exclude those commands. Just so everyone knows, it works either way. :)
     
  17. kkluba

    kkluba New Member

    235
    0
    Oct 18, 2002
    This worked well for me...
     
  18. twosox

    twosox New Member

    21
    0
    Jan 1, 2003
    I'm having the log problem noted in this thread, but I'm also experiencing a problem with my DirecTiVo where my Season Passes are not being recorded, and the guide data is somehow corrupt.

    This is the other thread on the recording/guide issues:
    http://www.tivocommunity.com/tivo-vb/showthread.php?t=332166

    Any chance these two issues are related?

    I have 2 Series 2 DirecTiVos -- modified both for networking and multi-room, but only one of them is having the problem (so far).
     

Share This Page