1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Turn off Tapatalk?

Discussion in 'Forum Operations Center' started by IndyJones1023, Mar 20, 2014.

  1. IndyJones1023

    IndyJones1023 Archeologist

    53,145
    6
    Apr 1, 2002
    Orlando, FL
    Every time I come to the forum with a mobile device I get the annoying request to use Tapatalk. Isn't there some way to remember that I always say NO!
     
  2. Mike Lang

    Mike Lang Administrator Staff Member Administrator TCF Club

    6,256
    140
    Nov 17, 1999
    If the device is handling the cookie correctly, it should only ask once every six months. I certainly don't see it any more often than that.
     
  3. IndyJones1023

    IndyJones1023 Archeologist

    53,145
    6
    Apr 1, 2002
    Orlando, FL
    I guess none of my devices handle cookies correctly.
     
  4. Unbeliever

    Unbeliever Random Nobody

    5,184
    5
    Feb 3, 2001
    Altadena, CA
    This request happens on a very regular basis by different people each time with the same type of report. Every single mobile browser, Firefox, Safari, Chrome, etc. behaves the same way. Close the session and the next time you visit, you get the nag popup. Mike is in denial. "If it doesn't happen to me, it doesn't exist." For each one of these reports, he replies the same way. "Your device's browser is broken."

    Every time, I come in, do a cookie analysis and report here that the cookie is a session cookie, and not a 6 month cookie, and therefore cookies are being properly handled by being deleted when you close the browser and/or reboot the device. Each time, it is ignored. Here's one as an example:

    http://www.tivocommunity.com/tivo-vb/showthread.php?p=9271108#post9271108

    I have a hypothesis that there is another cookie along the lines of "I'm an admin, don't bug me." that is properly being set to 6 months. Mike, create a fresh user and use a fresh browser with no Mike Lang cookies on it, and I bet you will see what all of us are seeing.

    The other hypothesis is that there is an obscure User setting that sets the cookie behavior on TCF. (for that, find an old abandoned account or two)

    --Carlos V.
     
  5. Unbeliever

    Unbeliever Random Nobody

    5,184
    5
    Feb 3, 2001
    Altadena, CA
    Yay! Sometime in the last 2 hours, someone fixed it.

    The tapatalk nag cookie is now set way in the future. The "we have an android app" nag took a couple times for it to get set way out, but the "we have an iPhone app" is still popping up. We're getting closer.

    The fact that the behavior changed at the exact same time on 4 different types of browsers on 3 different devices says this was a fix on your end. Don't tell us it was a browser issue.

    --Carlos "thank you!" V.
     
  6. Peter Redmer

    Peter Redmer New Member

    313
    0
    Jan 2, 2008
    Hi Unbeliever,

    I'm glad things are moving in the right direction, but I wanted to clarify that in all honesty, we haven't changed anything.

    We simply use what Tapatalk provides us: an installation that lives on our server that activates the plugin. I checked the admin area and Tapatalk does not appear to provide the ability to customize cookies/etc from the admin panel, which makes sense. The changes would have to be made the script/code directly, AFAIK.
     
  7. Unbeliever

    Unbeliever Random Nobody

    5,184
    5
    Feb 3, 2001
    Altadena, CA
    Ooookay. Visits several times a day for years, including right before my post in this thread, all had the nag. I post, and 2 hours later no nags. Awful huge coincidence.

    The only thing different was me setting up Wireshark on a laptop with a switched useragent so I could catch the cookie before it hit the browser to reproduce what I did last year. That's the first time I noticed the cookie (in the capture) was set to a real date instead of being a session key. I don't have the data anymore for last year, but it was session before.

    --Carlos V.
     
  8. IndyJones1023

    IndyJones1023 Archeologist

    53,145
    6
    Apr 1, 2002
    Orlando, FL
    It seems to have been fixed for me, too, somehow.
     
  9. mooseAndSquirrel

    mooseAndSquirrel Well-Known Member

    4,761
    44
    Aug 31, 2001
    Whatsamatta U
    So now this is happening to me. I ask safari to "remember me"' but now, quite regularly, I have to cancel tapatalk and then login all over again. So it's doubly annoying. Other sites I can have the login auto filled.

    Anybody have a permanent fix?
     

Share This Page