1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TTG Transfer - Choppy PC Playback

Discussion in 'TiVo Series3 HDTV DVRs' started by W Auggie H, Oct 24, 2007.

  1. W Auggie H

    W Auggie H Tivo Enthusiast

    364
    0
    Oct 11, 2001
    Atlanta,...
    I was excited, as most of you were today(yesterday) to finally have MVR/TTG enabled for my THD. One of the first things I tried was to transfer "Heros"(HD) from this week to my PC. It took several hours to transfer. When I tried to play it back on my PC using the default Windows Media Player the playback was choppy. The audio seemed fine, it was just the video. Not smooth at all. Picture was good but playback, not so much. Any thoughts. My PC is not that old. P4 with 2.5GB RAM.
     
  2. jrock

    jrock New Member

    676
    0
    Aug 27, 2002
    Connecticut
    I have a P4 3.4 GHZ with 2 GB of ram and it took me 1 hour to transfer Ugly Betty in HD. The file is just under 6 GB. I do notice it is very slightly choppy every so often. It has to be due to the large file size. I'm not sure how to fix this though. My PC is plenty powerfull enough. Maybe we need a better player than windows media.
     
  3. drew00001

    drew00001 New Member

    311
    0
    Jan 13, 2007
    I am assuming you have SDRAM since you have a P4. Is this correct?

    I have a AMD FX60 with 2 GB DDR ram. This is faster than a P4 but probably not as fast as a Intel Core 2 Duo (w/ DDR2 RAM).

    The only video I transferred was "The People vs Larry Flint," which was a 2.5 hour movie, at 18GB. The film transferred fine, but was choppy because playback outpaced the download. Next time I transfer something, I will wait longer before starting to watch . . . Or maybe I will buy a better router. The one I am using isn't good enough for an 18GB file transfer.

    My best guess is that your system is getting old . . . sorry. :( I would also recomend a good graphics processor. Your post did not indicate what you are using.
     
  4. rupesh97

    rupesh97 New Member

    13
    0
    Nov 3, 2006
    Depending on the relative speed of your hardware components, your hard disk could be the bottleneck. In that case, you may wish to disable anti virus checking for that folder. This can do wonders in some situations.
     
  5. pkscout

    pkscout Active Member

    3,928
    0
    Jan 10, 2003
    Honolulu, HI
  6. jtseltmann

    jtseltmann New Member

    147
    0
    May 22, 2005
    I have a new Dell Dimension Intel Core2 Quad 2.4ghz processor with 2Mb of Ram with Windows Vista. I have tranferred recordings to the PC via wireless and now via wired and I watched the entire program on the 24" widescreen...it was flawless. I had no problems with audio or video. The entire 1 hour HD recoding of Law And Order SVU took about 1.5 hours to xfer.
     
  7. sinanju

    sinanju Member

    653
    1
    Jan 3, 2005
    I'm seeing the same thing on my Thinkpad T60 with a 2GHz core duo processor and 3GB of memory.

    Interestingly, if I liberate the MPEG with DSD and view it in Intervideo WinDVD, it's perfect. Additionally, the Intervideo codecs result in better picture and sound than the codecs that come with the Desktop Plus.
     
  8. Revolutionary

    Revolutionary Too sleepy for TV...

    575
    0
    Dec 1, 2004
    Virginia
    EDIT
    /EDIT

    You have a combination of 1) an insufficient system and 2) poor software to blame.

    Taking the latter first, WMP is a lowsy player at default settings. You need to tweak the performance settings and employ a good MPEG-2 codec to get good playback performance. I recommend the NVIDIA PureVideo codec. To get smoother playback, try changing the "default renderer" in the Advanced performance settings dialogue to "Video Mixing Renderer" and not "Legacy;" use use the "Overlays" tick.

    That said, no codec or settings tweak will help if your system if it just doesn't have the horses. High definition MPEG video is very resource intensive. The hardware requirements for HD-DVD and Blu-Ray bear this out (dual core processor, 1GB of RAM, advanced video card). What speed is your P4? What kind of video hardware do you have (discrete video card, integrated video, etc)? I personally have a P4 3.2Ghz with 1.5GB of RAM and a GeForce 8600 card in my HTPC, and it struggles on high bitrate recordings with a lot of motion in the frame. Lower bitrate stuff plays like a champ.

    Your harddrive is almost certainly not the bottleneck. Virtually any harddrive in the last 10 years will have sufficient bandwidth to push a constant HD MPEG-2 stream.

    Lastly, try closing any unneccessary software or system processes (all the crap in the system tray, other than your firewall and anti-virus) and see if that improves playback.
     
  9. sinanju

    sinanju Member

    653
    1
    Jan 3, 2005
    Well, none of those things are the problem on my system. All of the settings to which you refer have been flipped in just about every permutation. Nor is it a horsepower problem -- the exact same recording simply plays beautifully in WinDVD once the mpg has been liberated.

    I agree that WMP is crappy software. Additionally, and unfortunately, the Plus codecs seem to be more geared toward transcoding for low bitrate/low resolution devices than high-quality playback.

    The odd thing is that disabling the Plus codecs by renaming their files so that WMP is forced to use the Intervideo codecs still results in choppy (more like a rollercoaster, actually) playback. So, my bet is on something in WMP or the DirectShow filter itself.

    But it isn't horsepower... WMP is taking 65% of my CPU and the rest is going to System Idle.
     
  10. Revolutionary

    Revolutionary Too sleepy for TV...

    575
    0
    Dec 1, 2004
    Virginia
    I wasn't specifically responding to your post, actually. My comments were directed at the OP.

    But addressing yours, there may be two options. First, are you using discrete graphics or an integrated chipset? The GPU is a major factor in accelerated HD video playback.

    Second, renaming the default DirectShow video codec is a very, very bad idea. If you want to change the codec that WMP uses by default, then you need to get the Radlight filter manager (or equivalent). Search for it on afterdawn.com or videohelp.com. Just change the relative priority levels for the Tivo Plus codec (-) and the Intervideo codec (+). XP requires a restart to register the changes.

    Third, depending on what Intervideo codec you are using, it may not default to use hardware acceleration in WMP, even though it will in the Intervideo player. This alone could account for the difference you are seeing between players. You can search on places like afterdawn and the MediaPortal forums to find the relevant registry changes to make sure that the Intervideo codec uses hardware acceleration in WMP. This is another reason I prefer the NDIVIA codec: not only does it give the best playback for MPEG-2 video, but it also allows you to select hardware acceleration in the codec control panel. :up:
     
  11. W Auggie H

    W Auggie H Tivo Enthusiast

    364
    0
    Oct 11, 2001
    Atlanta,...
    You are probably correct. I haven't really done any tweaks to WMP and I am using the defaults. I don't watch much on my PC. In general everything else that I play runs fine. It is just with these huge HD shows. I am going to look at a few things you mention and will see how that goes. Thanks for the info.
     
  12. wolverines

    wolverines New Member

    39
    0
    Jul 14, 2005
    What is DSD?
     
  13. snathanb

    snathanb New Member

    462
    0
    Sep 13, 2006
    Direct Show Dump.
     
  14. gdomeier

    gdomeier New Member

    72
    0
    Nov 6, 2001
    Sartell, MN USA
    I have a similar problem. I was getting no video playback or audio. I installed a windows codec bundle. That give me choppy video playback with no audio. I have tried playing hd and sd content. The sd actually plays worse.
     
  15. Revolutionary

    Revolutionary Too sleepy for TV...

    575
    0
    Dec 1, 2004
    Virginia
    PC Specs?

    What codec bundle? The only one I trust is Cole2k.
     
  16. bown

    bown New Member

    80
    0
    Nov 3, 2006
    I was having really choppy playback. In fact, HD content was unwatchable.

    I looked at the "Advanced Performance" settings in WMP and turned on "Turn on DirectX Video Acceleration" and that fixed my problem. I'm not sure why that wasn't turned on by default, but at least it works now.
     
  17. gdomeier

    gdomeier New Member

    72
    0
    Nov 6, 2001
    Sartell, MN USA
    I have 1.5 gigs of ram. I don't recall my processor speed, but it's older. An athlon 2600 or something similar.

    I did install the cole2k. Same thing. I found last night that installing videoredo, that my playback and sound work pretty well with that.
     
  18. yunlin12

    yunlin12 Tivonation Citizen

    1,223
    0
    Mar 14, 2003
    San Jose, CA
    I assume you guys all have S3 or HD, are you guys on 9.2J or 9.1 software?
     
  19. Laserfan

    Laserfan New Member

    412
    0
    Apr 25, 2000
    USA
    I thought that Tivo Desktop added a DirectShow filter so WMP could play .tivo files, but I don't see anything like that in the TD installation.

    What IS the codec that is used to play-back .tivo files?
     

Share This Page