1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to add Roamio activity to my ProntoPro remote

Discussion in 'TiVo Roamio DVRs' started by cosmicvoid, Oct 17, 2013.

  1. cosmicvoid

    cosmicvoid Tivo noob

    65
    0
    Oct 13, 2013
    Seattle-ish
    The Pronto IR code database doesn't have a codeset that matches the Roamio remote buttons, so I have learned the Roamio IR codes on the Pronto. This mostly works pretty well, except for the "Guide" button.

    The learned Guide code doesn't produce the correct action on the Roamio, and I cant figure out why. I tried copying the Guide button code from some old TiVo configurations, but they produce the same result. Does anyone have a list of Pronto hex codes for newer model TiVos, in particular the "Guide" button code?
     
  2. DigitalDawn

    DigitalDawn Member

    181
    1
    Apr 26, 2009
    Jupiter, FL
    Guide Button

    0000 006D 0022 0002 0155 00AB 0015 0040 0015 0015 0015 0040 0015 0015 0015 0015 0015 0015 0015 0015 0015 0040 0015 0015 0015 0015 0015 0015 0015 0015 0015 0040 0015 0040 0015 0015 0015 0015 0015 0015 0015 0040 0015 0040 0015 0015 0015 0040 0015 0040 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0040 0015 0040 0015 06D5 0155 0055 0015 0E55
     
  3. cosmicvoid

    cosmicvoid Tivo noob

    65
    0
    Oct 13, 2013
    Seattle-ish
    Thanks for your help.

    Your code looks like it matches what I learned from the Tivo remote, but I inserted it into the button just to check. The result is the same.

    The "same" is it toggles a "mini info banner" at the bottom of the screen. This is different than what the "info" button produces. I tried different durations (100ms, 200ms), and holding the button, but same result. So I'm still baffled by this one.

    Maybe its time to rig up a photodetector and haul out the digital o'scope, and see how the IR signals compare. What a hassle.
     
  4. DigitalDawn

    DigitalDawn Member

    181
    1
    Apr 26, 2009
    Jupiter, FL
    That's really odd because I use this code on a Series 3, an XL4, a Roamio Pro and several Minis and it works just fine.

    There must be something going on in your Pronto project. Try this. Create a new Pronto file and set it to IR only. On the home screen insert a button. Paste the hex code into the button, and try it via IR. This way you will know f you have a corrupted Pronto file and/or if there's a problem with your RF configuration.
     
  5. nyjklein

    nyjklein J-E-T-S JetsJetsJets TCF Club

    181
    0
    Aug 8, 2002
    North...
    I'm confused why you found it necessary to learn all the buttons. The IR codes for most TiVo buttons have remained the same forever. There are just a couple of new buttons on the Roamio remote, e.g. Back.

    I have a Pronto TSU 9600 and S3, S4 and Roamio TiVos all using IR from the OneRemote database with just a couple of manually learned buttons added.

    P.S. I should also note, that I primarily control my TiVos via TCP/IP control via JavaScript from my Pronto.

    Jeff
     
  6. cosmicvoid

    cosmicvoid Tivo noob

    65
    0
    Oct 13, 2013
    Seattle-ish
    Tried this, and it works :). Then I tried to use a Guide button definition from the factory DB, in my configuration... did not work, no effect at all. Then I pasted your Guide code directly into the button in my config, instead of referring to my 'learned' database definition; that also works.

    So my problem is solved, but it doesn't answer the question of why that specific code in my learned DB device does not work, when all the others do.

    Thanks for your help! :up:

    Being a programmer and geek, I just like to know what the code behind each command is, no other reason.

    However, since I discovered in my experiment mentioned above, I can't rely on the codes in the Philips database to work. To be fair, I didn't try more than one Tivo codeset from the DB, and I'm too lazy to try others, but the fact that the one didn't work is informative (in a bad way).

    BTW, using a TSU9400, with a fair amount of Javascript, but no TCP/IP, just IR and WiFi extended IR (RFX9400).
     
  7. eht

    eht New Member

    16
    0
    Dec 5, 2013
    So does anybody have the hex code for the "Back" button?
     
  8. JonHB

    JonHB New Member

    69
    0
    Aug 27, 2007
    Jeff, I could never get my IP control of Tivo working flawlessly. Would you mind sharing the Tivo code you've done?
     
  9. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,444
    165
    Apr 17, 2000
    Nevada
    I still have my old Pronto but my computer doesn't have a serial port to connect it to so I have no way of learning the code sorry. (not sure the software would even run on Win7 anyway)
     
  10. JonHB

    JonHB New Member

    69
    0
    Aug 27, 2007
    This should work:
    0000 006E 0022 0002 0155 00AA 0015 003F 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 003F 0015 0015 0015 0015 0015 003F 0015 0015 0015 003F 0015 003F 0015 0015 0015 0015 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 003F 0015 003F 0015 0015 0015 0696 0155 0055 0015 0E1E
     
  11. ganymebe

    ganymebe New Member

    1
    0
    May 22, 2014
    I know this forum entry has been dead for a while, but I seem to be having a similar problem. Every button on my Pronto works except Live TV. It worked on my old TiVo but not my new Roamio. Can anyone offer their IR code for Live TV? Even when I learn it, it looks legit but it doesn't work. Using the standard Tivo remote works 100% of the time. I am baffled.
     
  12. CrispyCritter

    CrispyCritter Purple Ribbon Wearer

    3,646
    0
    Feb 28, 2001
    North...
    I can't help you directly. However, I can tell you that the Live-TV button changed codes early on (in the change-over from Series 1 to Series 2 TiVos?), and that TiVos for that reason have to correctly identify the type of remote in order for Live-TV to work. So what is happening with you, IMO, is some other button is identifying the remote type incorrectly for your live-TV code.
     
  13. cosmicvoid

    cosmicvoid Tivo noob

    65
    0
    Oct 13, 2013
    Seattle-ish
    Here is the code I use for Live TV:

    0000 006E 0022 0002 0156 00AB 0015 003F 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 003F 0015 0015 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 003F 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 0015 003F 0015 003F 0015 003F 0015 06EF 0156 0055 0015 0E2A

    I just checked, and the Pronto seems to control Live TV properly.
     
  14. Dan203

    Dan203 Super Moderator Staff Member TCF Club

    37,444
    165
    Apr 17, 2000
    Nevada
    There is one that's just Live TV and one that is a combo Live TV/Guide button. But I think both still work on all TiVos.
     

Share This Page