1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transfers to Tivo Desktop Failing

Discussion in 'TiVo Help Center' started by oldradio99, Mar 11, 2013.

  1. oldradio99

    oldradio99 New Member

    99
    0
    Nov 22, 2005
    I have a Tivo XL4 with the 4 tuners that as recently replaced under extended warranty, but dont think that is the issue.

    I am using Tivo Desktop 2.6.2 as that has always been stable.

    Now all my transfers between my Tivo and the Tivo server fail. - Function Failed during execution.

    I have cleared cache and made sure the firwall is off. Am using Microsoft Security Essentials on the Tivo server but that hasnt changed either.

    Thought it may have been file size but even 30 minute shows wont transfer.

    Units are wired and not wireless.

    Thoughts?

    Thanks
     
  2. jrtroo

    jrtroo User

    4,059
    4
    Feb 4, 2008
    Lots of threads on this issue.

    Go to the tivo site and get the new patched version that came out Saturday.

    Or patch it yourself, I'm too lazy to find the thread with this, but you can search and find it.
     
  3. oldradio99

    oldradio99 New Member

    99
    0
    Nov 22, 2005
    I tried the curl.config fix and that didnt work.

    And the patch is only for ToGo 2.8 and I am running 2.6
     
  4. solutionsetc

    solutionsetc Member

    762
    0
    Apr 2, 2009
    Northern...
    The problem is a bug in the TiVo itself... a simple string in a file. Much like poorly written software around y2k.

    The question is when TiVo plans to role out an update to fix it instead of wasting time patching the client app.
     
  5. oldradio99

    oldradio99 New Member

    99
    0
    Nov 22, 2005
    I tried the change date to 1/1/2013 and it seems to have worked for now.
     
  6. solutionsetc

    solutionsetc Member

    762
    0
    Apr 2, 2009
    Northern...
    Yes, that works. But the real problem is that one of the idiots at tivo hard coded a date for cookie expiration on the tivo itself, and never updated it.

    This affected all of their users (not just the ones using their crappy desktop software).

    It is an incredibly simple fix they should have rolled out to users well before the expiration date. Of course that assumes a certain level of competence they are clearly lacking. :confused:
     
  7. wmcbrine

    wmcbrine Ziphead

    10,364
    22
    Aug 2, 2003
    Whoever wrote that bit of code probably left TiVo long ago, was maybe never even aware of the problem (given the stupid way in which that code is written), and if aware, likely failed to pass that awareness on to anyone else. Perhaps he thought, "Yeah, I'll fix that later, I've got plenty of time," and then promptly forgot about it.
     
  8. oldradio99

    oldradio99 New Member

    99
    0
    Nov 22, 2005
    Is there any reason to not update to 2.8?
     
  9. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    No reason not to.

    The only thing different that may affect you is the addition of using Bonjour for the Tivo DVR discovery protocol.
    Bonjour will be setup as the default protocol with the new installation, but you will still have the option of using Tivo Beacon and I recommend that you do so.
    That selection will be found in the Tivo Server Properties under the Network tab.

    ETA: Also, under File -> Preferences, you will have a file transfer speed option that affects transferring files from Series 4 Tivos.
    I think the faster transfers are selected by default.
    This may or may not affect how you use the files on the computer.
     
  10. MHunter1

    MHunter1 TiVo Bug Hunter

    286
    0
    Oct 11, 2007
    Silicon Valley
    I'm limited to using TiVo Desktop version 2.7 because installing v2.8 causes playback conflicts with Windows Media Player on my XP machine. Too much hassle installing third-party codecs just to make WMP and TD work together, so I'm sticking with TD v2.7 to push content to the DVR and TiVoPlayList v0.71 to pull shows from the DVR.
     
  11. vpittman1

    vpittman1 New Member

    6
    0
    Mar 5, 2011
    I know that this is an old topic, but I just ran into this myself with 2.6.2

    To fix...
    Edit the file D:\Users\<username>\AppData\Local\TiVo Desktop\TransferCookies

    The expire date is the 5th field 1360972800, in unix time (seconds from 1/1/1970) Sat, 16 Feb 2013 00:00:00 GMT

    I replace that with 1676505600 (Thu, 16 Feb 2023 00:00:00 GMT) rebooted and everything works fine
     

Share This Page