1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TiVoPlayList - Space Available App

Discussion in 'TiVo Coffee House - TiVo Discussion' started by dcahoe, Mar 27, 2006.

  1. Apr 22, 2006 #61 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    yes, i am pressing "Save", although I have experimented with pressing refresh, but the same problem exists.

    How can I "open the TiVoPlayList.ini and double check...." ?

    Thanks.
     
  2. Apr 22, 2006 #62 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    Yes, I found it. I have copied the results below. It appears everything is in order, but still not having any luck. I have XXX out the MAK.

    [Recorder1]
    Name=Den
    IP=192.168.1.177
    MAK=XXXX
    Size=0
    [Setup]
    Active_Unit=2
    Folder_View=1
    WinTop=0
    WinLeft=0
    WinHeight=8580
    [Recorder2]
    Name=Living Room
    IP=192.168.1.176
    MAK=XXXXXXX
    Size=160
     
  3. Apr 22, 2006 #63 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    Why does your skin crawl? I was under the impression that this is a pretty good product. At least better than McAfee. I will do a full uninstall and report back. What do you use?
     
  4. Apr 22, 2006 #64 of 140
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    Common sense. :)

    Just installed NIS 2005 (default options) and it mine still seems to be working. :eek:
     
  5. Apr 22, 2006 #65 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    Greg, first of all I appreciate your help with this matter and I see you helping many others in this forum on a regular basis, so I value your input. But why the attack? I was simply continuing a dialog with regards to my current problem. Obviously common sense is a must on the net these days, but extra security products seem to be necessary since common sense can not and will not always provide you with protection against attacks. Anyway, back to the situation...

    I did a complete uninstall of Norton, but am still having the problem. This is very strange. My TiVo Desktop software v2.2 is able to interact with my TiVo's with no problem. Does the TiVo desktop software need to be running to use TiVoPlayList? I would think the answer would be "no".
     
  6. Apr 22, 2006 #66 of 140
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    I noticed my comment came across kinda derogatory and I do apologize. (I even went back and added the smiley I forgot. :) )

    But honestly, I just use the firewall on my router and Windows Firewall in SP2. And I stopped running Antivirus years ago. But that's just me. Too each their own.

    And I stand by my comment on NIS. It honestly can slow my broadband internet connection to a crawl. Why? No idea. I've helped lots of people with odd networking problems at work that usually stem from the software (NIS) they bought to help them. :rolleyes:

    I would double check that you can still access it using IE. Make sure you are getting the Security Alert dialog warning and accepting it.

    [​IMG]


    I don't believe TivoDesktop needs to be running for web access. (Which is how TivoPlayList is doing its magic.)

    PS: I've been deleting my posts so as not to polute David's thread. Hope you don't mind.
     
  7. Apr 22, 2006 #67 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    Thanks again for your prompt responses. Well, here's the update. I still cannot access either TiVo from my desktop PC, and I have checked, double checked and triple checked every number in the IP and MAK. Also, I am getting the Security Alert message box stated above. I am able to access the NPL from IE, by clicking yes, then entering 'tivo' then my MAK in the password field.

    Now for the interesting part - just to see if the problem was my specific computer I decided to install TiVoPlayList on my aging laptop. The laptop is very old and takes about 5 minutes just to start the darn thing. I proceeded to enter the IP and the MAK and I was able to see the NPL's on both Tivo's instantly. So, the laptop works, the desktop (main computer) does not work and we can rule out Norton as the culprit (since it has been uninstalled) and we can rule out my network as the culprit. Therefore, it must be some setting on my PC. I just cannot figure out what setting. Very strange. Hope some more good ideas keep coming in.

    I do not want to polute this thread either, but it is the only place where I can get help. Just image the feedback that I would get if I started a new thread on this topic!
     
  8. Apr 22, 2006 #68 of 140
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    What version of wininet.dll are you running? You don't have the beta of IE 7 installed do you?

    c:\windows\system32\wininet.dll
    6.0.2900.2861

    FYI: I see David's version on his FTP site is 6.0.2900.2668.
     
  9. Apr 22, 2006 #69 of 140
    dcahoe

    dcahoe TiVoPlayList Author

    375
    0
    Jan 28, 2006
    Louisville, KY
    Hi, wow good to see a lot of activity today. Sorry I've been busy and don't have much time now either. Greg, don't worry about 'polluting' the thread, we're all here to help. ;)

    A couple of thoughts that leap to mind first:
    1) Replace the wininet.dll in your '\windows\system32' folder with the one on my FTP site (TiVoPlayList archive section)
    2) Since you can access your machines via the web interface, don't type your MAK into TiVoPlayList, just leave that empty and you should get the web login prompt.

    Hope this helps, I won't be back until late tonight. Thunder Over Louisville...
     
  10. Apr 22, 2006 #70 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    no, I am not running IE 7, just 6 as the default browser, but primarily use Firefox.

    Yes, 6.02900.2861 is the version installed.

    By the way, the more I think about this problem, it is not isolated just to this application. Last week, I tried to install Yahoo widgets, and that program could not connect to the yahoo server. I thought it was strange at the time but did not give it another thought until now. It seems like the problem could be related.
     
  11. Apr 22, 2006 #71 of 140
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
  12. Apr 22, 2006 #72 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    I reread your thread, and I agree that firefox could somehow be causing this problem. But it does not seem likely since I have IE6 as the default, not firefox. I have successfully connected using IE6 to the NPL but TiVoPlayList is still not working. It seems like a lost cause at this point and it is extremely frustrating to me since it should be obious as to what the problem should be. Between the Yahoo Widgets not working and now this, I am convinced there is some screwy setting somewhere. Maybe a firewall somewhere, or some piece of Norton that never uninstalled. Very strange is all I can say.
     
  13. Apr 22, 2006 #73 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002
    I FINALLY figured it out!!!!! I can't believe this. I was going through my list of installed programs and found that I still had Sygate Personal Firewall installed (but not operational). I launced Sygate, and followed by TiVoPlayList and Yahoo Widgets, followed by allowing access to those programs. Both work flawlessly.

    It seems that my version of Sygate, although not running and dormant was preventing any new application access to the internet. Therefore, since I have not used Sygate in a few months, the Yahoo widgets and TiVoPlayList applications were somehow not allowed through by Sygate.

    Greg - I wanted to thank you specifically for your help trying to get my issue resolved. Nice job.
     
  14. Apr 22, 2006 #74 of 140
    greg_burns

    greg_burns Now in HD

    6,384
    0
    May 21, 2004
    Slower...
    :up:
     
  15. Apr 22, 2006 #75 of 140
    Maren

    Maren New Member

    10
    0
    Jan 2, 2005
    Woodinville, WA
    And I want to thank YOU JB! I've been following this thread trying to get it to work. Had the same issues as you. When I read your solution, I realized I probably had the same hangup so I launched Sygate and allowed TivoPlayList and YIPPEE!!! It now works.

    And thanks to dcahoe for the app. It's great!
     
  16. Apr 22, 2006 #76 of 140
    jjberger2134

    jjberger2134 Member

    1,598
    0
    Nov 19, 2002

    Awesome!! Glad to see my problems are not isolated to myself and my problems also managed to help others. Seems pretty lousy that Sygate will still block internet access by newly installed programs, although Sygate is not running. Looks like I will be visiting my Add/Remove Programs shortly to Remove Sygate.

    Thanks again to dcachoe for an awesome app. Love it so far.
     
  17. Apr 23, 2006 #77 of 140
    dcahoe

    dcahoe TiVoPlayList Author

    375
    0
    Jan 28, 2006
    Louisville, KY
    Great news. I'm glad to see you got it working and the information has already helped someone else to get it working also.

    :)
     
  18. Apr 23, 2006 #78 of 140
    dcahoe

    dcahoe TiVoPlayList Author

    375
    0
    Jan 28, 2006
    Louisville, KY
    Finally got around to recording an episode of '24' to see if I could download it with TiVoPlayList. As twotivofella pointed out, version v0.53 (which added episode names to the default save as filename) did not work due to the colons (an invalid filename character).

    I have re-compiled the program to fix this, just download v0.53b of TiVoPlayList for the fix.
     
  19. Apr 24, 2006 #79 of 140
    mfrns0123

    mfrns0123 New Member

    162
    0
    Mar 25, 2005
    Chicago
    dcahoe, I have the same issue as Greg, I have to access tivo through IE in order to get downloads to start, Any idea why? Can this be fixed, or will I always have to do this?

    Also, just wanted to add a suggestion. If TivoPlaylist had the ability to schedule a time for the downloads to start, with some sort of a master download list, I believe this would replace Galleon and TvHarmony for me. :up:
     
  20. Apr 26, 2006 #80 of 140
    dcahoe

    dcahoe TiVoPlayList Author

    375
    0
    Jan 28, 2006
    Louisville, KY
    I'm currently working on an asynchronous read version which will let the program do playlist auto-refreshes pretty seamlessly. This version will probably also have a command line option to auto-export the playlist or playlists. The next logical step will be to add a command line option to auto-download shows. This would allow an external program to retrieve the playlist, parse it and download shows by calling TiVoPlayList.

    Eventually I could add some download list functionality, probably without a UI at first. This would probably be similar to Galleon and let you schedule downloads by time, or name, or various other criteria. I will probably wait until the new TiVoDeskTop comes out before doing something like this, because it may be really great and do all these things. I really don't want to re-invent the wheel here.

    This whole program has evolved because I (like many others) was having problems getting TiVoDeskTop to run reliably and although I really like Galleon and it did what I needed, it seemed to be a resource hog (as others have also noted).

    FYI. :rolleyes:
     

Share This Page