1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TiVo UI Control via Telnet - No Hacking Required!

Discussion in 'TiVo Underground' started by Omikron, Apr 30, 2008.

  1. Jan 2, 2011 #521 of 692
    wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    Not a fork; it's a totally different implementation, in Java. And there are others, too.

    Very unlikely.

    Was my comment about Enter vs. Select on point?
     
  2. Jan 5, 2011 #522 of 692
    wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    I decided that the CC_ON codes were worth an update -- this actually is much nicer than the old closed-caption toggling method; so far, it even seems not to leave any residue on the screen when I toggle them off, which happens all the time with the Info-menu method (even when just using a regular remote, and not the network interface).

    Since it's CC_ON and CC_OFF instead of a direct toggle, the program has to assume a state at startup, so it assumes that captions are off. If they're already on, that just means that the first press of the CC button will turn them on again (redundantly), and after that the program and the TiVo will be in sync.

    Note that there's no visual or aural feedback with this method, except the appearance or disappearance of the captions -- no menu pops up, no bongs or beeps sound. So, on programs with no captions, nothing will appear to happen at all.

    http://github.com/wmcbrine/tivoremote
     
  3. Jan 7, 2011 #523 of 692
    wmcbrine

    wmcbrine Ziphead

    10,369
    22
    Aug 2, 2003
    Another bug in the TiVo document: Although it's never stated explicitly, "After a successful channel change, all open clients receive the CH_STATUS message" carries the distinct implication that multiple clients can be connected simultaneously. AFAICT, this has never been the case -- back in the day, just trying it caused crashes; now, the second client just gets immediately disconnected (and there's still occasional weirdness).

    The document also fails to mention the Zeroconf announcements of the remote service.
     
  4. DarthObiwan

    DarthObiwan New Member

    18
    0
    Apr 9, 2010
    I'm wondering what new things they have added or will be adding for the iPad app. They mention it will be able to start a recording up right away. I would imagine they would make it much easier than having to have your sorting/grouping options match perfectly.

    I wrote a Windows Mobile 6.5 remote app for myself over Christmas. I may open source it once I get better auto-discovery. I ended up having to go the scan route since I could not find a good Zeroconf implementation for .NET CF. Unfortunately I could not do a Windows Phone 7 version at all, MS has kept TCP sockets closed for now. I do know it is one of the highest requested features and will probably make it into the update later this year
     
  5. mjh

    mjh Re: Member

    613
    0
    Dec 19, 2002
    No. That didn't really change anything. I'm still experiencing the problem.
     
  6. jafi

    jafi New Member

    18
    0
    Jun 16, 2009
    I've downloaded both the 1.03b and the 1.02b versions - I got one of them (1.02b I think) working with my Series 3 on a Dell Latitude D630 running XP pro. I was able to pull up my Now Playing list and start a recording playing and pause it.

    I accidentally dismissed the Netmote - and now I can't get either version of the Netmote to work with the Tivo again. I've tried both, shut off my firewall for testing. Is there a Windows service or process that needs to be killed/reset/restarted? (I haven't rebooted the laptop - though that's next).

    I configure Netmote with the IP address. I connect - and when I push a button on the Netmote I see the red indicator flash (which doesn't flash till I connect).

    I am able to connect directly to the series 3 via browser using the IP URL and the MAK as password.

    I do have the Tivo desktop installed - but that shouldn't interfere with Netmote?

    I'm just baffled why it worked the first time - but not when I restarted a minute later.

    FWIW - there's a great little browser based remote for the Roku player box called Remoku(google pops it right up). I run it in Chrome and seems to find/store the IP - I don't have to manually connect each time I use it.

    Update: Rebooting fixed it - and both versions now work even after being closed and restarted. Would like to understand what was causing the problem before though.

    Second update: Now Netmote (either version) isn't working again when I start and connect it. This is very frustrating.
     
  7. MPSAN

    MPSAN Active Member

    1,194
    1
    Jun 20, 2009
    Portland,...
    I will never figure out why they will not let us delete a show. It would be nice to remove a recorded show without turning on the TV...especially if it is a big screen set in another room!
     
  8. dswallow

    dswallow Save the ModeratŠ¾r TCF Club

    50,978
    32
    Dec 3, 2000
    Long...
    If they let you delete a show they won't have the opportunity to pass along your delete request to retention in the hopes they can talk you out of it.

    :p
     
  9. Fofer

    Fofer XenForo Rocks! TCF Club

    82,149
    310
    Oct 29, 2000
    You can delete a show, you just need to "upgrade" to a TiVo Premiere, and get an iPad, and then use the iPad app.

    [​IMG]
     
  10. MPSAN

    MPSAN Active Member

    1,194
    1
    Jun 20, 2009
    Portland,...
    Well, there are still a few features of my ReplayTV's that I miss with the TIVO's! :D
     
  11. Feb 4, 2011 #531 of 692
    ttocsmi

    ttocsmi New Member

    19
    0
    Jan 6, 2007
    @wmcbrine - ahahahahahhhahhha!!!! now it works; i downloaded the .zip file (using the Downloads button) and it works just fine. really cool!!

    thanks for your patience and for writing this code.
     
  12. nathanm412

    nathanm412 New Member

    10
    0
    Oct 23, 2008
    Thanks wmcbrine for this tool. I've been using it for a couple of years and really appreciate it.
     
  13. morac

    morac Cat God

    8,956
    22
    Mar 14, 2003
    NJ
    Is there a way to simulate holding down a button via the network interface? If not how does one jump to the beginning/end of a program on a Premiere that's set up to hold down the instant replay/skip button to jump to the beginning/end of a program?
     
  14. ThAbtO

    ThAbtO TiVoholic by the bay

    6,739
    9
    Apr 6, 2000
    SF Bay Area
    Without the 30-Sec skip enabled, pressing ->| will jump to end, pressing it again will then jump to the beginning.. An alternate way is to press << or >> then each press of ->| will jump to the next white tic mark in that direction.

    With 30-Sec skip, use the alternate.
     
  15. morac

    morac Cat God

    8,956
    22
    Mar 14, 2003
    NJ
    So I guess the answer is that there is no way to simulate holding down the button.

    I wonder if there is a special IRCODE to jump to the beginning/end. There must be since the iPad app can jump to any time in the playback stream.
     
  16. jmemmott

    jmemmott New Member

    393
    0
    Jul 12, 2003
    Santa Cruz, CA
    I suspect someone is casing the forum spam filters. There is also a spam entry that reactived my Closed Captioning thread from last November in the ToGo forum with Russian "traffic stoplight" verbage and an entry in the HME for Python thread in the Developers forum about "PinayTV". All first posts, all about the same time this morning...
     
  17. orangeboy

    orangeboy yes, I AM orangeboy!

    4,083
    0
    Apr 19, 2004
    East Moline, IL
    I've reported about half a dozen spam posts, which still remain on the boards. That russian one was one of them. I'm wondering if the "Report Post" function got clobbered with the hardware move done this past weekend...
     
  18. StanSimmons

    StanSimmons Senior Moment Member

    4,717
    0
    Jun 10, 2000
    Flower...
    It sometimes takes a while for the mods to make time to kill off the less obvious spam messages.
     
  19. Mar 2, 2011 #539 of 692
    grafton

    grafton New Member

    11
    0
    Nov 28, 2010
    thanks for the app any chance you'll be able to reconfigure to where it's standalone?
     
  20. bbrown9

    bbrown9 Member

    186
    0
    Mar 12, 2011
    I don't see buttons for mute and volume. The PDF has IRCODEs listed for them.

    Any chance that they will be implemented in the future?

    Another suggestion:
    A Help button that displays the readme.txt file (for viewing keybaord shortcuts, etc)
     

Share This Page