1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo transfers shows to PC in Spanish

Discussion in 'TiVo Home Media Features & TiVoToGo' started by woz77, May 10, 2012.

  1. woz77

    woz77 New Member

    4
    0
    May 10, 2012
    Good morning. I'm having the darndest issue with transfers to my PC. I transferred 4 English language episodes of Disney JR show Special Agent Oso from my Tivo Premiere to my Win7 laptop using TivoDesktop v2.8.3. However when I viewed them on my PC they were in Spanish. Oh no haha don't be silly not everything is in Spanish, the commercials before the program starts are in English. Only the main episodes are in Spanish. And, because this wasn't weird enough, 1 out of the 4 episodes transferred correctly with everything in English. Makes perfect sense. Does anyone know why this is happening or how to remedy it? Thank you!
     
  2. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    I can only guess, but it sounds like info in the file header is messed up which is causing the Spanish audio track to act as the default soundtrack. The commercials may be in English, only because they only have the one audio track.

    If the show has multiple sountracks and you have VideoReDo, you can load the file and "force" it to use the english soundtrack.

    If not, then I can only suggest you try re-transferring that one program.
    What software are you using to do the transfers?
    If Tivo Desktop, are you using the "faster" method of transferring?
     
  3. woz77

    woz77 New Member

    4
    0
    May 10, 2012
    I'm using TivoDesktop to do the transfers. I tried transferring both ways, regular and "faster", and both times the result was Spanish. I also used TivoDesktop to do the conversion to IpodTouch. I didn't see an option to choose the audio track in TivoDesktop either for the transfer or the conversion. That's a good idea, I'll try doing the conversion in Handbrake tonight and see if it will let me choose the audio track. Thanks for the suggestion!
     
  4. woz77

    woz77 New Member

    4
    0
    May 10, 2012
    Handbrake couldn't recognize any audio track on the file. I'm stumped.
     
  5. lrhorer

    lrhorer New Member

    6,922
    0
    Aug 31, 2003
    San...
    You can use ffmpeg to inspect the audio streams and identify the English version, and then use ffmpeg again to map the English stream to stream 0.1.
     
  6. Jun 5, 2012 #6 of 14
    agredon

    agredon New Member

    68
    0
    Jul 26, 2011
    Florida
    In my experience, TiVo To Go only seems to transfer ONE audio stream (English in my case) even when the show has multiple languages. So, I would suggest checking the settings on the TiVo. Perhaps there's a setting somewhere that set your default language as Spanish. It would be nice if TiVo To Go could transfer the alternate audio/SAP tracks.
     
  7. Jun 5, 2012 #7 of 14
    woz77

    woz77 New Member

    4
    0
    May 10, 2012
    Thanks for responding. I did check the settings on the box itself and all of the primary language settings are English. I think you're right that it is transferring the SAP track but I haven't been able to figure out why it chooses the SAP track on transfer but not on playback or why it chooses the SAP track on transfer for some episodes but not all episodes. It's just plain weird I tell ya!

     
  8. Jun 5, 2012 #8 of 14
    wmcbrine

    wmcbrine Ziphead

    10,363
    22
    Aug 2, 2003
    It's not (just?) that TTG only transfers one audio track; it's that, historically, the TiVo would only record one audio track. But I think this has changed with recent Premiere software. Whether they all come out via TTG (perhaps only via transport streams?), I'm not sure.
     
  9. Jul 3, 2012 #9 of 14
    glug0

    glug0 New Member

    4
    0
    Jul 3, 2012
    I think I'm running into the same problem. In my case, the clips I've recorded have more than one audio stream. Usually, the audio choices are 'Spanish - Dolby Digital' and 'English - Dolby Digital' with the first as AC3 2.0 and the second as AC3 5.1.

    Now when transfering with TivoDesktop from a premiere, I only get the AC3 2.0 track and not the 5.1. Programs with a single 5.1 stream transfer correctly so it looks like it's just getting the first audio stream. Ideally, it would receive the stream that you've selected as default in the tivo's audio settings...just like you're playing/watching it.... Changing the settings doesn't seem to have any effect on what's transferred.

    Ok, I figure as long as the transport stream is intact with multiple audio I can wait for Tivo to eventually fix this. To test this, I transfer a TS (fast transfer) from Tivo to PC and then right back to Tivo. Unfortunately it seems to lose the other audio stream and am left with the 2.0 track.

    I've tried calling tivo support a couple times so far and have ended up on hold and then disconnected. Will try a couple more times.... Fortunately, I still have a cable box and can capture via firewire. But still a bummer.

    As the roundtrip clip does not come back unmolested, I'm also concerned that transfers between premieres use the same mechanism...transferring the TS...and thus would lose the additional audio tracks.... Has anybody seen this or have any additional insight ? thanks
     
  10. moyekj

    moyekj Well-Known Member

    11,134
    27
    Jan 23, 2006
    Mission...
    No MRV & MRS are not the same transfer mechanism as TTG. TTG is a lot more CPU intensive since it involves decrypt, de-mux, re-mux, re-encrypt which is why it's always been historically a lot slower than MRV. I have been able to get 2 audio tracks working for MRV and MRS shows. I believe some metadata is still lost for MRV shows though so it's not a perfect copy of the original either.
     
  11. steve614

    steve614 what ru lookin at?

    10,722
    0
    May 1, 2006
    Dallas, TX
    Have you tried using the PS (slower transfer) option when doing your troubleshooting?
     
  12. glug0

    glug0 New Member

    4
    0
    Jul 3, 2012
    It's reassuring that MRS works properly considering the impending ip box will surely rely on it. But I was hoping that MRV and the fast method TTG would use the same underlying transfer method. i.e. encrypt TS file on drive, wrap with tivo meta, send, receiving tivo reverses process, pc just saves the file. Ideally, it's lossless. But it seems more is going on.

    Yes, the slow PS method sends only the first stream. It plays fine but with the wrong audio track. Also the file is smaller so I'm hopeful the fast method file may still have the other stream but tivo has mangled the audio header. tivodecode craps out. mediainfo gives an abbreviated report for audio so something is off.
     
  13. micgadget

    micgadget New Member

    2
    0
    May 15, 2009
    Ok so here's the deal...
    Play your recording. Press info. Go to Audio Track. If it lists Spanish first it will transfer that audio track. Note this happens even if you have English selected as your laguage of choice. English must be listed first if you want the English track. If Spanish is listed first you will get the Spanish audio track. It seems to depend on how the track comes in from the provider and I can find no way to change this. Tivo Desktop and KMTTG can't control this. The only solution I have found is to re-record the movie/show and hope I get lucky. I have so far. I hope this helps somone out. Also I have to give credit to my husband as he was the one who discovered the cause and allowed me to find a solution which is only to re-record. I know this doesn't help those with long ago saved recordings. Good luck!
     
  14. Ichinisan

    Ichinisan New Member

    19
    0
    Mar 14, 2013
    It's 2013. Has anyone found a solution for this?
     

Share This Page