1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tivo transfer causing internet to not work.

Discussion in 'TiVo Help Center' started by Embowe, Oct 1, 2012.

  1. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    I'm using a couple of Linksys BEFSR41 routers and a couple of WRT54G wireless routers (one running DD-WRT so I can use it in the other room as a wireless bridge) all on the same network

    192.168.1.0-192.168.1.255

    which sounds like an opportunity for a lot of problems, but I avoid almost all of them, because

    I GIVE EVERYTHING A FIXED IP ADDRESS

    and have about 5 addresses* in the total DHCP pool in case I need to log something onto the network temporarily or one day get something that'll also leave the house and log onto some other network occasionally as well.

    That way there's no chance of anything going wrong when a device and a router negotiate what the device's IP address is going to be, or when the lease on that address runs out, because none of that happens in the first place, and something that doesn't happen cannot go wrong. Solve problems by eliminating varibles.

    Currently I tell everything the gateway is the IP of the first router after the cable modem: 192.168.1.1


    *192.168.1.250--192.168.1.254
     
  2. misterclick

    misterclick New Member

    11
    0
    Oct 24, 2012
    One thing that you or Embawe don't mention is if your Internet connection is DSL or Cable. I think we are assuming cable, but your problems sound like when you take a DSL Modem (which is also a full flegged Router) and put a router behind it. Both will try to assign DHCP numbers, and then you have double NAT. Once you power cycle them, they will work for a few minutes, and then they will stop communicating. If you were patient enough, they would start working on their own after a long while. I see this all the time, I work with computers, and I get calls from people that have gone and purchased a router(wireless) and just connect it to the DSL modem. If you want to do this, you have to turn OFF the Routing portion of the DSL modem/router. It is called BRIDGE mode. Make sure you have your username and password, because you have to put them in the settings of the router, to authenticate you with the DSL provider, since the Modem is not doing it anymore in Bridge mode.
    This is TOTALLY different from having a Cable modem, since this modem does NOT have the built in functions of the router. In other words, just plug the router in and everything should work.
    You can also go to the router settings, and look at the attached devices, and see what the range of IP numbers are. Unitron is right, there should be only ONE device giving DHCP assignments, and if possible assign numbers yourself (permanent) and avoid headaches. Click
     
  3. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC

    A cable modem will DHCP assign an IP address to the WAN port of a router and that will likely have no effect on the IP address the router presents to the stuff connected to its LAN ports.

    For instance my cable modem can be seen on my LAN at 192.168.100.1, and I assume it sees my first router (to the WAN/Internet port of which it is connected) as 192.168.100.something greater than 1 which it has obtained from the cable modem because I've told the router to get an IP address on the WAN side via DHCP because that's what the cable modem wants to do, and since it's the only thing connected directly to the cable modem's downstream side, there's no risk of a conflict.


    And the cable modem presents itself to its cable side as who knows what and no doubt gets that via DHCP from the cable company's server.

    But if one is using something that eliminates the cable between the modem and the WAN port and incorporates that and the LAN ports in one box, whether it gets its internet from cable or DSL (I'm sure there must be some combo cable modem/router boxes out there somewhere), then you have to configure the LAN side of it, and if you hook a downstream router to it you have to configure that router as well and take both into consideration when you configure either.

    If my cable modem had a router built in, then I'd set it to present itself to stuff connected to its LAN ports as probably 192.168.1.1, and then connect my various routers to the LAN ports as 192.168.1.2, 192.168.1.3, 192.168.1.4, etc. and set the DHCP pool on the modemrouter to 192.168.1.250--192.168.1.254

    If it insisted on being 192.168.100.1, then I'd set the routers to 192.168.100.2, etc., since the Linksys's have that flexibility, and make the DHCP pool 192.168.100.250--192.168.100.254

    And unitron is not capitalized.

    It tickles.

    :D
     
  4. misterclick

    misterclick New Member

    11
    0
    Oct 24, 2012
    I know it is not capitalized, but since I ended the sentence with a period, grammar dictates that any word after a period be capitalized, since it starts another sentence. Click
     
  5. Adramelech

    Adramelech New Member

    6
    0
    Dec 6, 2012
    I'm using a Doc 3.0 Cable modem. So, none of the above is true for me. As I stated. I had no problems whatsoever running 2 Tivos & several computers wired & wireless for years. Once I added this XL4 it screwed everything up. My internet works perfect until I try to transfer a show from one Tivo to another Tivo. At that point it disconnects my Tivo from the internet, disconnects all the other devices from the internet, will begin to transfer a few shows, and then gets stuck on the same show for over an hour until I have to manually cancel the transfers. If I unplug the modem and router to reset it they will work again as long as I don't begin another transfer.

    Why did my system work perfect with the Series 2 networked with the Premeire, and now when I got rid of the Series 2.. and use my Premiere with my Elite XL4 I have this problem?
     
  6. unitron

    unitron Active Member

    16,387
    2
    Apr 28, 2006
    semi-coastal NC
    Give everything a fixed IP address and set up a small fan to blow directly on that WRT54G.

    If that doesn't fix it you can always go back to DHCP if you feel you must.
     
  7. misterclick

    misterclick New Member

    11
    0
    Oct 24, 2012
    Series 2 is very jealous... Put a jinx on your network...:D
     

Share This Page