1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

tivo so3 error and no video

Discussion in 'TiVo Help Center' started by chaseonbase, Jan 7, 2013.

  1. chaseonbase

    chaseonbase New Member

    1
    0
    Jan 7, 2013
    This is my first time posting to the forums and this seems like a good place to start. This is my first TiVo issue after having 2 boxes. The past few weeks ago, we experienced an ice storm and when they were repairing the power lines it made my power flicker like crazy. Since this issue my TiVo informed me it needed me to download program info. This is when the so3 error occurred. A few days ago I was messing around with my surge protector and changed my coaxials. Now. The TiVo won't even show basic channels. I even plugged up the coax to the tv and it appears to be working fine. Here is a list of things I have done. Hard and soft reset, completed guided setup, called cable company and requested signal reboot. The TiVo is the hundred dollar model from bestbuy and I have a western digital 1tb, expandable hd. The next attempt I am going to try is a complete factory reset. Anyone got some suggestions?

    Ps. I have also tried the pause 57 trick, and all it did was put me thru guided setup
     
  2. lillevig

    lillevig Hot in West Texas

    1,769
    0
    Dec 6, 2010
    San Angelo, TX
    You didn't say what model your Tivo is. Check the back label and let us know the TCD number. You can try the steps located here:

    http://dreadnaught.wordpress.com/2008/07/09/how-to-fix-tivo-error-s03/

    If that doesn't work you will likely need to re-image the hard drive. The imaging SW is free and images are available from friendly forum dwellers for free (check the Upgrade Forum for more info).
     
  3. bshrock

    bshrock New Member

    263
    0
    Jan 6, 2012
    1. Can you playback old recordings?

    2. Will the DVR download data from TiVo?

    3. Check the signal strength for several channels, Verify the cable is connected to "Cable" not the Antenna input.

    4 Switch to the SD menus look in settings -> recording
    And you should replace the surge protector strip with a UPS. The surge protector works by shorting the voltage spike to ground and will self destruct on the stronger ones in the process.
     

Share This Page